I agree it is confusing and that the proposed syntax would probably be less so.

But, I think that:

impl Trait for Type { ... }

Is still possible to confuse with:

impl Type { ... }

Because they both start with the same keyword. Though perhaps this is not significant.

Gareth
_______________________________________________
Rust-dev mailing list
[email protected]
https://mail.mozilla.org/listinfo/rust-dev

Reply via email to