As a (very) new user of Rust, I would definitely have found this confusing. I think the proposal makes it much clearer what is happening, and I think that reusing 'impl' is fine - the two 'impl' forms are sufficiently different to avoid any confusion.
Cheers, Colin On 1 January 2013 05:54, Patrick Walton <[email protected]> wrote: > On 12/31/12 3:05 AM, Gareth Smith wrote: > >> Because they both start with the same keyword. Though perhaps this is >> not significant. >> > > Agreed, I considered this. There are a couple of reasons why I didn't > propose a different keyword: > > 1. Rust tries hard to reuse keywords in general, since everyone likes a > small set of keywords. > > 2. I didn't really like any of the obvious options. The most obvious > keyword to switch to would be "inst" to mirror Haskell and so forth, but is > "impl"/"inst" really less confusing? I suspect many programmers would want > to "implement" a trait and would choose "impl". > > Patrick > > > ______________________________**_________________ > Rust-dev mailing list > [email protected] > https://mail.mozilla.org/**listinfo/rust-dev<https://mail.mozilla.org/listinfo/rust-dev> >
_______________________________________________ Rust-dev mailing list [email protected] https://mail.mozilla.org/listinfo/rust-dev
