On 12/31/12 3:05 AM, Gareth Smith wrote:
Because they both start with the same keyword. Though perhaps this is not significant.
Agreed, I considered this. There are a couple of reasons why I didn't propose a different keyword:
1. Rust tries hard to reuse keywords in general, since everyone likes a small set of keywords.
2. I didn't really like any of the obvious options. The most obvious keyword to switch to would be "inst" to mirror Haskell and so forth, but is "impl"/"inst" really less confusing? I suspect many programmers would want to "implement" a trait and would choose "impl".
Patrick _______________________________________________ Rust-dev mailing list [email protected] https://mail.mozilla.org/listinfo/rust-dev
