#15143: Improvements to SetPartitions
------------------------------------+-----------------------------
       Reporter:  tscrim            |        Owner:  sage-combinat
           Type:  enhancement       |       Status:  needs_review
       Priority:  major             |    Milestone:  sage-5.12
      Component:  combinatorics     |   Resolution:
       Keywords:                    |    Merged in:
        Authors:  Travis Scrimshaw  |    Reviewers:
Report Upstream:  N/A               |  Work issues:
         Branch:                    |       Commit:
   Dependencies:  #14234            |     Stopgaps:
------------------------------------+-----------------------------

Comment (by zabrocki):

 I have some additional doc changes.

 I have one additional recommendation.  I think you should use the name
 `size` instead of `weight`.  There was no method before this patch for
 computing the size of a set partition, but it could be done indirectly by
 `A.to_partition().size()` or `A.to_permutation().size()`.  So why call the
 "size" in this combinatorial object the "weight" of a set partition?

 If you are going to call anything the "weight" of the set partition I
 would think it would be the corresponding integer partition (which you
 called the "shape").

--
Ticket URL: <http://trac.sagemath.org/ticket/15143#comment:11>
Sage <http://www.sagemath.org>
Sage: Creating a Viable Open Source Alternative to Magma, Maple, Mathematica, 
and MATLAB

-- 
You received this message because you are subscribed to the Google Groups 
"sage-trac" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
Visit this group at http://groups.google.com/group/sage-trac.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to