#16953: Faster enumeration of points for toric varieties
-------------------------------------+-------------------------------------
Reporter: vbraun | Owner:
Type: enhancement | Status: needs_work
Priority: major | Milestone: sage-6.4
Component: algebraic | Resolution:
geometry | Merged in:
Keywords: | Reviewers:
Authors: Volker Braun | Work issues:
Report Upstream: N/A | Commit:
Branch: | 49a72410a19784c05c9fe320e28382df7e5b7338
u/vbraun/faster_enumeration | Stopgaps:
Dependencies: |
-------------------------------------+-------------------------------------
Changes (by vdelecroix):
* status: needs_review => needs_work
Comment:
Replying to [comment:13 vbraun]:
> IMHO `copy(zero)` is much more readable that `zero[:]`. And
`X.is_zero()` doesn't work for all numeric datatypes. Both are premature
optimizations for something that isn't even cythonized.
And you forgot that `copy(X)` needs `from copy import copy` which is very
readable. Doing `[zero]*n` each time would even be faster...
> Also, there isn't even a patch that deprecates !CartesianProduct. You
are getting ahead of yourself.
Really? what about #18411? Citation:
{{{
sage.combinat.cartesian_product.CartesianProduct is deprecated.
}}}
And these were not my only remarks...
--
Ticket URL: <http://trac.sagemath.org/ticket/16953#comment:15>
Sage <http://www.sagemath.org>
Sage: Creating a Viable Open Source Alternative to Magma, Maple, Mathematica,
and MATLAB
--
You received this message because you are subscribed to the Google Groups
"sage-trac" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To post to this group, send email to [email protected].
Visit this group at http://groups.google.com/group/sage-trac.
For more options, visit https://groups.google.com/d/optout.