#16953: Faster enumeration of points for toric varieties
-------------------------------------+-------------------------------------
Reporter: vbraun | Owner:
Type: enhancement | Status: needs_work
Priority: major | Milestone: sage-6.4
Component: algebraic | Resolution:
geometry | Merged in:
Keywords: | Reviewers:
Authors: Volker Braun | Work issues:
Report Upstream: N/A | Commit:
Branch: | 49a72410a19784c05c9fe320e28382df7e5b7338
u/vbraun/faster_enumeration | Stopgaps:
Dependencies: |
-------------------------------------+-------------------------------------
Comment (by vbraun):
Replying to [comment:17 vdelecroix]:
> Then there is `cartesian_product_iterator`.
How about you discuss what to do with cartesian products on #18411?
> What about all your useless `cached_method`?
They give names to quantities. Its true that you can replace the
multiplicative order with q-1 everywhere, but it is not true that q-1 in a
formula always refers to the order. Giving names to quantities makes code
more readable as it explains the "why". And I'm using the general pattern
of caching frequently-accessed methods, an extra `cached_method` has no
performance impact but a forgotten `cached_method` can be very bad. Also,
why should you have to read the finite fields implementation just to
decide whether to cache something in this module?
--
Ticket URL: <http://trac.sagemath.org/ticket/16953#comment:18>
Sage <http://www.sagemath.org>
Sage: Creating a Viable Open Source Alternative to Magma, Maple, Mathematica,
and MATLAB
--
You received this message because you are subscribed to the Google Groups
"sage-trac" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
To post to this group, send email to [email protected].
Visit this group at http://groups.google.com/group/sage-trac.
For more options, visit https://groups.google.com/d/optout.