Hi there,

I'm working with Sandeep on this issue. Everything is working fine
without SSL enabled, not sure what we're missing here.

Does anybody have SSL enabled and would be willing to share his or her
Icecast config? We should probably also post this on the Icecast mailing
list 😬

Best,
NKd

On 06.04.18 10:12, sandeep krishna wrote:
>
> i recompiled icecast2 with the open ssl and curl
>
>
> also enabled ssl on port 8000 and given the ssl cert (inclding cert
> privatekey and bundle in a single file) under path directive
>
> these are the main section in icecast2 config file
> ++
>
> <listen-socket>
> <port>8000</port>
> <ssl>1</ssl>
>
> </listen-socket>
>
> <paths>
>
> <basedir>/c</basedir>
> <ssl-certificate>/usr/share/icecast2/icecast.pem</ssl-certificate>
> <logdir>/var/log/icecast2</logdir>
> <webroot>/usr/share/icecast2/web</webroot>
> <adminroot>/usr/share/icecast2/admin</adminroot></paths>
>
> ++++
>
> I get a green padlock on domain:8000/radio
>
> But it says file not found, the error log says icecast is looking on
> the location "/usr/share/icecast2/web" and file is not found there. (I
> even tried removing the base dire and webroot but still not working )
>
>
> can you guys shed some lights on this.
>
>
> ~thanks
>
>
>
> -- 
> sandeep

Attachment: signature.asc
Description: OpenPGP digital signature

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Savonet-users mailing list
Savonet-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/savonet-users

Reply via email to