Re: [PATCH RFC net-next 3/6] net: Introduce IFF_LWT_NETDEV flag

2017-05-08 Thread Roopa Prabhu
On Mon, May 8, 2017 at 5:57 PM, David Ahern  wrote:
> On 5/8/17 1:11 PM, David Miller wrote:
>> From: Johannes Berg 
>> Date: Mon, 08 May 2017 10:55:12 +0200
>>
>>>
 +static inline bool netif_is_lwd(struct net_device *dev)
 +{
 +   return !!(dev->priv_flags & IFF_LWT_NETDEV);
 +}
>>>
>>> Am I the only one who thinks that this "LWT_NETDEV" vs "LWD" is a bit
>>> confusing?
>>
>> Agreed, my old eyes can't discern them at a distance :-)
>>
>
> perhaps it is the tiny font your old eyes are having trouble with :-)
>
> I am fine with Johannes' suggestion -- just spell it out:
> netif_is_lwt_netdev
>
> where lwt = LightWeighT

makes sense...but this does sound like a 'light weight tunnel
netdevice' though.just cause 'LWT' already expands to 'light
weight tunnel'


Re: [PATCH RFC net-next 3/6] net: Introduce IFF_LWT_NETDEV flag

2017-05-08 Thread David Ahern
On 5/8/17 1:11 PM, David Miller wrote:
> From: Johannes Berg 
> Date: Mon, 08 May 2017 10:55:12 +0200
> 
>>
>>> +static inline bool netif_is_lwd(struct net_device *dev)
>>> +{
>>> +   return !!(dev->priv_flags & IFF_LWT_NETDEV);
>>> +}
>>
>> Am I the only one who thinks that this "LWT_NETDEV" vs "LWD" is a bit
>> confusing?
> 
> Agreed, my old eyes can't discern them at a distance :-)
> 

perhaps it is the tiny font your old eyes are having trouble with :-)

I am fine with Johannes' suggestion -- just spell it out:
netif_is_lwt_netdev

where lwt = LightWeighT


Re: [PATCH RFC net-next 3/6] net: Introduce IFF_LWT_NETDEV flag

2017-05-08 Thread Roopa Prabhu
On Mon, May 8, 2017 at 1:11 PM, David Miller  wrote:
> From: Johannes Berg 
> Date: Mon, 08 May 2017 10:55:12 +0200
>
>>
>>> +static inline bool netif_is_lwd(struct net_device *dev)
>>> +{
>>> +return !!(dev->priv_flags & IFF_LWT_NETDEV);
>>> +}
>>
>> Am I the only one who thinks that this "LWT_NETDEV" vs "LWD" is a bit
>> confusing?
>
> Agreed, my old eyes can't discern them at a distance :-)


agree.

mix of LWT_NETDEV and LWD can get confusing.

LWT already stands for Light Weight Tunnel...,
this can only be LWD or  LWN ;)if people don't confuse it with
some weekly news device :)


Re: [PATCH RFC net-next 3/6] net: Introduce IFF_LWT_NETDEV flag

2017-05-08 Thread David Miller
From: Johannes Berg 
Date: Mon, 08 May 2017 10:55:12 +0200

> 
>> +static inline bool netif_is_lwd(struct net_device *dev)
>> +{
>> +return !!(dev->priv_flags & IFF_LWT_NETDEV);
>> +}
> 
> Am I the only one who thinks that this "LWT_NETDEV" vs "LWD" is a bit
> confusing?

Agreed, my old eyes can't discern them at a distance :-)


Re: [PATCH RFC net-next 3/6] net: Introduce IFF_LWT_NETDEV flag

2017-05-08 Thread Johannes Berg

> +static inline bool netif_is_lwd(struct net_device *dev)
> +{
> + return !!(dev->priv_flags & IFF_LWT_NETDEV);
> +}

Am I the only one who thinks that this "LWT_NETDEV" vs "LWD" is a bit
confusing?

Is "netif_is_lwt_netdev()" really too long?

johannes