Re: [OpenWrt-Devel] Collision between named interfaces in /etc/config/network and wifi indentifiers in /etc/config/wireless

2014-03-20 Thread Felix Fietkau
On 2014-03-19 20:22, Ben West wrote:
 I believe I discovered that interfaces in /etc/config/network and
 /etc/config/wireless sharing the same identifier causes a collision of
 some sort that can disable all the device's network interfaces, i.e.
 such that it no longer even responds to ping on eth0.
 
 Possibly, this is intentional?
AA or trunk?

At least in AA, wifi was still being set up by scripts that load both
the network config and the wireless config into one context, which is
probably causing these issues.
In trunk, wireless is being configured by netifd, which passes the full
config to the scripts, so it should be fixed there.

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Collision between named interfaces in /etc/config/network and wifi indentifiers in /etc/config/wireless

2014-03-20 Thread Ben West
Sorry for not specifying.  This was observed on AA r39154 and r39928.

Something I'm also looking into is whether olsrd (in my case v0.6.5-4) may
be what gets confused, i.e. besides netifd.  Especially since this problem
only seems to occur at bootup on repeater nodes in an OLSR-managed mesh,
not on the gateway nodes.

That is, I would see a repeater node respond to ping on its configured eth0
IP address for ~10sec briefly at boot and then go silent, suggesting
something like a race condition at bootup.  Adding the conflicting
interface identifiers to /etc/config/wireless on a device that its already
powered and out of bootup, and then issuing wifi restart does not trigger
the failure.  Pointing to a problem with bootup.



On Thu, Mar 20, 2014 at 9:20 AM, Felix Fietkau n...@openwrt.org wrote:

 On 2014-03-19 20:22, Ben West wrote:
  I believe I discovered that interfaces in /etc/config/network and
  /etc/config/wireless sharing the same identifier causes a collision of
  some sort that can disable all the device's network interfaces, i.e.
  such that it no longer even responds to ping on eth0.
 
  Possibly, this is intentional?
 AA or trunk?

 At least in AA, wifi was still being set up by scripts that load both
 the network config and the wireless config into one context, which is
 probably causing these issues.
 In trunk, wireless is being configured by netifd, which passes the full
 config to the scripts, so it should be fixed there.

 - Felix




-- 
Ben West
http://gowasabi.net
b...@gowasabi.net
314-246-9434
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Collision between named interfaces in /etc/config/network and wifi indentifiers in /etc/config/wireless

2014-03-20 Thread Felix Fietkau
On 2014-03-20 15:57, Ben West wrote:
 Sorry for not specifying.  This was observed on AA r39154 and r39928.
 
 Something I'm also looking into is whether olsrd (in my case v0.6.5-4)
 may be what gets confused, i.e. besides netifd.  Especially since this
 problem only seems to occur at bootup on repeater nodes in an
 OLSR-managed mesh, not on the gateway nodes.
netifd itself should not care about any duplicates here, as C (unlike
shell) tracks config files separately.
For AA there will be no fix, as it would be too intrusive. BB should not
have this issue.

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Collision between named interfaces in /etc/config/network and wifi indentifiers in /etc/config/wireless

2014-03-19 Thread Ben West
I believe I discovered that interfaces in /etc/config/network and
/etc/config/wireless sharing the same identifier causes a collision of some
sort that can disable all the device's network interfaces, i.e. such that
it no longer even responds to ping on eth0.

Possibly, this is intentional?

For example, in /etc/config/network:

config interface '*mesh*'
option proto 'static'
option ipaddr '5.X.X.X'
option dns  '208.67.222.222 208.67.222.220'
option netmask '255.0.0.0'
option broadcast '255.255.255.255'

And then this VIF in /etc/config/wireless:

config wifi-iface *mesh*
option network 'mesh'
option mode 'adhoc'
option device 'radio0'
option ssid 'MyMesh'
option bssid '02:CA:FF:EE:BA:BE'
option encryption 'psk2'
option key 'averystrongkey'

The collision was happening on repeater nodes in an OLSR-managed adhoc
network, not on gateway nodes oddly enough.  The repeater nodes in question
had 3 wireless VIFs, the adhoc IF, a public AP running coovachill, and a
private AP with WPA2 security.

Changing the identifier in /etc/config/wireless from *mesh* to *wmesh*,
i.e. anything besides mesh, seemed to resolve the problem.

config wifi-iface *wmesh*
option network 'mesh'
option mode 'adhoc'
option device 'radio0'
option ssid 'MyMesh'
option bssid '02:CA:FF:EE:BA:BE'
option encryption 'psk2'
option key 'averystrongkey'

The wiki about /etc/config/wireless doesn't appear to make explicitly clear
that interface identifiers should not be the same as the 'network' property
for that interface.
http://wiki.openwrt.org/doc/uci/wireless

-- 
Ben West
http://gowasabi.net
b...@gowasabi.net
314-246-9434
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel