Re: Flashing GSM firmware

2009-03-09 Thread Paul Fertser
Rask Ingemann Lambertsen r...@sygehus.dk writes: I did need two power off/on cycles between the two fluid invocations, though. I found by experimentation that with -od13,13 fluid was able to connect to the bootloader every time i tried power-cycling. But yes, without it it's like 1 out of 20

Re: Flashing GSM firmware

2009-03-09 Thread Tom Yates
On Thu, 5 Mar 2009, Joerg Reisenweber wrote: rootfs is a standard FSO-console MS5 patched to fix doesn't boot on r/o mounted fs issue. Kernel is recent Andy tracking with GSM sysfs node patch created originally by PaulFerster based on my suggestions. then, thank you to all of those people.

Re: Flashing GSM firmware

2009-03-09 Thread Steve 'dillo Okay
On Mar 9, 2009, at 00:44 , Tom Yates wrote: On Thu, 5 Mar 2009, Joerg Reisenweber wrote: rootfs is a standard FSO-console MS5 patched to fix doesn't boot on r/o mounted fs issue. Kernel is recent Andy tracking with GSM sysfs node patch created originally by PaulFerster based on my

Re: Flashing GSM firmware

2009-03-08 Thread Torfinn Ingolfsen
Hello, On Thu, Mar 5, 2009 at 4:22 PM, Tom Yates madhat...@teaparty.net wrote: if anyone else is minded to try it, there are a few more details at http://wiki.openmoko.org/wiki/GSM/Flashing#uSD-card_Image . Will this image work on a Neo 1973 as well? -- Regards, Torfinn Ingolfsen

Re: Flashing GSM firmware

2009-03-08 Thread Paul Fertser
Torfinn Ingolfsen tin...@gmail.com writes: On Thu, Mar 5, 2009 at 4:22 PM, Tom Yates madhat...@teaparty.net wrote: if anyone else is minded to try it, there are a few more details at http://wiki.openmoko.org/wiki/GSM/Flashing#uSD-card_Image . Will this image work on a Neo 1973 as well? Not

Re: Flashing GSM firmware

2009-03-08 Thread Rask Ingemann Lambertsen
On Thu, Mar 05, 2009 at 10:25:40AM +0300, Paul Fertser wrote: All this steps except starting fluid.exe are not strictly necessary and i'd recommend to start fluid like that: FLUID_PORT=/dev/ttySAC0 fluid.exe -oo -od13,13 -f path_to_moko11_bin Notice i use ROM bootloader and moko11

Re: Flashing GSM firmware

2009-03-05 Thread Tom Yates
On Thu, 5 Mar 2009, Paul Fertser wrote: Alternatively, try Joerg's uSD automated image: http://people.openmoko.org/joerg/calypso_moko_FW/moko11/flash-moko11_uSD-image.tar.gz It works and reliably flashes the firmware for you. yaaay joerg and thank you! i just safely and efficiently upgraded

Re: Flashing GSM firmware

2009-03-05 Thread Paul Fertser
Tom Yates madhat...@teaparty.net writes: On Thu, 5 Mar 2009, Paul Fertser wrote: Alternatively, try Joerg's uSD automated image: http://people.openmoko.org/joerg/calypso_moko_FW/moko11/flash-moko11_uSD-image.tar.gz It works and reliably flashes the firmware for you. yaaay joerg and thank

Re: Flashing GSM firmware

2009-03-05 Thread Joerg Reisenweber
Am Do 5. März 2009 schrieb Andy Green: Somebody in the thread at some point said: | On Thu, 5 Mar 2009, Paul Fertser wrote: | | Alternatively, try Joerg's uSD automated image: | http://people.openmoko.org/joerg/calypso_moko_FW/moko11/flash-moko11_uSD-image.tar.gz | | It works and

Re: Flashing GSM firmware

2009-03-05 Thread Andy Green
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Somebody in the thread at some point said: | I think there's a little confusion going on here, AIUI Werner did the | rootfs end and Deiter the GSM firmware upgrade and deserve the thanks | for that. | | You haven't understood it quite right, and

Re: Flashing GSM firmware

2009-03-05 Thread Steve 'dillo Okay
On Mar 5, 2009, at 19:26 , Joerg Reisenweber wrote: Am Do 5. März 2009 schrieb Andy Green: Somebody in the thread at some point said: | On Thu, 5 Mar 2009, Paul Fertser wrote: | | Alternatively, try Joerg's uSD automated image: |

Re: Flashing GSM firmware

2009-03-04 Thread Paul Fertser
Steve 'dillo Okay armad...@roadknightlabs.com writes: I'm trying to flash my GSM firmware and running into a problem. I get to the point where I run the fluid command line and it just sits there. Basically the idea is that in one terminal you run fluid with right parameters, and in the other

Re: Flashing GSM firmware

2009-02-24 Thread Steve 'dillo Okay
On Feb 23, 2009, at 04:48 , community-requ...@lists.openmoko.org wrote: Send community mailing list submissions to community@lists.openmoko.org To subscribe or unsubscribe via the World Wide Web, visit http://lists.openmoko.org/mailman/listinfo/community or, via email, send a

Re: Flashing GSM firmware (was Re: Recommended SIM for Italy ?)

2009-02-24 Thread Peter Klassen
2009/2/23 Steve 'dillo Okay armad...@roadknightlabs.com: r...@om-gta02:/usr/sbin# echo 0 /sys/bus/platform/devices/neo1973-pm- gsm.0/power_on r...@om-gta02:/usr/sbin# echo 1 /sys/bus/platform/devices/neo1973-pm- gsm.0/power_on r...@om-gta02:/usr/sbin# echo a...@poff /dev/ttySAC0

Re: Flashing GSM firmware

2009-02-24 Thread Paul Fertser
Steve \ 'dillo\ Okay armad...@roadknightlabs.com writes: Okay, I am pretty stuck here. I've tried the procedure on the Wiki here: http://wiki.openmoko.org/wiki/GSM/Flashing and here: http://lists.openmoko.org/nabble.html#nabble-td1565196|a1566012 to no effect. I run the fluid command and

Re: Flashing GSM firmware

2009-02-24 Thread Steve 'dillo Okay
On Feb 24, 2009, at 11:01 , Paul Fertser wrote: Steve \ 'dillo\ Okay armad...@roadknightlabs.com writes: Okay, I am pretty stuck here. I've tried the procedure on the Wiki here: http://wiki.openmoko.org/wiki/GSM/Flashing and here:

Re: Flashing GSM firmware

2009-02-24 Thread Steve 'dillo Okay
So fluid is still not flashing the image, but I noticed the following messages on the console after my latest attempt: The error message: rxerr: port ch=0x00, rxs=0x000c shows up in dmesg after I send the command: echo a...@poff /dev/ttySAC0 Looking back through dmesg, this seems to be a

Flashing GSM firmware (was Re: Recommended SIM for Italy ?)

2009-02-23 Thread Steve 'dillo Okay
From: Paul Fertser fercer...@gmail.com Date: February 23, 2009 2:09:45 AM GMT+01:00 To: community@lists.openmoko.org Subject: Re: Recommended SIM for Italy ? Reply-To: List for Openmoko community discussion community@lists.openmoko.org GNUtoo gnu...@no-log.org writes: it's a bug in