Re: Code review request: 6907367 extcheck should skip non-jar files

2011-12-05 Thread Alan Bateman
On 01/12/2011 21:47, Xueming Shen wrote: Please help review the change at http://cr.openjdk.java.net/~sherman/6907367/webrev The proposed change does not include the test case I was originally planed as showed at

Re: please review 7117612: warnings fixes in java.lang

2011-12-05 Thread Alan Bateman
On 05/12/2011 01:02, Stuart Marks wrote: Please review the following webrev submitted by Omair Majid, consisting of warnings fixes for a variety of files in java.lang. http://cr.openjdk.java.net/~omajid/webrevs/warnings-day-2011/01/ It looks pretty clean, but it would be good to get another

java.util and anonymous class

2011-12-05 Thread Rémi Forax
While removing generics warnings in java.util, I've seen that some anonymous classes are coded in a way that make javac to generate too much fields. This code: final ListString list = Arrays.asList(args); IteratorString iterator = new IteratorString() { private IteratorString it =

Re: java.util and anonymous class

2011-12-05 Thread Rémi Forax
On 12/05/2011 11:37 AM, Maurizio Cimadamore wrote: On 05/12/11 10:20, Rémi Forax wrote: While removing generics warnings in java.util, I've seen that some anonymous classes are coded in a way that make javac to generate too much fields. This code: final ListString list = Arrays.asList(args);

Re: java.util and anonymous class

2011-12-05 Thread Maurizio Cimadamore
On 05/12/11 10:20, Rémi Forax wrote: While removing generics warnings in java.util, I've seen that some anonymous classes are coded in a way that make javac to generate too much fields. This code: final ListString list = Arrays.asList(args); IteratorString iterator = new IteratorString() {

Re: Request for Review: 7116914 (Miscellaneous warnings (sun.text))

2011-12-05 Thread Yuka Kamiya
Hi Stuart, All right. Here's a new webrev which includes two changes: - 'length=(srcIndex-prevSrc);' in normalizer/NormalizerImpl.java - @SuppressWarnings(serial) in bidi/BidiBase.java http://cr.openjdk.java.net/~peytoia/7116914/webrev.01/ Could you please review it? Thanks, -- Yuka

Re: RFR 7117360: Warnings in java.util.concurrent.atomic package

2011-12-05 Thread Chris Hegarty
On 05/12/2011 02:52, David Holmes wrote: Thanks Chris and Doug et al. These fixups look good to me too. One minor nit: src/share/classes/java/util/concurrent/atomic/AtomicLong.java The javadoc changes on longValue() changed actual text not just formatting. It changes it to be consistent with

Re: review of 7117249: java.util warnings patches from LJC/Mike Barker

2011-12-05 Thread Alan Bateman
On 04/12/2011 08:56, Michael Barker wrote: Hi, scan of the webrev. There are still a couple of raw type warnings in JarFile and several more in other classes in these packages so it's possible you don't have everything (I wasn't following that thread closely on jdk8-dev). Question on a

Re: Cleanup fallthrough in FilePermission and PropertyPermission was: Request for Review of 7116890 (Warning Cleanup java.io)

2011-12-05 Thread Weijun Wang
On 12/03/2011 06:12 AM, Stuart Marks wrote: I'm adding Weijun (Max) Wang to this thread. The same ackbarfaccept code had come up a third time when I was reviewing some of Max's changes. The code in question all has to do with permissions, and Max is in the security group, so he might have a

hg: jdk8/tl/jdk: 2 new changesets

2011-12-05 Thread alan . bateman
Changeset: 053cb321467a Author:alanb Date: 2011-12-05 12:23 + URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/053cb321467a 7117717: (aio) Tests failing due to implementation bug 7052549 Reviewed-by: weijun, chegar ! test/ProblemList.txt !

RFR 7118066: Warnings in java.util.concurrent package

2011-12-05 Thread Chris Hegarty
Cleanup warnings in the j.u.c. package. This is a sync up with the warning fixes in Doug's CVS. There are also a few style cleanups, import fixes, trivial local variable renaming, typos, etc. But nothing too surprising! http://cr.openjdk.java.net/~chegar/7118066/webrev.00/webrev/ -Chris.

Re: Cleanup fallthrough in FilePermission and PropertyPermission was: Request for Review of 7116890 (Warning Cleanup java.io)

2011-12-05 Thread Sebastian Sickelmann
Am 05.12.2011 12:53, schrieb Weijun Wang: On 12/03/2011 06:12 AM, Stuart Marks wrote: I'm adding Weijun (Max) Wang to this thread. The same ackbarfaccept code had come up a third time when I was reviewing some of Max's changes. The code in question all has to do with permissions, and Max is

Re: please review 7117612: warnings fixes in java.lang

2011-12-05 Thread Omair Majid
On 12/05/2011 01:35 AM, Stuart Marks wrote: Whoops, good catch. Those changes are indeed not permitted. We'll have to use @SuppressWarnings(rawtypes) or some such instead. Thanks for the comments. I have an updated webrev available at:

Re: please review 7117612: warnings fixes in java.lang

2011-12-05 Thread Omair Majid
On 12/05/2011 11:28 AM, Alan Bateman wrote: On 05/12/2011 16:14, Omair Majid wrote: src/windows/classes/java/lang/ProcessEnvironment.java: - Added a serialVersionUID. Unfortunately, I don't have a windows box so I cant identify the previous serialVersionUID value for this class. Can someone

Re: please review 7117612: warnings fixes in java.lang

2011-12-05 Thread Joe Darcy
On 12/4/2011 5:02 PM, Stuart Marks wrote: Please review the following webrev submitted by Omair Majid, consisting of warnings fixes for a variety of files in java.lang. http://cr.openjdk.java.net/~omajid/webrevs/warnings-day-2011/01/ It looks pretty clean, but it would be good to get another

hg: jdk8/tl/jdk: 7117360: Warnings in java.util.concurrent.atomic package

2011-12-05 Thread chris . hegarty
Changeset: f352dd3cdff8 Author:dl Date: 2011-12-05 13:58 + URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/f352dd3cdff8 7117360: Warnings in java.util.concurrent.atomic package Reviewed-by: chegar, dholmes ! src/share/classes/java/util/concurrent/atomic/AtomicBoolean.java !

Re: RFR 7118066: Warnings in java.util.concurrent package

2011-12-05 Thread Maurizio Cimadamore
On 05/12/11 15:36, Chris Hegarty wrote: Cleanup warnings in the j.u.c. package. This is a sync up with the warning fixes in Doug's CVS. There are also a few style cleanups, import fixes, trivial local variable renaming, typos, etc. But nothing too surprising!

Re: Code Review Request for Bug #7069190

2011-12-05 Thread Darryl Mocek
I am withdrawing this request for code review. Thanks, Darryl On Wed 30 Nov 2011 02:16:36 PM PST, Darryl Mocek wrote: Hello. Please review this patch to fix the getting of the user's home setting using System.getProperty(user.home) on UNIX's. The previous implementation used getpwuid, which

Re: RFR 7118066: Warnings in java.util.concurrent package

2011-12-05 Thread Doug Lea
On 12/05/11 12:54, Maurizio Cimadamore wrote: http://cr.openjdk.java.net/~chegar/7118066/webrev.00/webrev/ -Chris. P.S. I have already reviewed this, and the contribution is of course from Doug. Nice work! Some comments below: Thanks for looking at this! In both cases, reducing warnings

hg: jdk8/tl/jdk: 5063455: (fmt) MissingFormatArgumentException.getFormatSpecifier() incorrect return value

2011-12-05 Thread xueming . shen
Changeset: 194faa6fdb3c Author:sherman Date: 2011-12-05 10:50 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/194faa6fdb3c 5063455: (fmt) MissingFormatArgumentException.getFormatSpecifier() incorrect return value Summary: updated the incorrect StringBuilder constructor usage

Re: please review 7117612: warnings fixes in java.lang

2011-12-05 Thread Omair Majid
Hi, On 12/04/2011 08:02 PM, Stuart Marks wrote: Please review the following webrev submitted by Omair Majid, consisting of warnings fixes for a variety of files in java.lang. http://cr.openjdk.java.net/~omajid/webrevs/warnings-day-2011/01/ It looks pretty clean, but it would be good to get

Re: Cleanup fallthrough in FilePermission and PropertyPermission was: Request for Review of 7116890 (Warning Cleanup java.io)

2011-12-05 Thread Eamonn McManus
To my mind, introducing a new shared parent means defining a new API that can be used by third-party subclasses. The point is that these permissions have an action list like read,write,delete, with parsing code that converts this into a bitmask and toString() code that converts it back. I think

Re: Request for Review: 7116914 (Miscellaneous warnings (sun.text))

2011-12-05 Thread Stuart Marks
Looks good. Thanks for making the updates. Go ahead and push. s'marks On 12/5/11 3:05 AM, Yuka Kamiya wrote: Hi Stuart, All right. Here's a new webrev which includes two changes: - 'length=(srcIndex-prevSrc);' in normalizer/NormalizerImpl.java - @SuppressWarnings(serial) in

hg: jdk8/tl/jdk: 7116914: Miscellaneous warnings (sun.text)

2011-12-05 Thread yuka . kamiya
Changeset: ca383e32deaf Author:peytoia Date: 2011-12-06 08:39 +0900 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/ca383e32deaf 7116914: Miscellaneous warnings (sun.text) Reviewed-by: smarks, okutsu ! src/share/classes/sun/text/CompactByteArray.java !

hg: jdk8/tl/jdk: 7116993: fix warnings in java.applet

2011-12-05 Thread stuart . marks
Changeset: f4fe86bba8a2 Author:smarks Date: 2011-12-05 16:30 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/f4fe86bba8a2 7116993: fix warnings in java.applet Reviewed-by: art, smarks Contributed-by: Danesh Dadachanji ddada...@redhat.com !

hg: jdk8/tl/jdk: 7117469: Warning cleanup for j.u.Currency and j.u.Locale related classes

2011-12-05 Thread naoto . sato
Changeset: 85363edbc92f Author:naoto Date: 2011-12-05 17:08 -0800 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/85363edbc92f 7117469: Warning cleanup for j.u.Currency and j.u.Locale related classes Reviewed-by: okutsu, smarks ! src/share/classes/java/util/Currency.java !

Re: RFR 7118066: Warnings in java.util.concurrent package

2011-12-05 Thread David Holmes
Chris, Doug, A few nits see below. Cheers, David - As a matter of style can we ensure annotations are on separate lines. I find this: @SuppressWarnings(unchecked) E x = (E) items[takeIndex]; hard to read. (I hate seeing local variable annotations in the first place - way too much

Re: RFR 7118066: Warnings in java.util.concurrent package

2011-12-05 Thread Rémi Forax
On 12/06/2011 02:12 AM, David Holmes wrote: Chris, Doug, A few nits see below. Cheers, David - As a matter of style can we ensure annotations are on separate lines. I find this: @SuppressWarnings(unchecked) E x = (E) items[takeIndex]; hard to read. (I hate seeing local variable

Re: RFR 7118066: Warnings in java.util.concurrent package

2011-12-05 Thread David Holmes
On 6/12/2011 11:45 AM, Rémi Forax wrote: On 12/06/2011 02:12 AM, David Holmes wrote: Is the reason for constructs like this: HashEntryK,V[] tab = (HashEntryK,V[])new HashEntry?,?[cap]; that we can't utilize diamond? Otherwise it would nicely reduce to: HashEntryK,V[] tab = new

Re: Swing Dev Add LookFeel support for AIX platform

2011-12-05 Thread Sean Chou
Hi, I'm not sure what to do for it next, shall I create a bug for it now ? But I don't think the bug system support AIX platform. I remembered it would report something like we are not supporting the platform. On Tue, Nov 29, 2011 at 10:05 AM, neugens.limasoftw...@gmail.com

Re: Cleanup fallthrough in FilePermission and PropertyPermission was: Request for Review of 7116890 (Warning Cleanup java.io)

2011-12-05 Thread Sebastian Sickelmann
Sorry for the broken history. I am answering to Answering to http://mail.openjdk.java.net/pipermail/core-libs-dev/2011-December/008582.html the mail and my predesecor is not received by my email-provider yet. Email is not the best tool to transport discussion, but the only practically we

Re: RFR 7118066: Warnings in java.util.concurrent package

2011-12-05 Thread David Holmes
On 6/12/2011 12:14 PM, David Holmes wrote: On 6/12/2011 11:45 AM, Rémi Forax wrote: On 12/06/2011 02:12 AM, David Holmes wrote: Is the reason for constructs like this: HashEntryK,V[] tab = (HashEntryK,V[])new HashEntry?,?[cap]; that we can't utilize diamond? Otherwise it would nicely reduce

Re: Swing Dev TextArea's/TextField's enableInputMethods is not working on linux

2011-12-05 Thread Charles Lee
On 05/27/2011 03:18 AM, Naoto Sato wrote: It simply sounds like a bug to me. The behavior should not be different. Naoto (5/26/11 12:25 AM), Sean Chou wrote: Hi all, I found TextArea's/TextField's enableInputMethods is not working on linux, even enableInputMethods(false) is invocated,