hg: jdk8/tl/langtools: 8025118: Annotation processing api returns default modifier for interface without default methods

2013-10-04 Thread jan . lahoda
Changeset: c13305cf8528 Author:jlahoda Date: 2013-10-04 08:29 +0200 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/c13305cf8528 8025118: Annotation processing api returns default modifier for interface without default methods Summary: TypeElement.getModifiers() should not

JDK 8 code review request for JDK-8025913 - Rename jdk.Supported to jdk.Exported

2013-10-04 Thread Joe Darcy
Hello, Per previous discussions on the mailing list, we've decided to rename the annotation type jdk.Supported to jdk.Exported. Other than the file rename, the changes to the contents of the type are below: /** - * Indicates whether or not a JDK specific type or package is a - *

Re: RFR (S) 8025238: nsk/jvmti/scenarios/bcinstr/BI04/bi04t002 crashed with SIGSEGV

2013-10-04 Thread Staffan Larsen
On 4 okt 2013, at 00:49, Coleen Phillmore coleen.phillim...@oracle.com wrote: Thanks Dan - On 10/3/2013 4:28 PM, Daniel D. Daugherty wrote: open webrev at http://cr.openjdk.java.net/~coleenp/8025238_jdk test/java/lang/instrument/RedefineMethodInBacktrace.sh No comments.

Re: JDK 8 RFC 7189139 version 2: BigInteger's staticRandom field can be a source of bottlenecks

2013-10-04 Thread Aleksey Shipilev
On 10/04/2013 03:34 AM, Brian Burkhalter wrote: Here is an alternative solution: http://cr.openjdk.java.net/~bpb/7189139.2/. Seems OK with me, as long as Miller-Rabin test tolerates the lower-entropy PRNG. If this seems reasonable, does anyone have suggestions as to testing? I would like to

Re: JDK 8 code review request for JDK-8025913 - Rename jdk.Supported to jdk.Exported

2013-10-04 Thread Paul Sandoz
+1. Paul. On Oct 4, 2013, at 8:43 AM, Joe Darcy joe.da...@oracle.com wrote: Hello, Per previous discussions on the mailing list, we've decided to rename the annotation type jdk.Supported to jdk.Exported. Other than the file rename, the changes to the contents of the type are below:

Re: RFR (S) CR 6857566: (bf) DirectByteBuffer garbage creation can outpace reclamation

2013-10-04 Thread Peter Levart
Hi Aleksey, I played with reference handling code and got the following idea: Instead of iterating over the set of active Cleaners looking for those that were cleared by the VM, make ReferenceQueue.poll/remove help ReferenceHandler thread in enqueue-ing the references. This assumes VM links

Re: RFR (S) CR 6857566: (bf) DirectByteBuffer garbage creation can outpace reclamation

2013-10-04 Thread Peter Levart
Hi Aleksey, This one is even better: http://cr.openjdk.java.net/~plevart/jdk8-tl/Cleaners/webrev.02/ Instead of hooking up on the ReferenceQueue.poll/remove methods, there are two new methods in ReferenceQueue: drain/drainLoop - only the 1st one helps in enqueue-ing while holding the

hg: jdk8/tl/nashorn: 8025771: Enhance Nashorn Contexts

2013-10-04 Thread sundararajan . athijegannathan
Changeset: 3470bc26128f Author:sundar Date: 2013-10-04 16:21 +0530 URL: http://hg.openjdk.java.net/jdk8/tl/nashorn/rev/3470bc26128f 8025771: Enhance Nashorn Contexts Reviewed-by: jlaskey, hannesw - make/java.security.override ! make/project.properties !

Re: JDK 8 code review request for JDK-8025913 - Rename jdk.Supported to jdk.Exported

2013-10-04 Thread Alan Bateman
On 03/10/2013 23:43, Joe Darcy wrote: : The webrev http://cr.openjdk.java.net/~darcy/8025913.0/ also contains the update for replacing all previous uses of jdk.Supported in the langtools repo with jdk.Exported. The Supported annotation type was not applied outside of langtools. Thanks

Re: (jaxp) RFR - 8025745: Clarify API documentation of JAXP factories.

2013-10-04 Thread Alan Bateman
On 04/10/2013 03:02, Daniel Fuchs wrote: : http://cr.openjdk.java.net/~dfuchs/webrev_8025745/webrev.00/ This mostly looks good, the only thing is that it reads the service-provider will use ... but I think you mean the service-provider loading facility will use ... -Alan.

Re: RFR (S) CR 6857566: (bf) DirectByteBuffer garbage creation can outpace reclamation

2013-10-04 Thread Aleksey Shipilev
Hi Peter, On 10/04/2013 04:43 PM, Peter Levart wrote: http://cr.openjdk.java.net/~plevart/jdk8-tl/Cleaners/webrev.02/ So you are taking on assisting the ReferenceHandler directly. Nice idea. I can only glimpse over the changes at this point... - You can't add the public methods to java.ref.*

hg: jdk8/tl/jdk: 8025829: Add java/lang/instrument/RetransformBigClass.sh to problemlist

2013-10-04 Thread staffan . larsen
Changeset: 77ba1e67707c Author:allwin Date: 2013-10-04 15:00 +0200 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/77ba1e67707c 8025829: Add java/lang/instrument/RetransformBigClass.sh to problemlist Reviewed-by: sla, jbachorik ! test/ProblemList.txt

Re: RFR: 8013839: Enhance Logger API for handling of resource bundles

2013-10-04 Thread Daniel Fuchs
Hi Mandy, On 10/3/13 9:29 PM, Mandy Chung wrote: test/java/util/ResourceBundle/getBaseBundleName/TestGetBaseBundleName.java 109 return new VectorString(java.util.Arrays.asList( 110 new String[] {dummy})).elements(); Could you use

Re: Review Request for project Threeten updates

2013-10-04 Thread Xueming Shen
looks fine. -sherman On 10/4/13 7:45 AM, roger riggs wrote: The webrev has been updated to: - In the until methods, add exclusive to the descriptions in the @param tags in addition to the parameter name - Optimize the use of requireNonNull so it appears only in the paths for instanceof ==

Re: (jaxp) RFR - 8025745: Clarify API documentation of JAXP factories.

2013-10-04 Thread Paul Sandoz
On Oct 4, 2013, at 6:11 PM, Daniel Fuchs daniel.fu...@oracle.com wrote: On 10/4/13 3:33 PM, Alan Bateman wrote: On 04/10/2013 03:02, Daniel Fuchs wrote: : http://cr.openjdk.java.net/~dfuchs/webrev_8025745/webrev.00/ This mostly looks good, the only thing is that it reads the

Re: JDK 8 code review request for JDK-8025913 - Rename jdk.Supported to jdk.Exported

2013-10-04 Thread Jonathan Gibbons
On 10/03/2013 11:43 PM, Joe Darcy wrote: Hello, Per previous discussions on the mailing list, we've decided to rename the annotation type jdk.Supported to jdk.Exported. Other than the file rename, the changes to the contents of the type are below: /** - * Indicates whether or not a JDK

hg: jdk8/tl/jdk: 7 new changesets

2013-10-04 Thread roger . riggs
Changeset: 1de0fac9b962 Author:rriggs Date: 2013-08-29 20:38 +0100 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/1de0fac9b962 8023764: Optimize Period addition Summary: Optimise plus/minus for common cases Reviewed-by: sherman Contributed-by: scolebou...@joda.org !

hg: jdk8/tl/jdk: 8021186: jdk/lambda/vm/DefaultMethodsTest.java fails

2013-10-04 Thread robert . field
Changeset: 7736abdf0805 Author:rfield Date: 2013-10-04 09:54 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/7736abdf0805 8021186: jdk/lambda/vm/DefaultMethodsTest.java fails Summary: remove DefaultMethodsTest from jdk/test/problemList.txt Reviewed-by: mduigou !

hg: jdk8/tl/langtools: 8025913: Rename jdk.Supported to jdk.Exported

2013-10-04 Thread joe . darcy
Changeset: 379c04c090cf Author:darcy Date: 2013-10-04 10:00 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/379c04c090cf 8025913: Rename jdk.Supported to jdk.Exported Reviewed-by: psandoz, forax, lancea, alanb, mchung, jjg !

Re: JDK 8 code review request for JDK-8025913 - Rename jdk.Supported to jdk.Exported

2013-10-04 Thread mark . reinhold
2013/10/3 16:43 -0700, joe.da...@oracle.com: Per previous discussions on the mailing list, we've decided to rename the annotation type jdk.Supported to jdk.Exported. ... Looks good to me. One question, though: Is it intended that one use of this annotation can be overridden by another at a

Re: RFR (M) 8001110: method handles should have a collectArguments transform, generalizing asCollector

2013-10-04 Thread Christian Thalinger
src/share/classes/java/lang/invoke/MethodHandles.java: You have renamed coll to filter but the documentation still references coll in multiple places, e.g.: + * If the filter method handle {@code coll} consumes one argument and produces + * a non-void result, then {@code

Re: (jaxp) RFR - 8025745: Clarify API documentation of JAXP factories.

2013-10-04 Thread huizhe wang
On 10/4/2013 9:36 AM, Paul Sandoz wrote: On Oct 4, 2013, at 6:11 PM, Daniel Fuchs daniel.fu...@oracle.com wrote: On 10/4/13 3:33 PM, Alan Bateman wrote: On 04/10/2013 03:02, Daniel Fuchs wrote: : http://cr.openjdk.java.net/~dfuchs/webrev_8025745/webrev.00/ This mostly looks good, the only

Re: RFR (M) 8001110: method handles should have a collectArguments transform, generalizing asCollector

2013-10-04 Thread John Rose
Yikes; good catch. I used javac -Xdoclint to find a couple typos in @param also. — John On Oct 4, 2013, at 11:17 AM, Christian Thalinger christian.thalin...@oracle.com wrote: You have renamed coll to filter but the documentation still references coll in multiple places, e.g.: + *

hg: jdk8/tl/jaxp: 8025745: Clarify API documentation of JAXP factories.

2013-10-04 Thread daniel . fuchs
Changeset: f031b2fe21cd Author:dfuchs Date: 2013-10-04 19:15 +0200 URL: http://hg.openjdk.java.net/jdk8/tl/jaxp/rev/f031b2fe21cd 8025745: Clarify API documentation of JAXP factories. Summary: Clarifies usage of ServiceLoader in JAXP factories. Reviewed-by: alanb, joehw, psandoz !

Re: RFR (S) CR 6857566: (bf) DirectByteBuffer garbage creation can outpace reclamation

2013-10-04 Thread mark . reinhold
2013/10/2 15:13 -0700, alan.bate...@oracle.com: BTW: Is this important enough to attempt to do this late in 8? I just wonder about a significant change like switching to weak references and whether it would be more sensible to hold it back to do early in 9. I share your concern. This is

RFR: improved exception messages in java.time 8025718

2013-10-04 Thread roger riggs
Hi, Please review these small improvements in messages resulting from parsing date and time errors and corresponding tests. Webrev: http://cr.openjdk.java.net/~rriggs/webrev-better-msg-8025718/ JBS: https://bugs.openjdk.java.net/browse/JDK-8025718 Thanks, Roger

hg: jdk8/tl/langtools: 8008164: Invisible table captions in javadoc-generated html

2013-10-04 Thread bhavesh . x . patel
Changeset: 6e186ca11ec0 Author:bpatel Date: 2013-10-04 13:32 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/6e186ca11ec0 8008164: Invisible table captions in javadoc-generated html Reviewed-by: jjg !

hg: jdk8/tl/langtools: 8024756: method grouping tabs are not selectable

2013-10-04 Thread bhavesh . x . patel
Changeset: 3344ea7404b1 Author:bpatel Date: 2013-10-04 13:41 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/3344ea7404b1 8024756: method grouping tabs are not selectable Reviewed-by: jjg ! src/share/classes/com/sun/tools/doclets/formats/html/markup/HtmlWriter.java !

Re: JDK 8 RFR 7179567: JCK8 tests: api/java_net/URLClassLoader/index.html#Ctor3 failed with NPE

2013-10-04 Thread Brian Burkhalter
On Oct 3, 2013, at 5:38 PM, Brian Burkhalter wrote: On Oct 3, 2013, at 5:35 PM, Alan Bateman wrote: On 03/10/2013 16:10, Brian Burkhalter wrote: Please review and comment at your convenience. Issue: https://bugs.openjdk.java.net/browse/JDK-7179567 Webrev:

hg: jdk8/tl/langtools: 8022163: javac exits with 0 status and no messages on error to construct an ann-procesor

2013-10-04 Thread jonathan . gibbons
Changeset: 2fa6ced325cc Author:jjg Date: 2013-10-04 13:59 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/2fa6ced325cc 8022163: javac exits with 0 status and no messages on error to construct an ann-procesor Reviewed-by: darcy !

Re: RFR (M) 8001110: method handles should have a collectArguments transform, generalizing asCollector

2013-10-04 Thread John Rose
Actually it's OK: The name coll is defined a couple lines up by the A collection adapter {@code collectArguments(mh, 0, coll)} ..., and the term filter is persistently applied to it. So I think it is intelligible as posted. — John On Oct 4, 2013, at 11:34 AM, John Rose john.r.r...@oracle.com

hg: jdk8/tl/langtools: 6525408: DiagnosticListener should receive MANDATORY_WARNING in standard compiler mode

2013-10-04 Thread jonathan . gibbons
Changeset: 515d54c1b063 Author:jjg Date: 2013-10-04 14:46 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/515d54c1b063 6525408: DiagnosticListener should receive MANDATORY_WARNING in standard compiler mode Reviewed-by: darcy !

Re: RFR (M) 8001110: method handles should have a collectArguments transform, generalizing asCollector

2013-10-04 Thread Christian Thalinger
On Oct 4, 2013, at 2:40 PM, John Rose john.r.r...@oracle.com wrote: Actually it's OK: The name coll is defined a couple lines up by the A collection adapter {@code collectArguments(mh, 0, coll)} ..., and the term filter is persistently applied to it. So I think it is intelligible as

hg: jdk8/tl/langtools: 8025970: Spurious characters in JavaCompiler

2013-10-04 Thread jonathan . gibbons
Changeset: 3e3c321710be Author:jjg Date: 2013-10-04 15:24 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/3e3c321710be 8025970: Spurious characters in JavaCompiler Reviewed-by: ksrini ! src/share/classes/com/sun/tools/javac/main/JavaCompiler.java

hg: jdk8/tl: 8025741: Fix jdk/make/docs/Makefile to point to correct docs URL for JDK 8.

2013-10-04 Thread bhavesh . x . patel
Changeset: 6b8f5030e5ad Author:bpatel Date: 2013-10-04 15:26 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/rev/6b8f5030e5ad 8025741: Fix jdk/make/docs/Makefile to point to correct docs URL for JDK 8. Reviewed-by: tbell ! common/makefiles/javadoc/Javadoc.gmk

hg: jdk8/tl/jdk: 8025741: Fix jdk/make/docs/Makefile to point to correct docs URL for JDK 8.

2013-10-04 Thread bhavesh . x . patel
Changeset: 66181f7991bd Author:bpatel Date: 2013-10-04 15:25 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/jdk/rev/66181f7991bd 8025741: Fix jdk/make/docs/Makefile to point to correct docs URL for JDK 8. Reviewed-by: tbell ! make/docs/Makefile

RFR: 8025968: Integrate test improvements made in lambda repo

2013-10-04 Thread Henry Jen
Hi, Please review a port from lambda repo to tl, it contains a refactoring of OpTestCase and a small addition to fill test gap. http://cr.openjdk.java.net/~henryjen/tl/8025968/0/webrev/ Cheers, Henry

hg: jdk8/tl/langtools: 8003537: javap use internal class name when printing bound of type variable

2013-10-04 Thread kumar . x . srinivasan
Changeset: bb87db832b31 Author:ksrini Date: 2013-10-04 16:08 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/bb87db832b31 8003537: javap use internal class name when printing bound of type variable Reviewed-by: jjg !

Re: Question about JDK-8023087

2013-10-04 Thread Joseph Darcy
Enum constructors (as compiled by javac) have synthetic parameters; constructors of nested classes [1] can have either implicit or synthetic parameters. HTH, -Joe [1] https://blogs.oracle.com/darcy/entry/nested_inner_member_and_top On 9/30/2013 8:25 PM, Eric Wang wrote: Including the

hg: jdk8/tl/langtools: 8005542: jtreg test OverrideBridge.java contains @ignore

2013-10-04 Thread kumar . x . srinivasan
Changeset: 15651a673358 Author:ksrini Date: 2013-10-04 16:23 -0700 URL: http://hg.openjdk.java.net/jdk8/tl/langtools/rev/15651a673358 8005542: jtreg test OverrideBridge.java contains @ignore Reviewed-by: jjg Contributed-by: steve.si...@oracle.com -

EnumSet and reification

2013-10-04 Thread cowwoc
Hi, Out of curiosity, is JDK 8's type reification improved enough so that we can replace E extends EnumE EnumSetE EnumSet.noneOf(ClassE) with E extends EnumE EnumSetE EnumSet.noneOf() and the JDK will figure out the value of E based on the expected return type? If so, can we