Re: RFR: 8326891: Prefer RPATH over RUNPATH for $ORIGIN rpaths in internal JDK binaries

2024-02-28 Thread David Holmes
On Wed, 28 Feb 2024 19:29:13 GMT, Erik Joelsson wrote: > There is no supported usecase that I can think of for injecting other > versions of such libraries in a JDK distribution. I can imagine it could be used to allow "hot patching" of the installed JDK/JRE. Whether anyone has ever needed to

Integrated: 8324799: Use correct extension for C++ test headers

2024-02-28 Thread Kim Barrett
On Wed, 28 Feb 2024 01:18:50 GMT, Kim Barrett wrote: > Please review this change that renames some test .h files to .hpp. These > files contain C++ code and should be named accordingly. Some of them contain > uses of NULL, which we change to nullptr. > > The renamed files are: > > test/hotspo

Re: RFR: 8324799: Use correct extension for C++ test headers [v2]

2024-02-28 Thread Kim Barrett
On Thu, 29 Feb 2024 00:16:28 GMT, Kim Barrett wrote: >> Please review this change that renames some test .h files to .hpp. These >> files contain C++ code and should be named accordingly. Some of them contain >> uses of NULL, which we change to nullptr. >> >> The renamed files are: >> >> test

Re: RFR: 8324799: Use correct extension for C++ test headers [v2]

2024-02-28 Thread Guoxiong Li
On Thu, 29 Feb 2024 00:16:28 GMT, Kim Barrett wrote: >> Please review this change that renames some test .h files to .hpp. These >> files contain C++ code and should be named accordingly. Some of them contain >> uses of NULL, which we change to nullptr. >> >> The renamed files are: >> >> test

Re: RFR: 8326227: Rounding error that may distort computeNextGaussian results [v3]

2024-02-28 Thread Chris Hennick
On Wed, 21 Feb 2024 02:18:08 GMT, Chris Hennick wrote: >> This provides a slightly more accurate bounding limit for >> `computeNextExponentialSoftCapped` when the computed bound is greater than >> `(1.0p53 - 1.0) * DoubleZigguratTables.exponentialX0`. This could cause the >> `while (computeNex

Re: RFR: 8324799: Use correct extension for C++ test headers [v2]

2024-02-28 Thread Kim Barrett
On Wed, 28 Feb 2024 14:15:25 GMT, Coleen Phillimore wrote: >> test/hotspot/jtreg/serviceability/jvmti/vthread/FollowReferences/libVThreadStackRefTest.cpp >> line 26: >> >>> 24: #include >>> 25: #include >>> 26: #include >> >> Should this be in quotes rather than <> ? > > Suggestion: > > #i

Re: RFR: 8324799: Use correct extension for C++ test headers [v2]

2024-02-28 Thread Kim Barrett
On Wed, 28 Feb 2024 14:18:58 GMT, Coleen Phillimore wrote: >> Kim Barrett has updated the pull request incrementally with two additional >> commits since the last revision: >> >> - add Oracle copyright >> - fix busted copyright text > > test/hotspot/jtreg/vmTestbase/nsk/jvmti/GetClassStatus/g

Re: RFR: 8324799: Use correct extension for C++ test headers [v2]

2024-02-28 Thread Kim Barrett
On Wed, 28 Feb 2024 04:06:08 GMT, Guoxiong Li wrote: >> Kim Barrett has updated the pull request incrementally with two additional >> commits since the last revision: >> >> - add Oracle copyright >> - fix busted copyright text > > test/hotspot/jtreg/serviceability/jvmti/thread/GetStackTrace/G

Re: RFR: 8324799: Use correct extension for C++ test headers [v2]

2024-02-28 Thread Kim Barrett
On Wed, 28 Feb 2024 14:11:49 GMT, Coleen Phillimore wrote: >> test/hotspot/jtreg/serviceability/jvmti/events/SingleStep/singlestep01/libsinglestep01.cpp >> line 28: >> >>> 26: #include >>> 27: #include >>> 28: #include "jvmti_common.hpp" >> >> The copyright of this file is wrong. >> >>> *

Re: RFR: 8324799: Use correct extension for C++ test headers [v2]

2024-02-28 Thread Kim Barrett
> Please review this change that renames some test .h files to .hpp. These > files contain C++ code and should be named accordingly. Some of them contain > uses of NULL, which we change to nullptr. > > The renamed files are: > > test/hotspot/jtreg/vmTestbase/nsk/share/aod/aod.h > test/hotspot/j

RFD: java.util.jar.Manifest.make72Safe has an invalid @deprecation tag

2024-02-28 Thread Eirik Bjørsnøs
Hi, The non-public method java.util.jar.Manifest.make72Safe is marked @Deprecated(since="13"). However, the Javadoc comment has a '@deprecation' tag which presumably should have been `@deprecated`. I first thought of proposing a PR to fix the invalid tag, but then I noticed that the method is no

Re: RFR: 8324799: Use correct extension for C++ test headers

2024-02-28 Thread Leonid Mesnik
On Wed, 28 Feb 2024 01:18:50 GMT, Kim Barrett wrote: > Please review this change that renames some test .h files to .hpp. These > files contain C++ code and should be named accordingly. Some of them contain > uses of NULL, which we change to nullptr. > > The renamed files are: > > test/hotspo

RFR: 8326891: Prefer RPATH over RUNPATH for $ORIGIN rpaths in internal JDK binaries

2024-02-28 Thread Erik Joelsson
Executables and dynamic libraries on Linux can encode a search path that the dynamic linker will use when looking up library dependencies, generally referred to as an "rpath". In the JDK we use this with the $ORIGIN feature to set search paths relative to the location of the binary itself. Typic

Result: New Core Libraries Group Member: Raffaello Giulietti

2024-02-28 Thread Brian Burkhalter
The vote for Raffaello Giulietti [1] is now closed. Yes: 14 Veto: 0 Abstain: 0 According to the Bylaws definition of Lazy Consensus, this is sufficient to approve the nomination. Brian Burkhalter [1] https://mail.openjdk.org/pipermail/core-libs-dev/2024-February/119208.html

Re: RFR: JDK-8316708: Augment WorstCaseTests with more cases [v8]

2024-02-28 Thread Joe Darcy
On Wed, 28 Feb 2024 06:08:18 GMT, Joe Darcy wrote: >> A new paper >> >> "Accuracy of Mathematical Functions in Single, Double, Double Extended, and >> Quadruple Precision" >> by Brian Gladman, Vincenzo Innocente and Paul Zimmermann >> https://members.loria.fr/PZimmermann/papers/accuracy.pdf >>

Integrated: 8326687: Inconsistent use of "ZIP", "Zip" and "zip" in java.util.zip/jar zipfs javadoc

2024-02-28 Thread Lance Andersen
On Mon, 26 Feb 2024 19:55:47 GMT, Lance Andersen wrote: > This PR updates the javadoc and comments within java.util.zip/jar and zipfs > module summary so that it is consistent with the use of "ZIP". > > In addition, open/src/java.base/share/classes/java/util/zip/package-info.java > has been up

Re: RFR: 8326172: Dubious claim on long[]/double[] alignment in MemorySegment javadoc [v3]

2024-02-28 Thread Guoxiong Li
On Mon, 26 Feb 2024 15:10:55 GMT, Maurizio Cimadamore wrote: >> Jorn Vernee has updated the pull request incrementally with one additional >> commit since the last revision: >> >> re-widen test > > src/java.base/share/classes/java/lang/foreign/MemorySegment.java line 328: > >> 326: * p

Re: RFR: 8326687: Inconsistent use of "ZIP", "Zip" and "zip" in java.util.zip/jar zipfs javadoc [v2]

2024-02-28 Thread Lance Andersen
On Wed, 28 Feb 2024 14:03:58 GMT, Jaikiran Pai wrote: > GitHub doesn't allow me to comment on unchanged lines in the PR, but while > reviewing this I noticed 2 things: > > * It looks like http://www.pkware.com/documents/casestudies/APPNOTE.TXT is > now auto redirecting to > https://pkware.cac

Re: RFR: 8326718: Test java/util/Formatter/Padding.java does not timeout on large inputs before JDK-8299677

2024-02-28 Thread Raffaello Giulietti
On Tue, 27 Feb 2024 20:37:03 GMT, Chad Rakoczy wrote: >> The fix in JDK-8299677 serves it's intended purpose but the test added with >> it does not test that. The original test does not timeout before or after >> the fix which is the issue. >> >> "8326718: Test java/util/Formatter/Padding.java

Re: RFR: 8310837: Use ByteArrayLittleEndian in java.util.zip [v7]

2024-02-28 Thread Glavo
On Wed, 28 Feb 2024 07:17:42 GMT, Jaikiran Pai wrote: > Hello Glavo, I'll need some more time on this to review this. In the > meantime, could you update the micro benchmark latest numbers with this > latest state? Latest results: Benchmark (size) Mode Cnt Scor

Re: RFR: 8326687: Inconsistent use of "ZIP", "Zip" and "zip" in java.util.zip/jar zipfs javadoc [v2]

2024-02-28 Thread Lance Andersen
On Wed, 28 Feb 2024 13:58:01 GMT, Jaikiran Pai wrote: > Hello Lance, this doc-only change looks good to me. > > These changes are merely changing the case of `zip` and aren't changing any > specification of the APIs and that looks fine to me. > > I had imagined that we would be changing only t

Re: RFR: 8326687: Inconsistent use of "ZIP", "Zip" and "zip" in java.util.zip/jar zipfs javadoc [v2]

2024-02-28 Thread Guoxiong Li
On Tue, 27 Feb 2024 16:15:06 GMT, Lance Andersen wrote: >> This PR updates the javadoc and comments within java.util.zip/jar and zipfs >> module summary so that it is consistent with the use of "ZIP". >> >> In addition, >> open/src/java.base/share/classes/java/util/zip/package-info.java has be

Re: RFR: 8324799: Use correct extension for C++ test headers

2024-02-28 Thread Coleen Phillimore
On Wed, 28 Feb 2024 03:58:39 GMT, Guoxiong Li wrote: >> Please review this change that renames some test .h files to .hpp. These >> files contain C++ code and should be named accordingly. Some of them contain >> uses of NULL, which we change to nullptr. >> >> The renamed files are: >> >> test

Re: RFR: 8326687: Inconsistent use of "ZIP", "Zip" and "zip" in java.util.zip/jar zipfs javadoc [v2]

2024-02-28 Thread Lance Andersen
On Wed, 28 Feb 2024 14:13:57 GMT, Guoxiong Li wrote: > I search the package `java.util.zip` and find several `zip64` in the file > [ZipConstants64.java](https://github.com/openjdk/jdk/blob/baa67f1130947c7204fc12018d25bfb48528784c/src/java.base/share/classes/java/util/zip/ZipConstants64.java#L51)

Re: RFR: 8324799: Use correct extension for C++ test headers

2024-02-28 Thread Coleen Phillimore
On Wed, 28 Feb 2024 01:18:50 GMT, Kim Barrett wrote: > Please review this change that renames some test .h files to .hpp. These > files contain C++ code and should be named accordingly. Some of them contain > uses of NULL, which we change to nullptr. > > The renamed files are: > > test/hotspo

Re: RFR: 8324799: Use correct extension for C++ test headers

2024-02-28 Thread Coleen Phillimore
On Wed, 28 Feb 2024 14:13:58 GMT, Coleen Phillimore wrote: >> Please review this change that renames some test .h files to .hpp. These >> files contain C++ code and should be named accordingly. Some of them contain >> uses of NULL, which we change to nullptr. >> >> The renamed files are: >> >

Re: RFR: 8310837: Use ByteArrayLittleEndian in java.util.zip [v8]

2024-02-28 Thread Glavo
> Using `ByteArrayLittleEndian` is simpler and faster. > > `make test TEST="micro:java.util.zip.ZipFileOpen"`: > > > Benchmark (size) Mode Cnt Score Error Units > - ZipFileOpen.openCloseZipFile 512 avgt 15 39052.832 ± 107.496 ns/op > + ZipFileOpen.ope

Re: RFR: 8326687: Inconsistent use of "ZIP", "Zip" and "zip" in java.util.zip/jar zipfs javadoc [v2]

2024-02-28 Thread Guoxiong Li
On Tue, 27 Feb 2024 16:15:06 GMT, Lance Andersen wrote: >> This PR updates the javadoc and comments within java.util.zip/jar and zipfs >> module summary so that it is consistent with the use of "ZIP". >> >> In addition, >> open/src/java.base/share/classes/java/util/zip/package-info.java has be

Re: RFR: 8326687: Inconsistent use of "ZIP", "Zip" and "zip" in java.util.zip/jar zipfs javadoc [v2]

2024-02-28 Thread Jaikiran Pai
On Tue, 27 Feb 2024 16:15:06 GMT, Lance Andersen wrote: >> This PR updates the javadoc and comments within java.util.zip/jar and zipfs >> module summary so that it is consistent with the use of "ZIP". >> >> In addition, >> open/src/java.base/share/classes/java/util/zip/package-info.java has be

Re: RFR: 8326687: Inconsistent use of "ZIP", "Zip" and "zip" in java.util.zip/jar zipfs javadoc [v2]

2024-02-28 Thread Jaikiran Pai
On Tue, 27 Feb 2024 16:15:06 GMT, Lance Andersen wrote: >> This PR updates the javadoc and comments within java.util.zip/jar and zipfs >> module summary so that it is consistent with the use of "ZIP". >> >> In addition, >> open/src/java.base/share/classes/java/util/zip/package-info.java has be

Re: RFR: 8310837: Use ByteArrayLittleEndian in java.util.zip [v7]

2024-02-28 Thread Lance Andersen
On Tue, 16 Jan 2024 16:38:34 GMT, Glavo wrote: >> Using `ByteArrayLittleEndian` is simpler and faster. >> >> `make test TEST="micro:java.util.zip.ZipFileOpen"`: >> >> >> Benchmark (size) Mode Cnt Score Error >> Units >> - ZipFileOpen.openCloseZipFile 512

Re: RFR: 8326096: Deprecate getTotalIn, getTotalOut methods of java.util.zip.Inflater, java.util.zip.Deflater [v11]

2024-02-28 Thread Lance Andersen
On Wed, 28 Feb 2024 09:19:20 GMT, Eirik Bjørsnøs wrote: >> Please review this PR which proposes that we officially deprecate the >> following four methods in the `java.util.zip` package: >> >> * `Inflater.getTotalIn()` >> * `Inflater.getTotalOut()` >> * `Deflater.getTotalIn()` >> * `Deflater.ge

Re: RFR: 8326591: New test JmodExcludedFiles.java fails on Windows when --with-external-symbols-in-bundles=public is used

2024-02-28 Thread Matthias Baesken
On Fri, 23 Feb 2024 19:18:46 GMT, Christoph Langer wrote: > The new test JmodExcludedFiles.java checks that no debug symbol files are > contained in the jmod files. It does not take into account that with > configure option --with-external-symbols-in-bundles=public we want to have > stripped p

Re: RFR: 8326947: Minimize MakeBase.gmk

2024-02-28 Thread Magnus Ihse Bursie
On Wed, 28 Feb 2024 11:24:06 GMT, Magnus Ihse Bursie wrote: > This is part of a general "spring cleaning" of the build system, addressing > old code that has bit-rotted, been subject to lava flow, or just had bad or > smelly code that we've never gotten around to fix. > > This particular patch

RFR: 8326947: Minimize MakeBase.gmk

2024-02-28 Thread Magnus Ihse Bursie
This is part of a general "spring cleaning" of the build system, addressing old code that has bit-rotted, been subject to lava flow, or just had bad or smelly code that we've never gotten around to fix. This particular patch tries to make MakeBase truly minimal; only including the core parts of

Re: RFR: 8326096: Deprecate getTotalIn, getTotalOut methods of java.util.zip.Inflater, java.util.zip.Deflater [v11]

2024-02-28 Thread Alan Bateman
On Wed, 28 Feb 2024 09:19:20 GMT, Eirik Bjørsnøs wrote: >> Please review this PR which proposes that we officially deprecate the >> following four methods in the `java.util.zip` package: >> >> * `Inflater.getTotalIn()` >> * `Inflater.getTotalOut()` >> * `Deflater.getTotalIn()` >> * `Deflater.ge

Re: RFR: 8326096: Deprecate getTotalIn, getTotalOut methods of java.util.zip.Inflater, java.util.zip.Deflater [v10]

2024-02-28 Thread Eirik Bjørsnøs
On Tue, 27 Feb 2024 20:14:27 GMT, Lance Andersen wrote: > Yes please move forward and thank you I have updated javadocs for the remaining methods. The CSR has been proposed and is ready for the initial round of review: https://bugs.openjdk.org/browse/JDK-8326326 - PR Comment: htt

Re: RFR: 8326096: Deprecate getTotalIn, getTotalOut methods of java.util.zip.Inflater, java.util.zip.Deflater [v11]

2024-02-28 Thread Eirik Bjørsnøs
> Please review this PR which proposes that we officially deprecate the > following four methods in the `java.util.zip` package: > > * `Inflater.getTotalIn()` > * `Inflater.getTotalOut()` > * `Deflater.getTotalIn()` > * `Deflater.getTotalOut()` > > Since these legacy methods return `int`, they c

Re: RFR: 8310837: Use ByteArrayLittleEndian in java.util.zip [v7]

2024-02-28 Thread Per Minborg
On Tue, 16 Jan 2024 16:38:34 GMT, Glavo wrote: >> Using `ByteArrayLittleEndian` is simpler and faster. >> >> `make test TEST="micro:java.util.zip.ZipFileOpen"`: >> >> >> Benchmark (size) Mode Cnt Score Error >> Units >> - ZipFileOpen.openCloseZipFile 512

Re: RFR: JDK-8323186: A faster algorithm for MutablebigInteger.divWord(long, int) [v3]

2024-02-28 Thread Daniel Jeliński
On Mon, 22 Jan 2024 18:52:32 GMT, fabioromano1 wrote: >> As you note, that would probably require two divisions. I don't know if the >> JIT compiler can detect that the arguments are the same and emit just one >> division instead. >> I think your code is good enough for the purpose of [Mutable]

Integrated: JDK-8326389: [test] improve assertEquals failure output

2024-02-28 Thread Matthias Baesken
On Wed, 21 Feb 2024 15:25:36 GMT, Matthias Baesken wrote: > Currently assertEquals has in the failure case sometimes confusing output > like : > > java.lang.RuntimeException: VM output should contain exactly one RTM locking > statistics entry for method > compiler.rtm.locking.TestRTMTotalCoun

Re: RFR: JDK-8326389: [test] improve assertEquals failure output [v4]

2024-02-28 Thread Matthias Baesken
On Tue, 27 Feb 2024 16:48:05 GMT, Matthias Baesken wrote: >> Currently assertEquals has in the failure case sometimes confusing output >> like : >> >> java.lang.RuntimeException: VM output should contain exactly one RTM locking >> statistics entry for method >> compiler.rtm.locking.TestRTMTot