Re: isif - debugging on dm365

2010-04-12 Thread Raffaele Recalcati
Hi Jean-Philippe, I finally create my patch against f5cef8f45739db4c0c1c346296922cac274c87eb in attachment, but the problem is that isif_set_hw_if_params is not called by gstreamer. If I set in drivers/media/video/davinci/isif.c (and not in drivers/media/video/davinci/dm365_ccdc.c as I don't

Re: isif - debugging on dm365

2010-04-12 Thread Jean-Philippe François
I suppose it does not work, because isif_set_hw_if params is only called if the user applications is doing a VIDIOC_S_INPUT. based on your log, it seems gstreamer does not do that. I don't know if the driver or the application should be corrected. May be there is a command switch to gstreamer

Re: dm365 - voice codec

2010-04-12 Thread Raffaele Recalcati
Hello everybody. If I'm not wrong it doesn't yet exist the voice codec for dm365. Is there any roadmap to support this peripheral? Thank in advance. 2010/4/1 Raffaele Recalcati lamiapost...@gmail.com It seems that in git kernel this peripheral is not yet supported. I search everywere:

RE: SPI Support for DA850 (OMAPL-138).

2010-04-12 Thread Brian Niebuhr
Mike - I do plan on resubmitting the driver as a replacement driver (remove the old and add the updated version) as suggested by TI. I am just trying to get some other work finished up first. If you want to try the version I submitted, the patch was actually against the arago kernel. You

Re: [PATCH v2 14/16] Davinci: tnetv107x gpio implementation

2010-04-12 Thread Cyril Chemparathy
Hi Kevin, Both the existing functions and the new functions all do basically the same thing: - read base + offset - set/clear bit(s) based on GPIO# - write base + offset Davinci doesn't really do a read-modify-write. Instead, it sets bits into set_data/clr_data registers to indirectly

[PATCH 0/8] davinci common code changes for tnetv107x

2010-04-12 Thread Cyril Chemparathy
This patch series contains a bundle of common code changes that are needed as a precursor to adding tnetv107x soc support. Some of these patches were sent out separately earlier, but have also been included here. This patch series has been boot-up tested on dm365, thanks to Sandeep. Cyril

[PATCH 3/8] Davinci: configurable pll divider mask

2010-04-12 Thread Cyril Chemparathy
This patch allows socs to override the divider ratio mask by setting an optional field (div_ratio_mask) in the pll_data structure. Signed-off-by: Cyril Chemparathy cy...@ti.com Tested-by: Sandeep Paulraj s-paul...@ti.com --- arch/arm/mach-davinci/clock.c |9 ++---

[PATCH 7/8] Davinci: gpio - controller type support

2010-04-12 Thread Cyril Chemparathy
This patch allows for gpio controllers that deviate from those found on traditional davinci socs. davinci_soc_info has an added field to indicate the soc-specific gpio controller type. The gpio initialization code then bails out of necessary. More elements (tnetv107x) to be added later into

[PATCH 2/8] Davinci: generalized debug macros

2010-04-12 Thread Cyril Chemparathy
This patch adopts a debug uart selection similar to the OMAP model. During the boot process, the uncompress code determines the physical and virtual base addresses of the board-specific debug uart. These addresses are then passed on to the in-kernel debug macros through a small chunk of memory

[PATCH 4/8] Davinci: gpio - minor cleanup

2010-04-12 Thread Cyril Chemparathy
macroized repeated container_of()s to improve readability. unified direction in/out functions. Signed-off-by: Cyril Chemparathy cy...@ti.com Tested-by: Sandeep Paulraj s-paul...@ti.com --- arch/arm/mach-davinci/gpio.c | 47 + 1 files changed, 24

[PATCH 1/8] Davinci: iotable based ioremap() interception

2010-04-12 Thread Cyril Chemparathy
This patch allows for a more flexible ioremap() interception. The mechanism works by translating physical addresses based on soc-specific iotable contents (davinci_soc_info.io_desc), once davinci_soc_info is populated by davinci_common_init(). Signed-off-by: Cyril Chemparathy cy...@ti.com

[PATCH 5/8] Davinci: gpio - struct renames

2010-04-12 Thread Cyril Chemparathy
Renamed gpio structures to something more sensible: struct gpio_controller -- struct davinci_gpio_regs struct davinci_gpio -- struct davinci_gpio_controller This change also moves davinci_gpio_controller definition to gpio.h. Eventually, the gpio registers structure will be

[PATCH 8/8] Davinci: gpio - fine grained locking

2010-04-12 Thread Cyril Chemparathy
This patch eliminates the global gpio_lock, and implements a per-controller lock instead. This also switches to irqsave/irqrestore locks in case gpios are manipulated in isr. Signed-off-by: Cyril Chemparathy cy...@ti.com Tested-by: Sandeep Paulraj s-paul...@ti.com ---

[PATCH 6/8] Davinci: gpio - register layout invariant inlines

2010-04-12 Thread Cyril Chemparathy
This patch renders the inlined gpio accessors in gpio.h independent of the underlying controller's register layout. This is done by including three new fields in davinci_gpio_controller to hold the addresses of the set, clear, and in data registers. Other changes: 1. davinci_gpio_regs structure

Removing excessive printing of NAND bad eraseblocks in nand/nand_bbt.c

2010-04-12 Thread Doug Rogers
Howdy, I don't know if this is the proper place for this, so please direct me elsewhere if it is not. I get a LOT of NAND bad eraseblocks when booting my dm6467t DVEVM. I've never dealt with NAND ROM before so I was surprised by how many bad eraseblocks are generated. I've seen elsewhere