Re: Replacing PR_LOG levels

2015-05-22 Thread Masayuki Nakano
Hi, I still want a same level as PR_LOG_ALWAYS. In nsTextStore which is an implementation of ITextStoreACP of TSF uses PR_LOG_ALWAYS only logs the module behavior. I.e., we can use to check specific IME behavior with this level. I don't like to call this as error. And also I wrote some

Re: Replacing PR_LOG levels

2015-05-22 Thread Patrick McManus
On Fri, May 22, 2015 at 4:11 PM, Eric Rescorla e...@rtfm.com wrote: I think it's generally valuable to have a trace level for all networking-type things. Having some separate mechanism seems like the more complicated thing. +1 - I actually wasn't aware of this debug+1 mechanism and now

Re: Replacing PR_LOG levels

2015-05-22 Thread Chris Peterson
On 5/22/15 4:50 AM, Ted Mielczarek wrote: On Thu, May 21, 2015, at 10:06 PM, Eric Rahm wrote: enum class LogLevel { Disabled = 0, // Logging is disabled for this module Error, Warning, Info, Debug, }; Just for comparison with other popular logging libraries:

Re: Replacing PR_LOG levels

2015-05-22 Thread Eric Rahm
Thanks Adam, these are good points. On Friday, May 22, 2015 at 2:08:33 PM UTC-7, Adam Roach wrote: On 5/22/15 15:51, Eric Rahm wrote: I agree, we shouldn't make it harder to turn on logging. The easy solution is just to add a separate logger for verbose messages (if we choose not to add

Re: Replacing PR_LOG levels

2015-05-22 Thread Mike Hommey
On Fri, May 22, 2015 at 04:08:21PM -0500, Adam Roach wrote: On 5/22/15 15:51, Eric Rahm wrote: I agree, we shouldn't make it harder to turn on logging. The easy solution is just to add a separate logger for verbose messages (if we choose not to add Verbose/Trace). I don't know why we

Re: Intent to implement and ship: document.execCommand(cut/copy)

2015-05-22 Thread Robert O'Callahan
On Sat, May 23, 2015 at 5:21 AM, Ehsan Akhgari ehsan.akhg...@gmail.com wrote: And that is exactly the point I have been trying to make. The potential for abuse definitely exists today, with Flash. And so far we have no evidence that this is an issue in practice today. At the very least, by

Re: Replacing PR_LOG levels

2015-05-22 Thread Eric Rescorla
On Fri, May 22, 2015 at 11:46 AM, Randell Jesup rjesup.n...@jesup.org wrote: As part of the effort to improve logging in gecko we'd like to introduce a new set of unified log levels. *PR_LOG_DEBUG + 1 aka log level 5* Various bits of code invented a log level that was less important than

Re: PSA: Xcode+gecko for newbies instructional video

2015-05-22 Thread Benoit Girard
I did the eclipse generation. It's not really meant to compile, it's only meant for writing code ATM. The challenge with Eclipse is dealing with the CDT limitations and quirks. There's part of our code base that is correct C++ that the CDT does not understand, some of which is for performance

Re: Replacing PR_LOG levels

2015-05-22 Thread Gregory Szorc
On Fri, May 22, 2015 at 12:22 PM, Bobby Holley bobbyhol...@gmail.com wrote: On Fri, May 22, 2015 at 12:11 PM, Gregory Szorc g...@mozilla.com wrote: Better than a log level is an event type (possibly enumerated). When people are looking at log output, they want to see specific events. While

Re: Replacing PR_LOG levels

2015-05-22 Thread Eric Rahm
+1 - I actually wasn't aware of this debug+1 mechanism and now that I am I would like to make use of it. Please, please, please don't do this until we work this out (once we switch to enum class this will not be an option). requiring special builds is much much less satisfying, especially

Re: Replacing PR_LOG levels

2015-05-22 Thread Adam Roach
On 5/22/15 15:51, Eric Rahm wrote: I agree, we shouldn't make it harder to turn on logging. The easy solution is just to add a separate logger for verbose messages (if we choose not to add Verbose/Trace). I don't know why we wouldn't just add a more verbose log level (Verbose, Trace... I

Re: Replacing PR_LOG levels

2015-05-22 Thread Nicholas Nethercote
On Sat, May 23, 2015 at 5:11 AM, Gregory Szorc g...@mozilla.com wrote: Better than a log level is an event type (possibly enumerated). I suspect that's right. Having said that, Eric is trying to clean up an existing system which is large and messy. Just fixing up the log levels is challenging

Re: PSA: Xcode+gecko for newbies instructional video

2015-05-22 Thread garvankeeley
I am interested in helping. I think if you can get it compiling, you can unlock more features of the IDE. And I think it requires a similar approach to Xcode generation, I'll follow up with you and Botond about this. ___ dev-platform mailing list

Re: Replacing PR_LOG levels

2015-05-22 Thread Eric Rahm
Thank you for the feedback, you make some good points. On Friday, May 22, 2015 at 1:31:14 AM UTC-7, masayuki nakano wrote: Hi, I still want a same level as PR_LOG_ALWAYS. Would switching this to the new level 'Info' suffice? The main difference is that by enabling the Info level you will

Re: Replacing PR_LOG levels

2015-05-22 Thread Nicholas Nethercote
On Sat, May 23, 2015 at 4:46 AM, Randell Jesup rjesup.n...@jesup.org wrote: Various bits of code invented a log level that was less important than debug (I would call this verbose). This was not specified in NSPR logging, but just kind of worked. With the addition of |Info| we can transition code

Re: Replacing PR_LOG levels

2015-05-22 Thread Eric Rescorla
On Fri, May 22, 2015 at 1:02 PM, Nicholas Nethercote n.netherc...@gmail.com wrote: On Sat, May 23, 2015 at 4:46 AM, Randell Jesup rjesup.n...@jesup.org wrote: Various bits of code invented a log level that was less important than debug (I would call this verbose). This was not specified in

Re: Replacing PR_LOG levels

2015-05-22 Thread Eric Rahm
Thanks Randell, these are good points. I'll address a few of your comments that have not already been covered in the rest of the conversation. This is used extensively in WebRTC and related media bits to enable *huge* amounts of debugs (like every-frame debugs for audio or video or

gecko.readthedocs.org

2015-05-22 Thread Philip Chee
https://gecko.readthedocs.org/en/latest/mobile/android/base/fennec/adjust.html I had a very confusing time the first time I tried to use readthedocs. Clicking on every link I could see always appeared to land me back at the TOC. It took me a while to realize that I had to scroll down to the

Re: Replacing PR_LOG levels

2015-05-22 Thread Ted Mielczarek
On Thu, May 21, 2015, at 10:06 PM, Eric Rahm wrote: enum class LogLevel { Disabled = 0, // Logging is disabled for this module Error, Warning, Info, Debug, }; Just for comparison with other popular logging libraries:

Re: PSA: Generate Linux64 gcov C++ code coverage data on try

2015-05-22 Thread Andrew Halberstadt
It's not sufficient, but it's enough to start building tooling around. Any future platforms will upload the data to the same places and in the same format. So anything that uses the data will be easier to generalize to additional platforms as they become available. I can start work scheduling

TemporaryRef implicit conversion changes

2015-05-22 Thread Nathan Froyd
Last night bug 1116905 (remove implicit conversions from T* to TemporaryRefT) and bug 1160485 (remove implicit conversions from RefPtrT to TemporaryRefT) landed on inbound. Both of these changes bring TemporaryRef more inline with already_AddRefed, and pave the way for removing TemporaryRef

Re: Replacing PR_LOG levels

2015-05-22 Thread Mike Hoye
On 2015-05-22 7:50 AM, Ted Mielczarek wrote: On Thu, May 21, 2015, at 10:06 PM, Eric Rahm wrote: enum class LogLevel { Disabled = 0, // Logging is disabled for this module Error, Warning, Info, Debug, }; Just for comparison with other popular logging libraries:

Re: PSA: Xcode+gecko for newbies instructional video

2015-05-22 Thread Mike Hoye
On 2015-05-22 2:19 PM, Jet Villegas wrote: Do we have instructions for Visual Studio anywhere? Video for Visual Studio Community Edition and Eclipse would both be very much welcomed by the community. - mhoye ___ dev-platform mailing list

Re: PSA: Xcode+gecko for newbies instructional video

2015-05-22 Thread garvankeeley
tl;dr it is in progress :) A bit of a long story actually. The current patch uses an approach of building on the python front-end (like Visual Studio does). This is guaranteed to to fail for Xcode generation. Xcode needs the _exact_ build commands per file, and that can't be generated using

Re: PSA: Xcode+gecko for newbies instructional video

2015-05-22 Thread garvankeeley
On Friday, May 22, 2015 at 2:37:14 PM UTC-4, Mike Hoye wrote: On 2015-05-22 2:19 PM, Jet Villegas wrote: Do we have instructions for Visual Studio anywhere? Video for Visual Studio Community Edition and Eclipse would both be very much welcomed by the community. - mhoye The Eclipse

Re: Replacing PR_LOG levels

2015-05-22 Thread Randell Jesup
As part of the effort to improve logging in gecko we'd like to introduce a new set of unified log levels. *PR_LOG_DEBUG + 1 aka log level 5* Various bits of code invented a log level that was less important than debug (I would call this verbose). This was not specified in NSPR logging, but just

Re: Replacing PR_LOG levels

2015-05-22 Thread David Rajchenbach-Teller
On 22/05/15 04:06, Eric Rahm wrote: After a rather thorough examination of usages of each I have come up with a set that I believe would fit our needs: enum class LogLevel { Disabled = 0, // Logging is disabled for this module Error, Warning, Info, Debug, }; I'll vote to

Re: Replacing PR_LOG levels

2015-05-22 Thread Gregory Szorc
On Thu, May 21, 2015 at 7:06 PM, Eric Rahm er...@mozilla.com wrote: As part of the effort to improve logging in gecko we'd like to introduce a new set of unified log levels. Currently we use NSPR logging which defines the following log levels: typedef enum PRLogModuleLevel {

Re: PSA: Xcode+gecko for newbies instructional video

2015-05-22 Thread Jet Villegas
Awesome! What's the plan for getting the patches you mention in the video into the tree? Do we have instructions for Visual Studio anywhere? --Jet On Fri, May 22, 2015 at 10:31 AM, garvankee...@gmail.com wrote: A video demo of how to get working quickly with Xcode:

Re: Replacing PR_LOG levels

2015-05-22 Thread Bobby Holley
On Fri, May 22, 2015 at 12:11 PM, Gregory Szorc g...@mozilla.com wrote: Better than a log level is an event type (possibly enumerated). When people are looking at log output, they want to see specific events. While filtering by the logger is a good way to limit/expand logging, I find that

Re: Intent to implement and ship: document.execCommand(cut/copy)

2015-05-22 Thread Ehsan Akhgari
On 2015-05-20 9:41 PM, t...@bocoup.com wrote: I am not sure if this is the right avenue to raise concern (again) over not requiring a prompt. It seems that user action here implies that a user intended on having their clipboard destroyed intentionally. (Like requesting a SHA from GitHub).

PSA: Xcode+gecko for newbies instructional video

2015-05-22 Thread garvankeeley
A video demo of how to get working quickly with Xcode: https://www.youtube.com/watch?v=D0qu8zNDH-M Feedback welcome. ___ dev-platform mailing list dev-platform@lists.mozilla.org https://lists.mozilla.org/listinfo/dev-platform