Re: [PATCH 40/59] drm/vram-helper: Drop drm_gem_prime_export/import

2019-06-17 Thread Gerd Hoffmann
Hi, > Aside: Would be really nice to switch the others over to > drm_gem_object_funcs. While most callbacks are pretty straight forward (just hook the same callbacks into the drm_gem_object_funcs. struct) the mmap bits are a bit more obscure. First, there seem to be two ways to mmap a gem

Re: use exact allocation for dma coherent memory

2019-06-17 Thread Dan Carpenter
I once wrote a Smatch check based on a commit message that said we can't pass dma_alloc_coherent() pointers to virt_to_phys(). But then I never felt like I understood the rules enough to actually report the warnings as bugs. drivers/platform/x86/dcdbas.c:108 smi_data_buf_realloc() error: 'buf'

Re: [PATCH] staging: fbtft: Fix checkpatch ERROR: space prohibited before that close parenthesis ')'

2019-06-17 Thread Geert Uytterhoeven
Hi Shobhit, Thanks for your patch! On Fri, Jun 14, 2019 at 4:34 AM Shobhit Kukreti wrote: > Cleaned up code to resolve the checkpatch error > ERROR: space prohibited before that close parenthesis ')' > from the file: > > fbtft/fbtft-bus.c IMHO that is a bogus checkpatch error... >

Re: [PATCH v3 4/7] lib/hexdump.c: Replace ascii bool in hex_dump_to_buffer with flags

2019-06-17 Thread Jani Nikula
On Mon, 17 Jun 2019, "Alastair D'Silva" wrote: > From: Alastair D'Silva > > In order to support additional features in hex_dump_to_buffer, replace > the ascii bool parameter with flags. > > Signed-off-by: Alastair D'Silva > --- > drivers/gpu/drm/i915/intel_engine_cs.c| 2 +- >

Re: [PATCH] i915: gvt: no need to check return value of debugfs_create functions

2019-06-17 Thread Zhenyu Wang
On 2019.06.13 15:34:19 +0200, Greg Kroah-Hartman wrote: > When calling debugfs functions, there is no need to ever check the > return value. The function can work or not, but the code logic should > never do something different based on this. Looks fine to me. We'd follow this idiom.

[PATCH 1/3] drm/stm: drv: fix suspend/resume

2019-06-17 Thread Yannick Fertré
Without this fix, the system can not go in "suspend" mode due to an error in drv_suspend function. Fixes: 35ab6cf ("drm/stm: support runtime power management") Signed-off-by: Yannick Fertré --- drivers/gpu/drm/stm/drv.c | 15 --- 1 file changed, 8 insertions(+), 7 deletions(-)

[PATCH v3 5/7] lib/hexdump.c: Allow multiple groups to be separated by lines '|'

2019-06-17 Thread Alastair D'Silva
From: Alastair D'Silva With the wider display format, it can become hard to identify how many bytes into the line you are looking at. The patch adds new flags to hex_dump_to_buffer() and print_hex_dump() to print vertical lines to separate every N groups of bytes. eg. buf:: 454d414e

[PATCH v3 0/7] Hexdump Enhancements

2019-06-17 Thread Alastair D'Silva
From: Alastair D'Silva Apologies for the large CC list, it's a heads up for those responsible for subsystems where a prototype change in generic code causes a change in those subsystems. This series enhances hexdump. These improve the readability of the dumped data in certain situations (eg.

[PATCH v3 4/7] lib/hexdump.c: Replace ascii bool in hex_dump_to_buffer with flags

2019-06-17 Thread Alastair D'Silva
From: Alastair D'Silva In order to support additional features in hex_dump_to_buffer, replace the ascii bool parameter with flags. Signed-off-by: Alastair D'Silva --- drivers/gpu/drm/i915/intel_engine_cs.c| 2 +- drivers/isdn/hardware/mISDN/mISDNisar.c | 6 --

Re: [PATCH libdrm v2 4/4] meson.build: Fix meson script on FreeBSD

2019-06-17 Thread Niclas Zeising
On 2019-06-16 15:23, Emil Velikov wrote: From: Niclas Zeising FreeBSD requires sys/types.h for sys/sysctl.h, add it as part of the includes when checking for headers. Instead of splitting out the check for sys/sysctl.h from the other header checks, just add sys/types.h to all header checks.

Re: [PATCH 6/6] drm/msm/gpu: add ocmem init/cleanup functions

2019-06-17 Thread Bjorn Andersson
On Sun 16 Jun 17:18 PDT 2019, Brian Masney wrote: > Hi Bjorn, > > On Sun, Jun 16, 2019 at 11:06:33AM -0700, Bjorn Andersson wrote: > > > diff --git a/drivers/gpu/drm/msm/adreno/adreno_gpu.c > > > b/drivers/gpu/drm/msm/adreno/adreno_gpu.c > > > index 6f7f4114afcf..e0a9409c8a32 100644 > > > ---

Re: [RFC v2 01/11] OPP: Don't overwrite rounded clk rate

2019-06-17 Thread Viresh Kumar
On 14-06-19, 10:57, Viresh Kumar wrote: > Hmm, so this patch won't break anything and I am inclined to apply it again :) > > Does anyone see any other issues with it, which I might be missing ? I have updated the commit log a bit more to clarify on things, please let me know if it looks okay.

Re: [PATCH libdrm v2 3/4] meson: normal shell will do

2019-06-17 Thread Niclas Zeising
On 2019-06-16 15:23, Emil Velikov wrote: As tweaked with previous patch - bash is not required. Any shell will do Signed-off-by: Emil Velikov Reviewed-by: Niclas Zeising --- amdgpu/meson.build| 2 +- etnaviv/meson.build | 2 +- exynos/meson.build| 2 +-

[PATCH v3 1/7] lib/hexdump.c: Fix selftests

2019-06-17 Thread Alastair D'Silva
From: Alastair D'Silva The overflow tests did not account for the situation where no overflow occurs and len < rowsize. This patch renames the cryptic variables and accounts for the above case. The selftests now pass. Signed-off-by: Alastair D'Silva --- lib/test_hexdump.c | 47

[PATCH v3 7/7] lib/hexdump.c: Optionally retain byte ordering

2019-06-17 Thread Alastair D'Silva
From: Alastair D'Silva The behaviour of hexdump groups is to print the data out as if it was a native-endian number. This patch tweaks the documentation to make this clear, and also adds the HEXDUMP_RETAIN_BYTE_ORDER flag to allow groups of multiple bytes to be printed without affecting the

[PATCH v3 3/7] lib/hexdump.c: Optionally suppress lines of repeated bytes

2019-06-17 Thread Alastair D'Silva
From: Alastair D'Silva Some buffers may only be partially filled with useful data, while the rest is padded (typically with 0x00 or 0xff). This patch introduces a flag to allow the supression of lines of repeated bytes, which are replaced with '** Skipped %u bytes of value 0x%x **' An inline

[PATCH v3 2/7] lib/hexdump.c: Relax rowsize checks in hex_dump_to_buffer

2019-06-17 Thread Alastair D'Silva
From: Alastair D'Silva This patch removes the hardcoded row limits and allows for other lengths. These lengths must still be a multiple of groupsize. This allows structs that are not 16/32 bytes to display on a single line. This patch also expands the self-tests to test row sizes up to 64

Re: [PATCH v3 3/7] lib/hexdump.c: Optionally suppress lines of repeated bytes

2019-06-17 Thread Alastair D'Silva
On Mon, 2019-06-17 at 12:04 +1000, Alastair D'Silva wrote: > From: Alastair D'Silva > > Some buffers may only be partially filled with useful data, while the > rest > is padded (typically with 0x00 or 0xff). > > This patch introduces a flag to allow the supression of lines of > repeated >

Re: [EXTERNAL] Re: [PATCH 1/1] drm/bochs: Fix connector leak during driver unload

2019-06-17 Thread Sam Bobroff
On Tue, May 21, 2019 at 10:10:29AM +0200, Gerd Hoffmann wrote: > Hi, > > The bug is in the driver, so ... > > > Bisecting the issue for commits to drivers/gpu/drm/bochs/ points to: > > 6579c39594ae ("drm/bochs: atomic: switch planes to atomic, wire up > > helpers.") > > ... but the issue also

[PATCH v3 6/7] lib/hexdump.c: Allow multiple groups to be separated by spaces

2019-06-17 Thread Alastair D'Silva
From: Alastair D'Silva Similar to the previous patch, this patch separates groups by 2 spaces for the hex fields, and 1 space for the ASCII field. eg. buf:: 454d414e 43415053 4e495f45 00584544 NAMESPAC E_INDEX. buf:0010: 0002

[Bug 110928] wx5100 gpu crash!!!!

2019-06-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=110928 --- Comment #2 from baopeng --- Created attachment 144568 --> https://bugs.freedesktop.org/attachment.cgi?id=144568=edit situation_1_dmesg situation 1 dmesg -- You are receiving this mail because: You are the assignee for the

[Bug 110928] wx5100 gpu crash!!!!

2019-06-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=110928 --- Comment #1 from baopeng --- Created attachment 144567 --> https://bugs.freedesktop.org/attachment.cgi?id=144567=edit gstack info -- You are receiving this mail because: You are the assignee for the

[Bug 110928] wx5100 gpu crash!!!!

2019-06-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=110928 Bug ID: 110928 Summary: wx5100 gpu crash Product: DRI Version: DRI git Hardware: All OS: Linux (All) Status: NEW Severity: critical

Re: [PATCH 07/59] drm/arm/komeda: Remove DRIVER_HAVE_IRQ

2019-06-17 Thread james qian wang (Arm Technology China)
On Fri, Jun 14, 2019 at 10:35:23PM +0200, Daniel Vetter wrote: > Read the docs, komeda is not an old enough driver for this :-) > > Signed-off-by: Daniel Vetter > Cc: "James (Qian) Wang" > Cc: Liviu Dudau > --- > drivers/gpu/drm/arm/display/komeda/komeda_kms.c | 3 +-- > 1 file changed, 1

[Bug 110897] HyperZ is broken for r300 (bad z for some micro and macrotiles?)

2019-06-17 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=110897 --- Comment #65 from Richard Thier --- Okay. Then variant 1 is the way to go I think. -- You are receiving this mail because: You are the assignee for the bug.___ dri-devel mailing list

Re: [PATCH 40/59] drm/vram-helper: Drop drm_gem_prime_export/import

2019-06-17 Thread Gerd Hoffmann
On Fri, Jun 14, 2019 at 10:35:56PM +0200, Daniel Vetter wrote: > They're the default. > > Aside: Would be really nice to switch the others over to > drm_gem_object_funcs. > > Signed-off-by: Daniel Vetter > Cc: Maarten Lankhorst > Cc: Maxime Ripard > Cc: Sean Paul > Cc: David Airlie > Cc:

Re: [PATCH 37/59] drm/virtio: Drop drm_gem_prime_export/import

2019-06-17 Thread Gerd Hoffmann
On Fri, Jun 14, 2019 at 10:35:53PM +0200, Daniel Vetter wrote: > They're the default. > > Aside: Would be really nice to switch the others over to > drm_gem_object_funcs. > > Signed-off-by: Daniel Vetter > Cc: David Airlie > Cc: Gerd Hoffmann > Cc: virtualizat...@lists.linux-foundation.org >

Re: [PATCH 25/59] drm/qxl: Drop drm_gem_prime_export/import

2019-06-17 Thread Gerd Hoffmann
On Fri, Jun 14, 2019 at 10:35:41PM +0200, Daniel Vetter wrote: > They're the default. > > Aside: Would be really nice to switch the others over to > drm_gem_object_funcs. > > Signed-off-by: Daniel Vetter > Cc: Dave Airlie > Cc: Gerd Hoffmann > Cc: virtualizat...@lists.linux-foundation.org >

Re: [PATCH 01/59] drm/todo: Improve drm_gem_object funcs todo

2019-06-17 Thread Gerd Hoffmann
On Fri, Jun 14, 2019 at 10:35:17PM +0200, Daniel Vetter wrote: > We're kinda going in the wrong direction. Spotted while typing better > gem/prime docs. > > Cc: Thomas Zimmermann > Cc: Gerd Hoffmann > Cc: Rob Herring > Cc: Noralf Trønnes > Signed-off-by: Daniel Vetter Acked-by: Gerd

<    1   2   3