Re: [PATCH v1 03/35] drm/atomic: Add TV subconnector property to get/set_property

2022-08-08 Thread Noralf Trønnes
Den 29.07.2022 18.34, skrev Maxime Ripard: > The subconnector property was created by drm_mode_create_tv_properties(), > but wasn't exposed to the userspace through the generic > atomic_get/set_property implementation, and wasn't stored in any generic > state structure. > > Let's solve this. >

Re: [PATCH v1 02/35] drm/connector: Rename subconnector state variable

2022-08-08 Thread Noralf Trønnes
Den 29.07.2022 18.34, skrev Maxime Ripard: > There is two TV subconnector related properties registered by > drm_mode_create_tv_properties(): subconnector and select subconnector. > > While the select subconnector property is stored in the kernel by the > drm_tv_connector_state structure, the

Re: [PATCH v1 01/35] drm/atomic-helper: Rename drm_atomic_helper_connector_tv_reset to avoid ambiguity

2022-08-08 Thread Noralf Trønnes
Den 29.07.2022 18.34, skrev Maxime Ripard: > We currently have two sets of TV properties. > > The first one is there to deal with analog TV properties, creating > properties such as the TV mode, subconnectors, saturation, hue and so on. > It's created by calling the

Re: [PATCH 02/12] drm/format-helper: Merge drm_fb_memcpy() and drm_fb_memcpy_toio()

2022-08-08 Thread Thomas Zimmermann
Hi Sam, thanks for reviewing the patchset. Am 04.08.22 um 21:52 schrieb Sam Ravnborg: Hi Thomas, On Wed, Jul 27, 2022 at 01:33:02PM +0200, Thomas Zimmermann wrote: Merge drm_fb_memcpy() and drm_fb_memcpy() into drm_fb_memcpy() that One of these is drm_fb_memcpy_toio() I had to laugh when

Re: [PATCH] drm/ttm: Fix dummy res NULL ptr deref bug

2022-08-08 Thread Christian König
Am 26.07.22 um 18:22 schrieb Arunpravin Paneer Selvam: Check the bo->resource value before accessing the resource mem_type. [ 40.191227][ T184] general protection fault, probably for non-canonical address 0xdc02: [#1] SMP KASAN PTI [ 40.192995][ T184] KASAN:

Re: [PATCH] amdgpu: add context creation flags in CS IOCTL

2022-08-08 Thread Sharma, Shashank
On 8/8/2022 12:59 PM, Christian König wrote: Am 02.08.22 um 15:55 schrieb Shashank Sharma: This patch adds: - A new input parameter "flags" in the amdgpu_ctx_create2 call. - Some new flags defining workload type hints. - Some change in the caller function of amdgpu_ctx_create2, to   

Re: [PATCH] i2c: qcom-geni: Fix GPI DMA buffer sync-back

2022-08-08 Thread Konrad Dybcio
On 7.08.2022 16:04, Robin Reckmann wrote: > Fix i2c transfers using GPI DMA mode for all message types that do not set > the I2C_M_DMA_SAFE flag (e.g. SMBus "read byte"). > > In this case a bounce buffer is returned by i2c_get_dma_safe_msg_buf(), > and it has to synced back to the message

Re: [PATCH 12/12] drm/format-helper: Move destination-buffer handling into internal helper

2022-08-08 Thread Thomas Zimmermann
Hi Sam Am 05.08.22 um 19:52 schrieb Sam Ravnborg: Hi Thomas, On Wed, Jul 27, 2022 at 01:33:12PM +0200, Thomas Zimmermann wrote: The format-convertion helpers handle several cases for different values of destination buffer and pitch. Move that code into the internal helper drm_fb_xfrm() and

Re: [PATCH v2 2/6] drm/ttm: Implement intersect/compatible functions

2022-08-08 Thread Christian König
Am 25.07.22 um 13:42 schrieb Arunpravin Paneer Selvam: Implemented a new intersect and compatible callback functions to ttm range manager fetching start offset from drm mm range allocator. Signed-off-by: Christian König Signed-off-by: Arunpravin Paneer Selvam ---

Re: [PATCH v6 1/2] drm/panfrost: Add specific register offset macros for JS and MMU AS

2022-08-08 Thread Steven Price
On 29/07/2022 15:46, Adrián Larumbe wrote: > Each Panfrost job has its own job slot and MMU address space set of > registers, which are selected with a job-specific index. > > Turn the shift and stride used for selection of the right register set base > into a define rather than using magic

Re: [PATCH v2 1/6] drm/ttm: Add new callbacks to ttm res mgr

2022-08-08 Thread Christian König
Am 25.07.22 um 13:42 schrieb Arunpravin Paneer Selvam: We are adding two new callbacks to ttm resource manager function to handle intersection and compatibility of placement and resources. v2: move the amdgpu and ttm_range_manager changes to separate patches (Christian) Signed-off-by:

Re: [PATCH v6 2/2] drm/panfrost: Add support for devcoredump

2022-08-08 Thread Steven Price
On 29/07/2022 15:46, Adrián Larumbe wrote: > In the event of a job timeout, debug dump information will be written into > /sys/class/devcoredump. > > Inspired by etnaviv's similar feature. > > Signed-off-by: Adrián Larumbe Reviewed-by: Steven Price I'll push these to drm-misc-next. Thanks,

Re: [Linaro-mm-sig] [PATCH 1/3] dma-buf: Add ioctl to query mmap info

2022-08-08 Thread Christian König
Am 07.08.22 um 21:10 schrieb Rob Clark: On Sun, Aug 7, 2022 at 11:05 AM Christian König wrote: Am 07.08.22 um 19:56 schrieb Rob Clark: On Sun, Aug 7, 2022 at 10:38 AM Christian König wrote: [SNIP] And exactly that was declared completely illegal the last time it came up on the mailing list.

Re: [PATCH] amdgpu: add context creation flags in CS IOCTL

2022-08-08 Thread Christian König
Am 02.08.22 um 15:55 schrieb Shashank Sharma: This patch adds: - A new input parameter "flags" in the amdgpu_ctx_create2 call. - Some new flags defining workload type hints. - Some change in the caller function of amdgpu_ctx_create2, to accomodate this new parameter. The idea is to pass the

Re: [PATCH v7 08/13] usb: typec: tcpci_mt6370: Add MediaTek MT6370 tcpci driver

2022-08-08 Thread Heikki Krogerus
On Fri, Aug 05, 2022 at 03:06:05PM +0800, ChiaEn Wu wrote: > From: ChiYuan Huang > > The MediaTek MT6370 is a highly-integrated smart power management IC, > which includes a single cell Li-Ion/Li-Polymer switching battery > charger, a USB Type-C & Power Delivery (PD) controller, dual > Flash LED

[PATCH 1/3] MAINTAINERS: Drop Bartlomiej Zolnierkiewicz

2022-08-08 Thread Krzysztof Kozlowski
Bartlomiej's Samsung email address is not working since around last year and there was no follow up patch take over of the drivers, so drop the email from maintainers. Cc: Bartlomiej Zolnierkiewicz Signed-off-by: Krzysztof Kozlowski --- I assume that if other change was preferred, there was

[PATCH 3/3] dt-bindings: display: simple-framebuffer: Drop Bartlomiej Zolnierkiewicz

2022-08-08 Thread Krzysztof Kozlowski
Bartlomiej's Samsung email address is not working since around last year and there was no follow up patch take over of the drivers, so drop the email from maintainers. Cc: Bartlomiej Zolnierkiewicz Signed-off-by: Krzysztof Kozlowski --- I assume that if other change was preferred, there was

[PATCH 2/3] MAINTAINERS: pwm-fan: Drop Bartlomiej Zolnierkiewicz

2022-08-08 Thread Krzysztof Kozlowski
Bartlomiej's Samsung email address is not working since around last year and there was no follow up patch take over of the drivers, so drop the email from maintainers. Cc: Bartlomiej Zolnierkiewicz Signed-off-by: Krzysztof Kozlowski --- I assume that if other change was preferred, there was

Re: imx8mm lcdif->dsi->adv7535 no video, no errors

2022-08-08 Thread Adam Ford
On Mon, Aug 8, 2022 at 3:54 AM Marco Felsch wrote: > > On 22-08-07, Adam Ford wrote: > > On Fri, Aug 5, 2022 at 4:05 PM Adam Ford wrote: > > > > > > On Fri, Aug 5, 2022 at 7:56 AM Adam Ford wrote: > > > > > > > > On Fri, Aug 5, 2022 at 5:55 AM Adam Ford wrote: > > > > > > > > > > On Fri, Aug

RE: [RESEND RFC 18/18] drm/display/dp_mst: Move all payload info into the atomic state

2022-08-08 Thread Lin, Wayne
[Public] > -Original Message- > From: Lyude Paul > Sent: Thursday, August 4, 2022 4:28 AM > To: Lin, Wayne ; dri-devel@lists.freedesktop.org; > nouv...@lists.freedesktop.org; amd-...@lists.freedesktop.org > Cc: Ville Syrjälä ; Zuo, Jerry > ; Jani Nikula ; Imre Deak > ; Daniel Vetter ;

Re: [PATCH] drm/bridge: sii902x: add support for DRM_BRIDGE_ATTACH_NO_CONNECTOR

2022-08-08 Thread Neil Armstrong
On 08/08/2022 11:15, Neil Armstrong wrote: Hi Dmitry, On 31/07/2022 22:07, Dmitry Osipenko wrote: 13.01.2022 17:43, Neil Armstrong пишет: This adds support for DRM_BRIDGE_ATTACH_NO_CONNECTOR by adding the bridge get_edid() and detect() callbacks after refactoring the connector get_modes() and

Re: [PATCH] gpu: lontium-lt9611: Fix NULL pointer dereference in lt9611_connector_init()

2022-08-08 Thread Robert Foss
On Wed, 27 Jul 2022 at 09:31, Zeng Jingxiang wrote: > > From: Zeng Jingxiang > > A NULL check for bridge->encoder shows that it may be NULL, but it > already been dereferenced on all paths leading to the check. > 812 if (!bridge->encoder) { > > Dereference the pointer bridge->encoder. > 810

Re: [PATCH] drm/bridge: sii902x: add support for DRM_BRIDGE_ATTACH_NO_CONNECTOR

2022-08-08 Thread Neil Armstrong
Hi Dmitry, On 31/07/2022 22:07, Dmitry Osipenko wrote: 13.01.2022 17:43, Neil Armstrong пишет: This adds support for DRM_BRIDGE_ATTACH_NO_CONNECTOR by adding the bridge get_edid() and detect() callbacks after refactoring the connector get_modes() and connector_detect() callbacks. In order to

FYI: misc: visconti: Toshiba Visconti Pyramid accelerator driver sample

2022-08-08 Thread Yuji Ishikawa
Hi Odded This is a sample (wip) driver for a Pyramid accelerator found on Toshiba Visconti SoC. This accelerator accepts a image (and table for scaling filter), then yields 4 differently scaled output images at a time. Therefore (image-in, image-out), they say this driver should be classified

Re: imx8mm lcdif->dsi->adv7535 no video, no errors

2022-08-08 Thread Marco Felsch
On 22-08-07, Adam Ford wrote: > On Fri, Aug 5, 2022 at 4:05 PM Adam Ford wrote: > > > > On Fri, Aug 5, 2022 at 7:56 AM Adam Ford wrote: > > > > > > On Fri, Aug 5, 2022 at 5:55 AM Adam Ford wrote: > > > > > > > > On Fri, Aug 5, 2022 at 3:44 AM Biju Das > > > > wrote: > > > > > > > > > > Hi

Re: [PATCH] drm/meson: Fix refcount bugs in meson_vpu_has_available_connectors()

2022-08-08 Thread Neil Armstrong
Hi, On Tue, 26 Jul 2022 09:07:22 +0800, Liang He wrote: > In this function, there are two refcount leak bugs: > (1) when breaking out of for_each_endpoint_of_node(), we need call > the of_node_put() for the 'ep'; > (2) we should call of_node_put() for the reference returned by >

Re: [PATCH] drm/meson: Fix refcount bugs in meson_vpu_has_available_connectors()

2022-08-08 Thread Neil Armstrong
On 26/07/2022 03:07, Liang He wrote: In this function, there are two refcount leak bugs: (1) when breaking out of for_each_endpoint_of_node(), we need call the of_node_put() for the 'ep'; (2) we should call of_node_put() for the reference returned by of_graph_get_remote_port() when it is not

Re: [PATCH] i2c: qcom-geni: Fix GPI DMA buffer sync-back

2022-08-08 Thread Luca Weiss
Hi Robin, On Sun Aug 7, 2022 at 4:04 PM CEST, Robin Reckmann wrote: > Fix i2c transfers using GPI DMA mode for all message types that do not set > the I2C_M_DMA_SAFE flag (e.g. SMBus "read byte"). > > In this case a bounce buffer is returned by i2c_get_dma_safe_msg_buf(), > and it has to synced

Re: [PATCH] amdgpu: add context creation flags in CS IOCTL

2022-08-08 Thread Somalapuram, Amaranath
On 8/2/2022 7:25 PM, Shashank Sharma wrote: This patch adds: - A new input parameter "flags" in the amdgpu_ctx_create2 call. - Some new flags defining workload type hints. - Some change in the caller function of amdgpu_ctx_create2, to accomodate this new parameter. The idea is to pass the

Re: How to test whether a buffer is in linear format

2022-08-08 Thread Sebastian Krzyszkowiak
On 8/6/22, Hoosier, Matt wrote: > Any idea what’s up with some compositors adding code to infer > DRM_FORMAT_MOD_LINEAR semantics when the buffer’s modifiers are set to 0? > Wlroots, for example, added this as a “safety net for drm drivers not > announcing modifiers”. > >

Re: New subsystem for acceleration devices

2022-08-08 Thread Greg Kroah-Hartman
On Sun, Aug 07, 2022 at 02:25:33PM +0300, Oded Gabbay wrote: > 2. Common code to handle drivers that want to allow a single user at a > time to run open the device char file. Note, that's an impossible request, and one that the kernel should never worry about, so don't even try it. Think about

<    1   2