Re: Standard modules?

2014-01-21 Thread David Bruant
Le 20/01/2014 23:16, Kevin Reid a écrit : SES needs to visit every 'primordial' / 'singleton' object to ensure they're made immutable and harmless. (Other 'meta' code might also benefit though I don't know of any examples offhand.) This job is easier if all such objects are reachable via

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Tom Van Cutsem
I really like the way the ES6 spec is coming together. Generally the way in which abstract ops are used and internal methods are specified is much clearer and more uniform in ES6 than in ES5. Also, the table of contents is much better structured. I like your classification according to indexed

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Kevin Smith
Couple of nits WRT modules: - The instantiationRequest interface is defined as having two properties: execute and deps. I believe deps should be spelled dependencies to match the naming conventions throughout the rest of the document. Besides that, there is no reason that I can see to optimize

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Sam Tobin-Hochstadt
On Tue, Jan 21, 2014 at 9:29 AM, Kevin Smith zenpars...@gmail.com wrote: 2) The current loader is an instance of the Loader type. It is incongruent to name an instance with a capitalized identifier. I believe it would be more appropriate to provide access to the current loader via a

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread John Barton
On Mon, Jan 20, 2014 at 7:42 PM, Allen Wirfs-Brock al...@wirfs-brock.comwrote: The draft is available at http://wiki.ecmascript.org/doku.php?id=harmony:specification_drafts#january_20_2014_draft_rev_22 Big news: Promise and Module Loading/Linking. Still a few loose ends, but we're getting

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Allen Wirfs-Brock
John, js-loaders is both the initial spec. draft and the initial prototype of the module subsystem. What we have now is the integration of the that initial draft into the actual ES6 spec. In doing that there is some editorial renaming and refactoring intended to improve the spec. clarity and

Re: Standard modules?

2014-01-21 Thread Allen Wirfs-Brock
On Jan 20, 2014, at 11:46 PM, Andy Wingo wrote: On Mon 20 Jan 2014 18:39, Brendan Eich bren...@mozilla.com writes: Allen Wirfs-Brock wrote: It isn't clear that there much need for a global name for GeneratorFunction. If you really eed to access it can always get it via: (function

Re: Standard modules?

2014-01-21 Thread Allen Wirfs-Brock
On Jan 20, 2014, at 2:16 PM, Kevin Reid wrote: On Sun, Jan 19, 2014 at 7:21 PM, Allen Wirfs-Brock al...@wirfs-brock.com wrote: It isn't clear that there much need for a global name for GeneratorFunction. If you really eed to access it can always get it via: (function *()

SameValueZero comparator and compatibility

2014-01-21 Thread Brandon Benvie
The implementations of Maps and Sets in the wild that I am aware of (IE11, SpiderMonkey, and V8 behind a flag) all currently use SameValue as comparator while the spec calls for SameValueZero. It seems like either the implementations need to update (quickly) to match the spec. before too much

Re: New ES6 spec draft (Rev 22, Jan 20, 2014)

2014-01-21 Thread Kevin Smith
First, there are plenty of standard bindings on the global object that are not constructors and yet are capitalized -- `Math` is a prime example here. Math (and Reflect, JSON, etc) are functioning not as objects with per-instance state, but as namespaces. Infinity is a value object, but

Re: SameValueZero comparator and compatibility

2014-01-21 Thread Mark S. Miller
The most reliable way to get the implementations to conform is to contribute a test262 test. As for how to contribute a test262 test, I am still confused about the situation and leave it for others to comment. On Tue, Jan 21, 2014 at 9:58 AM, Brandon Benvie bben...@mozilla.com wrote: The

Re: SameValueZero comparator and compatibility

2014-01-21 Thread Allen Wirfs-Brock
On Jan 21, 2014, at 9:58 AM, Brandon Benvie wrote: The implementations of Maps and Sets in the wild that I am aware of (IE11, SpiderMonkey, and V8 behind a flag) all currently use SameValue as comparator while the spec calls for SameValueZero. It seems like either the implementations need

Re: SameValueZero comparator and compatibility

2014-01-21 Thread Andrea Giammarchi
I wish there was an answer to that too ... if implementors are confused, how could developers even think about contributing there? I have expressed already my wishes for a Test Driven Development of JS specs/features but I find myself unable to help. Any hint would be appreciated. Thanks On

Re: SameValueZero comparator and compatibility

2014-01-21 Thread Allen Wirfs-Brock
On Jan 21, 2014, at 2:09 PM, Andrea Giammarchi wrote: I wish there was an answer to that too ... if implementors are confused, how could developers even think about contributing there? I have expressed already my wishes for a Test Driven Development of JS specs/features but I find myself

Re: SameValueZero comparator and compatibility

2014-01-21 Thread Andrea Giammarchi
last 3 points are way too much high-level ... ask feature champions other TC39 participants ... how? Just trashing code in test262-discuss? On my initial implementation ... well, I can write the test accordingly with specs, it would be implementors eventually making the test green via their

Re: Code compilation alternative to Function()

2014-01-21 Thread Sean Silva
On Mon, Jan 20, 2014 at 4:21 PM, Gustavs Tēbergs fixplzsecr...@gmail.comwrote: Following up with a benchmark. (I thought of this idea while working on a parser generator library, but unfortunately for my argument the library turned out really fast...) I decided to write a converter for

Re: Code compilation alternative to Function()

2014-01-21 Thread Gustavs Tēbergs
On 22 January 2014 01:50, Sean Silva sil...@purdue.edu wrote: Your `load` routine is not how I described and is inducing a ton of cache-busting heap traffic. You need to put *all* strings in a single, constant array and append references to those constant strings to a single growing array.

Re: Code compilation alternative to Function()

2014-01-21 Thread Sean Silva
On Tue, Jan 21, 2014 at 9:06 PM, Gustavs Tēbergs fixplzsecr...@gmail.comwrote: On 22 January 2014 01:50, Sean Silva sil...@purdue.edu wrote: Your `load` routine is not how I described and is inducing a ton of cache-busting heap traffic. You need to put *all* strings in a single, constant