[FFmpeg-devel] [PATCH v2 2/4] libavcodec: write out user data unregistered SEI for x265

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- libavcodec/libx265.c | 20 1 file changed, 20 insertions(+) diff --git a/libavcodec/libx265.c b/libavcodec/libx265.c index a1bd205201..013a991e52 100644 --- a/libavcodec/libx265.c +++ b/libavcodec/libx265.c @@ -484,6 +484,7 @@ static int

[FFmpeg-devel] Encode user data unregistered SEI (H.264/H.265)

2021-04-30 Thread Brad Hards
MISB ST 0604 and ST 2101 require user data unregistered SEI messages (precision timestamps and sensor identifiers) to be included. That currently isn't supported. This series adds encoding for libx264, libx265, hevc_nvenc and h264_nvenc. v2 removes the API addition, modifies nvenc to use a

[FFmpeg-devel] [PATCH v2 3/4] libavcodec: write out user data unregistered SEI for nvenc

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- libavcodec/nvenc.c | 25 - 1 file changed, 24 insertions(+), 1 deletion(-) diff --git a/libavcodec/nvenc.c b/libavcodec/nvenc.c index 0dcd93a99c..c7659975b9 100644 --- a/libavcodec/nvenc.c +++ b/libavcodec/nvenc.c @@ -2170,9 +2170,10 @@

[FFmpeg-devel] [PATCH v2 4/4] doc: add example for user data unregistered SEI encoding

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- configure | 2 + doc/examples/.gitignore| 1 + doc/examples/Makefile | 1 + doc/examples/Makefile.example | 1 + doc/examples/encode_unregistered.c | 205 + 5 files changed,

[FFmpeg-devel] [PATCH v2 1/4] libavcodec: write out user data unregistered SEI for x264

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- libavcodec/libx264.c | 21 + 1 file changed, 21 insertions(+) diff --git a/libavcodec/libx264.c b/libavcodec/libx264.c index 22c91d8df7..c19a9b2804 100644 --- a/libavcodec/libx264.c +++ b/libavcodec/libx264.c @@ -31,6 +31,7 @@ #include

Re: [FFmpeg-devel] [PATCH 3/4] avfilter/vf_identify: remove unnecessary check

2021-04-30 Thread lance . lmwang
On Fri, Apr 30, 2021 at 06:59:52PM +0200, Paul B Mahol wrote: > filter name is wrong thanks, will fix the typo > > On Fri, Apr 30, 2021 at 3:32 AM wrote: > > > On Thu, Apr 29, 2021 at 06:24:02PM +0200, Paul B Mahol wrote: > > > commit log/message is wrong > > > > Sorry, I'm not sure what's

Re: [FFmpeg-devel] [PATCH 4/5] libavcodec: write out user data unregistered SEI for nvenc

2021-04-30 Thread Timo Rothenpieler
On 01.05.2021 01:30, Brad Hards wrote: I don't understand this comment. The existing code defines a fixed size array, and I don't want to change it because I couldn't find an authoritative source as to why that size or approach. I assume it could be a hardware limitation on at least some

Re: [FFmpeg-devel] [PATCH 4/5] libavcodec: write out user data unregistered SEI for nvenc

2021-04-30 Thread Brad Hards
On Saturday, 1 May 2021 1:27:44 AM AEST Timo Rothenpieler wrote: > On 30.04.2021 13:34, Brad Hards wrote: > > +num_unregistered_sei = av_frame_num_side_data(frame, > > AV_FRAME_DATA_SEI_UNREGISTERED); +for (int i = 0; i < > > num_unregistered_sei; i++) { > > redefines i from

Re: [FFmpeg-devel] [PATCH] avpacket: ABI bump additions

2021-04-30 Thread Marton Balint
On Mon, 26 Apr 2021, Lynne wrote: Apr 26, 2021, 02:36 by c...@passwd.hu: On Sun, 25 Apr 2021, Lynne wrote: This is the same patch sent in January, rebased on top of the ABI bump patchset. Two additions mirror exactly what AVFrame has - an opaque field and an opaque_ref for user-side

Re: [FFmpeg-devel] [PATCH] avpacket: ABI bump additions

2021-04-30 Thread James Almer
On 4/25/2021 10:27 PM, Andreas Rheinhardt wrote: Lynne: From 097aed2ac33dda0bb2052d8b0402711ce95079ba Mon Sep 17 00:00:00 2001 From: Lynne Date: Sat, 23 Jan 2021 19:56:18 +0100 Subject: [PATCH] avpacket: ABI bump additions --- libavcodec/avpacket.c | 5 + libavcodec/packet.h | 21

Re: [FFmpeg-devel] [PATCH 1/5] libavutil: add convenience accessors for frame side data

2021-04-30 Thread Marton Balint
On Fri, 30 Apr 2021, Lynne wrote: Apr 30, 2021, 13:34 by br...@frogmouth.net: Signed-off-by: Brad Hards --- libavutil/frame.c | 31 +++ libavutil/frame.h | 23 +++ 2 files changed, 54 insertions(+) diff --git a/libavutil/frame.c

Re: [FFmpeg-devel] [PATCH] avfilter/vf_scale: store pointer offsets in a local variable before adding them

2021-04-30 Thread James Almer
On 4/29/2021 1:24 PM, James Almer wrote: Fixes -Wint-in-bool-context warnings. Signed-off-by: James Almer --- libavfilter/vf_scale.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/libavfilter/vf_scale.c b/libavfilter/vf_scale.c index d95a8ad48a..759499395f 100644

Re: [FFmpeg-devel] [PATCH] avcodec/mjpegdec: fix SOF check in EOI

2021-04-30 Thread James Almer
On 4/28/2021 11:53 AM, James Almer wrote: For frames decoded with skip_frame == AVDISCARD_ALL, a picture is not allocated and got_picture is never set to 1 even if a SOF and SOS were parsed. The existing check in EOI only cares if a SOF was parsed, not if a picture allocated, so change it and

[FFmpeg-devel] [PATCH 2/2] avformat/dv: use av_packet_alloc() to allocate packets

2021-04-30 Thread James Almer
As avpriv_dv_get_packet can fail now, make it return < 0 on error, 0 on no packet found, and > 0 on packet found. Signed-off-by: James Almer --- libavdevice/iec61883.c | 2 +- libavformat/avidec.c | 4 +++- libavformat/dv.c | 51 ++ 3 files

[FFmpeg-devel] [PATCH 1/2] avformat/dv: add avpriv_dv_close_demux

2021-04-30 Thread James Almer
This is in preparation for the next commit. Signed-off-by: James Almer --- libavdevice/iec61883.c | 2 +- libavformat/avidec.c | 2 +- libavformat/dv.c | 56 -- libavformat/dv.h | 1 + libavformat/mov.c | 2 +- 5 files changed, 41

Re: [FFmpeg-devel] [PATCH 3/4] avfilter/vf_identify: remove unnecessary check

2021-04-30 Thread Paul B Mahol
filter name is wrong On Fri, Apr 30, 2021 at 3:32 AM wrote: > On Thu, Apr 29, 2021 at 06:24:02PM +0200, Paul B Mahol wrote: > > commit log/message is wrong > > Sorry, I'm not sure what's wrong, check -> checks? what's your suggestion? > > > > > On Thu, Apr 29, 2021 at 3:16 PM wrote: > > > > >

Re: [FFmpeg-devel] [PATCH 4/5] libavcodec: write out user data unregistered SEI for nvenc

2021-04-30 Thread Timo Rothenpieler
On 30.04.2021 13:34, Brad Hards wrote: Signed-off-by: Brad Hards --- libavcodec/nvenc.c | 16 1 file changed, 16 insertions(+) diff --git a/libavcodec/nvenc.c b/libavcodec/nvenc.c index 0dcd93a99c..1a895a64f4 100644 --- a/libavcodec/nvenc.c +++ b/libavcodec/nvenc.c @@

Re: [FFmpeg-devel] [PATCH 1/5] libavutil: add convenience accessors for frame side data

2021-04-30 Thread James Almer
On 4/30/2021 10:36 AM, Lynne wrote: Apr 30, 2021, 13:34 by br...@frogmouth.net: Signed-off-by: Brad Hards --- libavutil/frame.c | 31 +++ libavutil/frame.h | 23 +++ 2 files changed, 54 insertions(+) diff --git a/libavutil/frame.c

[FFmpeg-devel] [PATCH] avformat: add Argonaut Games CVG demuxer

2021-04-30 Thread Zane van Iperen
Signed-off-by: Zane van Iperen --- Changelog| 1 + MAINTAINERS | 1 + libavformat/Makefile | 1 + libavformat/allformats.c | 1 + libavformat/argo_cvg.c | 251 +++ libavformat/version.h| 2 +- 6 files changed,

Re: [FFmpeg-devel] [PATCH 1/5] libavutil: add convenience accessors for frame side data

2021-04-30 Thread Lynne
Apr 30, 2021, 13:34 by br...@frogmouth.net: > Signed-off-by: Brad Hards > --- > libavutil/frame.c | 31 +++ > libavutil/frame.h | 23 +++ > 2 files changed, 54 insertions(+) > > diff --git a/libavutil/frame.c b/libavutil/frame.c > index

Re: [FFmpeg-devel] [PATCH 2/2] lavc/aarch64: add hevc epel/qpel assembly

2021-04-30 Thread Martin Storsjö
On Wed, 28 Apr 2021, Josh Dekker wrote: From: Rafal Dabrowa First a couple technical details: The use of '.ifeqs "\op", "sshr"' needs to be changed into '.ifc \op, sshr', because gas-preprocessor doesn't implement '.ifeqs'. The checkasm tests for hevc_pel that were added in

[FFmpeg-devel] Encode user data unregistered SEI (H.264/H.265)

2021-04-30 Thread Brad Hards
MISB ST 0604 and ST 2101 require user data unregistered SEI messages (precision timestamps and sensor identifiers) to be included. That currently isn't supported. This series adds encoding for libx264, libx265, hevc_nvenc and h264_nvenc. ___

[FFmpeg-devel] [PATCH 5/5] doc: add example for user data unregistered SEI encoding

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- configure | 2 + doc/examples/.gitignore| 1 + doc/examples/Makefile | 1 + doc/examples/Makefile.example | 1 + doc/examples/encode_unregistered.c | 205 + 5 files changed,

[FFmpeg-devel] [PATCH 1/5] libavutil: add convenience accessors for frame side data

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- libavutil/frame.c | 31 +++ libavutil/frame.h | 23 +++ 2 files changed, 54 insertions(+) diff --git a/libavutil/frame.c b/libavutil/frame.c index 2ec59b44b1..9f9953c2b4 100644 --- a/libavutil/frame.c +++

[FFmpeg-devel] [PATCH 4/5] libavcodec: write out user data unregistered SEI for nvenc

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- libavcodec/nvenc.c | 16 1 file changed, 16 insertions(+) diff --git a/libavcodec/nvenc.c b/libavcodec/nvenc.c index 0dcd93a99c..1a895a64f4 100644 --- a/libavcodec/nvenc.c +++ b/libavcodec/nvenc.c @@ -2173,6 +2173,8 @@ static int

[FFmpeg-devel] [PATCH 2/5] libavcodec: write out user data unregistered SEI for x264

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- libavcodec/libx264.c | 15 +++ 1 file changed, 15 insertions(+) diff --git a/libavcodec/libx264.c b/libavcodec/libx264.c index 22c91d8df7..6d4cee55c0 100644 --- a/libavcodec/libx264.c +++ b/libavcodec/libx264.c @@ -31,6 +31,7 @@ #include "internal.h"

[FFmpeg-devel] [PATCH 3/5] libavcodec: write out user data unregistered SEI for x265

2021-04-30 Thread Brad Hards
Signed-off-by: Brad Hards --- libavcodec/libx265.c | 13 + 1 file changed, 13 insertions(+) diff --git a/libavcodec/libx265.c b/libavcodec/libx265.c index a1bd205201..3dceb3d165 100644 --- a/libavcodec/libx265.c +++ b/libavcodec/libx265.c @@ -484,6 +484,8 @@ static int

Re: [FFmpeg-devel] [PATCH] movenc: add movie_timescale option instead of hardcoding 1000

2021-04-30 Thread Kevin Wheatley
This is quite similar to my patch suggestion from last year: http://ffmpeg.org/pipermail/ffmpeg-devel/2020-April/261088.html mine was missing some docs updates, and I followed the existing naming scheme of prefixing the argument as 'mov_' rather than movie, but otherwise is quite similar Kevin

Re: [FFmpeg-devel] [PATCH 2/4] avcodec/mv30: Check available space in decode_intra() more completly

2021-04-30 Thread Michael Niedermayer
On Thu, Apr 29, 2021 at 06:25:06PM +0200, Paul B Mahol wrote: > I suggest to write better non-hacky solutions. can you be more specific ? thx > > On Wed, Apr 28, 2021 at 4:33 PM Michael Niedermayer > wrote: > > > On Thu, Feb 11, 2021 at 10:29:15PM +0100, Paul B Mahol wrote: > > > this is

Re: [FFmpeg-devel] [PATCH 46/72] avcodec/sunrastenc: Mark encoder as init-threadsafe

2021-04-30 Thread Andreas Rheinhardt
On Fri, Nov 27, 2020 at 6:46 PM Andreas Rheinhardt < andreas.rheinha...@gmail.com> wrote: > Signed-off-by: Andreas Rheinhardt > --- > libavcodec/sunrastenc.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/libavcodec/sunrastenc.c b/libavcodec/sunrastenc.c > index 97b2242a6e..3a66eab615