[FFmpeg-devel] [PATCH] avfilter/scale.c: factorize ff_scale_eval_dimensions

2019-12-04 Thread Gyan
Will help reduce code duplication when adding animation support to vf_scale. See Michael's last comment in https://patchwork.ffmpeg.org/patch/16272/ Gyan From 138a8dba766674a1b017614c58fa99aeca98e9e5 Mon Sep 17 00:00:00 2001 From: Gyan Doshi Date: Mon, 2 Dec 2019 21:11:21 +0530 Subject: [PATCH]

[FFmpeg-devel] [PATCH] avformat/cache: rename the class name fro Cache to cache

2019-12-04 Thread Steven Liu
Because the protocol name is cache, but the class name is Cache. for example: ffmpeg -protocols will show: Supported file protocols: Input: async bluray cache concat crypto data ffrtmphttp file ftp gopher hls http httpproxy https mmsh mmst pipe rtmp rtmps rt

Re: [FFmpeg-devel] [PATCH v3] avfilter/buffersrc: deprecate sws_param option

2019-12-04 Thread Nicolas George
quinkbl...@foxmail.com (12019-12-04): > From: Zhao Zhili > > --- > patch v3: document how to set the parameters for automatically inserted > filters. > > doc/filters.texi| 7 +++ > libavfilter/buffersrc.c | 14 -- > libavfilter/version.h | 5 - > 3 files changed

Re: [FFmpeg-devel] [PATCH V3 2/2] lavf/libsrt: enable other encryption parameters

2019-12-04 Thread Moritz Barsnick
On Wed, Dec 04, 2019 at 10:20:00 +0800, myp...@gmail.com wrote: > > > +{ "enforced_encryption", "Enforces that both connection parties > > > have the same passphrase set ", OFFSET(enforced_encryption), > > > AV_OPT_TYPE_INT, { .i64 = -1 }, -1, 1, .flags = D|E }, > > >

Re: [FFmpeg-devel] [PATCH V3 2/2] lavf/libsrt: enable other encryption parameters

2019-12-04 Thread myp...@gmail.com
On Wed, Dec 4, 2019 at 5:46 PM Moritz Barsnick wrote: > > On Wed, Dec 04, 2019 at 10:20:00 +0800, myp...@gmail.com wrote: > > > > +{ "enforced_encryption", "Enforces that both connection > > > > parties have the same passphrase set ", OFFSET(enforced_encryption), > > > > AV_OPT_T

Re: [FFmpeg-devel] [PATCH V3 2/2] lavf/libsrt: enable other encryption parameters

2019-12-04 Thread Limin Wang
On Wed, Dec 04, 2019 at 10:46:44AM +0100, Moritz Barsnick wrote: > On Wed, Dec 04, 2019 at 10:20:00 +0800, myp...@gmail.com wrote: > > > > +{ "enforced_encryption", "Enforces that both connection > > > > parties have the same passphrase set ", OFFSET(enforced_encryption), > > > >

Re: [FFmpeg-devel] [PATCH 3/3] avfilter/vf_convolution: add X86 SIMD for filter_column()

2019-12-04 Thread Paul B Mahol
On 12/4/19, Song, Ruiling wrote: >> -Original Message- >> From: ffmpeg-devel On Behalf Of >> chen >> Sent: Wednesday, December 4, 2019 9:36 AM >> To: FFmpeg development discussions and patches > de...@ffmpeg.org> >> Subject: Re: [FFmpeg-devel] [PATCH 3/3] avfilter/vf_convolution: add X86

[FFmpeg-devel] [PATCH] avfilter/crop: avoid premature eval error

2019-12-04 Thread Gyan
Valid width expressions were being rejected. Regards, Gyan From be3aacc114a0b2b6c8ec9e8b73be38f414ecbb3d Mon Sep 17 00:00:00 2001 From: Gyan Doshi Date: Wed, 4 Dec 2019 16:03:11 +0530 Subject: [PATCH] avfilter/crop: avoid premature eval error Width and height expressions can refer to each other

[FFmpeg-devel] Thoughts about error reporting

2019-12-04 Thread Nicolas George
Hi. This mail is more specifically addressed to people who develop applications with the FFmpeg libraries, especially non-console applications (GUI, web). Please reply on libav-u...@ffmpeg.org exclusively. My question is: do you find the error reporting mechanism satisfactory? I mean not only th

[FFmpeg-devel] [PATCH v4] avfilter/buffersrc: deprecate sws_param option

2019-12-04 Thread quinkblack
From: Zhao Zhili --- patch v4: update doc doc/filters.texi| 8 libavfilter/buffersrc.c | 14 -- libavfilter/version.h | 5 - 3 files changed, 20 insertions(+), 7 deletions(-) diff --git a/doc/filters.texi b/doc/filters.texi index 5fdec6f015..d15cf74c84 1006

Re: [FFmpeg-devel] [PATCH 3/3] avfilter/vf_convolution: add X86 SIMD for filter_column()

2019-12-04 Thread chen
At 2019-12-04 16:51:52, "Paul B Mahol" wrote: >On 12/4/19, Song, Ruiling wrote: >>> -Original Message- >>> From: ffmpeg-devel On Behalf Of >>> chen >>> >> At 2019-12-03 15:52:07, xuju...@sjtu.edu.cn wrote: >>> >> >From: Xu Jun >>> >[...] >>> >> >+ >>> >> >+cvtdq2ps m4, m4 >>>

[FFmpeg-devel] [PATCH 1/3] avformat/mpeg: Make VobSub demuxer have its own context struct

2019-12-04 Thread Andreas Rheinhardt
When the VobSub demuxer was added, the fields it required were simply added to the MpegDemuxContext (if the VobSub demuxer was selected at all). The mpeg demuxer of course doesn't use these fields even if they are there; and the VobSub demuxer doesn't use the old ones: It opens an mpeg subdemuxer o

[FFmpeg-devel] [PATCH 2/3] avformat/mpeg: Don't copy or leak string in AVBPrint

2019-12-04 Thread Andreas Rheinhardt
vobsub_read_header() uses an AVBPrint to write a string and up until now, it collected the string stored in the AVBPrint via av_bprint_finalize(), which might involve an allocation and copy of the string. But this is unnecessary, as the lifetime of the returned string does not exceed the lifetime o

[FFmpeg-devel] [PATCH 3/3] avformat/mpeg: Fix leaks of AVFormatContext and subtitle packets

2019-12-04 Thread Andreas Rheinhardt
If an error happens in vobsub_read_header() after allocating the AVFormatContext intended to read the sub-file, both the AVFormatContext as well as the data in the subtitles queues leaks. This has been fixed. Signed-off-by: Andreas Rheinhardt --- Supersedes https://ffmpeg.org/pipermail/ffmpeg-dev

[FFmpeg-devel] [PATCH 1/2] fftools/ffmpeg_filter: remove sws_param option from buffersrc

2019-12-04 Thread quinkblack
From: Zhao Zhili The option is deprecated and ignored by buffersrc. --- fftools/ffmpeg_filter.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/fftools/ffmpeg_filter.c b/fftools/ffmpeg_filter.c index 72838de1e2..40cc4c191c 100644 --- a/fftools/ffmpeg_filter.c +++ b/fftoo

[FFmpeg-devel] [PATCH] avfilter/buffersrc: remove redundant flag

2019-12-04 Thread quinkblack
From: Zhao Zhili !(c->pix_fmt != AV_PIX_FMT_NONE || c->got_format_from_params) equals (c->pix_fmt == AV_PIX_FMT_NONE) && !c->got_format_from_params 1. When (c->pix_fmt == AV_PIX_FMT_NONE) is true, got_format_from_params is always false, the flag doesn't contribute to the result. 2. When the f

[FFmpeg-devel] [PATCH V4 1/2] lavf/libsrt: add linger parameter to libsrt

2019-12-04 Thread Jun Zhao
From: Jun Zhao add linger parameter to libsrt, it's setting the number of seconds that the socket waits for unsent data when closing. Reviewed-by: Andriy Gelman Signed-off-by: Jun Zhao --- doc/protocols.texi |6 ++ libavformat/libsrt.c | 13 + 2 files changed, 19 inser

[FFmpeg-devel] [PATCH V4 0/2] Enable other srt options.

2019-12-04 Thread Jun Zhao
V4: - changed the option enforced_encryption type from int to bool. tks Michael & Moritz's comments. - add range info in the docs. tks Gyan's comments. V3: - add more details for linger options. tks Andriy Gelman's comments. - fix minor typo in commit message. V2: - correct the com

[FFmpeg-devel] [PATCH V4 2/2] lavf/libsrt: enable other encryption parameters

2019-12-04 Thread Jun Zhao
From: Jun Zhao Enable the SRTO_ENFORCEDENCRYPTION/SRTO_KMREFRESHRATE/ SRTO_KMPREANNOUNCE for srt encryption control. Signed-off-by: Jun Zhao --- doc/protocols.texi | 20 libavformat/libsrt.c | 18 ++ 2 files changed, 38 insertions(+), 0 deletions(-)

Re: [FFmpeg-devel] [PATCH v2 1/3] lavc/hevc_mp4toannexb: Fix integer overflow

2019-12-04 Thread Andriy Gelman
On Tue, 03. Dec 21:42, Andriy Gelman wrote: > On Wed, 04. Dec 01:26, Andreas Rheinhardt wrote: > > On Wed, Dec 4, 2019 at 1:04 AM Andriy Gelman > > wrote: > > > > > From: Andriy Gelman > > > > > > Check packet grow size against INT_MAX instead of SIZE_MAX. > > > > > > Found with libFuzzer: > > >

[FFmpeg-devel] [PATCH 0/7] Add decoding/encoding support for QSV HEVC REXT

2019-12-04 Thread Linjie Fu
Add decoding support for: 4:2:2 8 bit: yuyv422 4:2:2 10 bit:y210 4:4:4 8 bit:0yuv 4:4:4 10 bit:y410 Add encoding support for: 4:4:4 8 bit:0yuv 4:4:4 10 bit:y410 Linjie Fu (7): lavu/pixfmt: add new pixel format 0yuv/y210/y410 swscale: Add swscale

[FFmpeg-devel] [PATCH, v3, 2/7] swscale: Add swscale and fate support for 0YUV

2019-12-04 Thread Linjie Fu
Add input and output support in swscale for 0YUV. Since AV_PIX_FMT_0RGB would be treated as AV_PIX_FMT_ARGB, the default X(0) channel for 0YUV is set to 0xFF as well. Add fate test for 0YUV. Signed-off-by: Linjie Fu --- libswscale/input.c | 25 libswscale

[FFmpeg-devel] [PATCH, v3, 1/7] lavu/pixfmt: add new pixel format 0yuv/y210/y410

2019-12-04 Thread Linjie Fu
Previously, media driver provided planar format(like 420 8 bit), but for HEVC Range Extension (422/444 8/10 bit), the decoded image is produced in packed format because Windows expects it. Add some packed pixel formats for hardware decode support in VAAPI and QSV: 4:2:2 10 bit: Y210 4:4:4 8 bit:

[FFmpeg-devel] [PATCH, v3, 3/7] swscale: Add swscale input support for Y210

2019-12-04 Thread Linjie Fu
Add swscale input support for Y210, output support and fate test could be added later if there is requirement for software CSC to this packed format. Signed-off-by: Linjie Fu --- libswscale/input.c | 48 libswscale/utils.c | 2 ++ 2 files changed

[FFmpeg-devel] [PATCH, 4/7] lavu/hwcontext_vaapi: add vaapi_format_map support for 0YUV/Y210/Y410

2019-12-04 Thread Linjie Fu
VA_RT_FORMAT describes the desired sampling format for surface. When creating surface, VA_RT_FORMAT will be used firstly to choose the expected fourcc/media_format for the surface. And the fourcc will be revised by the value of VASurfaceAttribPixelFormat. Add vaapi_format_map support for new pixe

[FFmpeg-devel] [PATCH, v3, 5/7] qsv: get FrameInfo.Shift by desc->comp[0].shift

2019-12-04 Thread Linjie Fu
Since Y410 is a pixel format with depth > 8 but shift = 0, get Shift info by depth is not quite accurate. Signed-off-by: Linjie Fu --- libavcodec/qsvenc.c | 4 ++-- libavutil/hwcontext_qsv.c | 2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/libavcodec/qsvenc.c b/libavc

[FFmpeg-devel] [PATCH 6/7] lavc/qsv: Add decoding support for HEVC Range Extension

2019-12-04 Thread Linjie Fu
Add some pix_fmt, fourcc and frame map support for new pixel formats. This enables decoding support for HEVC Range Extension. 4:2:2 8 bit: yuyv422 4:2:2 10 bit:y210 4:4:4 8 bit:0yuv 4:4:4 10 bit:y410 Signed-off-by: Linjie Fu --- libavcodec/qsv.c | 26 +

[FFmpeg-devel] [PATCH 7/7] lavc/qsvenc: Add support for 4:4:4 8/10 bit HEVC REXT encoding

2019-12-04 Thread Linjie Fu
Enables HEVC Range Extension encoding support for 4:4:4 8/10 bit on ICL(gen11 +) platform with VDENC(low power mode). CMD: ffmpeg -hwaccel qsv -init_hw_device qsv=hw -filter_hw_device hw -f rawvideo -video_size 1920x1080 -pix_fmt 0yuv -i ./0yuv.yuv -vf hwupload=extra_hw_frames=64,format=q

[FFmpeg-devel] [PATCH] lavc/x265: set preferred_transfer_characteristics for HLG

2019-12-04 Thread Zhong Li
"HEVC HDR UHDTV Bitstreams using HLG10 shall also contain the alternative_transfer_characteristics SEI message. The alternative_transfer_characteristics SEI message shall be inserted on the HEVC DVB_RAP, and preferred_transfer_characteristics shall be set equal to "18", indicating Recommendation IT

Re: [FFmpeg-devel] [PATCH v1 1/2] avformat/libsrt: change tlpktdrop, nakreport, messageapi options to boolean type

2019-12-04 Thread Limin Wang
ping the very old patch, please review and push it. On Fri, Sep 20, 2019 at 07:17:27PM +0800, lance.lmw...@gmail.com wrote: > From: Limin Wang > > Signed-off-by: Limin Wang > --- > libavformat/libsrt.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/libavforma

Re: [FFmpeg-devel] [PATCH v2] avcodec/v4l2_m2m_enc: Check encoder pix_fmt matches pix_fmt on device

2019-12-04 Thread Andriy Gelman
On Sat, 23. Nov 06:18, Andriy Gelman wrote: > On Tue, 12. Nov 22:46, Andriy Gelman wrote: > > From: Andriy Gelman > > > > Fixes #8079 > > > > During initialization of a v4l2m2m device, the configured pix_fmt can be > > different to the pix_fmt of the encoder (i.e. avctx->pix_fmt). > > > > For e

Re: [FFmpeg-devel] [PATCH v3] avformat/matroskaenc: Use random TrackUID

2019-12-04 Thread Michael Niedermayer
On Tue, Dec 03, 2019 at 04:19:47PM +0100, Andreas Rheinhardt wrote: > Up until now, the TrackUID of a Matroska track which is supposed to be > random was not random at all: It always coincided with the TrackNumber > which is usually the 1-based index of the corresponding stream in the > array of AV

Re: [FFmpeg-devel] [PATCH V1 2/2] lavfi/avf_showspectrum: Fix the memory leak in error handle path

2019-12-04 Thread Michael Niedermayer
On Tue, Dec 03, 2019 at 07:01:00PM +0800, Jun Zhao wrote: > From: Jun Zhao > > Fix the memory leak in error handle path. > > Signed-off-by: Jun Zhao > --- > libavfilter/avf_showspectrum.c |5 ++--- > 1 files changed, 2 insertions(+), 3 deletions(-) probably ok, iam not maintainer of this

Re: [FFmpeg-devel] [PATCH] avformat/rmdec: Use av_packet_move_ref() for packet ownership transfer

2019-12-04 Thread Michael Niedermayer
On Tue, Dec 03, 2019 at 11:28:07AM +0100, Andreas Rheinhardt wrote: > Signed-off-by: Andreas Rheinhardt > --- > libavformat/rmdec.c | 5 + > 1 file changed, 1 insertion(+), 4 deletions(-) will apply thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB Into

Re: [FFmpeg-devel] [PATCH v2 1/3] avfilter/vf_elbg: Fix for the seed type

2019-12-04 Thread Michael Niedermayer
On Fri, Nov 22, 2019 at 09:50:36AM +0800, lance.lmw...@gmail.com wrote: > From: Limin Wang > > Signed-off-by: Limin Wang > --- > libavfilter/vf_elbg.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) will apply thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF13

Re: [FFmpeg-devel] [PATCH v2 1/5] lavc/libxavs2.c: use more descriptive variable names in xavs2_copy_frame* functions

2019-12-04 Thread Michael Niedermayer
On Tue, Dec 03, 2019 at 10:41:22AM +0800, hwren wrote: > Signed-off-by: hwren > --- > libavcodec/libxavs2.c | 29 ++--- > 1 file changed, 14 insertions(+), 15 deletions(-) will apply thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Re: [FFmpeg-devel] [PATCH v2 3/5] lavc/libxavs2.c: fix code style - spaces

2019-12-04 Thread Michael Niedermayer
On Tue, Dec 03, 2019 at 10:41:24AM +0800, hwren wrote: > Signed-off-by: hwren > --- > libavcodec/libxavs2.c | 13 + > 1 file changed, 5 insertions(+), 8 deletions(-) will apply thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB Rewriting code tha

Re: [FFmpeg-devel] [PATCH v2 2/5] lavc/libxavs2.c: avoid recomputations of pointers in xavs2_copy_frame* functions

2019-12-04 Thread Michael Niedermayer
On Tue, Dec 03, 2019 at 10:41:23AM +0800, hwren wrote: > Signed-off-by: hwren > --- > libavcodec/libxavs2.c | 32 +++- > 1 file changed, 23 insertions(+), 9 deletions(-) will apply thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Re: [FFmpeg-devel] [PATCH v2 5/5] lavc/libxavs2.c: optimize error descriptions

2019-12-04 Thread Michael Niedermayer
On Tue, Dec 03, 2019 at 10:41:26AM +0800, hwren wrote: > Signed-off-by: hwren > --- > libavcodec/libxavs2.c | 12 ++-- > 1 file changed, 6 insertions(+), 6 deletions(-) will apply thx [...] -- Michael GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB While the State exi

Re: [FFmpeg-devel] [PATCH] avdevice/xcbgrab: Improve non-shm performance

2019-12-04 Thread Marton Balint
On Wed, 4 Dec 2019, Kusanagi Kouichi wrote: On 2019-12-03 21:25:37 +0100, Marton Balint wrote: On Tue, 3 Dec 2019, Kusanagi Kouichi wrote: > On 2019-11-19 22:59:56 +0900, Kusanagi Kouichi wrote: > > Use AVBufferPool. You don't need a buffer pool for the non-shm case, you should wrap the X

[FFmpeg-devel] Next developer meeting...

2019-12-04 Thread Jean-Baptiste Kempf
Hello Folks, Following the previous discussions, and the decisions taken during the last IRL meeting, summarized here: https://ffmpeg.org/pipermail/ffmpeg-devel/2019-November/253153.html we will do our next meeting, Monday 9 December 2019, at 17:00 Berlin/Paris/Brussels time. The time is select

Re: [FFmpeg-devel] [aarch64] improve performance of ff_hscale_8_to_15_neon

2019-12-04 Thread Sebastian Pop
Hi Clément, please find attached the updated patch addressing all your comments. Let me know if there is anything else that I missed and that I need to address. Thanks, Sebastian On Sun, Dec 1, 2019 at 3:01 PM Martin Storsjö wrote: > > On Sun, 1 Dec 2019, Clément Bœsch wrote: > > > On Wed, Nov

[FFmpeg-devel] [PATCH] libswscale/swscale_unscaled.c: remove redundant code

2019-12-04 Thread Ting Fu
Signed-off-by: Ting Fu --- libswscale/swscale_unscaled.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/libswscale/swscale_unscaled.c b/libswscale/swscale_unscaled.c index d9260c151a..0d109da2d7 100644 --- a/libswscale/swscale_unscaled.c +++ b/libswscale/swscale_unscaled.c @@ -2032,7 +2032,

Re: [FFmpeg-devel] [PATCH 6/8] avformat/matroskadec: Remove unnecessary check

2019-12-04 Thread James Almer
On 12/3/2019 2:09 PM, Andreas Rheinhardt wrote: > 870e7552 introduced validating the lace sizes when they are parsed and > removed the old check; yet when merging this libav commit in 6902c3ac, > the old check for whether the frame extends beyond the frame has been kept. > It is unnecessary and has

Re: [FFmpeg-devel] [PATCH 3/3] avfilter/vf_convolution: add X86 SIMD for filter_column()

2019-12-04 Thread 徐鋆
Hi, chen - 原始邮件 - > 发件人: "chen" > 收件人: "FFmpeg development discussions and patches" > 发送时间: 星期二, 2019年 12 月 03日 下午 4:59:06 > 主题: Re: [FFmpeg-devel] [PATCH 3/3] avfilter/vf_convolution: add X86 SIMD for > filter_column() > comments inline in code > > > At 2019-12-03 15:52:07, xuju...@