[FFmpeg-devel] [PATCH 3/4 v2] avcodec/cbs_h265: move the payload_extension_present check into its own function

2020-04-23 Thread James Almer
Will be reused in the following patch. Signed-off-by: James Almer --- libavcodec/cbs_h2645.c| 9 + libavcodec/cbs_h265_syntax_template.c | 7 +++ 2 files changed, 12 insertions(+), 4 deletions(-) diff --git a/libavcodec/cbs_h2645.c b/libavcodec/cbs_h2645.c index

Re: [FFmpeg-devel] headers for gapless playback

2020-04-23 Thread Kaplan, John
> > > > I think opening a generic ticket for this would be a good move. Having > > > > the ability to trim essence would be very useful. Then we could also > > > > remove that godawful hack in mov.c as well, hopefully. There's more > > > > than a few formats that need some

Re: [FFmpeg-devel] about ffmpeg 2.8.16

2020-04-23 Thread Michael Niedermayer
On Thu, Apr 16, 2020 at 01:25:51AM +0200, Michael Niedermayer wrote: > On Wed, Apr 15, 2020 at 06:37:55PM -0300, James Almer wrote: > > On 4/15/2020 6:10 PM, 曾经的梦 wrote: > > > Because I added many custom features in ffmpeg 2.8 and upgrading ffmpeg > > > to the latest version is a difficult task,

Re: [FFmpeg-devel] [PATCH 3/4 v2] avcodec/cbs_h265: move the payload_extension_present check into its own function

2020-04-23 Thread Andreas Rheinhardt
James Almer: > Will be reused in the following patch. > > Signed-off-by: James Almer > --- > libavcodec/cbs_h2645.c| 9 + > libavcodec/cbs_h265_syntax_template.c | 7 +++ > 2 files changed, 12 insertions(+), 4 deletions(-) > > diff --git a/libavcodec/cbs_h2645.c

Re: [FFmpeg-devel] [PATCH] libavformat/flacdec: Workaround for truncated metadata picture size

2020-04-23 Thread Andreas Rheinhardt
Mattias Wadman: > lavf flacenc could previously write truncated metadata picture size if > the picture data did not fit in 24 bits. Detect this by truncting the > size found inside the picture block and if it matches the block size > use it and read rest of picture data. > > Also only enable this

[FFmpeg-devel] [PATCH] Don't adjust start time for MP3 files; packets are not adjusted.

2020-04-23 Thread Dale Curtis
This is a patch Chromium has carried for a while, we forgot to send it upstream. 7546ac2fee4 made it so that the start_time for mp3 files is adjusted for skip_samples. However, this appears incorrect because subsequent packet timestamps are not adjusted and skip_samples are applied by deleting

Re: [FFmpeg-devel] [PATCH 3/4 v2] avcodec/cbs_h265: move the payload_extension_present check into its own function

2020-04-23 Thread Andreas Rheinhardt
James Almer: > Will be reused in the following patch. > > Signed-off-by: James Almer > --- > libavcodec/cbs_h2645.c| 9 + > libavcodec/cbs_h265_syntax_template.c | 7 +++ > 2 files changed, 12 insertions(+), 4 deletions(-) > > diff --git a/libavcodec/cbs_h2645.c

Re: [FFmpeg-devel] [PATCH 2/3] swscale/x86/output: add AVX2 version of yuv2nv12cX

2020-04-23 Thread James Almer
On 4/24/2020 12:13 AM, Nelson Gomez wrote: > From: Nelson Gomez > > 256 bits is just wide enough to fit all the operands needed to vectorize > the software implementation, but AVX2 is needed to for some instructions > like 16-to-32 bit vector sign extension. > > Output is bit-for-bit identical

[FFmpeg-devel] [PATCH 4/4 v2] avcodec/cbs_h265: add missing support for reserved_payload_extension_data SEI bits

2020-04-23 Thread James Almer
Fixes ticket #8622 Signed-off-by: James Almer --- libavcodec/cbs_h2645.c| 1 + libavcodec/cbs_h265.h | 1 + libavcodec/cbs_h265_syntax_template.c | 62 +-- 3 files changed, 60 insertions(+), 4 deletions(-) diff --git

[FFmpeg-devel] [PATCH 2/3] swscale/x86/output: add AVX2 version of yuv2nv12cX

2020-04-23 Thread Nelson Gomez
From: Nelson Gomez 256 bits is just wide enough to fit all the operands needed to vectorize the software implementation, but AVX2 is needed to for some instructions like 16-to-32 bit vector sign extension. Output is bit-for-bit identical to C. Signed-off-by: Nelson Gomez ---

[FFmpeg-devel] [PATCH 1/3] swscale: make yuv2interleavedX more asm-friendly

2020-04-23 Thread Nelson Gomez
From: Nelson Gomez Extracting information from SwsContext in assembly is difficult, and rearranging SwsContext just for asm access didn't look good. These functions only need a couple of fields from it anyway, so just make them parameters in their own right. Signed-off-by: Nelson Gomez ---

[FFmpeg-devel] [PATCH 3/3] swscale: cosmetic fixes

2020-04-23 Thread Nelson Gomez
From: Nelson Gomez Signed-off-by: Nelson Gomez --- libswscale/output.c | 13 - libswscale/swscale_internal.h | 3 ++- 2 files changed, 10 insertions(+), 6 deletions(-) diff --git a/libswscale/output.c b/libswscale/output.c index 2e5d6076ab..bddfaf16af 100644 ---

[FFmpeg-devel] [PATCH 0/3] swscale: add AVX2 version of yuv2nv12cX

2020-04-23 Thread Nelson Gomez
This patchset aims to optimize yuv2nv12cX_c for Intel/AMD chips by adding an AVX2 implementation of it. To support this change, the typedef declaration for yuv2interleavedX_fn has been changed to pass two additional parameters for chrDither8 and dstFormat rather than passing a pointer to the

Re: [FFmpeg-devel] [PATCH 6/8] avcodec/dump_extradata_bsf: Remove unnecessary header

2020-04-23 Thread Andreas Rheinhardt
Anton Khirnov: > > As far as I'm concerned, feel free to push the whole set as is. > I pushed the set without removing the log.h headers. - Andreas ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org https://ffmpeg.org/mailman/listinfo/ffmpeg-devel

[FFmpeg-devel] [PATCH v1 2/2] doc/APIchanges: add lavu part entry for DOVI sidedata

2020-04-23 Thread Jun Zhao
From: Jun Zhao missed the lavu entry for dovi_meta.h in APIchanges. Signed-off-by: Jun Zhao --- doc/APIchanges | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/doc/APIchanges b/doc/APIchanges index 5aa25de..42e53f6 100644 --- a/doc/APIchanges +++ b/doc/APIchanges @@ -16,7

[FFmpeg-devel] [PATCH v2] lavu/version: bump minor version for DOVI sidedata

2020-04-23 Thread Jun Zhao
From: Jun Zhao bump minor version for DOVI sidedata, because added the dovi_meta.h as lavu API part. Also update APIchanges. Signed-off-by: Jun Zhao --- doc/APIchanges | 5 +++-- libavutil/version.h | 2 +- 2 files changed, 4 insertions(+), 3 deletions(-) diff --git a/doc/APIchanges

Re: [FFmpeg-devel] [PATCH v2] lavu/version: bump minor version for DOVI sidedata

2020-04-23 Thread myp...@gmail.com
On Thu, Apr 23, 2020 at 7:36 PM Nicolas George wrote: > > Jun Zhao (12020-04-23): > > From: Jun Zhao > > > > bump minor version for DOVI sidedata, because added the dovi_meta.h > > as lavu API part. Also update APIchanges. > > > > Signed-off-by: Jun Zhao > > --- > > doc/APIchanges | 5

Re: [FFmpeg-devel] [PATCH] configure: enable ffnvcodec, nvenc, nvdec for aarch64

2020-04-23 Thread Timo Rothenpieler
On 23.04.2020 06:03, ManojGuptaBonda wrote: Adding the support to build FFMPEG with HW accelerated decode(nvdec) and encode on aarch64 architecture. Applied, thanks ___ ffmpeg-devel mailing list ffmpeg-devel@ffmpeg.org

Re: [FFmpeg-devel] [PATCH v6 0/9] Support Dolby Vision

2020-04-23 Thread myp...@gmail.com
On Thu, Apr 23, 2020 at 5:55 PM Anton Khirnov wrote: > > Quoting myp...@gmail.com (2020-04-23 04:16:41) > > On Wed, Apr 22, 2020 at 7:53 PM Jun Zhao wrote: > > > > > > From: Jun Zhao > > > > > > V6: > > > - split the header and .c file > > > - bump version and update APIChnage > > > > > > V5: >

Re: [FFmpeg-devel] [PATCH v2] lavu/version: bump minor version for DOVI sidedata

2020-04-23 Thread Nicolas George
Jun Zhao (12020-04-23): > From: Jun Zhao > > bump minor version for DOVI sidedata, because added the dovi_meta.h > as lavu API part. Also update APIchanges. > > Signed-off-by: Jun Zhao > --- > doc/APIchanges | 5 +++-- > libavutil/version.h | 2 +- > 2 files changed, 4 insertions(+), 3

Re: [FFmpeg-devel] [PATCH v6 0/9] Support Dolby Vision

2020-04-23 Thread Anton Khirnov
Quoting myp...@gmail.com (2020-04-23 04:16:41) > On Wed, Apr 22, 2020 at 7:53 PM Jun Zhao wrote: > > > > From: Jun Zhao > > > > V6: > > - split the header and .c file > > - bump version and update APIChnage > > > > V5: > > - add a constructor for DOVI (tks Anton Khirnov) > > - some minor coding

[FFmpeg-devel] [PATCH v1 1/2] lavu/version: bump minor version for DOVI sidedata

2020-04-23 Thread Jun Zhao
From: Jun Zhao bump minor version for DOVI sidedata, add dovi_meta.h as lavu API part. Signed-off-by: Jun Zhao --- libavutil/version.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/libavutil/version.h b/libavutil/version.h index 70836a5..e4fa0a9 100644 ---

Re: [FFmpeg-devel] [PATCH v1 2/2] doc/APIchanges: add lavu part entry for DOVI sidedata

2020-04-23 Thread Nicolas George
Jun Zhao (12020-04-23): > From: Jun Zhao > > missed the lavu entry for dovi_meta.h in APIchanges. > > Signed-off-by: Jun Zhao > --- > doc/APIchanges | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) You can do the APIchanges entry and the bump in the same commit. After all, the

Re: [FFmpeg-devel] [PATCH v1 2/2] doc/APIchanges: add lavu part entry for DOVI sidedata

2020-04-23 Thread myp...@gmail.com
On Thu, Apr 23, 2020 at 7:18 PM Nicolas George wrote: > > Jun Zhao (12020-04-23): > > From: Jun Zhao > > > > missed the lavu entry for dovi_meta.h in APIchanges. > > > > Signed-off-by: Jun Zhao > > --- > > doc/APIchanges | 3 ++- > > 1 file changed, 2 insertions(+), 1 deletion(-) > > You can

[FFmpeg-devel] [PATCH v3] lavu/version: bump minor version for DOVI sidedata

2020-04-23 Thread Jun Zhao
From: Jun Zhao bump minor version for DOVI sidedata, because added the dovi_meta.h as lavu API part. Also update APIchanges. Signed-off-by: Jun Zhao --- doc/APIchanges | 5 +++-- libavutil/version.h | 4 ++-- 2 files changed, 5 insertions(+), 4 deletions(-) diff --git a/doc/APIchanges

[FFmpeg-devel] [PATCH] dnn-layer-mathbinary-test: Fix tests for cases with extra intermediate precision

2020-04-23 Thread Martin Storsjö
This fixes tests on 32 bit x86 mingw with clang, which uses x87 fpu by default. In this setup, while the get_expected function is declared to return float, the compiler is (especially given the optimization flags set) free to keep the intermediate values (in this case, the return value from the

Re: [FFmpeg-devel] [PATCH 1/8] lavc: Rename hwaccel.h to hwconfig.h

2020-04-23 Thread Lynne
Apr 13, 2020, 16:33 by s...@jkqxz.net: > This already applied to decoders as well as hwaccels, and adding encoder > support was going to make the name even more inaccurate. > --- > libavcodec/cuviddec.c| 2 +- > libavcodec/decode.c | 2 +- > libavcodec/h263dec.c

Re: [FFmpeg-devel] [PATCH] avformat/mpegtsenc: use av_log_once for data stream warning

2020-04-23 Thread Gyan Doshi
On 23-04-2020 01:33 am, Marton Balint wrote: On Wed, 22 Apr 2020, Gyan Doshi wrote: --- libavformat/mpegtsenc.c | 15 +++ 1 file changed, 11 insertions(+), 4 deletions(-) diff --git a/libavformat/mpegtsenc.c b/libavformat/mpegtsenc.c index 4fe3d84c59..f2be6c6632 100644 ---

[FFmpeg-devel] [PATCH] fate: Skip the dnxhd-uhd-hr-sq tests of large tests are disabled

2020-04-23 Thread Martin Storsjö
These tests are also in the same size range as the previously skipped 2k and 4k tests. --- tests/fate/vcodec.mak | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/tests/fate/vcodec.mak b/tests/fate/vcodec.mak index fc27da5456..ec2a9c339d 100644 --- a/tests/fate/vcodec.mak

[FFmpeg-devel] [PATCH] fate: hevc: Skip a few large testcases if large tests are disabled

2020-04-23 Thread Martin Storsjö
--- I've seen spurious failures of specifically these tests, in memory constrained setups. --- tests/fate/hevc.mak | 19 ++- 1 file changed, 18 insertions(+), 1 deletion(-) diff --git a/tests/fate/hevc.mak b/tests/fate/hevc.mak index 35af3e43ac..65c5a262e9 100644 ---

Re: [FFmpeg-devel] [PATCH] dnn-layer-mathbinary-test: Fix tests for cases with extra intermediate precision

2020-04-23 Thread Guo, Yejun
> -Original Message- > From: ffmpeg-devel [mailto:ffmpeg-devel-boun...@ffmpeg.org] On Behalf Of > Martin Storsj? > Sent: Thursday, April 23, 2020 2:34 PM > To: ffmpeg-devel@ffmpeg.org > Subject: [FFmpeg-devel] [PATCH] dnn-layer-mathbinary-test: Fix tests for cases > with extra

Re: [FFmpeg-devel] [PATCH] libavformat/flacdec: Workaround for truncated metadata picture size

2020-04-23 Thread Mattias Wadman
On Thu, Apr 23, 2020 at 5:15 PM Mattias Wadman wrote: > > lavf flacenc could previously write truncated metadata picture size if > the picture data did not fit in 24 bits. Detect this by truncting the > size found inside the picture block and if it matches the block size > use it and read rest of

Re: [FFmpeg-devel] [PATCH] libavformat/flacdec: Workaround for truncated metadata picture size

2020-04-23 Thread Andreas Rheinhardt
Mattias Wadman: > On Thu, Apr 23, 2020 at 5:15 PM Mattias Wadman > wrote: >> >> lavf flacenc could previously write truncated metadata picture size if >> the picture data did not fit in 24 bits. Detect this by truncting the >> size found inside the picture block and if it matches the block size

Re: [FFmpeg-devel] [PATCH 0/2] lavd/avfoundation: Fix build on iOS and fix screen capture

2020-04-23 Thread Thilo Borgmann
Am 22.04.20 um 23:54 schrieb Carl Eugen Hoyos: > Am Mi., 22. Apr. 2020 um 17:06 Uhr schrieb Thilo Borgmann > : >> >> Am 04.04.20 um 13:55 schrieb Thilo Borgmann: >>> Hi, >>> >>> fixing two bugs revealed after last patch to avfoundation. >>> >>> Will apply soon if there are no objections. >> >>

[FFmpeg-devel] [PATCH] libavformat/flacdec: Workaround for truncated metadata picture size

2020-04-23 Thread Mattias Wadman
lavf flacenc could previously write truncated metadata picture size if the picture data did not fit in 24 bits. Detect this by truncting the size found inside the picture block and if it matches the block size use it and read rest of picture data. Also only enable this workaround flac files and

Re: [FFmpeg-devel] [PATCH] lavc/vaapi_encode: add FF_CODEC_CAP_INIT_CLEANUP caps for encoders

2020-04-23 Thread Fu, Linjie
> From: Fu, Linjie > Sent: Tuesday, March 31, 2020 23:34 > To: ffmpeg-devel@ffmpeg.org > Cc: Fu, Linjie > Subject: [PATCH] lavc/vaapi_encode: add FF_CODEC_CAP_INIT_CLEANUP > caps for encoders > > ff_vaapi_encode_close() is not enough to free the resources like cbs > if initialization failure

Re: [FFmpeg-devel] [PATCH v3] libavcodec/jpeg2000dec.c: ROI marker support

2020-04-23 Thread Michael Niedermayer
On Thu, Apr 23, 2020 at 09:36:07AM +0530, gautamr...@gmail.com wrote: > From: Gautam Ramakrishnan > > This patch adds support for decoding images > with a Region of Interest. Allows decoding > samples such as p0_03.j2k. This patch should > fix ticket #4681. > --- > libavcodec/jpeg2000.h| 1

Re: [FFmpeg-devel] [PATCH 1/2] avcodec/hevc_mp4toannexb_bsf: Check nalu_size

2020-04-23 Thread Michael Niedermayer
On Mon, Apr 20, 2020 at 12:21:21AM +0200, Michael Niedermayer wrote: > Fixes: Timeout (29sec -> 5ms) > Fixes: > 20237/clusterfuzz-testcase-minimized-ffmpeg_BSF_HEVC_MP4TOANNEXB_fuzzer-5165615044362240 > > Found-by: continuous fuzzing process >

Re: [FFmpeg-devel] [PATCH] avformat/r3d: Remove write-only array

2020-04-23 Thread Andreas Rheinhardt
Andreas Rheinhardt: > Andreas Rheinhardt: >> Signed-off-by: Andreas Rheinhardt >> --- >> libavformat/r3d.c | 20 +++- >> 1 file changed, 3 insertions(+), 17 deletions(-) >> >> diff --git a/libavformat/r3d.c b/libavformat/r3d.c >> index 224bcf780d..7aa0c5a2c3 100644 >> ---

Re: [FFmpeg-devel] [PATCH] libavcodec/avpacket: Don't simply forward return value of av_dict_set()

2020-04-23 Thread Andreas Rheinhardt
Andreas Rheinhardt: > Andreas Rheinhardt: >> The documentation of av_dict_set() states that values >= 0 indicate >> success, whereas av_packet_unpack_dictionary() implies that return >> values > 0 are impossible. So only forward the return value of >> av_dict_set() in av_packet_unpack_dictionary()

Re: [FFmpeg-devel] [PATCH] avformat/webvttdec: Remove write-only variable

2020-04-23 Thread Andreas Rheinhardt
Andreas Rheinhardt: > Andreas Rheinhardt: >> Signed-off-by: Andreas Rheinhardt >> --- >> libavformat/webvttdec.c | 4 +--- >> 1 file changed, 1 insertion(+), 3 deletions(-) >> >> diff --git a/libavformat/webvttdec.c b/libavformat/webvttdec.c >> index 52579c5ed2..6c4d5f6736 100644 >> ---