[Framework-Team] install-plone.py

2006-10-22 Thread Daniel Nouri
Hello there! I created a script install-plone.py that should help at least get an idea of how the deployment of Plone 3.0 should look like. Note that this is work in progress. I hope that people will help me with figuring out the problems with this, and help me improve it. You can download it

Re: [Framework-Team] install-plone.py

2006-10-22 Thread Martin Aspeli
Hi Daniel, - Zope does not start up due to some import error. ImportError: No module named ZopeVersionControl.ZopeRepository. I couldn't find this Product, any pointers welcome! See getCVS.sh in the bundle; it comes from the old Zope cvs. Martin

[Framework-Team] Re: install-plone.py

2006-10-22 Thread Daniel Nouri
I forgot another obvious problem: - Should not depend on the user to have workingenv.py installed. The script should download it if it's not there. ___ Framework-Team mailing list Framework-Team@lists.plone.org

Re: [Framework-Team] Re: Error starting 3.0 bundle

2006-10-22 Thread whit
Daniel Nouri wrote: whit wrote: ugh... could we devote a little time to packaging love here? maybe at the conference? This is tipping my suckometer. None of this is too fancy, but I think we've exceeded the utility of our bundle system and should fix our dev deploy story. some notes in

Re: [Framework-Team] Re: Error starting 3.0 bundle

2006-10-22 Thread whit
Daniel Nouri wrote: whit wrote: You could call it temporary in that Zope will hopefully get better at development eggs and therefore render a weaved-together bundle like this obsolete (instead, you'd have a bundle with eggs and then you'd easy_install each one). To be honest, I find the