Re: [Freedreno] [PATCH v4] drm/msm/dp: power off DP phy at suspend

2021-06-02 Thread Stephen Boyd
Quoting Kuogee Hsieh (2021-06-02 09:43:05) > Normal DP suspend operation contains two steps, display off followed > by dp suspend, to complete system wide suspending cycle if display is > up at that time. In this case, DP phy will be powered off at display > off. However there is an exception case

Re: [Freedreno] [v5 2/5] drm/panel-simple: Support DP AUX backlight

2021-06-02 Thread Doug Anderson
Hi, On Sun, May 30, 2021 at 8:57 AM Rajeev Nandan wrote: > > If there is no backlight specified in the device tree and the panel > has access to the DP AUX channel then create a DP AUX backlight if > supported by the panel. > > Signed-off-by: Rajeev Nandan > --- > > This patch depends on [1]

Re: [Freedreno] [v5 3/5] drm/panel-simple: Support for delays between GPIO & regulator

2021-06-02 Thread Doug Anderson
Hi, On Sun, May 30, 2021 at 8:57 AM Rajeev Nandan wrote: > > Some panels datasheets may specify a delay between the enable GPIO and > the regulator. Support this in panel-simple. > > Signed-off-by: Rajeev Nandan > --- > > Changes in v4: > - New > > Changes in v5: > - Update description

Re: [Freedreno] [PATCH] drm/msm/dsi: add continuous clock support for 7nm PHY

2021-06-02 Thread abhinavk
On 2021-06-02 07:43, Dmitry Baryshkov wrote: Unlike previous generations, 7nm PHYs are required to collaborate with the host for conitnuos clock mode. Add changes neccessary to enable continuous clock mode in the 7nm DSI PHYs. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/dsi/dsi.h

Re: [Freedreno] [v5 1/5] drm/panel: add basic DP AUX backlight support

2021-06-02 Thread Doug Anderson
Hi, On Sun, May 30, 2021 at 8:57 AM Rajeev Nandan wrote: > > +static int dp_aux_backlight_update_status(struct backlight_device *bd) > +{ > + struct dp_aux_backlight *bl = bl_get_data(bd); > + u16 brightness = backlight_get_brightness(bd); > + int ret = 0; > + > + if

Re: [Freedreno] [RESEND 13/26] drm/msm/dp/dp_catalog: Correctly document param 'dp_catalog'

2021-06-02 Thread Stephen Boyd
Quoting Lee Jones (2021-06-02 07:32:47) > Fixes the following W=1 kernel build warning(s): > > drivers/gpu/drm/msm/dp/dp_catalog.c:206: warning: Function parameter or > member 'dp_catalog' not described in 'dp_catalog_aux_reset' > drivers/gpu/drm/msm/dp/dp_catalog.c:206: warning: Excess

[Freedreno] [PATCH 2/3] drm/msm/a6xx: add CONFIG_QCOM_LLCC dependency

2021-06-02 Thread Kees Cook
From: Arnd Bergmann When LLCC support is in a loadable module, the adreno support cannot be built-in: aarch64-linux-ld: drivers/gpu/drm/msm/adreno/a6xx_gpu.o: in function `a6xx_gpu_init': a6xx_gpu.c:(.text+0xe0): undefined reference to `llcc_slice_getd' a6xx_gpu.c:(.text+0xe0): relocation

[Freedreno] [PATCH 3/3] drm/pl111: depend on CONFIG_VEXPRESS_CONFIG

2021-06-02 Thread Kees Cook
Avoid randconfig build failures by requiring VEXPRESS_CONFIG: aarch64-linux-gnu-ld: drivers/gpu/drm/pl111/pl111_versatile.o: in function `pl111_vexpress_clcd_init': pl111_versatile.c:(.text+0x220): undefined reference to `devm_regmap_init_vexpress_config' Fixes: 826fc86b5903 ("drm: pl111: Move

[Freedreno] [PATCH 1/3] drm: Avoid circular dependencies for CONFIG_FB

2021-06-02 Thread Kees Cook
When cleaning up other drm config dependencies, it is too easy to create larger problems. Instead, mark CONFIG_FB as a "depends": drivers/gpu/drm/Kconfig:74:error: recursive dependency detected! Suggested-by: Arnd Bergmann Link:

[Freedreno] [PATCH 0/3] drm: Fix randconfig link failures

2021-06-02 Thread Kees Cook
Hi, While tracking down spurious "orphan section" warnings on arm and arm64, I needed to fix several other issues that it seems other folks have tripped over before. Here's the series that fixed everything for me... -Kees Arnd Bergmann (1): drm/msm/a6xx: add CONFIG_QCOM_LLCC dependency

Re: [Freedreno] (no subject)

2021-06-02 Thread Dmitry Baryshkov
On 16/05/2021 01:57, Dmitry Baryshkov wrote: From Dmitry Baryshkov # This line is ignored. From: Dmitry Baryshkov Reply-To: Subject: [PATCH v2 0/6] drm/msm/dpu: simplify RM code In-Reply-To: There is no need to request most of hardware blocks through the resource manager (RM), since

Re: [Freedreno] [PATCH v2 5/6] drm/msm/dpu: drop unused lm_max_width from RM

2021-06-02 Thread Dmitry Baryshkov
On 16/05/2021 04:21, Arnaud Vrac wrote: Hi Dmitry, Le dim. 16 mai 2021 à 00:58, Dmitry Baryshkov a écrit : No code uses lm_max_width from resource manager, so drop it. I have a pending patch which uses this value to properly determine the number of LMs to use in the topology. Currently the

Re: [Freedreno] [PATCH v3 0/3] drm/msm/dpu: simplify dpu_hw_blk handling

2021-06-02 Thread Dmitry Baryshkov
On 15/05/2021 22:09, Dmitry Baryshkov wrote: Drop most of "extra" features of dpu_hw_blk. Changes since v2: - Include a patch to fix compilation issue with merge3d id handling Changes since v1: - Make dpu_hw_blk an empty structure - Split this into separate patchset Gracious ping for

Re: [Freedreno] [PATCH] arm64/dts/qcom/sc7180: Add Display Port dt node

2021-06-02 Thread Stephen Boyd
Subject should be "arm64: dts: qcom: sc7180: Add DisplayPort node" Quoting Kuogee Hsieh (2021-06-02 14:08:38) > Add DP device node on sc7180. > > Signed-off-by: Kuogee Hsieh > --- > arch/arm64/boot/dts/qcom/sc7180-trogdor.dtsi | 9 > arch/arm64/boot/dts/qcom/sc7180.dtsi |

[Freedreno] [PATCH] arm64/dts/qcom/sc7180: Add Display Port dt node

2021-06-02 Thread Kuogee Hsieh
Add DP device node on sc7180. Signed-off-by: Kuogee Hsieh --- arch/arm64/boot/dts/qcom/sc7180-trogdor.dtsi | 9 arch/arm64/boot/dts/qcom/sc7180.dtsi | 77 2 files changed, 86 insertions(+) diff --git a/arch/arm64/boot/dts/qcom/sc7180-trogdor.dtsi

Re: [Freedreno] [v1 1/3] dt-bindings: msm/dsi: Add yaml schema for 7nm DSI PHY

2021-06-02 Thread rajeevny
On 02-06-2021 02:28, Rob Herring wrote: On Mon, May 31, 2021 at 07:03:53PM +0530, Rajeev Nandan wrote: + +properties: + compatible: +oneOf: + - const: qcom,dsi-phy-7nm When would one use this? This is for SM8250. + - const: qcom,dsi-phy-7nm-7280 + - const:

Re: [Freedreno] [v5 4/5] dt-bindings: display: simple: Add Samsung ATNA33XC20

2021-06-02 Thread Rob Herring
On Sun, 30 May 2021 21:26:11 +0530, Rajeev Nandan wrote: > Add Samsung 13.3" FHD eDP AMOLED panel. > > Signed-off-by: Rajeev Nandan > Reviewed-by: Douglas Anderson > --- > > (no changes since v4) > > Changes in v4: > - New > >

Re: [Freedreno] [RESEND 14/26] drm/msm/dp/dp_link: Fix some potential doc-rot

2021-06-02 Thread abhinavk
On 2021-06-02 07:32, Lee Jones wrote: Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/dp/dp_link.c:374: warning: expecting prototype for dp_parse_video_pattern_params(). Prototype was for dp_link_parse_video_pattern_params() instead drivers/gpu/drm/msm/dp/dp_link.c:573:

Re: [Freedreno] [RESEND 10/26] drm/msm/disp/dpu1/dpu_hw_interrupts: Demote a bunch of kernel-doc abuses

2021-06-02 Thread abhinavk
On 2021-06-02 07:32, Lee Jones wrote: Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c:17: warning: expecting prototype for Register offsets in MDSS register file for the interrupt registers(). Prototype was for MDP_SSPP_TOP0_OFF() instead

Re: [Freedreno] [RESEND 13/26] drm/msm/dp/dp_catalog: Correctly document param 'dp_catalog'

2021-06-02 Thread abhinavk
On 2021-06-02 07:32, Lee Jones wrote: Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/dp/dp_catalog.c:206: warning: Function parameter or member 'dp_catalog' not described in 'dp_catalog_aux_reset' drivers/gpu/drm/msm/dp/dp_catalog.c:206: warning: Excess function

Re: [Freedreno] [RESEND 11/26] drm/msm/disp/dpu1/dpu_plane: Fix a couple of naming issues

2021-06-02 Thread abhinavk
On 2021-06-02 07:32, Lee Jones wrote: Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/disp/dpu1/dpu_plane.c:373: warning: expecting prototype for _dpu_plane_set_panic_lut(). Prototype was for _dpu_plane_set_danger_lut() instead

Re: [Freedreno] [RESEND 09/26] drm/msm/disp/dpu1/dpu_encoder_phys_cmd: Remove unused variable 'cmd_enc'

2021-06-02 Thread abhinavk
On 2021-06-02 07:32, Lee Jones wrote: Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c: In function ‘dpu_encoder_phys_cmd_wait_for_commit_done’: drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c:688:31: warning: variable ‘cmd_enc’ set

[Freedreno] [RESEND PATCH v4 6/6] drm/msm: devcoredump iommu fault support

2021-06-02 Thread Rob Clark
From: Rob Clark Wire up support to stall the SMMU on iova fault, and collect a devcore- dump snapshot for easier debugging of faults. Currently this is a6xx-only, but mostly only because so far it is the only one using adreno-smmu-priv. Signed-off-by: Rob Clark ---

[Freedreno] [RESEND PATCH v4 5/6] drm/msm: Add crashdump support for stalled SMMU

2021-06-02 Thread Rob Clark
From: Rob Clark For collecting devcoredumps with the SMMU stalled after an iova fault, we need to skip the parts of the GPU state which are normally collected with the hw crashdumper, since with the SMMU stalled the hw would be unable to write out the requested state to memory. Signed-off-by:

[Freedreno] [RESEND PATCH v4 4/6] iommu/arm-smmu-qcom: Add stall support

2021-06-02 Thread Rob Clark
From: Rob Clark Add, via the adreno-smmu-priv interface, a way for the GPU to request the SMMU to stall translation on faults, and then later resume the translation, either retrying or terminating the current translation. This will be used on the GPU side to "freeze" the GPU while we snapshot

[Freedreno] [RESEND PATCH v4 3/6] drm/msm: Improve the a6xx page fault handler

2021-06-02 Thread Rob Clark
From: Jordan Crouse Use the new adreno-smmu-priv fault info function to get more SMMU debug registers and print the current TTBR0 to debug per-instance pagetables and figure out which GPU block generated the request. Signed-off-by: Jordan Crouse Signed-off-by: Rob Clark ---

[Freedreno] [RESEND PATCH v4 2/6] iommu/arm-smmu-qcom: Add an adreno-smmu-priv callback to get pagefault info

2021-06-02 Thread Rob Clark
From: Jordan Crouse Add a callback in adreno-smmu-priv to read interesting SMMU registers to provide an opportunity for a richer debug experience in the GPU driver. Signed-off-by: Jordan Crouse Signed-off-by: Rob Clark --- drivers/iommu/arm/arm-smmu/arm-smmu-qcom.c | 17

[Freedreno] [RESEND PATCH v4 1/6] iommu/arm-smmu: Add support for driver IOMMU fault handlers

2021-06-02 Thread Rob Clark
From: Jordan Crouse Call report_iommu_fault() to allow upper-level drivers to register their own fault handlers. Signed-off-by: Jordan Crouse Signed-off-by: Rob Clark --- drivers/iommu/arm/arm-smmu/arm-smmu.c | 9 +++-- 1 file changed, 7 insertions(+), 2 deletions(-) diff --git

[Freedreno] [RESEND PATCH v4 0/6] iommu/arm-smmu: adreno-smmu page fault handling

2021-06-02 Thread Rob Clark
From: Rob Clark (Resend, first attempt seems to not have entirely shown up in patchwork and had a random already merged patch tagging along because 00*patch picks up things I forgot to delete) This picks up an earlier series[1] from Jordan, and adds additional support needed to generate GPU

[Freedreno] [PATCH v4] drm/msm/dp: power off DP phy at suspend

2021-06-02 Thread Kuogee Hsieh
Normal DP suspend operation contains two steps, display off followed by dp suspend, to complete system wide suspending cycle if display is up at that time. In this case, DP phy will be powered off at display off. However there is an exception case that depending on the timing of dongle plug in

Re: [Freedreno] [PATCH v3] drm/msm/dp: power off DP phy at suspend

2021-06-02 Thread khsieh
On 2021-06-01 19:00, Stephen Boyd wrote: Please add dri-de...@lists.freedesktop.org next time Quoting Kuogee Hsieh (2021-06-01 16:50:08) Normal DP suspend operation contains two steps, display off followed by dp suspend, to complete system wide suspending cycle if display is up at that time.

[Freedreno] [PATCH] drm/msm/dsi: add continuous clock support for 7nm PHY

2021-06-02 Thread Dmitry Baryshkov
Unlike previous generations, 7nm PHYs are required to collaborate with the host for conitnuos clock mode. Add changes neccessary to enable continuous clock mode in the 7nm DSI PHYs. Signed-off-by: Dmitry Baryshkov --- drivers/gpu/drm/msm/dsi/dsi.h | 4 +++-

[Freedreno] [RESEND 14/26] drm/msm/dp/dp_link: Fix some potential doc-rot

2021-06-02 Thread Lee Jones
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/dp/dp_link.c:374: warning: expecting prototype for dp_parse_video_pattern_params(). Prototype was for dp_link_parse_video_pattern_params() instead drivers/gpu/drm/msm/dp/dp_link.c:573: warning: expecting prototype for

[Freedreno] [RESEND 13/26] drm/msm/dp/dp_catalog: Correctly document param 'dp_catalog'

2021-06-02 Thread Lee Jones
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/dp/dp_catalog.c:206: warning: Function parameter or member 'dp_catalog' not described in 'dp_catalog_aux_reset' drivers/gpu/drm/msm/dp/dp_catalog.c:206: warning: Excess function parameter 'aux' description in

[Freedreno] [RESEND 12/26] drm/msm/msm_gem: Demote kernel-doc abuses

2021-06-02 Thread Lee Jones
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/msm_gem.c:364: warning: This comment starts with '/**', but isn't a kernel-doc comment. Refer Documentation/doc-guide/kernel-doc.rst drivers/gpu/drm/msm/msm_gem.c:763: warning: This comment starts with '/**', but isn't a

[Freedreno] [RESEND 10/26] drm/msm/disp/dpu1/dpu_hw_interrupts: Demote a bunch of kernel-doc abuses

2021-06-02 Thread Lee Jones
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c:17: warning: expecting prototype for Register offsets in MDSS register file for the interrupt registers(). Prototype was for MDP_SSPP_TOP0_OFF() instead

[Freedreno] [RESEND 11/26] drm/msm/disp/dpu1/dpu_plane: Fix a couple of naming issues

2021-06-02 Thread Lee Jones
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/disp/dpu1/dpu_plane.c:373: warning: expecting prototype for _dpu_plane_set_panic_lut(). Prototype was for _dpu_plane_set_danger_lut() instead drivers/gpu/drm/msm/disp/dpu1/dpu_plane.c:498: warning: expecting prototype for

[Freedreno] [RESEND 09/26] drm/msm/disp/dpu1/dpu_encoder_phys_cmd: Remove unused variable 'cmd_enc'

2021-06-02 Thread Lee Jones
Fixes the following W=1 kernel build warning(s): drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c: In function ‘dpu_encoder_phys_cmd_wait_for_commit_done’: drivers/gpu/drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c:688:31: warning: variable ‘cmd_enc’ set but not used [-Wunused-but-set-variable]

[Freedreno] [RESEND 00/26] Rid W=1 warnings from GPU

2021-06-02 Thread Lee Jones
Some off these patches have been knocking around for a while. Who will hoover them up please? This set is part of a larger effort attempting to clean-up W=1 kernel builds, which are currently overwhelmingly riddled with niggly little warnings. Lee Jones (26): drm/mediatek/mtk_disp_color:

Re: [Freedreno] [RFC PATCH 03/13] drm/msm/dsi: add support for dsc data

2021-06-02 Thread Vinod Koul
On 28-05-21, 13:29, Dmitry Baryshkov wrote: > On 21/05/2021 15:49, Vinod Koul wrote: > > DSC needs some configuration from device tree, add support to read and > > store these params and add DSC structures in msm_drv > > > > Signed-off-by: Vinod Koul > > --- > >

Re: [Freedreno] [RFC PATCH 03/13] drm/msm/dsi: add support for dsc data

2021-06-02 Thread Vinod Koul
On 28-05-21, 02:45, Dmitry Baryshkov wrote: > On 21/05/2021 15:49, Vinod Koul wrote: > > DSC needs some configuration from device tree, add support to read and > > store these params and add DSC structures in msm_drv > > > > Signed-off-by: Vinod Koul > > --- > >

Re: [Freedreno] [RFC PATCH 00/13] drm/msm: Add Display Stream Compression Support

2021-06-02 Thread Vinod Koul
On 27-05-21, 16:30, Rob Clark wrote: > On Wed, May 26, 2021 at 8:00 AM Jeffrey Hugo wrote: > > On Tue, May 25, 2021 at 11:46 PM Vinod Koul wrote: > > Frankly, I don't like the MSM ACPI solution that I've seen on the laptops. > > The ACPI assumes the entire MDSS (including DSI parts) and GPU is

Re: [Freedreno] [RFC PATCH 00/13] drm/msm: Add Display Stream Compression Support

2021-06-02 Thread Vinod Koul
On 26-05-21, 09:00, Jeffrey Hugo wrote: > On Tue, May 25, 2021 at 11:46 PM Vinod Koul wrote: > > On 21-05-21, 08:09, Jeffrey Hugo wrote: > > > On Fri, May 21, 2021 at 6:50 AM Vinod Koul wrote: > > > > > > > > Display Stream Compression (DSC) compresses the display stream in host > > > > which >