Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread Beckmann, Brad
1. Below is a snip of a protocol trace that I recently used. I think it is important for us maintain that there is no DPRINTF information prepended to each line. The initial motivation for the protocol trace, was that tracing protocol transitions using standard debug print was too

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread Nilay
Brad, This how protocol trace would look like. I actually did not some such thing exists. I was currently relying on DPRINTF statements for checking the events that occurred. This is certainly easier to read and much more compact. 1395: system.l1_cntrl3:1395 3L1Cache

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread nathan binkert
Looks like we should just remove the first, second, and third columns that are spit out since they're covered almost exactly by the implicit columns added by DPRINTF. Right? Nate This how protocol trace would look like. I actually did not some such thing exists. I was currently relying on

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread nathan binkert
1. Below is a snip of a protocol trace that I recently used. I think it is important for us maintain that there is no DPRINTF information prepended to each line. The initial motivation for the protocol trace, was that tracing protocol transitions using standard debug print was too

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread Beckmann, Brad
AM To: M5 Developer List Cc: Beckmann, Brad Subject: Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh Looks like we should just remove the first, second, and third columns that are spit out since they're covered almost exactly by the implicit columns added by DPRINTF. Right

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread Beckmann, Brad
So if we explicitly handled the SIGABRT signal, we would only want to do that if we are running interactively, correct? If so, then we would still have some sort of conditional similar, if not the same as, the current conditional in the assert macro if (isatty(STDIN_FILENO)). If my

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread nathan binkert
Is it possible to fix the width of the information prepended by DPRINTF?  I would be great if we could maintain the current fixed width format. That might be hard (and may argue for DPRINTFN). In practice, when I want that, I usually just ensure that my object names end up not varying in

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread nathan binkert
So if we explicitly handled the SIGABRT signal, we would only want to do that if we are running interactively, correct?  If so, then we would still have some sort of conditional similar, if not the same as, the current conditional in the assert macro “if (isatty(STDIN_FILENO))”.  If my

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-05 Thread Beckmann, Brad
Sent: Wednesday, January 05, 2011 12:30 PM To: Beckmann, Brad Cc: M5 Developer List Subject: Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh Is it possible to fix the width of the information prepended by DPRINTF?  I would be great if we could maintain the current fixed width

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-04 Thread Nathan Binkert
--- This is an automatically generated e-mail. To reply, visit: http://reviews.m5sim.org/r/367/ --- (Updated 2011-01-04 15:02:38.269001) Review request for Default, Ali Saidi, Gabe

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-04 Thread Brad Beckmann
--- This is an automatically generated e-mail. To reply, visit: http://reviews.m5sim.org/r/367/#review608 --- Hi Nate, I have a couple questions: 1. Have you looked at the protocol

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-04 Thread Ali Saidi
--- This is an automatically generated e-mail. To reply, visit: http://reviews.m5sim.org/r/367/#review611 --- src/mem/ruby/buffers/MessageBuffer.cc

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-04 Thread Nathan Binkert
On 2011-01-04 16:48:28, Ali Saidi wrote: src/mem/ruby/buffers/MessageBuffer.cc, line 163 http://reviews.m5sim.org/r/367/diff/3/?file=8418#file8418line163 Why continue to comment this out? Mostly because I didn't do it. I don't like commented code in the tree, and one of the

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-04 Thread Nilay Vaish
On 2011-01-04 16:31:01, Brad Beckmann wrote: Hi Nate, I have a couple questions: 1. Have you looked at the protocol trace output after your change? Does it look exactly like it did before? It seems that the output should be the same based on my brief inspection of your patch, but I

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-04 Thread nathan binkert
Brad, do you have some protocol trace with you? I have seen the trace that gets generated with the current trace facility using Ruby trace flag. It prints all the events for all the cache controllers and network routers. If you prefer, I can send you an example trace. Or you can generate

Re: [m5-dev] Review Request: ruby: get rid of ruby's Debug.hh

2011-01-04 Thread Nathan Binkert
On 2011-01-04 19:17:43, Nilay Vaish wrote: src/mem/ruby/network/garnet/flexible-pipeline/GarnetNetwork.cc, line 194 http://reviews.m5sim.org/r/367/diff/3/?file=8431#file8431line194 Should this not be converted to DPRINTF()? Perhaps, but that is really a separate change. I don't