Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Tim Harder
On 2019-12-06 Fri 02:15, Michał Górny wrote: > > I think that is not an apt description in my understanding of your original > > post on the matter. The package.deprecated file is supposed to contain not > > just (qualified) package names, but some sort of package dependency > > specifications

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Michał Górny
On Fri, 2019-12-06 at 01:36 +0100, Chí-Thanh Christopher Nguyễn wrote: > Michał Górny schrieb: > > + > > +# > > +# This file specifies packages that are considered deprecated > > I think that is not an apt description in my

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Kent Fredric
On Thu, 5 Dec 2019 09:40:50 -0500 Aaron Bauman wrote: > Wonderful response, William. Just because its EOL, doesn't mean it stops working. It just means *support* for defects and security problems is dropped. It doesn't prevent us from: a) vendor patching bugs b) vendor patching security

[gentoo-dev] media-sound/abcde mask seems unnecessary

2019-12-05 Thread Ashley Dixon
media-sound/abcde was added to the package.mask due to the lack of python3 support on one of its dependencies, dev-python/eyeD3. Since that has been fixed, and eyeD3 is no longer masked, why the abcde mask ? From a quick look, it doesn't need any packages which have no python3 implementation. [I

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Chí-Thanh Christopher Nguyễn
Michał Górny schrieb: + +# +# This file specifies packages that are considered deprecated I think that is not an apt description in my understanding of your original post on the matter. The package.deprecated file is supposed

[gentoo-portage-dev] [PATCH] repoman: support profiles/package.deprecated (bug 702100)

2019-12-05 Thread Zac Medico
Bug: https://bugs.gentoo.org/702100 Signed-off-by: Zac Medico --- repoman/cnf/qa_data/qa_data.yaml | 1 + repoman/cnf/repository/qa_data.yaml | 1 + repoman/lib/repoman/modules/scan/depend/_depend_checks.py | 5 + repoman/lib/repoman/scanner.py

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Aaron Bauman
On Thu, Dec 05, 2019 at 05:09:57PM +0100, Michał Górny wrote: > Signed-off-by: Michał Górny > --- > profiles/package.deprecated | 17 + > 1 file changed, 17 insertions(+) > create mode 100644 profiles/package.deprecated > > diff --git a/profiles/package.deprecated

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Rich Freeman
On Thu, Dec 5, 2019 at 5:23 PM David Seifert wrote: > > And that's exactly the straw-man argument I've been making. You can > always come up with an excuse to delay action on python 2, because > "someone, somewhere, will maintain it". Hey, if somebody actually does want to maintain it I don't

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread David Seifert
On Thu, 2019-12-05 at 21:56 +0100, Thomas Deutschmann wrote: > On 2019-12-05 21:31, David Seifert wrote: > > > On another topic, I'd prefer for python 2.7 not to be removed > > > from > > > gentoo. Tons of code still uses it. > > > > > Sorry, but I'll have to disagree with you on this. > > > >

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Alexis Ballier
On Thu, 2019-12-05 at 19:04 +0100, Michał Górny wrote: > On Thu, 2019-12-05 at 18:59 +0100, Alexis Ballier wrote: > > On Thu, 2019-12-05 at 18:39 +0100, Michał Górny wrote: > > > On Thu, 2019-12-05 at 17:36 +0100, Alexis Ballier wrote: > > > > On Thu, 2019-12-05 at 17:09 +0100, Michał Górny wrote:

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Thomas Deutschmann
On 2019-12-05 21:31, David Seifert wrote: >> On another topic, I'd prefer for python 2.7 not to be removed from >> gentoo. Tons of code still uses it. >> > Sorry, but I'll have to disagree with you on this. > > We're removing Java too from Gentoo (more implicitly than explicitly), > because the

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread David Seifert
On Thu, 2019-12-05 at 14:59 +0100, Jason A. Donenfeld wrote: > On Thu, Dec 5, 2019 at 2:56 PM Rich Freeman wrote: > > On Thu, Dec 5, 2019 at 8:42 AM Jason A. Donenfeld > > wrote: > > > Hi, > > > > > > Aaron has marked tons of important and useful Python 2.7 packages > > > for removal: > > > >

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Gerion Entrup
Am Donnerstag, 5. Dezember 2019, 19:04:50 CET schrieb Michał Górny: > On Thu, 2019-12-05 at 18:59 +0100, Alexis Ballier wrote: > > unless i missed something, repoman is still the standard for pre-commit > > checks and raising everyone's attention on potential > > improvements/issues; > > Nope.

[gentoo-dev] Last rites: app-laptop/nvidiabl

2019-12-05 Thread Michał Górny
# Michał Górny (2019-12-05) # Last maintainer activity in 2016. Does not build for quite some time # already. Needs a version bump, at the very least. # Removal in 30 days. Bug #602024. app-laptop/nvidiabl -- Best regards, Michał Górny signature.asc Description: This is a digitally signed

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Alec Warner
On Thu, Dec 5, 2019 at 8:10 AM Michał Górny wrote: > Signed-off-by: Michał Górny > --- > profiles/package.deprecated | 17 + > 1 file changed, 17 insertions(+) > create mode 100644 profiles/package.deprecated > > This looks great Michał, thanks for putting it together. -A >

[gentoo-portage-dev] [PATCH] emerge: add --implicit-system-deps option (bug 681312)

2019-12-05 Thread Zac Medico
Assume that packages may have implicit dependencies on packages which belong to the @system set. This option is enabled by default. One of the effects of disabling this option is to allow the --jobs option to spawn jobs without accounting for the possiblity of implicit dependencies on packages

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Michał Górny
On Thu, 2019-12-05 at 18:59 +0100, Alexis Ballier wrote: > On Thu, 2019-12-05 at 18:39 +0100, Michał Górny wrote: > > On Thu, 2019-12-05 at 17:36 +0100, Alexis Ballier wrote: > > > On Thu, 2019-12-05 at 17:09 +0100, Michał Górny wrote: > > > >

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Alexis Ballier
On Thu, 2019-12-05 at 18:39 +0100, Michał Górny wrote: > On Thu, 2019-12-05 at 17:36 +0100, Alexis Ballier wrote: > > On Thu, 2019-12-05 at 17:09 +0100, Michał Górny wrote: > > > + > > > > > > +# > > > +# This file specifies

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Mikle Kolyada
+1 5 декабря 2019 г. 19:09:57 GMT+03:00, "Michał Górny" пишет: >Signed-off-by: Michał Górny >--- > profiles/package.deprecated | 17 + > 1 file changed, 17 insertions(+) > create mode 100644 profiles/package.deprecated > >diff --git a/profiles/package.deprecated

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Michał Górny
On Thu, 2019-12-05 at 17:36 +0100, Alexis Ballier wrote: > On Thu, 2019-12-05 at 17:09 +0100, Michał Górny wrote: > > + > > +# > > +# This file specifies packages that are considered deprecated (but > > not > > +# masked yet). It

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Alexis Ballier
On Thu, 2019-12-05 at 10:53 -0600, William Hubbs wrote: > On Thu, Dec 05, 2019 at 05:36:58PM +0100, Alexis Ballier wrote: > > On Thu, 2019-12-05 at 17:09 +0100, Michał Górny wrote: > > > + > > > > > > +# > > > +# This file

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread William Hubbs
On Thu, Dec 05, 2019 at 05:36:58PM +0100, Alexis Ballier wrote: > On Thu, 2019-12-05 at 17:09 +0100, Michał Górny wrote: > > + > > +# > > +# This file specifies packages that are considered deprecated (but > > not > > +# masked

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Matt Turner
On Thu, Dec 5, 2019 at 11:10 AM Michał Górny wrote: > > Signed-off-by: Michał Górny > --- > profiles/package.deprecated | 17 + > 1 file changed, 17 insertions(+) > create mode 100644 profiles/package.deprecated > > diff --git a/profiles/package.deprecated

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Andreas K. Huettel
Am Donnerstag, 5. Dezember 2019, 17:09:57 CET schrieb Michał Górny: [...] > +# This file specifies packages that are considered deprecated (but not > +# masked yet). It will trigger pkgcheck warnings whenever other > +# packages depend on them. Just saying, this is an awesome functionality, and

Re: [gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Alexis Ballier
On Thu, 2019-12-05 at 17:09 +0100, Michał Górny wrote: > + > +# > +# This file specifies packages that are considered deprecated (but > not > +# masked yet). It will trigger pkgcheck warnings whenever other > +# packages depend

[gentoo-dev] Last rites: net-wireless/ndiswrapper

2019-12-05 Thread Michał Górny
# Michał Górny (2019-12-05) # Unmaintained since 2016. Last touched in 2018. Pending bump since # Feb 2019. Does not build anymore. # Removal in 30 days. Bug #695580. net-wireless/ndiswrapper -- Best regards, Michał Górny signature.asc Description: This is a digitally signed message part

[gentoo-dev] [PATCH] package.deprecated: Create initial template

2019-12-05 Thread Michał Górny
Signed-off-by: Michał Górny --- profiles/package.deprecated | 17 + 1 file changed, 17 insertions(+) create mode 100644 profiles/package.deprecated diff --git a/profiles/package.deprecated b/profiles/package.deprecated new file mode 100644 index ..b4803a4ce68f ---

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Andreas K. Huettel
How about adding yourself as maintainer then? :) Am Donnerstag, 5. Dezember 2019, 14:42:59 CET schrieb Jason A. Donenfeld: > Hi, > > Aaron has marked tons of important and useful Python 2.7 packages for > removal: > > https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d85e166dd999c354a5346fb

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Aaron Bauman
On Thu, Dec 05, 2019 at 09:34:16AM -0500, William Breathitt Gray wrote: > On Thu, Dec 05, 2019 at 09:24:26AM -0500, Rich Freeman wrote: > > On Thu, Dec 5, 2019 at 8:59 AM Jason A. Donenfeld wrote: > > > > > > It's quite another to mask random packages that have USE flags to > > > optionally

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Aaron Bauman
On Thu, Dec 05, 2019 at 02:42:59PM +0100, Jason A. Donenfeld wrote: > Hi, > > Aaron has marked tons of important and useful Python 2.7 packages for removal: > > https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d85e166dd999c354a5346fbb5768cc6f38ac > > There are quite a few useful

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread William Breathitt Gray
On Thu, Dec 05, 2019 at 09:24:26AM -0500, Rich Freeman wrote: > On Thu, Dec 5, 2019 at 8:59 AM Jason A. Donenfeld wrote: > > > > It's quite another to mask random packages that have USE flags to > > optionally support whatever python 2.7 library. If you're going to > > last rites these, talk with

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Rich Freeman
On Thu, Dec 5, 2019 at 8:59 AM Jason A. Donenfeld wrote: > > It's quite another to mask random packages that have USE flags to > optionally support whatever python 2.7 library. If you're going to > last rites these, talk with the maintainer first, and only then, send > emails one at a time. Doing

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Jason A. Donenfeld
On Thu, Dec 5, 2019 at 2:56 PM Rich Freeman wrote: > > On Thu, Dec 5, 2019 at 8:42 AM Jason A. Donenfeld wrote: > > > > Hi, > > > > Aaron has marked tons of important and useful Python 2.7 packages for > > removal: > > > > Can we not do this prematurely? I've revered this commit until such a >

Re: [gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Rich Freeman
On Thu, Dec 5, 2019 at 8:42 AM Jason A. Donenfeld wrote: > > Hi, > > Aaron has marked tons of important and useful Python 2.7 packages for removal: > > Can we not do this prematurely? I've revered this commit until such a > thing an be appropriately agreed upon. Might make sense to wait to mask

[gentoo-dev] unsanctioned python 2.7 crusade

2019-12-05 Thread Jason A. Donenfeld
Hi, Aaron has marked tons of important and useful Python 2.7 packages for removal: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d85e166dd999c354a5346fbb5768cc6f38ac There are quite a few useful packages in here. Can we not do this prematurely? I've revered this commit until such a

Re: [gentoo-dev] Last rites: dev-python/* leaf packages

2019-12-05 Thread Alexis Ballier
On Wed, 2019-12-04 at 19:15 -0500, Aaron Bauman wrote: > * Removal in 30 days > IMHO masking with unfixed, or much later, removal date will better help achieve your goal: You are making your point by having them masked so that it will make enough noise for interested people to understand py2

Re: [gentoo-dev] Last rites: dev-python/* leaf packages

2019-12-05 Thread Gerion Entrup
Am Donnerstag, 5. Dezember 2019, 01:15:48 CET schrieb Aaron Bauman: > dev-python/pycdio Has Python 3 support since 2.1 (released in August this year). Developed by libcdio itself. > app-text/pdfshuffler Was last rited a few day ago. As I said, pdfarranger

Re: [gentoo-dev] Last rites: dev-python/* leaf packages

2019-12-05 Thread Tobias Klausmann
Hi! On Wed, 04 Dec 2019, Aaron Bauman wrote: > dev-python/eyeD3 > media-sound/abcde > media-sound/gpodder FWIW, eyeD3 has a Py3 (only!) version available. Since abcde is a shell script that just calls the eyeD3 binary, the API changes don't matter. And gpodder is Py3 only itself, so it can't