[PATCH v3 5/5] init: kill git_link variable

2016-09-24 Thread Nguyễn Thái Ngọc Duy
Signed-off-by: Nguyễn Thái Ngọc Duy --- builtin/init-db.c | 16 1 file changed, 4 insertions(+), 12 deletions(-) diff --git a/builtin/init-db.c b/builtin/init-db.c index 8069cd2..37e318b 100644 --- a/builtin/init-db.c +++ b/builtin/init-db.c @@ -22,7 +22,6 @@

[PATCH v3 4/5] init: do not set unnecessary core.worktree

2016-09-24 Thread Nguyễn Thái Ngọc Duy
The function needs_work_tree_config() that is called from create_default_files() is supposed to be fed the path to ".git" that looks as if it is at the top of the working tree, and decide if that location matches the actual worktree being used. This comparison allows "git init" to decide if

[PATCH v3 1/5] init: correct re-initialization from a linked worktree

2016-09-24 Thread Nguyễn Thái Ngọc Duy
When 'git init' is called from a linked worktree, we treat '.git' dir (which is $GIT_COMMON_DIR/worktrees/something) as the main '.git' (i.e. $GIT_COMMON_DIR) and populate the whole repository skeleton in there. It does not harm anything (*) but it is still wrong. Since 'git init' calls

[PATCH v3 2/5] init: call set_git_dir_init() from within init_db()

2016-09-24 Thread Nguyễn Thái Ngọc Duy
The next commit requires that set_git_dir_init() must be called before init_db(). Let's make sure nobody can do otherwise. Signed-off-by: Nguyễn Thái Ngọc Duy --- builtin/clone.c | 15 +++ builtin/init-db.c | 18 +++--- cache.h | 5 +++--

[PATCH v3 3/5] init: kill set_git_dir_init()

2016-09-24 Thread Nguyễn Thái Ngọc Duy
This is a pure code move, necessary to kill the global variable git_link later (and also helps a bit in the next patch). Signed-off-by: Nguyễn Thái Ngọc Duy --- builtin/init-db.c | 50 +- 1 file changed, 21 insertions(+), 29

Re: [PATCH v2 4/3] init: combine set_git_dir_init() and init_db() into one

2016-09-24 Thread Duy Nguyen
On Sat, Sep 24, 2016 at 11:55:33AM -0700, Junio C Hamano wrote: > Junio C Hamano writes: > > > I think this 4/3 is not quite enough to fix the damage to the code > > caused by 2/3. > > ... > > after 4/3 is applied, we should be able to remove the global > > variable 2/3

Re: [PATCH v8 05/11] pkt-line: add packet_flush_gently()

2016-09-24 Thread Jakub Narębski
W dniu 20.09.2016 o 21:02, larsxschnei...@gmail.com pisze: > From: Lars Schneider > > packet_flush() would die in case of a write error even though for some > callers an error would be acceptable. Add packet_flush_gently() which > writes a pkt-line flush packet like

Re: [PATCH v3 2/2] gitweb: use highlight's shebang detection

2016-09-24 Thread Ian Kelling
On Sat, Sep 24, 2016, at 09:21 AM, Jakub Narębski wrote: > W dniu 24.09.2016 o 00:15, Jakub Narębski pisze: > > Sidenote: this way of benchmarking of gitweb falls between two ways of > doing a benchmark. > > The first method is to simply run gitweb as a standalone script, passing > its

Re: [PATCH v3 2/2] gitweb: use highlight's shebang detection

2016-09-24 Thread Ian Kelling
On Fri, Sep 23, 2016, at 03:15 PM, Jakub Narębski wrote: > W dniu 23.09.2016 o 11:08, Ian Kelling napisał: > > > The "highlight" binary can, in some cases, determine the language type > > by the means of file contents, for example the shebang in the first line > > for some scripting languages.

[PATCH v4 2/2] gitweb: use highlight's shebang detection

2016-09-24 Thread Ian Kelling
The "highlight" binary can, in some cases, determine the language type by the means of file contents, for example the shebang in the first line for some scripting languages. Make use of this autodetection for files which syntax is not known by gitweb. In that case, pass the blob contents to

[PATCH v4 1/2] gitweb: remove unused guess_file_syntax() parameter

2016-09-24 Thread Ian Kelling
Signed-off-by: Ian Kelling --- Notes: The only change from v3 is a more descriptive commit message gitweb/gitweb.perl | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/gitweb/gitweb.perl b/gitweb/gitweb.perl index 33d701d..6cb4280 100755 ---

Re: [PATCH v8 04/11] pkt-line: add packet_write_fmt_gently()

2016-09-24 Thread Jakub Narębski
W dniu 20.09.2016 o 21:02, larsxschnei...@gmail.com pisze: > From: Lars Schneider > > packet_write_fmt() would die in case of a write error even though for > some callers an error would be acceptable. Add packet_write_fmt_gently() > which writes a formatted pkt-line

Re: [PATCH v8 03/11] run-command: move check_pipe() from write_or_die to run_command

2016-09-24 Thread Jakub Narębski
W dniu 20.09.2016 o 21:02, larsxschnei...@gmail.com pisze: > From: Lars Schneider > > Move check_pipe() to run_command and make it public. This is necessary > to call the function from pkt-line in a subsequent patch. All right. > > Signed-off-by: Lars Schneider

Re: [PATCH v8 02/11] pkt-line: extract set_packet_header()

2016-09-24 Thread Jakub Narębski
W dniu 20.09.2016 o 21:02, larsxschnei...@gmail.com pisze: > From: Lars Schneider > > Subject: [PATCH v8 02/11] pkt-line: extract set_packet_header() > > set_packet_header() converts an integer to a 4 byte hex string. Make > this function locally available so that

Re: [PATCH v8 01/11] pkt-line: rename packet_write() to packet_write_fmt()

2016-09-24 Thread Jakub Narębski
Hello Lars, W dniu 20.09.2016 o 21:02, larsxschnei...@gmail.com pisze: > From: Lars Schneider > > packet_write() should be called packet_write_fmt() as the string > parameter can be formatted. I would say: packet_write() should be called packet_write_fmt() because

Re: [PATCH v3] checkout: eliminate unnecessary merge for trivial checkout

2016-09-24 Thread Philip Oakley
Hi Junio, From: "Junio C Hamano" "Philip Oakley" writes: > >"git checkout -b foo" (without -f -m or ) is defined in > >the manual as being a shortcut for/equivalent to: > > > >(1a) "git branch foo" > >(1b) "git checkout foo" > > >

Re: [RFC/PATCH 0/6] Add --format to tag verification

2016-09-24 Thread Jakub Narębski
W dniu 22.09.2016 o 21:01, Stefan Beller pisze: > On Thu, Sep 22, 2016 at 11:53 AM, wrote: > >> >> P.S. Gmane seems to be broken for git after it was rebooted. Should we ping >> them about it? > > I think most of the git developers have moved on and reference emails by >

Re: What's cooking in git.git (Sep 2016, #07; Fri, 23)

2016-09-24 Thread Johannes Schindelin
Hi Junio, On Fri, 23 Sep 2016, Junio C Hamano wrote: > A bunch of topics have graduated to 'next', including a few that > were so far marked as "needs review" or "will hold", as I think > giving them a greater visibility and guinea pigs would be the most > efficient way to get feedback from the

Re: [PATCH v2 4/3] init: combine set_git_dir_init() and init_db() into one

2016-09-24 Thread Junio C Hamano
Junio C Hamano writes: > I think this 4/3 is not quite enough to fix the damage to the code > caused by 2/3. > ... > after 4/3 is applied, we should be able to remove the global > variable 2/3 introduced, make init_db() receive that information as > the return value of

Re: [PATCH v3] checkout: eliminate unnecessary merge for trivial checkout

2016-09-24 Thread Junio C Hamano
"Philip Oakley" writes: >> > >"git checkout -b foo" (without -f -m or ) is defined in >> > >the manual as being a shortcut for/equivalent to: >> > > >> > >(1a) "git branch foo" >> > >(1b) "git checkout foo" >> > > >> > >However, it has been our experience in

Re: [PATCH] git-gui: stop using deprecated merge syntax

2016-09-24 Thread Johannes Sixt
Am 24.09.2016 um 13:30 schrieb René Scharfe: Starting with v2.5.0 git merge can handle FETCH_HEAD internally and warns when it's called like 'git merge HEAD ' because that syntax is deprecated. Use this feature in git-gui and get rid of that warning. Signed-off-by: Rene Scharfe

Re: [PATCH v3 2/2] gitweb: use highlight's shebang detection

2016-09-24 Thread Junio C Hamano
Jakub Narębski writes: >> Also, "curling" is not the word I would like to see. I would say: >> >> Simple benchmark comparing performance of 'blob' view of files without >> syntax highlighting in gitweb before and after this change indicates >> ±1% difference in request

Re: [PATCH v3 2/2] gitweb: use highlight's shebang detection

2016-09-24 Thread Jakub Narębski
W dniu 24.09.2016 o 00:15, Jakub Narębski pisze: > W dniu 23.09.2016 o 11:08, Ian Kelling napisał: >>After curling blob view of unhighlighted large and small text >> files of perl code and license text 100 times each on a local >> Apache/2.4.23 (Debian) instance, it's logs indicate +-1%

Re: [PATCH v3] checkout: eliminate unnecessary merge for trivial checkout

2016-09-24 Thread Philip Oakley
Ben, Using a 'bottom / in-line' posting flow is much preferred, which may require some manual editing[1], hopefully I have it about right... Philip -- [1] this is massaged and mangled Outlook Express, sometimes one has to work with the tools at hand... From: "Ben Peart"

[PATCH] git-gui: stop using deprecated merge syntax

2016-09-24 Thread René Scharfe
Starting with v2.5.0 git merge can handle FETCH_HEAD internally and warns when it's called like 'git merge HEAD ' because that syntax is deprecated. Use this feature in git-gui and get rid of that warning. Signed-off-by: Rene Scharfe --- Tested only _very_ lightly!

Ich werde warten, von Ihnen zu hören.

2016-09-24 Thread Andrew Hau Chan
-- Lieber Freund, Wie geht es Ihnen heute? Ich habe eine Investitionsmöglichkeit mit Ihnen zu teilen, die die Übertragung einer großen Geldsumme zum gegenseitigen Nutzen für beide von uns betreffen. Mein Name ist Andrew Hau Chung, ich in einem Finanzinstitut arbeiten hier in Hong Kong.