Re: [PATCH v12 13/13] bisect--helper: `bisect_start` shell function partially in C

2016-08-13 Thread Christian Couder
On Wed, Aug 10, 2016 at 11:57 PM, Pranit Bauva wrote: > > @@ -431,6 +434,244 @@ static int bisect_terms(struct bisect_terms *terms, > const char **argv, int argc) > return 0; > } > > +static int bisect_start(struct bisect_terms *terms, int no_checkout, > + const cha

Re: A note from the maintainer

2016-08-13 Thread Jeff King
On Fri, Aug 12, 2016 at 10:42:55PM +, Eric Wong wrote: > Junio C Hamano wrote: > > For those who prefer to read it over NNTP: > > > > nntp://news.gmane.org/gmane.comp.version-control.git > > > > is still available. An alternative > > > > nntp://news.public-inbox.org/inbox.comp

Re: [PATCH] Speed up sparse checkout when $GIT_DIR/info/sparse-checkout is unchanged

2016-08-13 Thread Duy Nguyen
Ping.. On Tue, Jul 12, 2016 at 1:15 AM, Nguyễn Thái Ngọc Duy wrote: > When a "tree unpacking" operation is needed, which is part of > switching branches using "git checkout", the following happens in a > sparse checkout: > > 1) Run all existing entries through $GIT_DIR/info/sparse-checkout, >

Re: [PATCH v4] config: add conditional include

2016-08-13 Thread Duy Nguyen
Ping.. On Thu, Jul 14, 2016 at 10:33 PM, Nguyễn Thái Ngọc Duy wrote: > Helped-by: Jeff King > Signed-off-by: Nguyễn Thái Ngọc Duy > --- > The diff from v3 is mostly clarification in code and document. > > diff --git a/Documentation/config.txt b/Documentation/config.txt > index 18623ee.

Re: storing cover letter of a patch series?

2016-08-13 Thread Duy Nguyen
On Tue, Aug 9, 2016 at 12:27 AM, Stefan Beller wrote: > On Thu, Sep 10, 2015 at 9:28 AM, Jacob Keller wrote: >> Hey, >> >> does anyone know of any tricks for storing a cover letter for a patch >> series inside of git somehow? I'd guess the only obvious way currently >> is to store it at the top o

Re: [PATCH 8/8] diff: improve positioning of add/delete blocks in diffs

2016-08-13 Thread Jeff King
On Sat, Aug 13, 2016 at 01:25:05AM +0200, Michael Haggerty wrote: > > These two flags are mutually exclusive in the xdiff code, so we should > > probably handle that here. > > > > TBH, I do not care that much what: > > > > [diff] > > compactionHeuristic = true > > indentHeuristic = true >

[PATCH] correct FLEXPTR_* example in comment

2016-08-13 Thread René Scharfe
This section is about "The FLEXPTR_* variants", so use FLEXPTR_ALLOC_STR in the example. Signed-off-by: Rene Scharfe --- git-compat-util.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/git-compat-util.h b/git-compat-util.h index 590bfdd..f52e00b 100644 --- a/git-compat-util

Re: A note from the maintainer

2016-08-13 Thread Eric Wong
Jeff King wrote: > On Fri, Aug 12, 2016 at 10:42:55PM +, Eric Wong wrote: > > Junio C Hamano wrote: > > > is still available. An alternative > > > > > > nntp://news.public-inbox.org/inbox.comp.version-control.git > > > > > > will become usable once it catches up with old messages.

[PATCH] mailinfo: recycle strbuf in check_header()

2016-08-13 Thread René Scharfe
handle_message_id() duplicates the contents of the strbuf that is passed to it. Its only caller proceeds to release the strbuf immediately after that. Reuse it instead and make that change of object ownership more obvious by inlining this short function. Signed-off-by: Rene Scharfe --- mailinf

Re: [PATCH] correct FLEXPTR_* example in comment

2016-08-13 Thread Jeff King
On Sat, Aug 13, 2016 at 11:01:21AM +0200, René Scharfe wrote: > This section is about "The FLEXPTR_* variants", so use FLEXPTR_ALLOC_STR > in the example. Oops, yeah. Your patch is clearly an improvement. Since this is obviously an easy mistake to make (using one form rather than the other), I w

[PATCH] commit: introduce set_merge_remote_desc()

2016-08-13 Thread René Scharfe
Add a helper function for allocating, populating and attaching struct merge_remote_desc to a commit and use it consistently. It allocates the necessary memory in a single block. commit.c::get_merge_parent() forgot to check for memory allocation failures of strdup(3). merge-recursive.c::make_virt

Re: [PATCH] correct FLEXPTR_* example in comment

2016-08-13 Thread René Scharfe
Am 13.08.2016 um 11:09 schrieb Jeff King: On Sat, Aug 13, 2016 at 11:01:21AM +0200, René Scharfe wrote: This section is about "The FLEXPTR_* variants", so use FLEXPTR_ALLOC_STR in the example. Oops, yeah. Your patch is clearly an improvement. Since this is obviously an easy mistake to make (

Re: [PATCH] commit: introduce set_merge_remote_desc()

2016-08-13 Thread Jeff King
On Sat, Aug 13, 2016 at 11:14:31AM +0200, René Scharfe wrote: > Add a helper function for allocating, populating and attaching struct > merge_remote_desc to a commit and use it consistently. It allocates the > necessary memory in a single block. > > commit.c::get_merge_parent() forgot to check f

[ANNOUNCE] Git for Windows 2.9.3

2016-08-13 Thread Johannes Schindelin
Dear Git users, It is my pleasure to announce that Git for Windows 2.9.3 is available from: https://git-for-windows.github.io/ Changes since Git for Windows v2.9.2 (July 16th 2016) New Features ??? Comes with Git 2.9.3. ??? Updated Git Credential Manager to version 1.6.0. ??? Inc

Re: git difftool and git mergetool aren't returning errors when the tool has issues

2016-08-13 Thread John Keeping
On Fri, Aug 12, 2016 at 07:13:41AM -, Tom Tanner (BLOOMBERG/ LONDON) wrote: > For instance, if you set your diff/mergetool to meld and you don't have it > installed: > > git difftool > > Viewing (1/1): 'blah' > Launch 'meld' [Y/n]? y > /home/ttanner/bin/meld[8]: /opt/swt/bin/meld: not found >

Re: A note from the maintainer

2016-08-13 Thread Jeff King
On Sat, Aug 13, 2016 at 09:04:32AM +, Eric Wong wrote: > > Is there an easy way to get _just_ the list of message-ids you are > > storing (I know I can download the whole archive, but it's big)? > > XHDR (or HDR) over NNTP should do it (that's how I checked > against gmane): > 8<-

[PATCH] difftool: always honor "command not found" exit code

2016-08-13 Thread John Keeping
At the moment difftool's "trust exit code" logic always suppresses the exit status of the diff utility we invoke. This is useful because we don't want to exit just because diff returned "1" because the files differ, but it's confusing if the shell returns an error because the selected diff utility

Re: [PATCH] commit: introduce set_merge_remote_desc()

2016-08-13 Thread René Scharfe
Am 13.08.2016 um 11:23 schrieb Jeff King: On Sat, Aug 13, 2016 at 11:14:31AM +0200, René Scharfe wrote: Add a helper function for allocating, populating and attaching struct merge_remote_desc to a commit and use it consistently. It allocates the necessary memory in a single block. commit.c::g

[PATCH v2 1/4] commit: use xstrdup() in get_merge_parent()

2016-08-13 Thread René Scharfe
Handle allocation errors for the name member just like we already do for the struct merge_remote_desc itself. Signed-off-by: Rene Scharfe --- commit.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/commit.c b/commit.c index 71a360d..ccd232a 100644 --- a/commit.c +++ b/commit

[PATCH v2 2/4] commit: factor out set_merge_remote_desc()

2016-08-13 Thread René Scharfe
Export a helper function for allocating, populating and attaching a merge_remote_desc to a commit. Signed-off-by: Rene Scharfe --- commit.c | 19 --- commit.h | 2 ++ 2 files changed, 14 insertions(+), 7 deletions(-) diff --git a/commit.c b/commit.c index ccd232a..8bad713 10064

[PATCH v2 3/4] merge-recursive: fix verbose output for multiple base trees

2016-08-13 Thread René Scharfe
One of the indirect callers of make_virtual_commit() passes the result of oid_to_hex() as the name, i.e. a pointer to a static buffer. Since the function uses that string pointer directly in building a struct merge_remote_desc, multiple entries can end up sharing the same name inadvertently. Fix

[PATCH v2 4/4] commit: use FLEX_ARRAY in struct merge_remote_desc

2016-08-13 Thread René Scharfe
Convert the name member of struct merge_remote_desc to a FLEX_ARRAY and use FLEX_ALLOC_STR to build the struct. This halves the number of memory allocations, saves the storage for a pointer and avoids an indirection when reading the name. Suggested-by: Jeff King Signed-off-by: Rene Scharfe ---

Re: [PATCH] commit: introduce set_merge_remote_desc()

2016-08-13 Thread Jeff King
On Sat, Aug 13, 2016 at 02:07:42PM +0200, René Scharfe wrote: > So let's turn this dish into a full menu: > > commit: use xstrdup() in get_merge_parent() > commit: factor out set_merge_remote_desc() > merge-recursive: fix verbose output for multiple base trees > commit: use FLEX_ARRAY in

Re: [PATCH v12 13/13] bisect--helper: `bisect_start` shell function partially in C

2016-08-13 Thread Pranit Bauva
Hey Christian, On Sat, Aug 13, 2016 at 1:04 PM, Christian Couder wrote: > On Wed, Aug 10, 2016 at 11:57 PM, Pranit Bauva wrote: >> >> @@ -431,6 +434,244 @@ static int bisect_terms(struct bisect_terms *terms, >> const char **argv, int argc) >> return 0; >> } >> >> +static int bisect_sta

Re: Faith For Charity

2016-08-13 Thread Mrs. Maimouna Farooql
Dearly Beloved, I am very glad to write you this mail, my name is Mrs. Maimouna Farooq, and I am from Omani ancestral origin living in Abidjan for many years with my family. I am a good merchant; I have companies and good shares in various banks. I spend all my life on investment and Real Estat

Re: [PATCH] help: make option --help open man pages only for Git commands

2016-08-13 Thread Junio C Hamano
"Philip Oakley" writes: > But does it cope with the Guides? Should it cope if spelt that way? > > git help revisions > git revisions --help Hmph. Ralf's patch is not just "I wonder if we could do a bit better" but is also a regression. I do not particularly care if the latter stops working, bu

[PATCH] receive-pack: use FLEX_ALLOC_MEM in queue_command()

2016-08-13 Thread René Scharfe
Use the macro FLEX_ALLOC_MEM instead of open-coding it. This shortens and simplifies the code a bit. Signed-off-by: Rene Scharfe --- builtin/receive-pack.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/builtin/receive-pack.c b/builtin/receive-pack.c index 92e1213..011db

Re: [ANNOUNCE] Git for Windows 2.9.3

2016-08-13 Thread Junio C Hamano
Johannes Schindelin writes: > New Features > > • Comes with Git 2.9.3. For future reference, what time (in UTC) of the day is convenient for you to see an upstream tarball? > • Sports a new --smudge option for git cat-file that lets it pass > blob contents through smudge filters configu

Re: [PATCH 8/8] diff: improve positioning of add/delete blocks in diffs

2016-08-13 Thread Junio C Hamano
Jeff King writes: > So assuming everything I just said isn't complete bollocks, I think we > can move to a future where nobody uses the compaction heuristic. And > there are three ways to deal with that: > > 1. The knob and feature stay. It might be useful for somebody who > wants to exper

Re: [PATCH v1 1/2] t0027: Correct raciness in NNO test

2016-08-13 Thread Johannes Sixt
Am 12.08.2016 um 18:51 schrieb tbo...@web.de: From: Torsten Bögershausen When a non-reversible CRLF conversion is done in "git add", a warning is printed on stderr (or Git dies, depending on checksafe) The function commit_chk_wrnNNO() in t0027 was written to test this, but did the wrong thing:

Re: [PATCH] correct FLEXPTR_* example in comment

2016-08-13 Thread René Scharfe
Am 13.08.2016 um 11:09 schrieb Jeff King: On Sat, Aug 13, 2016 at 11:01:21AM +0200, René Scharfe wrote: This section is about "The FLEXPTR_* variants", so use FLEXPTR_ALLOC_STR in the example. Oops, yeah. Your patch is clearly an improvement. Since this is obviously an easy mistake to make (