[gwt-contrib] Comment on WAR_Design_1_6 in google-web-toolkit

2009-08-11 Thread codesite-noreply
Comment by mbiama.e...@live.fr: http://httpd.apache.org/docs/2.0/mod/core.html/?prefered=www.angosso_com_cgi.html/directive-dict.html#serverroot For more information: http://code.google.com/p/google-web-toolkit/wiki/WAR_Design_1_6 --~--~-~--~~~---~--~~

[gwt-contrib] Re: Add a tab key to wire protocol

2009-08-11 Thread jgw
On 2009/08/10 23:10:02, jat wrote: I also renamed the write* methods based on your earlier feedback. Minor nit, but is it really appropriate to call this a 'tab' key? It seems like more of a window key, by which I mean browser window, which may be a top-level window, a tab, or a frame.

[gwt-contrib] Re: Add a tab key to wire protocol

2009-08-11 Thread John Tamplin
On Tue, Aug 11, 2009 at 9:26 AM, j...@google.com wrote: On 2009/08/10 23:10:02, jat wrote: I also renamed the write* methods based on your earlier feedback. Minor nit, but is it really appropriate to call this a 'tab' key? It seems like more of a window key, by which I mean browser window,

[gwt-contrib] Re: UiBinder first impressions

2009-08-11 Thread Jason Parekh
Hey Gary, I can't speak more generally about GWT, but can give you some info on the plugin. We'll need more than just an XML schema (though we'll still have a simple schema defining the legal top-level elements, for example). The autocomplete choices will be too dynamic to be included in a

[gwt-contrib] add names to runAsync calls

2009-08-11 Thread spoon
Reviewers: scottb, Description: This patch allows naming a runAsync call using a class literal. There are now two overloads of GWT.runAsync, and the second one takes a class literal as an argument. That literal is recorded by the ReplaceRunAsyncs pass. It can then be used in the specification

[gwt-contrib] [google-web-toolkit] r5938 committed - Changed recently-committed test to exclude HtmlUnit, because it relies...

2009-08-11 Thread codesite-noreply
Revision: 5938 Author: j...@google.com Date: Tue Aug 11 09:09:06 2009 Log: Changed recently-committed test to exclude HtmlUnit, because it relies on correct layout. http://code.google.com/p/google-web-toolkit/source/detail?r=5938 Modified:

[gwt-contrib] [google-web-toolkit] r5939 committed - /trunk 5936 was merged into this branch...

2009-08-11 Thread codesite-noreply
Revision: 5939 Author: rj...@google.com Date: Tue Aug 11 09:25:40 2009 Log: /trunk 5936 was merged into this branch another wire protocol change to support the future ability to differentiate opening a new tab from refreshing an existing one svn merge -c5936

[gwt-contrib] Fix non-fatal WeakMapping compile errors

2009-08-11 Thread rjrjr
LGTM http://gwt-code-reviews.appspot.com/57810 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] [google-web-toolkit] r5940 committed - Fix compiler errors when importing only Core.gwt.xml....

2009-08-11 Thread codesite-noreply
Revision: 5940 Author: b...@google.com Date: Tue Aug 11 10:21:03 2009 Log: Fix compiler errors when importing only Core.gwt.xml. Fix generic type warnings in WeakMapping. Patch by: bobv Review by: rjrjr http://code.google.com/p/google-web-toolkit/source/detail?r=5940 Added:

[gwt-contrib] [google-web-toolkit] r5941 committed - Swap expectaed and actual args in assertEquals()

2009-08-11 Thread codesite-noreply
Revision: 5941 Author: r...@google.com Date: Tue Aug 11 10:26:45 2009 Log: Swap expectaed and actual args in assertEquals() http://code.google.com/p/google-web-toolkit/source/detail?r=5941 Modified: /trunk/user/test/com/google/gwt/emultest/java/util/EnumSetTest.java

[gwt-contrib] [google-web-toolkit] r5942 committed - Delete empty directory left by r5940....

2009-08-11 Thread codesite-noreply
Revision: 5942 Author: b...@google.com Date: Tue Aug 11 10:28:52 2009 Log: Delete empty directory left by r5940. Should have used 'git svn dcommit --rmdir' http://code.google.com/p/google-web-toolkit/source/detail?r=5942 Deleted:

[gwt-contrib] Re: Fix non-fatal WeakMapping compile errors

2009-08-11 Thread bruce
LGTM http://gwt-code-reviews.appspot.com/57810 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Bruce Johnson
There's sometimes an important difference between the kind of object model that is appropriate to send to the client and one you'd use on the server. That's the reason we haven't historically tried to make it easier to do no-brainer sharing of server-side object models to the client (i.e. because

[gwt-contrib] Re: Initial implementation of layout system, along with the first two layout widgets.

2009-08-11 Thread Joel Webber
Amir, Kango, A UI like Reader is very easy to formulate (it will be a lot easier when I check in DeckLayoutPanel). If you imagine a DeckPanel where 100% height actually works properly, you would write something like this: p.add(header, NORTH); p.add(navPane, WEST); p.add(footer, SOUTH);

[gwt-contrib] [google-web-toolkit] r5943 committed - Creates infrastructure to test individual compiler passes....

2009-08-11 Thread codesite-noreply
Revision: 5943 Author: sco...@google.com Date: Tue Aug 11 12:45:07 2009 Log: Creates infrastructure to test individual compiler passes. Also started some very basic tests for ControlFlowAnalyzer, ExpressionAnalyzer, and DeadCodeElimination. Hopefully this will start the process of fixing

[gwt-contrib] [google-web-toolkit] r5944 committed - Removes javax/servlet/*.java source files from gwt-user.jar....

2009-08-11 Thread codesite-noreply
Revision: 5944 Author: sco...@google.com Date: Tue Aug 11 12:50:31 2009 Log: Removes javax/servlet/*.java source files from gwt-user.jar. By popular demand, we're removing these source files from gwt-user.jar because Maven chokes on them and tries to recompile them. Issue: 3851 Review by:

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Nathan Wells
There's sometimes an important difference between the kind of object model that is appropriate to send to the client and one you'd use on the server. I absolutely agree with you here. And if I fully understand the current reasoning, DTO creation is a way of forcing developers to include as

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Fred Sauer
Nathan, To some extent you can make this happen by wrapping your method implementations with GWT.isScript() or GWT.isClient() calls as appropriate. Another approach is to use super-src so that you in fact have two implementations of your class, one for the client, one for the server. I realize

[gwt-contrib] Re: How to enable web mode debugging in GWT

2009-08-11 Thread Fred Sauer
gwt-log will print those stack traces for you. To get the most out of it you'll want to use GWT trunk and gwt-log trunk. To get started: http://code.google.com/p/gwt-log/wiki/GettingStarted In particular, make sure you: inherits name=com.google.gwt.core.EmulateJsStack/

[gwt-contrib] Re: Set cache headers properly in embedded Jetty for hosted mode

2009-08-11 Thread fredsa
Does this address issue 3682? http://code.google.com/p/google-web-toolkit/issues/detail?id=3682 http://gwt-code-reviews.appspot.com/56807 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Nathan Wells
Fred, If I understand you correctly, if I have a method void doFoo() { if (!(GWT.isClient() || GWT.isScript())){ //do server-side stuff with breaking JRE references } }//doFoo ... the compiler will ignore everything after the conditional. Is that accurate? On Aug 11, 2:13 pm, Fred

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Nathan Wells
Also, I don't know much about super-src. Can you point me to some documentation about that? Everything I've read says do X and this will happen I would like to have an understanding (superficial as my understanding is probably going to be) of what going on under the hood so that I know better

[gwt-contrib] Re: Initial implementation of layout system, along with the first two layout widgets.

2009-08-11 Thread Amir Kashani
You mean DockLayoutPanel, right? Anyway, makes perfect sense. The true challenge has always been with the 100% height desktop-app style layouts, which the new stuff will handle beautifully. Thanks. - Amir On Tue, Aug 11, 2009 at 12:38 PM, Joel Webber j...@google.com wrote: Amir, Kango, A UI

[gwt-contrib] Re: add names to runAsync calls

2009-08-11 Thread scottb
Hi Lex, I reviewed everything except CodeSplitter. I looked at it briefly, but that class is fairly unfamiliar to me. Maybe Kathrin or Bob is a better choice? http://gwt-code-reviews.appspot.com/56814/diff/1/10 File dev/core/src/com/google/gwt/dev/jjs/impl/ReplaceRunAsyncs.java (right):

[gwt-contrib] Re: Set cache headers properly in embedded Jetty for hosted mode

2009-08-11 Thread Scott Blum
I think so, I reassigned that bug to jat for that reason. On Tue, Aug 11, 2009 at 4:27 PM, fre...@gmail.com wrote: Does this address issue 3682? http://code.google.com/p/google-web-toolkit/issues/detail?id=3682 http://gwt-code-reviews.appspot.com/56807

[gwt-contrib] Re: Set cache headers properly in embedded Jetty for hosted mode

2009-08-11 Thread scottb
Adding potential second eyeball reviewers. http://gwt-code-reviews.appspot.com/56807 --~--~-~--~~~---~--~~ http://groups.google.com/group/Google-Web-Toolkit-Contributors -~--~~~~--~~--~--~---

[gwt-contrib] Re: add names to runAsync calls

2009-08-11 Thread Lex Spoon
On Tue, Aug 11, 2009 at 5:05 PM, sco...@google.com wrote: Hi Lex, I reviewed everything except CodeSplitter.  I looked at it briefly, but that class is fairly unfamiliar to me.  Maybe Kathrin or Bob is a better choice? Both of them already have reviews for me (or soon will). It's not

[gwt-contrib] Re: Initial implementation of layout system, along with the first two layout widgets.

2009-08-11 Thread ggeorg
Joel, is there a way to get the widget's default width/height? Maybe I do something wrong, but this code layer.setTopHeight(0, Unit.PX, north.getOffsetHeight(), Unit.PX); does not work, returned height is too small. Thanks, George. On Aug 11, 10:38 pm, Joel Webber j...@google.com wrote:

[gwt-contrib] Invalid version number 2.0 passed to external.gwtOnLoad()

2009-08-11 Thread Fred Sauer
When switching GWT versions on my project I get this error (when I'm lucky): *[ERROR] Invalid version number 2.0 passed to external.gwtOnLoad(), expected 1.6; your hosted mode bootstrap file may be out of date; if you are using -noserver try recompiling and redeploying your app* However, if I'm

[gwt-contrib] Re: Invalid version number 2.0 passed to external.gwtOnLoad()

2009-08-11 Thread John Tamplin
On Tue, Aug 11, 2009 at 7:50 PM, Fred Sauer fre...@google.com wrote: When switching GWT versions on my project I get this error (when I'm lucky): *[ERROR] Invalid version number 2.0 passed to external.gwtOnLoad(), expected 1.6; your hosted mode bootstrap file may be out of date; if you are

[gwt-contrib] Issue 3903 (cont'd) Add noscript tag to existing HTML pages

2009-08-11 Thread fredsa
Reviewers: Ray Ryan, Description: The .htmlsrc template was updated in http://gwt-code-reviews.appspot.com/51825 This review updates existing examples as well Please review this at http://gwt-code-reviews.appspot.com/57812 Affected files:

[gwt-contrib] Re: Invalid version number 2.0 passed to external.gwtOnLoad()

2009-08-11 Thread Fred Sauer
On Tue, Aug 11, 2009 at 5:14 PM, John Tamplin j...@google.com wrote: On Tue, Aug 11, 2009 at 7:50 PM, Fred Sauer fre...@google.com wrote: When switching GWT versions on my project I get this error (when I'm lucky): *[ERROR] Invalid version number 2.0 passed to external.gwtOnLoad(),

[gwt-contrib] [google-web-toolkit] r5945 committed - Correct misleading statement regarding plural forms reference....

2009-08-11 Thread codesite-noreply
Revision: 5945 Author: j...@google.com Date: Tue Aug 11 17:03:44 2009 Log: Correct misleading statement regarding plural forms reference. Patch by: rebeccaward Review by: abowers, bruce, jat http://code.google.com/p/google-web-toolkit/source/detail?r=5945 Modified:

[gwt-contrib] Re: Invalid version number 2.0 passed to external.gwtOnLoad()

2009-08-11 Thread John Tamplin
On Tue, Aug 11, 2009 at 8:22 PM, Fred Sauer fre...@google.com wrote: I'm not sure I understand the issue. If you have different versions of hosted.html and GWT, things are likely to not work and that is why that check was added in 1.6. I don't see how you could have the incorrect contents

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Gary Miller
I agree the problem is begging out for a more elegant solution. From the Google IO presentation on Google Wave powered by GWT a solution using proto buffer and JSON instead of GWT RPC is mentioned. I've been thinking that a similar result could be achieved annotation the server side object model

[gwt-contrib] Re: add names to runAsync calls

2009-08-11 Thread Scott Blum
On Tue, Aug 11, 2009 at 6:29 PM, Lex Spoon sp...@google.com wrote: Both of them already have reviews for me (or soon will). It's not really a code splitter change, but new code to associate names with AST nodes (in ReplaceRunAsync). CodeSplitter then looks up the names as recorded. I was

[gwt-contrib] [google-web-toolkit] r5946 committed - HtmlUnit should release its resources when the webClient reference is ...

2009-08-11 Thread codesite-noreply
Revision: 5946 Author: amitman...@google.com Date: Tue Aug 11 18:19:35 2009 Log: HtmlUnit should release its resources when the webClient reference is no longer held. Patch by: amitmanjhi Review by: kprobst (TBR) http://code.google.com/p/google-web-toolkit/source/detail?r=5946 Modified:

[gwt-contrib] Re: UiBinder first impressions

2009-08-11 Thread Gary Miller
Sounds great. Is there enough information in the classes for new GEP functionality or is extra information in going to need to be provided. Eg. the capabilities of the com.google.gwt.uibinder.parsers classes. There might be an opportunity to solve the custom widget parsing issue and the GEP auto

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Nathan Wells
Gary, I'm really much more concerned about the API itself, rather than the implementation details. That being said, I like the look of json marshaller. On Aug 11, 7:01 pm, Gary Miller miller.ga...@gmail.com wrote: I agree the problem is begging out for a more elegant solution. From the Google

[gwt-contrib] [google-web-toolkit] r5947 committed - Sort format SerializableTypeOracleBuilderTest.

2009-08-11 Thread codesite-noreply
Revision: 5947 Author: sco...@google.com Date: Tue Aug 11 19:11:51 2009 Log: Sort format SerializableTypeOracleBuilderTest. http://code.google.com/p/google-web-toolkit/source/detail?r=5947 Modified: /trunk/user/test/com/google/gwt/user/rebind/rpc/SerializableTypeOracleBuilderTest.java

[gwt-contrib] [google-web-toolkit] r5948 committed - Build fix: SerializableTypeOracleBuilderTest should use all the standa...

2009-08-11 Thread codesite-noreply
Revision: 5948 Author: sco...@google.com Date: Tue Aug 11 19:15:27 2009 Log: Build fix: SerializableTypeOracleBuilderTest should use all the standard units. Also some minor related cleanup. http://code.google.com/p/google-web-toolkit/source/detail?r=5948 Modified:

[gwt-contrib] [google-web-toolkit] r5949 committed - Make SerializableTypeOracleBuilderTest run much faster by not building...

2009-08-11 Thread codesite-noreply
Revision: 5949 Author: sco...@google.com Date: Tue Aug 11 19:16:05 2009 Log: Make SerializableTypeOracleBuilderTest run much faster by not building the same type oracle over and over. http://code.google.com/p/google-web-toolkit/source/detail?r=5949 Modified:

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Gary Miller
Nathan, I'm not quite sure which API you are referring too. As there isn't an API for DTOs. My interpritation of Fred's post presents alternate ways of implementing DTO. If the Wave protobuffer mechanism was publicly available it would be a great alternative to hand coded DTOs. An annotation

[gwt-contrib] SOYC for multiple permutations, plus updated layout

2009-08-11 Thread kprobst
Reviewers: Lex, Description: Hi Lex, would you review this patch to the SOYC dashboard for me? It has two main parts: 1) SOYC for multiple permutations. The dashboard will now read all files in the symbolMaps directory and from it derive all the permutations and their attributes. The

[gwt-contrib] Prettier GWT version names for upcoming 2.0 releases

2009-08-11 Thread Bruce Johnson
Mostly, this writeup is aimed at people who have been working on GWT's own build-related stuff, but if anyone else has objections, now would be a good time to raise them (though it seems unlikely anyone would). In the past, we've never had a good naming scheme for distros other than the general

[gwt-contrib] Re: Invalid version number 2.0 passed to external.gwtOnLoad()

2009-08-11 Thread Fred Sauer
On Tue, Aug 11, 2009 at 5:47 PM, John Tamplin j...@google.com wrote: On Tue, Aug 11, 2009 at 8:22 PM, Fred Sauer fre...@google.com wrote: I'm not sure I understand the issue. If you have different versions of hosted.html and GWT, things are likely to not work and that is why that check was

[gwt-contrib] Re: DTO compiler optimization

2009-08-11 Thread Miroslav Pokorny
@Gary I have not seen the GoogleIo vid, why do you say wave uses json AND protocol buffers to talk between client - server...? On 12/08/2009, at 11:01 AM, Gary Miller miller.ga...@gmail.com wrote: I agree the problem is begging out for a more elegant solution. From the Google IO