[Intel-gfx] [PATCH 2/5] drm/i915: Grab uncore.lock around enabling vblank evasion

2018-02-09 Thread Maarten Lankhorst
Signed-off-by: Maarten Lankhorst --- drivers/gpu/drm/i915/i915_irq.c | 2 +- drivers/gpu/drm/i915/intel_drv.h| 1 + drivers/gpu/drm/i915/intel_sprite.c | 10 ++ 3 files changed, 8 insertions(+), 5 deletions(-) diff --git

[Intel-gfx] [PATCH 4/5] drm/i915: Move all locking for plane updates to caller

2018-02-09 Thread Maarten Lankhorst
Signed-off-by: Maarten Lankhorst --- drivers/gpu/drm/i915/i915_trace.h| 15 +++- drivers/gpu/drm/i915/intel_display.c | 74 ++-- drivers/gpu/drm/i915/intel_pm.c | 16 drivers/gpu/drm/i915/intel_sprite.c |

[Intel-gfx] [PATCH 5/5] drm/i915: Use DOUBLE_BUFFER_CTL on top of vblank evasion for GEN9+.

2018-02-09 Thread Maarten Lankhorst
This way, if somehow we wait too long there won't be much damage done.. Signed-off-by: Maarten Lankhorst --- drivers/gpu/drm/i915/i915_reg.h | 3 +++ drivers/gpu/drm/i915/intel_sprite.c | 6 ++ 2 files changed, 9 insertions(+) diff --git

[Intel-gfx] [PATCH 1/5] drm/i915: Keep vblank irq enabled during vblank evasion.

2018-02-09 Thread Maarten Lankhorst
This is a nice preparation for grabbing the uncore lock during evasion. Grabbing the spinlock with the lock held messes up the locking, so it's easier to handover the reference to the event. Signed-off-by: Maarten Lankhorst ---

Re: [Intel-gfx] [PATCH v9 4/7] drm/i915/guc: Add support to return CNL specific reserved GuC WOPCM size

2018-02-09 Thread Joonas Lahtinen
Quoting Jackie Li (2018-02-09 01:03:52) > CNL has its specific reserved GuC WOPCM size for RC6 and other hardware > contexts. > > This patch updates the code to return CNL specific reserved GuC WOPCM size > for RC6 and other hardware contexts so that the GuC WOPCM size can be > calculated

Re: [Intel-gfx] ✗ Fi.CI.BAT: warning for ICL display initialization, selected patches (rev3)

2018-02-09 Thread Tomi Sarvela
On 02/08/18 15:34, Paulo Zanoni wrote: Em Ter, 2018-02-06 às 19:54 +, Patchwork escreveu: == Series Details == Series: ICL display initialization, selected patches (rev3) URL : https://patchwork.freedesktop.org/series/37668/ State : warning == Summary == Series 37668v3 ICL display

Re: [Intel-gfx] [PATCH] drm/i915: Rename drm_i915_gem_request to i915_request

2018-02-09 Thread Chris Wilson
Quoting Joonas Lahtinen (2018-02-09 07:48:21) > Quoting Chris Wilson (2018-02-09 01:11:34) > > We want to de-emphasize the link between the request (dependency, > > execution and fence tracking) from GEM and so rename the struct from > > drm_i915_gem_request to i915_request. That is we may

Re: [Intel-gfx] [PATCH v9 3/7] drm/i915/guc: Implement dynamic GuC WOPCM offset and size

2018-02-09 Thread Joonas Lahtinen
Quoting Jackie Li (2018-02-09 01:03:51) > Hardware may have specific restrictions on GuC WOPCM offset and size. On > Gen9, the value of the GuC WOPCM size register needs to be larger than the > value of GuC WOPCM offset register + a Gen9 specific offset (144KB) for > reserved GuC WOPCM. Fail to

[Intel-gfx] [PATCH v7] drm/i915/userptr: Probe vma range before gup

2018-02-09 Thread Chris Wilson
We want to exclude any GGTT objects from being present on our internal lists to avoid the deadlock we may run into with our requirement for struct_mutex during invalidate. However, if the gup_fast fails, we put the userptr onto the workqueue and mark it as active, so that we remember to serialise

Re: [Intel-gfx] [RFC] drm/i915: Use DOUBLE_BUFFER_CTL instead of vblank evasion for GEN9+.

2018-02-09 Thread Maarten Lankhorst
Op 08-02-18 om 19:27 schreef Ville Syrjälä: > On Thu, Feb 08, 2018 at 09:55:38AM +0100, Maarten Lankhorst wrote: >> References: https://bugs.freedesktop.org/show_bug.cgi?id=104975 >> Signed-off-by: Maarten Lankhorst >> --- >> drivers/gpu/drm/i915/i915_drv.h

Re: [Intel-gfx] [PATCH v9 2/7] drm/i915/guc: Rename guc_ggtt_offset to intel_guc_ggtt_offset

2018-02-09 Thread Joonas Lahtinen
Quoting Jackie Li (2018-02-09 01:03:50) > GuC related exported functions should start with "intel_guc_" prefix and > pass intel_guc as the first parameter since its guc related. Current > guc_ggtt_offset() failed to follow this code convention and this is a > problem for future patches that needs

<    1   2