Re: [PATCH 06/11] bcache: Use the blk_queue_flag_{set,clear}() functions

2018-03-02 Thread Martin K. Petersen

Bart,

> Use the blk_queue_flag_{set,clear}() functions instead of open-coding
> these.

Reviewed-by: Martin K. Petersen 

-- 
Martin K. Petersen  Oracle Linux Engineering


Re: [PATCH 06/11] bcache: Use the blk_queue_flag_{set,clear}() functions

2018-03-01 Thread Johannes Thumshirn
Looks good,
Reviewed-by: Johannes Thumshirn 
-- 
Johannes Thumshirn  Storage
jthumsh...@suse.de+49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850


Re: [PATCH 06/11] bcache: Use the blk_queue_flag_{set,clear}() functions

2018-02-28 Thread Michael Lyle
LGTM

On Wed, Feb 28, 2018 at 11:28 AM, Bart Van Assche
 wrote:
> Use the blk_queue_flag_{set,clear}() functions instead of open-coding
> these.
>
> Signed-off-by: Bart Van Assche 
> Cc: Michael Lyle 
> Cc: Kent Overstreet 
> Cc: Christoph Hellwig 
> Cc: Hannes Reinecke 
> Cc: Johannes Thumshirn 
> Cc: Ming Lei 
> ---
>  drivers/md/bcache/super.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/md/bcache/super.c b/drivers/md/bcache/super.c
> index 312895788036..047e30cb93dc 100644
> --- a/drivers/md/bcache/super.c
> +++ b/drivers/md/bcache/super.c
> @@ -833,9 +833,9 @@ static int bcache_device_init(struct bcache_device *d, 
> unsigned block_size,
> q->limits.io_min= block_size;
> q->limits.logical_block_size= block_size;
> q->limits.physical_block_size   = block_size;
> -   set_bit(QUEUE_FLAG_NONROT,  &d->disk->queue->queue_flags);
> -   clear_bit(QUEUE_FLAG_ADD_RANDOM, &d->disk->queue->queue_flags);
> -   set_bit(QUEUE_FLAG_DISCARD, &d->disk->queue->queue_flags);
> +   blk_queue_flag_set(QUEUE_FLAG_NONROT, d->disk->queue);
> +   blk_queue_flag_clear(QUEUE_FLAG_ADD_RANDOM, d->disk->queue);
> +   blk_queue_flag_set(QUEUE_FLAG_DISCARD, d->disk->queue);
>
> blk_queue_write_cache(q, true, true);
>
> --
> 2.16.2
>