Re: [PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Sean Young
On Mon, May 04, 2015 at 07:32:59PM +0200, Kamil Debski wrote: From: Hans Verkuil hansv...@cisco.com The added HDMI CEC framework provides a generic kernel interface for HDMI CEC devices. Signed-off-by: Hans Verkuil hansv...@cisco.com -snip- +int cec_create_adapter(struct cec_adapter

re: rtl2832_sdr: move from staging to media

2015-05-13 Thread Dan Carpenter
Hello Antti Palosaari, The patch 77bbb2b049c1: rtl2832_sdr: move from staging to media from Jul 15, 2014, leads to the following static checker warning: drivers/media/dvb-frontends/rtl2832_sdr.c:1265 rtl2832_sdr_s_ctrl() warn: test_bit() bitwise op in bit number This is harmless

Re:hallo

2015-05-13 Thread niyrscyio
Sehr geehrter Herr gute Nachrichten für Sie laptop, moto, mobile, gultar,iphone 6 plus,390euro si te: lyuuoaa. com

Disappearing dvb-usb stick IT9137FN (Kworld 499-2T)

2015-05-13 Thread Mike Martin
Hi I have the above usb stick (dual frontend) which works fine for a while then just vanishes. ie: frontend just goes eg ls /dev/dvb (I have a permanent DVB card as well) /dev/dvb/adapter0 /dev/dvb/adapter1 /dev/dvb/adapter2 goes to ls /dev/dvb (I have a permanent DVB card as well)

Re: [PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Hans Verkuil
Typo and question: On 05/04/15 19:32, Kamil Debski wrote: +static long cec_ioctl(struct file *filp, unsigned int cmd, unsigned long arg) +{ + struct cec_devnode *cecdev = cec_devnode_data(filp); + struct cec_adapter *adap = to_cec_adapter(cecdev); + void __user *parg = (void

Re: [PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Hans Verkuil
Hi Kamil, Here is the first cec-compliance bug report: CEC_G_CAPS doesn't zero the reserved field! cec.c needs a memset there. I think this is missing in cec.c for all structs with a reserved field in them. Only G_EVENT looks to be OK. Regards, Hans -- To unsubscribe from this list:

[PATCH] dma-mapping: Use tab instead of spaces for indenting.

2015-05-13 Thread Mauro Carvalho Chehab
I wouldn't mind about this, if it won't be caused lots of smatch warnings (one for each file that includes this header) when the media drivers are compiled: ./arch/x86/include/asm/dma-mapping.h:125 dma_alloc_coherent_gfp_flags() warn: inconsistent indenting That makes harder to identify real

[PATCH 0/9 v5] Helper to abstract vma handling in media layer

2015-05-13 Thread Jan Kara
Hello, I'm sending the fifth version of my patch series to abstract vma handling from the various media drivers. The patches got some review from mm people and testing from device driver guys so unless someone objects, patches will be queued in media tree for the next merge window. After this

[PATCH 6/9] media: vb2: Convert vb2_vmalloc_get_userptr() to use frame vector

2015-05-13 Thread Jan Kara
Convert vb2_vmalloc_get_userptr() to use frame vector infrastructure. When we are doing that there's no need to allocate page array and some code can be simplified. Acked-by: Marek Szyprowski m.szyprow...@samsung.com Tested-by: Marek Szyprowski m.szyprow...@samsung.com Signed-off-by: Jan Kara

[PATCH 5/9] media: vb2: Convert vb2_dma_sg_get_userptr() to use frame vector

2015-05-13 Thread Jan Kara
Acked-by: Marek Szyprowski m.szyprow...@samsung.com Tested-by: Marek Szyprowski m.szyprow...@samsung.com Signed-off-by: Jan Kara j...@suse.cz --- drivers/media/v4l2-core/videobuf2-dma-sg.c | 97 +- 1 file changed, 15 insertions(+), 82 deletions(-) diff --git

[PATCH 7/9] media: vb2: Convert vb2_dc_get_userptr() to use frame vector

2015-05-13 Thread Jan Kara
Convert vb2_dc_get_userptr() to use frame vector infrastructure. When we are doing that there's no need to allocate page array and some code can be simplified. Acked-by: Marek Szyprowski m.szyprow...@samsung.com Tested-by: Marek Szyprowski m.szyprow...@samsung.com Signed-off-by: Jan Kara

[PATCH 8/9] media: vb2: Remove unused functions

2015-05-13 Thread Jan Kara
Conversion to the use of pinned pfns made some functions unused. Remove them. Also there's no need to lock mmap_sem in __buf_prepare() anymore. Acked-by: Marek Szyprowski m.szyprow...@samsung.com Tested-by: Marek Szyprowski m.szyprow...@samsung.com Signed-off-by: Jan Kara j...@suse.cz ---

[PATCH 2/9] mm: Provide new get_vaddr_frames() helper

2015-05-13 Thread Jan Kara
Provide new function get_vaddr_frames(). This function maps virtual addresses from given start and fills given array with page frame numbers of the corresponding pages. If given start belongs to a normal vma, the function grabs reference to each of the pages to pin them in memory. If start

[PATCH 9/9] drm/exynos: Convert g2d_userptr_get_dma_addr() to use get_vaddr_frames()

2015-05-13 Thread Jan Kara
Convert g2d_userptr_get_dma_addr() to pin pages using get_vaddr_frames(). This removes the knowledge about vmas and mmap_sem locking from exynos driver. Also it fixes a problem that the function has been mapping user provided address without holding mmap_sem. Signed-off-by: Jan Kara j...@suse.cz

[PATCH 4/9] vb2: Provide helpers for mapping virtual addresses

2015-05-13 Thread Jan Kara
Provide simple helper functions to map virtual address range into an array of pfns / pages. Acked-by: Marek Szyprowski m.szyprow...@samsung.com Tested-by: Marek Szyprowski m.szyprow...@samsung.com Signed-off-by: Jan Kara j...@suse.cz --- drivers/media/v4l2-core/videobuf2-memops.c | 58

[PATCH 3/9] media: omap_vout: Convert omap_vout_uservirt_to_phys() to use get_vaddr_pfns()

2015-05-13 Thread Jan Kara
Convert omap_vout_uservirt_to_phys() to use get_vaddr_pfns() instead of hand made mapping of virtual address to physical address. Also the function leaked page reference from get_user_pages() so fix that by properly release the reference when omap_vout_buffer_release() is called. Signed-off-by:

[PATCH 1/9] [media] vb2: Push mmap_sem down to memops

2015-05-13 Thread Jan Kara
Currently vb2 core acquires mmap_sem just around call to __qbuf_userptr(). However since commit f035eb4e976ef5 (videobuf2: fix lockdep warning) it isn't necessary to acquire it so early as we no longer have to drop queue mutex before acquiring mmap_sem. So push acquisition of mmap_sem down into

Re: rtl2832_sdr: move from staging to media

2015-05-13 Thread Antti Palosaari
Moikka! On 05/13/2015 02:11 PM, Dan Carpenter wrote: Hello Antti Palosaari, The patch 77bbb2b049c1: rtl2832_sdr: move from staging to media from Jul 15, 2014, leads to the following static checker warning: drivers/media/dvb-frontends/rtl2832_sdr.c:1265 rtl2832_sdr_s_ctrl()

Re: Disappearing dvb-usb stick IT9137FN (Kworld 499-2T)

2015-05-13 Thread Antti Palosaari
On 05/13/2015 12:26 PM, Mike Martin wrote: Hi I have the above usb stick (dual frontend) which works fine for a while then just vanishes. ie: frontend just goes eg ls /dev/dvb (I have a permanent DVB card as well) /dev/dvb/adapter0 /dev/dvb/adapter1 /dev/dvb/adapter2 goes to ls /dev/dvb (I

Re: [PATCH] si2165 - Add DVB-C Support

2015-05-13 Thread Mauro Carvalho Chehab
Em Thu, 16 Apr 2015 15:37:46 +0200 beta992 beta...@gmail.com escreveu: From: beta990 Well, first of all you need to identify yourself with your real name. Subject: [PATCH] si2165 - Add DVB-C Support This patch is based of the work of ZZram. The best here would be to either get the ZZram

Re: v4.1-rcX regression in v4l2 build

2015-05-13 Thread Robert Jarzmik
Guennadi Liakhovetski g.liakhovet...@gmx.de writes: ...zip... First, a question for Russell : Given that the current PXA architecture is not implementing the clk_round_rate() function, while implementing clk_get(), etc..., is it correct to say that it is betraying the clk API by doing so ?

Re: [Y2038] [PATCH v3] Staging: media: Replace timeval with ktime_t

2015-05-13 Thread John Stultz
On Wed, May 13, 2015 at 2:10 PM, Mauro Carvalho Chehab mche...@osg.samsung.com wrote: Em Wed, 13 May 2015 21:53:07 +0200 Arnd Bergmann a...@arndb.de escreveu: On Wednesday 13 May 2015 10:04:48 John Stultz wrote: On Wed, May 13, 2015 at 9:57 AM, Ksenija Stanojevic

Re: [Y2038] [PATCH v3] Staging: media: Replace timeval with ktime_t

2015-05-13 Thread Arnd Bergmann
On Wednesday 13 May 2015 10:04:48 John Stultz wrote: On Wed, May 13, 2015 at 9:57 AM, Ksenija Stanojevic ksenija.stanoje...@gmail.com wrote: 'struct timeval last_tv' is used to get the time of last signal change and 'struct timeval last_intr_tv' is used to get the time of last UART

Re: v4.1-rcX regression in v4l2 build

2015-05-13 Thread Russell King - ARM Linux
On Wed, May 13, 2015 at 09:26:03PM +0200, Robert Jarzmik wrote: First, a question for Russell : Given that the current PXA architecture is not implementing the clk_round_rate() function, while implementing clk_get(), etc..., is it correct to say that it is betraying the clk API by

Re: [Y2038] [PATCH v3] Staging: media: Replace timeval with ktime_t

2015-05-13 Thread Mauro Carvalho Chehab
Em Wed, 13 May 2015 21:53:07 +0200 Arnd Bergmann a...@arndb.de escreveu: On Wednesday 13 May 2015 10:04:48 John Stultz wrote: On Wed, May 13, 2015 at 9:57 AM, Ksenija Stanojevic ksenija.stanoje...@gmail.com wrote: 'struct timeval last_tv' is used to get the time of last signal change

Re: v4.1-rcX regression in v4l2 build

2015-05-13 Thread Robert Jarzmik
Russell King - ARM Linux li...@arm.linux.org.uk writes: On Wed, May 13, 2015 at 09:26:03PM +0200, Robert Jarzmik wrote: First, a question for Russell : Given that the current PXA architecture is not implementing the clk_round_rate() function, while implementing clk_get(), etc..., is it

Re: [PATCH 2/4] dw2102: remove unnecessary newline from log printouts

2015-05-13 Thread Mauro Carvalho Chehab
Em Tue, 5 May 2015 19:33:53 +0300 Olli Salonen olli.salo...@iki.fi escreveu: The info and warn functions already add a newline to the end of the log printouts, so remove the extra newline from the printouts. Hi Olli, The best here would be to convert this driver to use dvb-usb2, and replace

[PATCH] [media] dib0700: avoid the risk of forgetting to add the adapter's size

2015-05-13 Thread Mauro Carvalho Chehab
For every frontend entry, we need to add the adapter's size. There are already two patches fixing it. So, it doesn't seem trivial to keep it there at the right place. Also, currently, the indentation is wrong on all places. So, it seems that keeping it right is not too trivial. Better to use a

Re: [Y2038] [PATCH v3] Staging: media: Replace timeval with ktime_t

2015-05-13 Thread Mauro Carvalho Chehab
Em Wed, 13 May 2015 14:45:38 -0700 John Stultz john.stu...@linaro.org escreveu: On Wed, May 13, 2015 at 2:10 PM, Mauro Carvalho Chehab mche...@osg.samsung.com wrote: Em Wed, 13 May 2015 21:53:07 +0200 Arnd Bergmann a...@arndb.de escreveu: On Wednesday 13 May 2015 10:04:48 John Stultz

cron job: media_tree daily build: ERRORS

2015-05-13 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Thu May 14 04:00:16 CEST 2015 git branch: test git hash: e989a73ebd09d22c22ead51fa363a2f56f70f28a gcc

[PATCH v3] Staging: media: Replace timeval with ktime_t

2015-05-13 Thread Ksenija Stanojevic
'struct timeval last_tv' is used to get the time of last signal change and 'struct timeval last_intr_tv' is used to get the time of last UART interrupt. 32-bit systems using 'struct timeval' will break in the year 2038, so we have to replace that code with more appropriate types. Here struct

Re: [PATCH v3] Staging: media: Replace timeval with ktime_t

2015-05-13 Thread John Stultz
On Wed, May 13, 2015 at 9:57 AM, Ksenija Stanojevic ksenija.stanoje...@gmail.com wrote: 'struct timeval last_tv' is used to get the time of last signal change and 'struct timeval last_intr_tv' is used to get the time of last UART interrupt. 32-bit systems using 'struct timeval' will break in

[PATCH 2/2] [media] saa7134: fix CodingStyle issues on the lines touched by pr_foo refactor

2015-05-13 Thread Mauro Carvalho Chehab
Several lines touched by the pr_foo refactoring patches are not following the Linux Coding style. While we won't be fixing the style globally at the driver, we should, at least, fix on the lines we touched. Basically, this patch add (or remove) whitespaces and blank lines where needed. No

[PATCH 1/2] [media] saa7134: avoid complex macro warnings

2015-05-13 Thread Mauro Carvalho Chehab
The debug macros are not properly defined, as they generate warnings like: ERROR: Macros with complex values should be enclosed in parentheses +#define core_dbg(fmt, arg...)if (core_debug) \ + printk(KERN_DEBUG pr_fmt(core: fmt), ## arg) Use do { } while (0) for those macros.

[PATCH] s5p-mfc: fix state check from encoder queue_setup

2015-05-13 Thread Seung-Woo Kim
MFCINST_GOT_INST state is set to encoder context with set_format only for catpure buffer. In queue_setup of encoder called during reqbufs, it is checked MFCINST_GOT_INST state for both capture and output buffer. So this patch fixes to encoder to check MFCINST_GOT_INST state only for capture buffer

Re: [PATCHv2 0/5] cobalt: new HDMI Rx/Tx PCIe driver

2015-05-13 Thread Hans Verkuil
Oops, I forgot to mention that patches 1-4 are unchanged from v1. Also, if there are no comments about this driver, then I intend to make a pull request on Monday. Regards, Hans On 05/13/15 09:22, Hans Verkuil wrote: From: Hans Verkuil hans.verk...@cisco.com Changes since v1: -

[PATCHv2 3/5] v4l2-subdev: allow subdev to send an event to the v4l2_device notify function

2015-05-13 Thread Hans Verkuil
From: jean-michel.hautb...@vodalys.com jean-michel.hautb...@vodalys.com All drivers use custom notifications, in particular when source changes. The bridge only has to map the subdev that sends it to whatever video node it is connected to. Signed-off-by: Jean-Michel Hautbois

[PATCHv2 2/5] vb2: allow requeuing buffers while streaming

2015-05-13 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com vb2_buffer_done() already allows STATE_QUEUED, but currently only when not streaming. It is useful to allow it while streaming as well, as this makes it possible for drivers to requeue buffers while waiting for a stable video signal. Signed-off-by: Hans

[PATCHv2 4/5] adv7604/adv7842: replace FMT_CHANGED by V4L2_DEVICE_NOTIFY_EVENT

2015-05-13 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com This makes it easier for the bridge driver to just passthrough such events to the corresponding device node. Signed-off-by: Hans Verkuil hans.verk...@cisco.com --- drivers/media/i2c/adv7604.c | 12 +--- drivers/media/i2c/adv7842.c | 11

[PATCHv2 0/5] cobalt: new HDMI Rx/Tx PCIe driver

2015-05-13 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com Changes since v1: - Fixed a lockdep bug in the alsa driver - Moved the DMA descriptor allocation/freeing to buf_init and buf_cleanup, which is where it belongs. - Rebased to the latest media_tree master. Hi all, This driver is for the Cisco Cobalt

[PATCHv2 1/5] adv7842: Make output format configurable through pad format operations

2015-05-13 Thread Hans Verkuil
From: Hans Verkuil hans.verk...@cisco.com Replace the dummy video format operations by pad format operations that configure the output format. Copied from the adv7604 driver. Note: while arch/blackfin/mach-bf609/boards/ezkit.c uses adv7842_platform_data this source has not been updated because

$200,000 USD

2015-05-13 Thread Gloria Mackenzie
We are donating the sum of $200,000 USD to you. -- To unsubscribe from this list: send the line unsubscribe linux-media in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Hans Verkuil
Hi Kamil, I've started work on a cec-compliance utility and while doing that I noticed a confusing name: On 05/04/15 19:32, Kamil Debski wrote: +struct cec_caps { + __u32 available_log_addrs; + __u32 capabilities; + __u32 vendor_id; + __u8 version; + __u8

[GIT PULL 4.2] msi2500 / msi001 enhancements

2015-05-13 Thread Antti Palosaari
The following changes since commit 356484cabe44984d2dc66a90bd5e3465ba1f64fb: [media] dw2102: resync fifo when demod locks (2015-05-13 17:12:42 -0300) are available in the git repository at: git://linuxtv.org/anttip/media_tree.git mirics_pull for you to fetch changes up to