[PATCH] exynos4-is: add of_platform_populate() call for FIMC-IS child devices

2016-09-16 Thread Sylwester Nawrocki
Instead of relying on the "simple-bus" compatible and the driver core populating FIMC-IS child devices make the fimc-is driver populating its child devices. This prevents issues related to accessing ISP_I2C clock registers with corresponding power domain switched off, which happens after applying

Re: [git:v4l-utils/master] media-ctl: Fix a compilation bug introduced by changeset 7a21d66983f7

2016-09-16 Thread Sakari Ailus
On 09/16/16 10:11, Mauro Carvalho Chehab wrote: > This is an automatic generated email to let you know that the following patch > were queued at the > http://git.linuxtv.org/cgit.cgi/v4l-utils.git tree: > > Subject: media-ctl: Fix a compilation bug introduced by changeset 7a21d66983f7 > Author:

[PATCH] media: s5p-mfc: fix failure path of s5p_mfc_alloc_memdev()

2016-09-16 Thread Marek Szyprowski
s5p_mfc_alloc_memdev() function lacks proper releasing of allocated device in case of reserved memory initialization failure. This results in NULL pointer dereference: [2.828457] Unable to handle kernel NULL pointer dereference at virtual address 0001 [2.835089] pgd = c0004000 [

[PATCHv2 1/8] videodev2.h: checkpatch cleanup

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil Format comments according to what checkpatch wants. No other changes. Signed-off-by: Hans Verkuil --- include/uapi/linux/videodev2.h | 50 +- 1 file changed, 30 insertions(+), 20

[PATCHv2 0/8] dv-timings: add VICs and picture aspect ratio

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil The v4l2_bt_timings struct is missing information about the picture aspect ratio and the CEA-861 and HDMI VIC (Video Identification Code). This patch series adds support for this. Changes since v1: - Split the first patch into a cleanup patch and a

[PATCHv2 3/8] vidioc-g-dv-timings.rst: document the new dv_timings flags

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil Document the new flags. Signed-off-by: Hans Verkuil --- .../media/uapi/v4l/vidioc-g-dv-timings.rst | 23 ++ Documentation/media/videodev2.h.rst.exceptions | 3 +++ 2 files changed, 26

[PATCHv2 5/8] v4l2-dv-timings: add helpers to find vic and pixelaspect ratio

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil Add a helper to find timings based on the CEA-861 VIC code. Also add a helper that returns the pixel aspect ratio based on the v4l2_dv_timings struct. Signed-off-by: Hans Verkuil --- drivers/media/v4l2-core/Kconfig |

[PATCHv2 2/8] videodev2.h: add VICs and picture aspect ratio

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil Add picture aspect ratio information, the CEA-861 VIC (Video Identification Code) and the HDMI VIC to struct v4l2_bt_timings. The picture aspect was chosen rather than the pixel aspect since 1) the CEA-861 standard uses picture aspect, and 2) pixel

[PATCHv2 7/8] adv7604: add vic detect

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil Obtain the correct timings based on the VIC code from the AVI InfoFrame. It does a sanity check to see if at least the measured width and height are in line with what the VIC code reports. If not, then use the timings instead of the VIC code (as per

[PATCHv2 4/8] v4l2-dv-timings: add VICs and picture aspect ratio

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil Add the CEA-861 VIC, the HDMI VIC and the picture aspect ratio information where applicable. Signed-off-by: Hans Verkuil --- include/uapi/linux/v4l2-dv-timings.h | 97 +++- 1 file changed, 63

[PATCHv2 6/8] cobalt: add cropcap support

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil Now that the timings contain picture aspect ratio information, we can support cropcap to return the pixel aspect ratio. Signed-off-by: Hans Verkuil --- drivers/media/pci/cobalt/cobalt-v4l2.c | 21 + 1 file

[PATCHv2 8/8] v4l2-dv-timings: add v4l2_dv_timings_cea861_aspect_ratio

2016-09-16 Thread Hans Verkuil
From: Hans Verkuil This new function determines the picture aspect ratio from the DV timings and returns it in CEA-861 AVI InfoFrame format. Signed-off-by: Hans Verkuil --- drivers/media/v4l2-core/v4l2-dv-timings.c | 18 ++

Re: [PATCH 6/6] media/cobalt: use pci_irq_allocate_vectors

2016-09-16 Thread Hans Verkuil
Hi Christoph, On 09/11/2016 03:31 PM, Christoph Hellwig wrote: > Simply the interrupt setup by using the new PCI layer helpers. > > Despite using pci_enable_msi_range, this driver was only requesting a > single MSI vector anyway. > > Signed-off-by: Christoph Hellwig > --- >

Re: [PATCH 6/6] media/cobalt: use pci_irq_allocate_vectors

2016-09-16 Thread Christoph Hellwig
On Fri, Sep 16, 2016 at 10:01:42AM +0200, Hans Verkuil wrote: > PCI_IRQ_MSI is unknown, I assume that this will appear in 4.9? The flag is in 4.8-rc. -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majord...@vger.kernel.org More majordomo info

[PATCH] hva: fix sparse warnings

2016-09-16 Thread Hans Verkuil
drivers/media/platform/sti/hva/hva-v4l2.c:43:22: warning: symbol 'hva_encoders' was not declared. Should it be static? drivers/media/platform/sti/hva/hva-v4l2.c:1401:24: warning: symbol 'hva_driver' was not declared. Should it be static? Make these static. Signed-off-by: Hans Verkuil

[GIT PULL FOR v4.9] Various fixes

2016-09-16 Thread Hans Verkuil
The following changes since commit c3b809834db8b1a8891c7ff873a216eac119628d: [media] pulse8-cec: fix compiler warning (2016-09-12 06:42:44 -0300) are available in the git repository at: git://linuxtv.org/hverkuil/media_tree.git for-v4.9f for you to fetch changes up to

[GIT PULL FOR v4.9] rcar-vin fixes and removal of old soc-camera driver

2016-09-16 Thread Hans Verkuil
This patch series has various fixes/enhancements for the rcar-vin driver. It also removes the old soc-camera rcar-vin driver. After this patch series there are only two soc-camera drivers left: atmel-isi and sh-mobile-ceu-camera. I hope I can get my atmel-isi replacement driver merged for 4.10

ad5820 sparse warning

2016-09-16 Thread Hans Verkuil
Sakari, Can you take a look at this sparse warning: drivers/media/i2c/ad5820.c:73:14: warning: incorrect type in assignment (different base types) Thanks! Hans -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to

Re: [PATCH v8 1/2] media: adv7604: automatic "default-input" selection

2016-09-16 Thread Hans Verkuil
Hi Ulrich, What should I do with this? I dropped it for now. I'm just going ahead and post the pull request without this patch as I don't want this to be a blocker. Regards, Hans On 09/15/2016 06:42 PM, Laurent Pinchart wrote: > Hi Ulrich, > > Thank you for the patch. > > On

[PATCH 1/2] media: adv7604: fix bindings inconsistency for default-input

2016-09-16 Thread Ulrich Hecht
The text states that default-input is an endpoint property, but in the example it is a device property. The example makes more sense. Signed-off-by: Ulrich Hecht --- Documentation/devicetree/bindings/media/i2c/adv7604.txt | 3 +-- 1 file changed, 1 insertion(+),

[PATCH 2/2] media: adv7604: automatic "default-input" selection

2016-09-16 Thread Ulrich Hecht
Fall back to input 0 if "default-input" property is not present. Documentation states that the "default-input" property should reside directly in the node for adv7612. Hence, also adjust the parsing to make the implementation consistent with this. Based on patch by William Towle

Re: [PATCH 2/2] media: adv7604: automatic "default-input" selection

2016-09-16 Thread Laurent Pinchart
Hi Ulrich, Thank you for the patch. On Friday 16 Sep 2016 11:39:42 Ulrich Hecht wrote: > Fall back to input 0 if "default-input" property is not present. > > Documentation states that the "default-input" property should reside > directly in the node for adv7612. Not just fo adv7612. > Hence,

[PATCH 1/1] ad5820: Fix sparse warning

2016-09-16 Thread Sakari Ailus
Use a type with explicit endianness in machine to big endian conversion. Signed-off-by: Sakari Ailus --- drivers/media/i2c/ad5820.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/media/i2c/ad5820.c b/drivers/media/i2c/ad5820.c

[PATCH 0/2] media: adv7604: fix default-input property inconsistencies

2016-09-16 Thread Ulrich Hecht
Hi! This is a fix for the inconsistency in the adv7604 bindings regarding the default-input property, clarifying that it should be a property of the device, not the endpoint, and a patch to implement it. CU Uli Ulrich Hecht (2): media: adv7604: fix bindings inconsistency for default-input

Re: [PATCH 1/2] media: adv7604: fix bindings inconsistency for default-input

2016-09-16 Thread Laurent Pinchart
Hi Ulrich, Thank you for the patch. On Friday 16 Sep 2016 11:39:41 Ulrich Hecht wrote: > The text states that default-input is an endpoint property, but in the > example it is a device property. The example makes more sense. You should explain why it makes more sense. Something along the lines

[PATCH] Potential fix for "[BUG] process stuck when closing saa7146 [dvb_ttpci]"

2016-09-16 Thread Andrey Utkin
Hi Philipp, Please try this patch. It is purely speculative as I don't have the hardware, but I hope my approach is right. --- drivers/media/common/saa7146/saa7146_video.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/media/common/saa7146/saa7146_video.c

cron job: media_tree daily build: WARNINGS

2016-09-16 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Sat Sep 17 04:00:19 CEST 2016 git branch: test git hash: c3b809834db8b1a8891c7ff873a216eac119628d gcc

[PATCH 0/2] media: Use complete() instead complete_all()

2016-09-16 Thread Daniel Wagner
From: Daniel Wagner Hi, Using complete_all() is not wrong per se but it suggest that there might be more than one waiter. For -rt I am reviewing all complete_all() users and would like to leave only the real ones in the tree. The main problem for -rt about

[PATCH 1/2] [media] imon: use complete() instead of complete_all()

2016-09-16 Thread Daniel Wagner
From: Daniel Wagner There is only one waiter for the completion, therefore there is no need to use complete_all(). Let's make that clear by using complete() instead of complete_all(). While we are at it, we do a small optimization with the reinitialization of the

[PATCH 2/2] ARM: dts: koelsch: add HDMI input

2016-09-16 Thread Ulrich Hecht
From: Hans Verkuil Add support in the dts for the HDMI input. Based on the Lager dts patch from Ulrich Hecht. Signed-off-by: Hans Verkuil [uli: removed "renesas," prefixes from pfc nodes] Signed-off-by: Ulrich Hecht

[PATCH 1/3] ARM: dts: r8a7793: Enable VIN0, VIN1

2016-09-16 Thread Ulrich Hecht
Signed-off-by: Ulrich Hecht --- arch/arm/boot/dts/r8a7793.dtsi | 20 1 file changed, 20 insertions(+) diff --git a/arch/arm/boot/dts/r8a7793.dtsi b/arch/arm/boot/dts/r8a7793.dtsi index 8d02aac..0898668 100644 ---

[PATCH 0/3] r8a7793 Gose video input support

2016-09-16 Thread Ulrich Hecht
Hi! This is a by-the-datasheet implementation of analog and digital video input on the Gose board. I don't have that hardware, so if somebody could test this, I would appreciate it. To get the digital part to work, use Hans's R-Car branch

[PATCH 1/2] ARM: dts: lager: Add entries for VIN HDMI input support

2016-09-16 Thread Ulrich Hecht
From: William Towle Add DT entries for vin0, vin0_pins, and adv7612. Sets the 'default-input' property for ADV7612, enabling image and video capture without the need to have userspace specifying routing. Signed-off-by: William Towle

[PATCH 0/2] Renesas Lager/Koelsch HDMI input

2016-09-16 Thread Ulrich Hecht
Hi! This series enables HDMI input on the Lager and Koelsch boards. It sits on renesas-devel-20160913-v4.8-rc6 and also applies to the media tree. Testing this on a Lager board with v4l2-compliance on top of Hans's R-Car branch (https://git.linuxtv.org/hverkuil/media_tree.git/log/?h=rcar) with

Re: mceusb xhci issue?

2016-09-16 Thread Alan Stern
On Thu, 15 Sep 2016, Wade Berrier wrote: > On Thu Sep 15 15:13, Alan Stern wrote: > > On Sat, 10 Sep 2016, Wade Berrier wrote: > > > > > On Thu Aug 11 16:18, Alan Stern wrote: > > > > I never received any replies to this message. Should the patch I > > > > suggested be merged? > > > > > > > >

[PATCH] USB: change bInterval default to 10 ms

2016-09-16 Thread Alan Stern
Some full-speed mceusb infrared transceivers contain invalid endpoint descriptors for their interrupt endpoints, with bInterval set to 0. In the past they have worked out okay with the mceusb driver, because the driver sets the bInterval field in the descriptor to 1, overwriting whatever value may

[GIT PULL] Samsung fixes for 4.8

2016-09-16 Thread Sylwester Nawrocki
Hi Mauro, The following changes since commit 7892a1f64a447b6f65fe288863b7c26d81d3: [media] rcar-fcp: Make sure rcar_fcp_enable() returns 0 on success (2016-09-15 09:02:16 -0300) are available in the git repository at: git://linuxtv.org/snawrocki/samsung.git for-v4.9/media/fixes for

Re: [PATCH v2 1/8] doc: DT: vidc: binding document for Qualcomm video driver

2016-09-16 Thread Rob Herring
On Wed, Sep 07, 2016 at 02:37:02PM +0300, Stanimir Varbanov wrote: > Adds binding document for vidc video encoder/decoder driver > > Cc: Rob Herring > Cc: Mark Rutland > Cc: devicet...@vger.kernel.org > Signed-off-by: Stanimir Varbanov

[GIT PULL] Samsung SoC updates for v4.9, part 2

2016-09-16 Thread Sylwester Nawrocki
Hi Mauro, The following changes since commit c3b809834db8b1a8891c7ff873a216eac119628d: [media] pulse8-cec: fix compiler warning (2016-09-12 06:42:44 -0300) are available in the git repository at: git://linuxtv.org/snawrocki/samsung.git for-v4.9/media/next-2 for you to fetch changes up to

[PATCH 2/2] [media] lirc_imon: use complete() instead complete_all()

2016-09-16 Thread Daniel Wagner
From: Daniel Wagner There is only one waiter for the completion, therefore there is no need to use complete_all(). Let's make that clear by using complete() instead of complete_all(). While we are at it, we do a small optimization with the reinitialization of the

[PATCH v5 0/4] Refactor media IOCTL handling

2016-09-16 Thread Sakari Ailus
Hi, Here's the 5th version of the media IOCTL rework set. since v4: - Don't refactor compat IOCTL handling. The assumption is that the compat code will stay as-is and only the ENUM_LINKS IOCTL will require compat handling in the future and newer IOCTLs would use u64 for pointers. This has

[PATCH v5 2/4] media: Unify IOCTL handler calling

2016-09-16 Thread Sakari Ailus
Each IOCTL handler can be listed in an array instead of using a large and cumbersome switch. Do that. Signed-off-by: Sakari Ailus Reviewed-by: Laurent Pinchart Acked-by: Hans Verkuil ---

[PATCH v5 3/4] media: Refactor copying IOCTL arguments from and to user space

2016-09-16 Thread Sakari Ailus
Refactor copying the IOCTL argument structs from the user space and back, in order to reduce code copied around and make the implementation more robust. As a result, the copying is done while not holding the graph mutex. Signed-off-by: Sakari Ailus Acked-by: Hans

[PATCH v5 1/4] media: Determine early whether an IOCTL is supported

2016-09-16 Thread Sakari Ailus
Preparation for refactoring media IOCTL handling to unify common parts. Signed-off-by: Sakari Ailus Reviewed-by: Laurent Pinchart Acked-by: Hans Verkuil --- drivers/media/media-device.c | 20

[PATCH v5 4/4] media: Add flags to tell whether to take graph mutex for an IOCTL

2016-09-16 Thread Sakari Ailus
New IOCTLs (especially for the request API) do not necessarily need the graph mutex acquired. Leave this up to the drivers. Signed-off-by: Sakari Ailus Reviewed-by: Laurent Pinchart Acked-by: Hans Verkuil

[PATCH 3/3] ARM: dts: gose: add composite video input

2016-09-16 Thread Ulrich Hecht
Signed-off-by: Ulrich Hecht --- arch/arm/boot/dts/r8a7793-gose.dts | 36 1 file changed, 36 insertions(+) diff --git a/arch/arm/boot/dts/r8a7793-gose.dts b/arch/arm/boot/dts/r8a7793-gose.dts index e22d63c..981f0fe 100644 ---

[PATCH 2/3] ARM: dts: gose: add HDMI input

2016-09-16 Thread Ulrich Hecht
Identical to the setup on Lager. Signed-off-by: Ulrich Hecht --- arch/arm/boot/dts/r8a7793-gose.dts | 41 ++ 1 file changed, 41 insertions(+) diff --git a/arch/arm/boot/dts/r8a7793-gose.dts

Re: [PATCH] USB: change bInterval default to 10 ms

2016-09-16 Thread Mauro Carvalho Chehab
Em Fri, 16 Sep 2016 10:24:26 -0400 (EDT) Alan Stern escreveu: > Some full-speed mceusb infrared transceivers contain invalid endpoint > descriptors for their interrupt endpoints, with bInterval set to 0. > In the past they have worked out okay with the mceusb driver,

Re: [PATCH v2 0/3] doc-rst:c-domain: fix some issues in the c-domain

2016-09-16 Thread Jonathan Corbet
On Wed, 7 Sep 2016 09:12:55 +0200 Markus Heiser wrote: > according to your remarks I fixed the first and second patch. The third patch > is > resend unchanged; OK, I've applied the first two, finally. > > Am 06.09.2016 um 14:28 schrieb Jonathan Corbet

Re: mceusb xhci issue?

2016-09-16 Thread Mauro Carvalho Chehab
Em Fri, 16 Sep 2016 10:25:31 -0400 (EDT) Alan Stern escreveu: > On Thu, 15 Sep 2016, Wade Berrier wrote: > > > On Thu Sep 15 15:13, Alan Stern wrote: > > > On Sat, 10 Sep 2016, Wade Berrier wrote: > > > > > > > On Thu Aug 11 16:18, Alan Stern wrote: > > > > > I

Re: [PATCH] media: s5p-mfc: fix failure path of s5p_mfc_alloc_memdev()

2016-09-16 Thread Javier Martinez Canillas
Hello Marek, On 09/16/2016 02:14 AM, Marek Szyprowski wrote: > s5p_mfc_alloc_memdev() function lacks proper releasing of allocated device > in case of reserved memory initialization failure. This results in NULL > pointer > dereference: Patch looks good to me. Reviewed-by: Javier Martinez