Re: [PATCH 1/3] dmaengine: pl330: Set residue in tx_status callback.

2013-10-01 Thread Dylan Reid
On Thu, Sep 12, 2013 at 4:40 AM, Chanho Park wrote: > Hi Padmavathi, > >> -Original Message- >> From: linux-arm-kernel [mailto:linux-arm-kernel- >> boun...@lists.infradead.org] On Behalf Of Padmavathi Venna >> Sent: Wednesday, September 11, 2013 3:08 PM >> To: linux-samsung-soc@vger.kernel

Re: RE: [PATCH v2 00/12] clk/exynos convert clock IDs to macros

2013-10-01 Thread Mike Turquette
Quoting Kukjin Kim (2013-09-30 03:11:41) > Mike Turquette wrote: > > > > Quoting Sylwester Nawrocki (2013-09-16 07:33:45) > > > On 09/12/2013 12:50 PM, Kukjin Kim wrote: > > > > Well...I'm not sure changing to use macro is better or not at this > > moment... > > > > > > I think it is. ;) It's real

Re: [PATCH] PCI: exynos: missing clk_disable_unprepare() on error in exynos_pcie_probe()

2013-10-01 Thread Jingoo Han
On Tuesday, October 01, 2013 10:49 PM, Sylwester Nawrocki wrote: > On 10/01/2013 03:33 AM, Jingoo Han wrote: > > On Sunday, September 29, 2013 11:29 AM, Wei Yongjun wrote: > >> > >> From: Wei Yongjun > >> > >> Add the missing clk_disable_unprepare() before return > >> from exynos_pcie_probe() in th

[PATCH 4/5] drm/exynos: Initialize ptn3460 if present

2013-10-01 Thread Sean Paul
This patch adds code to look for the ptn3460 in the device tree file on exynos initialization. If ptn node is found, the driver will initialize the ptn3460 driver and skip creating a DP connector (since the bridge driver will register its own connector). Signed-off-by: Sean Paul --- drivers/gpu/

[PATCH 3/5] drm/bridge: Add PTN3460 bridge driver

2013-10-01 Thread Sean Paul
This patch adds a drm_bridge driver for the PTN3460 DisplayPort to LVDS bridge chip. Signed-off-by: Sean Paul --- .../devicetree/bindings/drm/bridge/ptn3460.txt | 27 ++ drivers/gpu/drm/Kconfig| 2 + drivers/gpu/drm/Makefile | 1 + d

[PATCH 2/5] ARM: dts: Add dp-controller node to exynos5250-snow

2013-10-01 Thread Sean Paul
This patch adds the dp-controller node to the exynos5250-snow board dts file. Signed-off-by: Sean Paul --- arch/arm/boot/dts/exynos5250-snow.dts | 12 1 file changed, 12 insertions(+) diff --git a/arch/arm/boot/dts/exynos5250-snow.dts b/arch/arm/boot/dts/exynos5250-snow.dts index

[PATCH 5/5] ARM: dts: Add ptn3460 to exynos5250-snow

2013-10-01 Thread Sean Paul
This patch adds a node for the ptn3460 DP-LVDS chip in the exynos5250-snow board dts file. Signed-off-by: Sean Paul --- arch/arm/boot/dts/exynos5250-snow.dts | 19 +++ 1 file changed, 19 insertions(+) diff --git a/arch/arm/boot/dts/exynos5250-snow.dts b/arch/arm/boot/dts/exynos

[PATCH 1/5] ARM: dts: Add fimd display-timings for exynos5250-snow

2013-10-01 Thread Sean Paul
This patch adds the internal panel timings to the exynos5250-snow board dts file. Signed-off-by: Sean Paul --- arch/arm/boot/dts/exynos5250-snow.dts | 17 + 1 file changed, 17 insertions(+) diff --git a/arch/arm/boot/dts/exynos5250-snow.dts b/arch/arm/boot/dts/exynos5250-snow.d

[PATCH 0/5] Add some missing bits for exynos5250-snow

2013-10-01 Thread Sean Paul
This set adds some missing devicetree nodes to the exynos5250-snow file as well as adds a drm_bridge driver for the ptn3460 DP-LVDS chip. This chip is used in the exynos5250-snow board. Sean Sean Paul (5): ARM: dts: Add fimd display-timings for exynos5250-snow ARM: dts: Add dp-controller node

Re: [PATCH 2/6] clk: exynos5410: register clocks using common clock framework

2013-10-01 Thread Stephen Warren
On 10/01/2013 10:17 AM, Vyacheslav Tyrtov wrote: > From: Tarek Dakhran > > The EXYNOS5410 clocks are statically listed and registered > using the Samsung specific common clock helper functions. > diff --git a/Documentation/devicetree/bindings/clock/exynos5410-clock.txt > b/Documentation/devicet

Re: [PATCH 09/10] pwm-backlight: Use an optional power supply

2013-10-01 Thread Thierry Reding
On Tue, Oct 01, 2013 at 02:59:43PM -0600, Stephen Warren wrote: > On 10/01/2013 02:53 PM, Thierry Reding wrote: > > On Tue, Oct 01, 2013 at 12:43:57PM -0600, Stephen Warren wrote: > >> On 09/23/2013 03:41 PM, Thierry Reding wrote: > >>> Many backlights require a power supply to work properly. This

Re: [PATCH 05/10] ARM: SAMSUNG: Initialize PWM backlight enable_gpio field

2013-10-01 Thread Thierry Reding
On Tue, Oct 01, 2013 at 02:58:22PM -0600, Stephen Warren wrote: > On 10/01/2013 02:43 PM, Thierry Reding wrote: > > On Tue, Oct 01, 2013 at 12:31:04PM -0600, Stephen Warren wrote: > >> On 09/23/2013 03:41 PM, Thierry Reding wrote: > >>> The GPIO API defines 0 as being a valid GPIO number, so this >

Re: [PATCH 10/10] pwm-backlight: Allow backlight to remain disabled on boot

2013-10-01 Thread Thierry Reding
On Tue, Oct 01, 2013 at 12:50:51PM -0600, Stephen Warren wrote: > On 09/23/2013 03:41 PM, Thierry Reding wrote: > > The default for backlight devices is to be enabled immediately when > > registering with the backlight core. This can be useful for setups that > > use a simple framebuffer device and

Re: [PATCH 09/10] pwm-backlight: Use an optional power supply

2013-10-01 Thread Stephen Warren
On 10/01/2013 02:53 PM, Thierry Reding wrote: > On Tue, Oct 01, 2013 at 12:43:57PM -0600, Stephen Warren wrote: >> On 09/23/2013 03:41 PM, Thierry Reding wrote: >>> Many backlights require a power supply to work properly. This >>> commit uses a power-supply regulator, if available, to power up >>>

Re: [PATCH 05/10] ARM: SAMSUNG: Initialize PWM backlight enable_gpio field

2013-10-01 Thread Stephen Warren
On 10/01/2013 02:43 PM, Thierry Reding wrote: > On Tue, Oct 01, 2013 at 12:31:04PM -0600, Stephen Warren wrote: >> On 09/23/2013 03:41 PM, Thierry Reding wrote: >>> The GPIO API defines 0 as being a valid GPIO number, so this >>> field needs to be initialized explicitly. >> >>> static void __init

Re: [PATCH 09/10] pwm-backlight: Use an optional power supply

2013-10-01 Thread Thierry Reding
On Tue, Oct 01, 2013 at 12:43:57PM -0600, Stephen Warren wrote: > On 09/23/2013 03:41 PM, Thierry Reding wrote: > > Many backlights require a power supply to work properly. This commit > > uses a power-supply regulator, if available, to power up and power down > > the panel. > > I think that all b

Re: [PATCH 08/10] pwm-backlight: Use new enable_gpio field

2013-10-01 Thread Thierry Reding
On Tue, Oct 01, 2013 at 12:39:36PM -0600, Stephen Warren wrote: > On 09/23/2013 03:41 PM, Thierry Reding wrote: > > Make use of the new enable_gpio field and allow it to be set from DT as > > well. Now that all legacy users of platform data have been converted to > > initialize this field to an inv

Re: [PATCH 05/10] ARM: SAMSUNG: Initialize PWM backlight enable_gpio field

2013-10-01 Thread Thierry Reding
On Tue, Oct 01, 2013 at 12:31:04PM -0600, Stephen Warren wrote: > On 09/23/2013 03:41 PM, Thierry Reding wrote: > > The GPIO API defines 0 as being a valid GPIO number, so this field needs > > to be initialized explicitly. > > > static void __init smdkv210_map_io(void) > > > @@ -70,6 +70,7 @@ st

Re: [PATCH 01/10] pwm-backlight: Refactor backlight power on/off

2013-10-01 Thread Thierry Reding
On Tue, Oct 01, 2013 at 12:26:07PM -0600, Stephen Warren wrote: > On 09/23/2013 03:40 PM, Thierry Reding wrote: > > In preparation for adding an optional regulator and enable GPIO to the > > driver, split the power on and power off sequences into separate > > functions to reduce code duplication at

Re: [PATCH 3/6] ARM: EXYNOS: add Exynos Dual Cluster Support

2013-10-01 Thread Nicolas Pitre
On Tue, 1 Oct 2013, Vyacheslav Tyrtov wrote: > From: Tarek Dakhran > > Add EDCS(Exynos Dual Cluster Support) for Samsung Exynos5410 SoC. > This enables all 8 cores, 4 x A7 and 4 x A15 run at the same time. > > Signed-off-by: Tarek Dakhran > Signed-off-by: Vyacheslav Tyrtov > --- > arch/arm/m

Re: [PATCH 3/7] Return info for device and its memory regions and interrupts

2013-10-01 Thread Alex Williamson
On Tue, 2013-10-01 at 19:32 +, Yoder Stuart-B08248 wrote: > > Antonios Motakis wrote > > > Alex Williamson wrote: > > > I notice all the open firmware calls here and I'm curious, > > > will all platform devices be making use of open firmware? > > > I don't know if this is synonymous with devic

RE: [PATCH 3/7] Return info for device and its memory regions and interrupts

2013-10-01 Thread Yoder Stuart-B08248
> Antonios Motakis wrote > > Alex Williamson wrote: > > I notice all the open firmware calls here and I'm curious, > > will all platform devices be making use of open firmware? > > I don't know if this is synonymous with device tree or not. > > Thanks, > > This VFIO driver will support only device

RE: [PATCH 1/7] VFIO_IOMMU_TYPE1 workaround to build for platform devices

2013-10-01 Thread Yoder Stuart-B08248
> > static int __init vfio_iommu_type1_init(void) > > { > > - if (!iommu_present(&pci_bus_type)) > > +#ifdef CONFIG_PCI > > + if (iommu_present(&pci_bus_type)) { > > + iommu_bus_type = &pci_bus_type; > > + /* For PCI targets, IOMMU_CAP_INTR_REMAP is required */ > > +

Re: [PATCH 10/10] pwm-backlight: Allow backlight to remain disabled on boot

2013-10-01 Thread Stephen Warren
On 09/23/2013 03:41 PM, Thierry Reding wrote: > The default for backlight devices is to be enabled immediately when > registering with the backlight core. This can be useful for setups that > use a simple framebuffer device and where the backlight cannot otherwise > be hooked up to the panel. > >

Re: [PATCH 09/10] pwm-backlight: Use an optional power supply

2013-10-01 Thread Stephen Warren
On 09/23/2013 03:41 PM, Thierry Reding wrote: > Many backlights require a power supply to work properly. This commit > uses a power-supply regulator, if available, to power up and power down > the panel. I think that all backlights require a power supply, albeit the supply may not be SW-controllab

Re: [PATCH 08/10] pwm-backlight: Use new enable_gpio field

2013-10-01 Thread Stephen Warren
On 09/23/2013 03:41 PM, Thierry Reding wrote: > Make use of the new enable_gpio field and allow it to be set from DT as > well. Now that all legacy users of platform data have been converted to > initialize this field to an invalid value, it is safe to use the field > from the driver. > diff --git

Re: [PATCH 05/10] ARM: SAMSUNG: Initialize PWM backlight enable_gpio field

2013-10-01 Thread Stephen Warren
On 09/23/2013 03:41 PM, Thierry Reding wrote: > The GPIO API defines 0 as being a valid GPIO number, so this field needs > to be initialized explicitly. > static void __init smdkv210_map_io(void) > @@ -70,6 +70,7 @@ static struct samsung_bl_drvdata samsung_dfl_bl_data > __initdata = { >

Re: [PATCH 01/10] pwm-backlight: Refactor backlight power on/off

2013-10-01 Thread Stephen Warren
On 09/23/2013 03:40 PM, Thierry Reding wrote: > In preparation for adding an optional regulator and enable GPIO to the > driver, split the power on and power off sequences into separate > functions to reduce code duplication at the multiple call sites. > diff --git a/drivers/video/backlight/pwm_bl

Re: [PATCH 6/6] ARM: smdk5410_defconfig: add defconfig for smdk5410

2013-10-01 Thread Bartlomiej Zolnierkiewicz
Hi, On Tuesday, October 01, 2013 08:17:07 PM Vyacheslav Tyrtov wrote: > From: Tarek Dakhran > > Since current exynos_defconfig cannot support for EXYNOS5410 because > of big.LITTLE architecture, MCPM and ARM_CCI bus there added CONFIG_MCPM and CONFIG_ARM_CCI are optional features that won't be

Re: [PATCH 5/6] ARM: EXYNOS: Minor fixes to enable EXYNOS5410 support

2013-10-01 Thread Bartlomiej Zolnierkiewicz
Hi, On Tuesday, October 01, 2013 08:17:06 PM Vyacheslav Tyrtov wrote: > From: Tarek Dakhran > > Configure ARM_NR_BANKS as 16 for EXYNOS SoC. > Enable cci_control_port_by_index for ACE_PORT. > Add additional irqs for Exynos MCT. > Set irq base as 256 for EXYNOS5410 SoC. It would be better if th

Re: [RFC PATCH v2 0/7] VFIO for device tree based platform devices (work in progress)

2013-10-01 Thread Antonios Motakis
On Tue, Oct 1, 2013 at 5:47 PM, Christoffer Dall wrote: > On Mon, Sep 30, 2013 at 05:28:36PM +0200, Antonios Motakis wrote: >> This is a preview of the base work, towards VFIO support on ARM platforms >> with an IOMMU. It forms a base on to which to implement the functionality >> necessary to enab

Re: [PATCH 2/6] clk: exynos5410: register clocks using common clock framework

2013-10-01 Thread Bartlomiej Zolnierkiewicz
Hi, On Tuesday, October 01, 2013 08:17:03 PM Vyacheslav Tyrtov wrote: > From: Tarek Dakhran > > The EXYNOS5410 clocks are statically listed and registered > using the Samsung specific common clock helper functions. > > Signed-off-by: Tarek Dakhran > Signed-off-by: Vyacheslav Tyrtov > --- >

[PATCH 2/6] clk: exynos5410: register clocks using common clock framework

2013-10-01 Thread Vyacheslav Tyrtov
From: Tarek Dakhran The EXYNOS5410 clocks are statically listed and registered using the Samsung specific common clock helper functions. Signed-off-by: Tarek Dakhran Signed-off-by: Vyacheslav Tyrtov --- .../devicetree/bindings/clock/exynos5410-clock.txt | 72 ++ drivers/clk/samsung/Makef

[PATCH 3/6] ARM: EXYNOS: add Exynos Dual Cluster Support

2013-10-01 Thread Vyacheslav Tyrtov
From: Tarek Dakhran Add EDCS(Exynos Dual Cluster Support) for Samsung Exynos5410 SoC. This enables all 8 cores, 4 x A7 and 4 x A15 run at the same time. Signed-off-by: Tarek Dakhran Signed-off-by: Vyacheslav Tyrtov --- arch/arm/mach-exynos/Makefile | 2 + arch/arm/mach-exynos/edcs.c

[PATCH 4/6] ARM: dts: Add initial device tree support for EXYNOS5410

2013-10-01 Thread Vyacheslav Tyrtov
From: Tarek Dakhran Add initial device tree nodes for EXYNOS5410 SoC and SMDK5410 board. Signed-off-by: Tarek Dakhran Signed-off-by: Vyacheslav Tyrtov --- arch/arm/boot/dts/Makefile| 1 + arch/arm/boot/dts/exynos5410-smdk5410.dts | 67 +++ arch/arm/boot/dts/exynos54

[PATCH 1/6] ARM: EXYNOS: Add support for EXYNOS5410 SoC

2013-10-01 Thread Vyacheslav Tyrtov
From: Tarek Dakhran EXYNOS5410 is SoC in Samsung's Exynos5 SoC series. Add initial support for this SoC. Signed-off-by: Tarek Dakhran Signed-off-by: Vyacheslav Tyrtov --- arch/arm/mach-exynos/Kconfig | 10 ++ arch/arm/mach-exynos/common.c| 18 ++

[PATCH 5/6] ARM: EXYNOS: Minor fixes to enable EXYNOS5410 support

2013-10-01 Thread Vyacheslav Tyrtov
From: Tarek Dakhran Configure ARM_NR_BANKS as 16 for EXYNOS SoC. Enable cci_control_port_by_index for ACE_PORT. Add additional irqs for Exynos MCT. Set irq base as 256 for EXYNOS5410 SoC. Signed-off-by: Vyacheslav Tyrtov --- arch/arm/Kconfig | 2 +- drivers/bus/arm-cci.c

[PATCH 6/6] ARM: smdk5410_defconfig: add defconfig for smdk5410

2013-10-01 Thread Vyacheslav Tyrtov
From: Tarek Dakhran Since current exynos_defconfig cannot support for EXYNOS5410 because of big.LITTLE architecture, MCPM and ARM_CCI bus there added smdk5410_defconfig which is tested on SMDK5410 board for all 8 cpu running at the same time. This defconfig enables ARM_CCI, MCPM, EDCS. Signed-of

[PATCH 0/6] Exynos 5410 Dual cluster support

2013-10-01 Thread Vyacheslav Tyrtov
The series of patches represent support of Exynos 5410 SoC The Exynos 5410 is the first Samsung SoC based on bigLITTLE architecture. Patches allow all 8 CPU cores (4 x A7 and 4 x A15) to run at the same time Patches add new platform description, support of clock controller, dual cluster s

Re: [RFC PATCH v2 0/7] VFIO for device tree based platform devices (work in progress)

2013-10-01 Thread Christoffer Dall
On Mon, Sep 30, 2013 at 05:28:36PM +0200, Antonios Motakis wrote: > This is a preview of the base work, towards VFIO support on ARM platforms > with an IOMMU. It forms a base on to which to implement the functionality > necessary to enable using device tree devices on ARM (and other platforms > bas

Re: [PATCH V5 1/5] ARM: dts: Add MIPI PHY node to exynos4.dtsi

2013-10-01 Thread Kishon Vijay Abraham I
On Wednesday 02 October 2013 02:43 AM, Sylwester Nawrocki wrote: > On 10/01/2013 07:28 AM, Kishon Vijay Abraham I wrote: >> On Sunday 29 September 2013 12:57 AM, Sylwester Nawrocki wrote: >>> > Add PHY provider node for the MIPI CSIS and MIPI DSIM PHYs. >>> > >>> > Signed-off-by: Sylwester Nawroc

Re: [PATCH] i2c: s3c2410 : Add polling mode support

2013-10-01 Thread Mark Brown
On Tue, Oct 01, 2013 at 04:03:40PM +0530, Yuvaraj Kumar C D wrote: > +static bool is_ack(struct s3c24xx_i2c *i2c) > +{ > + u32 time_out = i2c->tx_setup; > + > + while (--time_out) { > + if (readl(i2c->regs + S3C2410_IICCON) > + & S3C2410_IICCON_IRQPEND) { >

Re: [PATCH V5 1/5] ARM: dts: Add MIPI PHY node to exynos4.dtsi

2013-10-01 Thread Sylwester Nawrocki
On 10/01/2013 07:28 AM, Kishon Vijay Abraham I wrote: On Sunday 29 September 2013 12:57 AM, Sylwester Nawrocki wrote: > Add PHY provider node for the MIPI CSIS and MIPI DSIM PHYs. > > Signed-off-by: Sylwester Nawrocki > Signed-off-by: Kyungmin Park > Acked-by: Felipe Balbi Can this patch b

Re: [PATCH] PCI: exynos: missing clk_disable_unprepare() on error in exynos_pcie_probe()

2013-10-01 Thread Sylwester Nawrocki
On 10/01/2013 03:33 AM, Jingoo Han wrote: On Sunday, September 29, 2013 11:29 AM, Wei Yongjun wrote: From: Wei Yongjun Add the missing clk_disable_unprepare() before return from exynos_pcie_probe() in the error handling case. Signed-off-by: Wei Yongjun Acked-by: Jingoo Han However, the com

Re: [PATCH 2/3] Phy: Exynos: Add Exynos5250 sata phy driver

2013-10-01 Thread Kishon Vijay Abraham I
On Tuesday 01 October 2013 12:03 PM, Yuvaraj Kumar C D wrote: > This patch adds the sata phy driver for Exynos5250.Exynos5250 sata > phy comprises of CMU and TRSV blocks which are of I2C register Map. > So this patch also adds a i2c client driver, which is used configure > the CMU and TRSV block of

Re: [PATCH 1/3] ahci: exynos: add ahci sata support on Exynos platform

2013-10-01 Thread Kishon Vijay Abraham I
On Tuesday 01 October 2013 12:03 PM, Yuvaraj Kumar C D wrote: > Exynos5250 contains one Synopsys AHCI SATA controller.The avalaible > ahci_platform driver is not sufficient to handle the AHCI PHY and PHY > clock related initialization. > > This patch adds exynos specific ahci sata driver,contained

[PATCH] i2c: s3c2410 : Add polling mode support

2013-10-01 Thread Yuvaraj Kumar C D
From: Vasanth Ananthan This patch adds polling mode support for i2c-s3c2410 driver.The SATA PHY controller's CMU and TRSV block's are of I2C register map in exynos5250.These blocks can be configured using i2c. But i2c controller instance on which these block's sits lacks an interrupt line.Also t

Re: [PATCH 2/7] Initial skeleton of VFIO support for Device Tree based devices

2013-10-01 Thread Antonios Motakis
On Mon, Sep 30, 2013 at 9:41 PM, Alex Williamson wrote: > > On Mon, 2013-09-30 at 17:28 +0200, Antonios Motakis wrote: > > Platform devices in the Linux kernel are usually managed by the DT > > interface. This patch forms the base to support these kind of devices > > with VFIO. > > > > Signed-off-

Re: [PATCH 1/7] VFIO_IOMMU_TYPE1 workaround to build for platform devices

2013-10-01 Thread Antonios Motakis
On Mon, Sep 30, 2013 at 7:39 PM, Alex Williamson wrote: > > On Mon, 2013-09-30 at 17:28 +0200, Antonios Motakis wrote: > > This is a workaround to make the VFIO_IOMMU_TYPE1 driver usable with > > platform devices instead of PCI. A future permanent fix should support > > both. This is required in o

Re: [PATCH 2/3] Phy: Exynos: Add Exynos5250 sata phy driver

2013-10-01 Thread Sachin Kamat
Hi Yuvaraj, On 1 October 2013 12:03, Yuvaraj Kumar C D wrote: > +static int exynos_sata_i2c_remove(struct i2c_client *client) > +{ > + dev_info(&client->adapter->dev, > + "detached %s from i2c adapter successfully\n", > + client->name); > + > + return 0; >