[PATCH v2 0/7] wireless: Use macros from wireless.h

2010-03-18 Thread Joe Perches
Move the STD_IW_HANDLER macro from orinoco to wireless.h Use the wireless.h macros in various wireless files Remove local #defines of IW_IOCTL Joe Perches (7): wireless.h: Add STD_IW_HANDLER macro net/wireless/wext_core.c: Use IW_IOCTL_IDX macro net/wireless/wext-core.c: Use IW_EVENT_IDX

[PATCH v2 5/7] drivers/net: Remove local #define IW_IOCTL, use STD_IW_HANDLER

2010-03-18 Thread Joe Perches
Use #define STD_IW_HANDLER from wireless.h instead Signed-off-by: Joe Perches j...@perches.com --- drivers/net/ps3_gelic_wireless.c | 35 +++--- drivers/net/wireless/ipw2x00/ipw2200.c | 83 2 files changed, 58 insertions(+), 60 deletions(-)

Re: [PATCH] powerpc/fsl-booke: Get coherent bit from PTE

2010-03-18 Thread Kumar Gala
On Mar 18, 2010, at 2:02 AM, Micha Nelissen wrote: Kumar Gala wrote: We shouldn't be always setting 'M' in the TLB entry since its reasonable for somethings to be mapped non-coherent. The PTE should have 'M' set properly. properly = not at all? AFAICS the patch only removes the setting

Re: [PATCH] powerpc/fsl-booke: Get coherent bit from PTE

2010-03-18 Thread Micha Nelissen
Kumar Gala wrote: We shouldn't be always setting 'M' in the TLB entry since its reasonable for somethings to be mapped non-coherent. The PTE should have 'M' set properly. properly = not at all? AFAICS the patch only removes the setting of the bit; so where is that 'M' bit set then? Micha

Re: how can I write a Device Tree Source for PCI-PCI Bridge?

2010-03-18 Thread Benjamin Herrenschmidt
On Thu, 2010-03-18 at 01:05 +0800, Jianbin Hu wrote: My board have a PCIe switch(PLX PEX8608), which have a AMCC 460EX processor. I have parted the dts source file from canyonlands.dts. But I have no idea for the PCI bridge device node. Is anyone have a suggestion ? Hi ! First, you don't

Re: [PATCH] powerpc: Build fix for mpc52xx

2010-03-18 Thread Grant Likely
On Wed, Mar 10, 2010 at 3:03 PM, Jeff Mahoney je...@suse.com wrote: mpc52xx_gpt_wdt_setup is defined as 0, which causes the following build failure with gcc 4.5, since it's built with -Werror. arch/powerpc/platforms/52xx/mpc52xx_gpt.c:761:3: error: statement with no effect Defining it as

[git pull updated] driver bug fixes and mpc5200 defconfig updates

2010-03-18 Thread Grant Likely
Hi Linus, I've updated my merge branch to add a build fix (mpc52xx) and an OF regression (fix comparison...). Please pull. Thanks, g. The following changes since commit 57d54889cd00db2752994b389ba714138652e60c: Linus Torvalds (1): Linux 2.6.34-rc1 are available in the git repository

[PATCH] powerpc/fsl: Add multiple MSI bank support

2010-03-18 Thread Kumar Gala
From: Lan Chunhe-B25806 b25...@freescale.com Freescale QorIQ P4080 has three MSI banks and the original code can not work well. This patch adds multiple MSI banks support for Freescale processor. Signed-off-by: Lan Chunhe-B25806 b25...@freescale.com Signed-off-by: Roy Zang

[V2 PATCH 00/10] of: Consolidate scattered device node pointers in struct device

2010-03-18 Thread Grant Likely
Currently, each of_device has a copy of the device tree node pointer in both .node, and in .dev.archdata.of_node (microblaze and powerpc) or .dev.archdata.prom_node (sparc). Also, other architectures will be adding CONFIG_OF support, and they will also need a reference to the device tree node

[V2 PATCH 01/10] driver-core: Add device node pointer to struct device

2010-03-18 Thread Grant Likely
Currently, platforms using CONFIG_OF add a 'struct device_node *of_node' to dev-archdata. However, with CONFIG_OF becoming generic for all architectures, it makes sense for commonality to move it out of archdata and into struct device proper. This patch adds a struct device_node *of_node member

[V2 PATCH 02/10] i2c/of: Allow device node to be passed via i2c_board_info

2010-03-18 Thread Grant Likely
The struct device_node *of_node pointer is moving out of dev-archdata and into the struct device proper. of_i2c.c needs to set the of_node pointer before the device is registered. Since the i2c subsystem doesn't allow 2 stage allocation and registration of i2c devices, the of_node pointer needs

[V2 PATCH 03/10] arch/sparc: Always use 'struct device.of_node' to get device node pointer.

2010-03-18 Thread Grant Likely
The following structure elements duplicate the information in 'struct device.of_node' and so are being eliminated. This patch makes all readers of the following elements use device.of_node instead. struct of_device.node struct dev_archdata.prom_node Signed-off-by: Grant Likely

[V2 PATCH 04/10] arch/powerpc: Always use 'struct device.of_node' to get device node pointer.

2010-03-18 Thread Grant Likely
The following structure elements duplicate the information in 'struct device.of_node' and so are being eliminated. This patch makes all readers of the following elements use device.of_node instead. struct of_device.node struct dev_archdata.of_node Signed-off-by: Grant Likely

[V2 PATCH 05/10] arch/microblaze: Always use 'struct device.of_node' to get device node pointer.

2010-03-18 Thread Grant Likely
The following structure elements duplicate the information in 'struct device.of_node' and so are being eliminated. This patch makes all readers of the following elements use device.of_node instead. struct of_device.node struct dev_archdata.of_node Signed-off-by: Grant Likely

[V2 PATCH 07/10] of: eliminate calls to dev_archdata_set_node()

2010-03-18 Thread Grant Likely
At this point, there are no more users of the archdata node pointer, so the calls to set it can be dropped. Signed-off-by: Grant Likely grant.lik...@secretlab.ca --- drivers/of/of_i2c.c |1 - drivers/of/of_mdio.c |1 - drivers/of/of_spi.c |1 - 3 files changed, 0 insertions(+), 3

[V2 PATCH 08/10] arch/powerpc: Remove obsolete dev_archdata.of_node and of_devce.node

2010-03-18 Thread Grant Likely
Both dev_archdata.of_node and of_device.node are duplications of the device.of_node value. This patch removes them. Signed-off-by: Grant Likely grant.lik...@secretlab.ca --- arch/powerpc/include/asm/device.h | 15 --- arch/powerpc/include/asm/of_device.h|1 -

[V2 PATCH 09/10] arch/microblaze: Remove obsolete dev_archdata.of_node and of_devce.node

2010-03-18 Thread Grant Likely
Both dev_archdata.of_node and of_device.node are duplications of the device.of_node value. This patch removes them. Signed-off-by: Grant Likely grant.lik...@secretlab.ca --- arch/microblaze/include/asm/device.h| 14 -- arch/microblaze/include/asm/of_device.h |1 -

[V2 PATCH 10/10] arch/sparc: Remove obsolete dev_archdata.prom_node and of_devce.node

2010-03-18 Thread Grant Likely
Both dev_archdata.prom_node and of_device.node are duplications of the device.of_node value. This patch removes them. Signed-off-by: Grant Likely grant.lik...@secretlab.ca --- arch/sparc/include/asm/device.h| 15 --- arch/sparc/include/asm/of_device.h |1 -

Re: [V2 PATCH 00/10] of: Consolidate scattered device node pointers in struct device

2010-03-18 Thread Grant Likely
On Thu, Mar 18, 2010 at 9:22 AM, Grant Likely grant.lik...@secretlab.ca wrote: Currently, each of_device has a copy of the device tree node pointer in both .node, and in .dev.archdata.of_node (microblaze and powerpc) or .dev.archdata.prom_node (sparc).  Also, other architectures will be adding

Re: [V2 PATCH 08/10] arch/powerpc: Remove obsolete dev_archdata.of_node and of_devce.node

2010-03-18 Thread Anton Vorontsov
Hi Grant, On Thu, Mar 18, 2010 at 09:22:50AM -0600, Grant Likely wrote: Both dev_archdata.of_node and of_device.node are duplications of the device.of_node value. This patch removes them. Yeah, they're plain duplications since you introduced dev.of_node. I wonder what was the problem with

Re: [V2 PATCH 06/10] of/drivers: Always use struct device.of_node to get node pointer

2010-03-18 Thread Jochen Friedrich
Hi Grant, The following structure elements duplicate the information in 'struct device.of_node' and so are being eliminated. This patches makes all readers of the following elements use device.of_node instead. struct dev_archdata.prom_node (sparc) struct dev_archdata.of_node (powerpc) struct

Re: [V2 PATCH 08/10] arch/powerpc: Remove obsolete dev_archdata.of_node and of_devce.node

2010-03-18 Thread Grant Likely
On Thu, Mar 18, 2010 at 9:47 AM, Anton Vorontsov avoront...@ru.mvista.com wrote: Hi Grant, On Thu, Mar 18, 2010 at 09:22:50AM -0600, Grant Likely wrote: Both dev_archdata.of_node and of_device.node are duplications of the device.of_node value.  This patch removes them. Yeah, they're plain

Re: [V2 PATCH 06/10] of/drivers: Always use struct device.of_node to get node pointer

2010-03-18 Thread Grant Likely
On Thu, Mar 18, 2010 at 9:58 AM, Jochen Friedrich joc...@scram.de wrote: Hi Grant, The following structure elements duplicate the information in 'struct device.of_node' and so are being eliminated.  This patches makes all readers of the following elements use device.of_node instead. struct

PPC405EX PCI CPU vs bus address mapping question

2010-03-18 Thread Steven A. Falco
I have a Kilauea board with one custom PCIE card plugged into the PCIE1 slot. The custom card contains four PCI devices which are connected via a PCIE-PCI bridge to the Kilauea. These devices need to communicate directly with each other. This is done by telling each device the PCI bus address of

Re: [PATCH] powerpc/of: Fix comparison of compatible properties

2010-03-18 Thread Michal Simek
Grant Likely wrote: On Wed, Mar 17, 2010 at 6:09 PM, Benjamin Herrenschmidt b...@kernel.crashing.org wrote: Commit 7c7b60cb87547b1664a4385c187f029bf514a737 of: put default string compare and #a/s-cell values into common header Breaks various things on powerpc due to using strncasecmp instead

Re: [V2 PATCH 06/10] of/drivers: Always use struct device.of_node to get node pointer

2010-03-18 Thread Sean MacLennan
On Thu, 18 Mar 2010 09:22:39 -0600 Grant Likely grant.lik...@secretlab.ca wrote: The following structure elements duplicate the information in 'struct device.of_node' and so are being eliminated. This patches makes all readers of the following elements use device.of_node instead. The NDFC

Re: [PATCH v2 0/7] wireless: Use macros from wireless.h

2010-03-18 Thread Johannes Berg
On Wed, 2010-03-17 at 23:21 -0700, Joe Perches wrote: Move the STD_IW_HANDLER macro from orinoco to wireless.h Use the wireless.h macros in various wireless files Remove local #defines of IW_IOCTL I really don't want to debug any breakage here, but otherwise I don't care and this is fine with

Re: [V2 PATCH 06/10] of/drivers: Always use struct device.of_node to get node pointer

2010-03-18 Thread Grant Likely
On Thu, Mar 18, 2010 at 10:59 AM, Sean MacLennan smaclen...@pikatech.com wrote: On Thu, 18 Mar 2010 09:22:39 -0600 Grant Likely grant.lik...@secretlab.ca wrote: The following structure elements duplicate the information in 'struct device.of_node' and so are being eliminated.  This patches

Re: [V2 PATCH 06/10] of/drivers: Always use struct device.of_node to get node pointer

2010-03-18 Thread Sean MacLennan
On Thu, 18 Mar 2010 11:07:35 -0600 Grant Likely grant.lik...@secretlab.ca wrote: On Thu, Mar 18, 2010 at 10:59 AM, Sean MacLennan smaclen...@pikatech.com wrote: On Thu, 18 Mar 2010 09:22:39 -0600 Grant Likely grant.lik...@secretlab.ca wrote: The following structure elements duplicate

Re: [V2 PATCH 06/10] of/drivers: Always use struct device.of_node to get node pointer

2010-03-18 Thread Sean MacLennan
On Thu, 18 Mar 2010 09:22:39 -0600 Grant Likely grant.lik...@secretlab.ca wrote: The following structure elements duplicate the information in 'struct device.of_node' and so are being eliminated. This patches makes all readers of the following elements use device.of_node instead. Acked-by:

Does ppc cpio have limit in size?

2010-03-18 Thread wilbur.chan
Recently I 'm using cpio filesystem (kernel and filesystem compressed as a whole) on ppc8270 . However I found that the bigger the size of uImage is , the easier kernel failed when booting. Everytime it failed when calling populate_rootfs when booting, so I guess maybe the size of uImage effect

Re: IRQ's missing with MPC5200 GPT as an interrupt controller

2010-03-18 Thread Grant Likely
Hi Henk, On Mon, Mar 8, 2010 at 8:20 AM, Henk Stegeman henk.stege...@gmail.com wrote: I'm trying to make use of the GPT as interrupt controller. My driver is getting most, but not all of the interrupts, besides that I'm getting a whole bunch of spurious IRQs, so I'm trying to figure out

Re: [PATCH v2] powerpc/perf_events: Implement perf_arch_fetch_caller_regs

2010-03-18 Thread Frederic Weisbecker
On Thu, Mar 18, 2010 at 04:05:13PM +1100, Paul Mackerras wrote: This implements a powerpc version of perf_arch_fetch_caller_regs. It's implemented in assembly because that way we can be sure there isn't a stack frame for perf_arch_fetch_caller_regs. If it was in C, gcc might or might not

Re: BUG in dma-mapping.h:218 // MESH SCSI driver not working

2010-03-18 Thread Benjamin Herrenschmidt
On Fri, 2010-03-19 at 00:21 +0100, Stef Simoens wrote: Hello, Some time ago (July 24th 2009 my mailbox says) I emailed you and the linuxppc-dev list about my problems booting from the mesh SCSI controller. I just compiled 2.6.31 (actually, gentoo-sources-2.6.31-r10); but the problem

Re: [PATCH 4/6] powerpc: Rename LWSYNC_ON_SMP to PPC_RELEASE_BARRIER, ISYNC_ON_SMP to PPC_ACQUIRE_BARRIER

2010-03-18 Thread Nick Piggin
On Wed, Feb 10, 2010 at 10:04:06PM +1100, Anton Blanchard wrote: For performance reasons we are about to change ISYNC_ON_SMP to sometimes be lwsync. Now that the macro name doesn't make sense, change it and LWSYNC_ON_SMP to better explain what the barriers are doing. Signed-off-by: Anton

[PATCH v3 0/9] wireless: Use macros from wireless.h

2010-03-18 Thread Joe Perches
Create a IW_HANDLER macro for iw_handler array entries in wireless.h Use the wireless.h macros in various wireless files Use starting index define SIOCIWFIRST where appropriate Remove local #defines of IW_IOCTL Remove STD_IW_HANDLER macro in orinoco, use IW_HANDLER instead Joe Perches (9):

[PATCH v3 7/9] drivers/net: Remove local #define IW_IOCTL, use IW_HANDLER

2010-03-18 Thread Joe Perches
Use #define IW_HANDLER from wireless.h instead Signed-off-by: Joe Perches j...@perches.com --- drivers/net/ps3_gelic_wireless.c | 35 +++--- drivers/net/wireless/ipw2x00/ipw2200.c | 83 2 files changed, 58 insertions(+), 60 deletions(-) diff

Re: [PATCH 4/6] powerpc: Rename LWSYNC_ON_SMP to PPC_RELEASE_BARRIER, ISYNC_ON_SMP to PPC_ACQUIRE_BARRIER

2010-03-18 Thread Benjamin Herrenschmidt
On Fri, 2010-03-19 at 12:08 +1100, Nick Piggin wrote: - ISYNC_ON_SMP + PPC_ACQUIRE_BARRIER I wonder if this shouldn't be called PPC_ISYNC_ACQUIRE_BARRIER ? Unlike PPC_RELEASE_BARRIER, it is not an acquire barrier unless it is used like an isync. Right. The semantic of isync

Re: [PATCH] powerpc/fsl: Add multiple MSI bank support

2010-03-18 Thread Michael Ellerman
On Thu, 2010-03-18 at 09:53 -0500, Kumar Gala wrote: From: Lan Chunhe-B25806 b25...@freescale.com Freescale QorIQ P4080 has three MSI banks and the original code can not work well. This patch adds multiple MSI banks support for Freescale processor. Signed-off-by: Lan Chunhe-B25806

Re: [PATCH] PPC: Skip over OF_DT_NOP when unflattening the device tree

2010-03-18 Thread Benjamin Herrenschmidt
On Tue, 2010-03-09 at 12:30 -0700, Jason Gunthorpe wrote: NOPs within the property section are skipped, but NOPs between OF_DT_END_NODE and OF_DT_BEGIN_NODE were not. My firmware NOPs out entire nodes depending on various environment parameters. of_scan_flat_dt already handles NOP more