Re: gnome, gdm problem on lenovo e14 gen2

2021-05-05 Thread Hrvoje Popovski
On 4.5.2021. 13:58, Nam Nguyen wrote: > Hrvoje Popovski writes: > >> Problem is that when i should get login screen, gdm to ask me for user >> and password, i'm getting blank grey screen .. >> >> after moving through terminals with ctrl-alt fX, from time to time

gnome, gdm problem on lenovo e14 gen2

2021-05-03 Thread Hrvoje Popovski
Hi all, I've installed a snapshot on e14gen2 and the installation went smooth. Gnome was installed and configured based on /usr/local/share/doc/pkg-readmes/gnome. Problem is that when i should get login screen, gdm to ask me for user and password, i'm getting blank grey screen .. after moving

Re: OpenBSD on Dell PE R6515

2021-04-12 Thread Hrvoje Popovski
On 12.4.2021. 20:04, Joerg Streckfuss wrote: > > Hello folks, > > in the past we used Dell servers like PE 1850, PE 2850, PE R730 and PE > R740. We had good experiences running Openbsd on these systems. These > models are all Intel based but for another project i'm considering > giving AMD a

Re: Small/Mini 10Gbe Router Recommendation

2021-04-08 Thread Hrvoje Popovski
On 8.4.2021. 22:16, Daniel Melameth wrote: > On Thu, Apr 8, 2021 at 1:52 PM Hrvoje Popovski wrote: >> On 8.4.2021. 20:56, Daniel Melameth wrote: >>> On Thu, Apr 8, 2021 at 3:57 AM Stuart Henderson >>> wrote: >>>> On 2021-04-07, Daniel Melameth wrote

Re: Small/Mini 10Gbe Router Recommendation

2021-04-08 Thread Hrvoje Popovski
On 8.4.2021. 20:56, Daniel Melameth wrote: > On Thu, Apr 8, 2021 at 3:57 AM Stuart Henderson wrote: >> On 2021-04-07, Daniel Melameth wrote: >>> Looking to finally part with my legacy OpenBSD router and upgrade to >>> something that can push more than 2Gbps out of a single port. Since >>> my

Re: OT: Dell EMC switches

2021-04-08 Thread Hrvoje Popovski
On 8.4.2021. 20:58, Ivo Chutkin wrote: > Hello everyone, > > Does anyone have experience with Dell EMS switches? > > Namely S4100 series, S4128F-ON or S4188F-ON. > > Are they robust and reliable? > > I need to replace number of Extreme Networks X650. 10G ports are loaded > nearly 80% all the

Re: pf firewall bridge0 vether0 blocks DHCP for bridge interfaces connected to Windows

2021-03-10 Thread Hrvoje Popovski
On 10.3.2021. 20:40, da...@hajes.org wrote: > Hi, > > I did set up OpenBSD router/firewall on PC Engines APU4d4 box. > > First interface is WAN that connects to Internet. > > Remaining three interfaces are bridged with bridge0 via vether0. > > firewall doesn't block LAN/bridge traffic on

Re: 10Gbit network work only 1Gbit

2021-02-26 Thread Hrvoje Popovski
On 26.2.2021. 9:00, csszep wrote: > Hi! > > I miss something , or veb(4) ifconfig bits not yet commited ? > > OpenBSD 6.9-beta (GENERIC.MP) #358: Wed Feb 24 17:11:53 MST 2021 > dera...@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP > > > ifconfig veb0 create > ifconfig:

Re: 10Gbit network work only 1Gbit

2021-02-25 Thread Hrvoje Popovski
On 12.11.2019. 10:54, Szél Gábor wrote: > Dear Hrvoje, Theo, > > Thank you for your answers! > > answers to the questions: > -  who is parent interface for carp?  -> vlan  ( carp10 interface parent > vlan10 -> vlan10 interface  parent -> trunk0 ) > - why vlan interfaces don't have ip address ?

Re: Switching from trunk(4) to aggr(4)

2020-12-14 Thread Hrvoje Popovski
On 13.12.2020. 23:40, Daniel Jakots wrote: > I just tried > # ifconfig aggr0 debug > # dmesg > > # ifconfig aggr0 down > # ifconfig aggr0 up > # ifconfig aggr0 # checked the debug flag was still there > # dmesg > > > I also looked at /var/log/message to be save, but nothing relevant. Hi,

Re: Intl I350 Network Card Not Found

2020-09-17 Thread Hrvoje Popovski
On 17.9.2020. 20:39, Brandon Woodford wrote: > Hello, > > I've been trying to fix an issue with my Intel I350-T4 PCI Network card not > being reported to the OpenBSD 6.7 system during boot. Looking through dmesg, > I was not able to find any reference to the card or the em interface name >

Re: openconnect

2020-09-03 Thread Hrvoje Popovski
On 1.9.2020. 15:22, Stuart Henderson wrote: > On 2020-09-01, Hrvoje Popovski wrote: >> Hi all, >> >> does anyone use an openconnect server on openbsd and have guidelines on >> how to configure it? i see that an openconnect server can use radius, so >> it's inter

openconnect

2020-09-01 Thread Hrvoje Popovski
Hi all, does anyone use an openconnect server on openbsd and have guidelines on how to configure it? i see that an openconnect server can use radius, so it's interesting to me. Which client do you use to connect to the openconnect server? If there is something else that can use radius, i would

Re: aggr(4) not working with Intel XXV710 SFP28 on a Supermicro X11DPi-N(T)

2020-08-17 Thread Hrvoje Popovski
On 17.8.2020. 11:46, Stuart Henderson wrote: > On 2020-08-15, Hrvoje Popovski wrote: >> On 15.8.2020. 0:48, Hrvoje Popovski wrote: >>> On 12.8.2020. 15:18, Winfred Harrelson wrote: >>>> On Tue, Aug 11, 2020 at 07:52:10PM +0100, Tom Smyth wrote: >>>>>

Re: aggr(4) not working with Intel XXV710 SFP28 on a Supermicro X11DPi-N(T)

2020-08-15 Thread Hrvoje Popovski
On 15.8.2020. 0:48, Hrvoje Popovski wrote: > On 12.8.2020. 15:18, Winfred Harrelson wrote: >> On Tue, Aug 11, 2020 at 07:52:10PM +0100, Tom Smyth wrote: >>> Hi Winfred, >>> the intel 710 is a complex card, I would suggest that you try updating the >>>

Re: aggr(4) not working with Intel XXV710 SFP28 on a Supermicro X11DPi-N(T)

2020-08-14 Thread Hrvoje Popovski
On 12.8.2020. 15:18, Winfred Harrelson wrote: > On Tue, Aug 11, 2020 at 07:52:10PM +0100, Tom Smyth wrote: >> Hi Winfred, >> the intel 710 is a complex card, I would suggest that you try updating the >> firmware on the card, available from intel.com or your card vendor, >> you may have to boot to

Re: IPSec heavy traffic slows down all network traffic

2020-07-18 Thread Hrvoje Popovski
On 17.7.2020. 20:17, jean-yves boisiaud wrote: > hello, > > Last week, I upgraded a couple of firewalls using carp/pfsync and sasyncd > from 6.0 to 6.7 (yes, big jump !). > > I also applied all the 6.7 published patches. > > When some heavy traffic takes one of the IPSec tunnel, I noticed that

Re: supermicro - A2SDV-8C-LN8F

2020-07-13 Thread Hrvoje Popovski
On 11.7.2020. 11:13, mlopenb...@xiphosura.co.uk wrote: > On Sat, 11 Jul 2020 00:13:34 +0200 > Hrvoje Popovski wrote: > >> Hi all, >> >> does anyone have experience or dmesg of this motherboard >> https://www.supermicro.com/en/products/motherboard/A2SDV-8C-

supermicro - A2SDV-8C-LN8F

2020-07-10 Thread Hrvoje Popovski
Hi all, does anyone have experience or dmesg of this motherboard https://www.supermicro.com/en/products/motherboard/A2SDV-8C-LN8F is it stable? i'm most interested in network performance and network cards. in motherboard manual i couldn't find what "Quad LAN with Intel® C3000 SoC" means ? is it

Re: strongSwan cannot install IPsec policies on OpenBSD

2020-02-21 Thread Hrvoje Popovski
On 20.2.2020. 18:47, Peter Müller wrote: > Hello openbsd-misc, > > is anybody out there running strongSwan as an IPsec client for a net-to-net > connection > on an OpenBSD machine? > > If so, I would be very grateful to know which steps are necessary in order to > successfully > route traffic

Re: Brand new server - bad adventures

2020-01-22 Thread Hrvoje Popovski
On 22.1.2020. 21:30, Özgür Kazancci wrote: > Hello everyone! Greetings to misc people! > > Got a brand new dedicated server with a hardware: Intel Xeon-E 2274G - > 64GB DDR4 ECC 2666MHz - 2x SSD NVMe 960GB > and installed "brand new" OpenBSD 6.6 on it. (I'm managing it remotely > via KVM/IPMI)

Re: small aggr problem ( on current )

2019-12-19 Thread Hrvoje Popovski
On 15.12.2019. 23:01, Hrvoje Popovski wrote: > On 15.12.2019. 12:45, Holger Glaess wrote: >> hi >> >> >>   runing version >> >> >> /etc 16>dmesg | more >> Copyright (c) 1982, 1986, 1989, 1991, 1993 >>     The Regents of the Universit

Re: small aggr problem ( on current )

2019-12-15 Thread Hrvoje Popovski
On 15.12.2019. 12:45, Holger Glaess wrote: > hi > > >   runing version > > > /etc 16>dmesg | more > Copyright (c) 1982, 1986, 1989, 1991, 1993 >     The Regents of the University of California.  All rights reserved. > Copyright (c) 1995-2019 OpenBSD. All rights reserved. >

Re: issues configuring vlan on top of aggr device

2019-12-03 Thread Hrvoje Popovski
On 3.12.2019. 15:11, Pedro Caetano wrote: > Hi again, > > I'm sorry, but since the boxes do not (yet) have working networking it > is not easy for me to get the text output. > I'm attaching a few pictures with the requested output. > >

Re: issues configuring vlan on top of aggr device

2019-12-03 Thread Hrvoje Popovski
rface. > > I'd appreciate any help on this topic. > can you send ifconfig aggr0 and ifconfig vlan3800 ? > This configuration is working on -current with em(4) nics. > > > Best regards, > Pedro Caetano > > A terça, 3/12/2019, 12:01, Hrvoje Popovski <mailto:hrv...@

Re: issues configuring vlan on top of aggr device

2019-12-03 Thread Hrvoje Popovski
On 3.12.2019. 12:21, Pedro Caetano wrote: > Hi misc@ > > I'm running openbsd 6.6 with latest patches running on a pair of hp dl 360 > gen6 servers. > > I'm attempting to configure an aggr0 device towards a cat 3650. > > The aggr0 associates successfully with the switch, but I'm unable to run >

Re: 10Gbit network work only 1Gbit

2019-11-13 Thread Hrvoje Popovski
hed over em0, pf disabled 8.10Gbps forwarding over ix0 and ix1, ipsec established over em0, pf enabled, 8 TCP streams 5.25Gbps > On 13.11.19 12:52, Hrvoje Popovski wrote: >> On 13.11.2019. 10:59, Hrvoje Popovski wrote: >>> On 12.11.2019. 10:54, Szél Gábor wrote: >>>> D

Re: 10Gbit network work only 1Gbit

2019-11-13 Thread Hrvoje Popovski
On 13.11.2019. 10:59, Hrvoje Popovski wrote: > On 12.11.2019. 10:54, Szél Gábor wrote: >> Dear Hrvoje, Theo, >> >> Thank you for your answers! >> >> answers to the questions: >> -  who is parent interface for carp?  -> vlan  ( carp10 interface parent >&

Re: 10Gbit network work only 1Gbit

2019-11-13 Thread Hrvoje Popovski
On 12.11.2019. 10:54, Szél Gábor wrote: > Dear Hrvoje, Theo, > > Thank you for your answers! > > answers to the questions: > -  who is parent interface for carp?  -> vlan  ( carp10 interface parent > vlan10 -> vlan10 interface  parent -> trunk0 ) > - why vlan interfaces don't have ip address ?

Re: 10Gbit network work only 1Gbit

2019-11-11 Thread Hrvoje Popovski
On 11.11.2019. 13:42, Szél Gábor wrote: > Hello @misc, > Hi, > We have an interesting problem, we run a lot of OpenBSD router/firewalls > in many places. > > We have a larger network than our client, 300-400 local wired or > wireless endpoint, 20+ VLAN, 20+ switches. > Network structure: > >

Re: alias vs inet alias in hostname.if

2019-09-20 Thread Hrvoje Popovski
On 20.9.2019. 13:12, Stuart Henderson wrote: > On 2019-09-20, Hrvoje Popovski wrote: >> Hi all, >> >> if i have "alias" directive in hostname.if with dot-notation netmask and >> networks are in 10/8 or 172.16/12 it seems i'm getting classless /8 or >>

alias vs inet alias in hostname.if

2019-09-20 Thread Hrvoje Popovski
Hi all, if i have "alias" directive in hostname.if with dot-notation netmask and networks are in 10/8 or 172.16/12 it seems i'm getting classless /8 or /16 networks ... inet 192.168.42.1 255.255.255.0 alias 10.10.10.0 255.255.255.0 ix0: flags=8843 mtu 1500 inet 192.168.42.1 netmask

Re: 6.6-beta (RAMDISK_CD) #281 hangs on fsck

2019-09-10 Thread Hrvoje Popovski
On 9.9.2019. 11:39, David Gwynne wrote: > This should be fixed in -current now. A snapshot should pick it up in a day > or so. Sorry for the inconvenience. > > Cheers, > dlg Hi, with new snapshot from 09-Sep-2019 bsd.rd and sysupgrade is working normally with mfii.. thank you ...

Re: 6.6-beta (RAMDISK_CD) #281 hangs on fsck

2019-09-08 Thread Hrvoje Popovski
On 8.9.2019. 18:19, Luke Small wrote: > It doesn’t work for me on the > ftp.hostserver.de/archive/2019-08-29-0105/amd64/ > bsd.rd! Hi, do you maybe have mfii on that box ? I'm having same problem as Mischa and i have mfii. with bsd.rd fsck stops with this command Which disk is the root disk?

Re: OpenBSD 6.5 dumps to debugger when using ifconfig bridge command

2019-06-05 Thread Hrvoje Popovski
On 4.6.2019. 21:22, Russell Sutherland wrote: > I tried loading current on the device and the same result: > > OpenBSD 6.5-current (GENERIC.MP) #5: Mon Jun 3 07:46:49 MDT 2019 > > # netstat -in > NameMtu Network Address Ipkts IfailOpkts Ofail > Colls > lo0 32768

Re: firefox, sndiod and pledge

2019-05-30 Thread Hrvoje Popovski
On 30.5.2019. 10:48, Solene Rapenne wrote: > On Thu, May 30, 2019 at 10:41:39AM +0200, Hrvoje Popovski wrote: >> Hi all, >> >> i'm not sure is this intended or not, but if sndiod isn't running and if >> i want to open youtube video with firefox i got this log >

firefox, sndiod and pledge

2019-05-30 Thread Hrvoje Popovski
Hi all, i'm not sure is this intended or not, but if sndiod isn't running and if i want to open youtube video with firefox i got this log firefox[54192]: pledge "tty", syscall 54 and firefox crashes when sndiod is running everything seems fine .. from kdump 70068 firefox CALL

Re: Problems installing 6.5 on Supermicro X11SDV-8C-TP8 motherboard - can't see/find network interfaces

2019-05-19 Thread Hrvoje Popovski
On 19.5.2019. 3:08, Don Jackson wrote: > I recently acquired a Supermicro 1019D-FRN8TP server with a X11SDV-8C-TP8 > motherboard. Hi, try to install latest snapshot. After installation execute sendbug -P > 1019D-FRN8TP.txt and send that output to b...@openbsd.org with hardware description and

Re: samba : snapshots of 6.5

2019-04-15 Thread Hrvoje Popovski
On 14.4.2019. 20:10, Tuyosi T wrote: > hi all . > > the samba of snapshots does not start . > > dell# /etc/rc.d/samba start > smbd(timeout) > I have similar problem with samba after upgrade to 4.8.11, smbd timeouts but it starts. # rcctl stop samba nmbd(ok) smbd(ok) # rcctl start samba

Re: 40G ixl nics

2019-04-10 Thread Hrvoje Popovski
On 3.2.2019. 19:09, Tony Sarendal wrote: > Good evening, > > We inserted a 2x40G NIC into one of our old franken-pc's, and got this: > > ixl0 at pci2 dev 0 function 0 "Intel XL710 QSFP+" rev 0x02: port 0, FW > 5.0.40043 API 1.5, msi, address 0c:c4:7a:5e:f9:c8 > ixl0: unable to query phy types >

Re: IBM x3650 M3 fatal page fault in supervisor mode

2019-03-12 Thread Hrvoje Popovski
On 12.3.2019. 22:26, Marco Nuessgen wrote: > I am trying to install OpenBSD 6.4 amd64 on an IBM x-series server. The > boot process halts after the kernel gets a "fatal page fault in > supervisor mode". > > The machine is a x3650 M3 server, 2x six-core XEON E5645 2.4GHz, 88GB > RAM, 3 x 146GB

Re: iked road warrior setup with multiple clients connecting

2019-02-25 Thread Hrvoje Popovski
On 25.2.2019. 16:44, Michael Lam wrote: > Hi, > > I have a very straight forward setup use case that I want to use my > OpenBSD router as a VPN gateway, which will accept IKEv2 road warrior > connections from the Internet and route all traffics through my > router. > > I am using a ms-chapv2

Re: OpenBSD 6.4-stable + current "freezes" after 4h

2019-01-14 Thread Hrvoje Popovski
On 14.1.2019. 16:25, Hrvoje Popovski wrote: > On 14.1.2019. 10:02, Marco Prause wrote: >> splassert: bstp_notify_rtage: want 2 have 0 >> splassert: bstp_notify_rtage: want 2 have 0 >> splassert: bstp_notify_rtage: want 2 have 0 >> splassert: bstp_notify_rtage:

Re: amd64 current snapshot reboots after http mirror entry

2019-01-14 Thread Hrvoje Popovski
On 14.1.2019. 15:35, Mihai Popescu wrote: > Hello, > > Just a short confirmation, amd64 current snapshot reboots the computer > at install, right after the [http] mirror input. > All I can see are 4 lines of blue background written, then reboot. I > am not able to see or capture the message since

Re: OpenBSD 6.4-stable + current "freezes" after 4h

2019-01-14 Thread Hrvoje Popovski
On 14.1.2019. 10:02, Marco Prause wrote: > splassert: bstp_notify_rtage: want 2 have 0 > splassert: bstp_notify_rtage: want 2 have 0 > splassert: bstp_notify_rtage: want 2 have 0 > splassert: bstp_notify_rtage: want 2 have 0 > splassert: bstp_notify_rtage: want 2 have 0 > splassert:

Intel X710-DA4 and Dell R420

2018-12-06 Thread Hrvoje Popovski
Hi all, i just wanted to warn people not to buy X710-DA4 and try to insert it in Dell R420. You can insert it in Dell R620 just fine. nic - http://kosjenka.srce.hr/~hrvoje/nic.jpg r420 pci slot - http://kosjenka.srce.hr/~hrvoje/r420-pci.jpg On other hand don't put chinese X710-DA2 or something

Re: Performance impact of PF on APU2

2018-10-04 Thread Hrvoje Popovski
On 4.10.2018. 5:58, Benjamin Petit wrote: > Ok so I compared 6.3-release, 6.3-release+syspatches(=stable?) and the latest > snapshot from October 2. > > I measured iperf3 throughput between A and B, like this: > PC A <---> APU2 <---> PC B > > pf rules are the one shipped by default in 6.3: > >

cpu's in dmesg

2018-08-22 Thread Hrvoje Popovski
Hi all, in today's snapshot i see some strange dmesg cpu output. it feels like cosmetic stuff only but i'm not sure ... cpu1: Intel(R) Xeon(R) Gold 6134 CPU @ 3.20GHz, 3192.49 MHz cpu1:

Re: 6.3-current kernel panic: aml_die aml_parse:4194 on PowerEdge

2018-05-16 Thread Hrvoje Popovski
On 2.5.2018. 11:28, Jan Vlach wrote: > R440 WAS( Re: Dell PowerEdge R430/R440 support) > Reply-To: > In-Reply-To: <20180425150215.gh20...@diehard.n-r-g.com> > > Hello misc@ > > > the Dell PowerEdge R440 server arrived for testing and it panics on boot > to installed system. Installer works

Re: 6.3-current kernel panic: aml_die aml_parse:4194 on PowerEdge

2018-05-02 Thread Hrvoje Popovski
On 2.5.2018. 19:06, Mike Larkin wrote: > On Wed, May 02, 2018 at 06:51:51PM +0200, Jan Vlach wrote: >>> Last time I checked, we don't support LoadTable. >>> >>> -ml >>> >> >> Thank you Mike for your reply. I have no clue about ACPI. Is this a new >> way how vendors extend ACPI? Is there generally

acpidump and bsd.rd

2018-03-19 Thread Hrvoje Popovski
Hi all, does it make sense to add acpidump to bsd.rd ? I've tried to install snapshot on Dell R640 and installation went well but booting stops with this error: http://kosjenka.srce.hr/~hrvoje/zaprocvat/r640-01.jpg i also noticed this ahci2 log while booting

Re: VLAN configuration problem on 6.1 ("no route to host" on other than own IP)

2017-11-06 Thread Hrvoje Popovski
On 6.11.2017. 17:47, Andre Ruppert wrote: > Hello @misc, > > perhaps I'm stupid, but I don't see my fault in a vlan network > configuration: > > I got a OpenBSD 6.1 gateway box, connected to several switches. > > On em0 I habe to serve two networks: > 172.16.210.0  (direct em0 - no vlan) >

Re: ping -R causes panic

2017-10-01 Thread Hrvoje Popovski
On 20.9.2017. 23:29, Kapetanakis Giannis wrote: > On 20/09/17 19:25, Visa Hankala wrote: >> On Wed, Sep 20, 2017 at 02:26:56PM +0300, Kapetanakis Giannis wrote: >>> I got this panic today after ping -R >>> I don't run pfsync >>> >>> # ping -R www.google.com >>> panic: kernel diagnostic assertion

Re: SoC Intel Xeon D-1518 & D-1548

2017-09-10 Thread Hrvoje Popovski
On 10.9.2017. 0:46, Daniel Ouellet wrote: > Hi, > > Is there anyone that know of have one of the Intel Xeon D-1548 SoC that > works on OpenBSD? > > I know the D-1518 does, I find the DMESG in the archive, but I can't > find anything at all on the D-1548. > > Any clue. > > Here is the D-1518 >

Re: OpenBSD-based ISP

2017-08-17 Thread Hrvoje Popovski
them set skip on { lo bge1 vlan123 vlan124 } > On Thu, Aug 17, 2017 at 4:45 PM, Hrvoje Popovski <hrv...@srce.hr> wrote: > >> On 17.8.2017. 21:23, Juan Guillermo Narvaez wrote: >>> This is the dmesg.boot. >> >> nice box with nice cpu and inter

Re: OpenBSD-based ISP

2017-08-17 Thread Hrvoje Popovski
f you see some performance improvement? > On Thu, Aug 17, 2017 at 3:46 PM, Hrvoje Popovski <hrv...@srce.hr> wrote: > >> On 17.8.2017. 17:13, Chris Cappuccio wrote: >>> Juan Guillermo Narvaez [guille...@nrvz.net] wrote: >>>> # sysctl | grep ifq >>>

Re: OpenBSD-based ISP

2017-08-17 Thread Hrvoje Popovski
On 17.8.2017. 17:13, Chris Cappuccio wrote: > Juan Guillermo Narvaez [guille...@nrvz.net] wrote: >> # sysctl | grep ifq >> net.inet.ip.ifq.len=0 >> net.inet.ip.ifq.maxlen=1024 >> net.inet.ip.ifq.drops=46068291 >> net.inet6.ip6.ifq.len=0 >> net.inet6.ip6.ifq.maxlen=256 >> net.inet6.ip6.ifq.drops=0

Re: OpenBSD-based ISP

2017-08-16 Thread Hrvoje Popovski
On 16.8.2017. 19:55, Juan Guillermo Narvaez wrote: > Hello everyone! > > I'm relative new using OpenBSD, I have just 4 years using this OS for dhcp > servers. > Today I have the mission of implement this OS in a cablemodem headend, in > my first try I get negative results with this rules: > >

Re: Gbit performance parameters

2017-07-13 Thread Hrvoje Popovski
On 13.7.2017. 0:26, Per-Olov Sjöholm wrote: > I increased net.inet.ip.ifq.maxlen in steps of 256… I had to increase the > net.inet.ip.ifq.maxlen 9 times to 2309 for the net.inet.ip.ifq.drops to stop > increasing. At a maxlen of 2309 the drops stopped completley. But all values > of

Re: solidrun marvell macchiatobin

2017-05-31 Thread Hrvoje Popovski
On 31.5.2017. 23:17, Patrick Wildt wrote: > Are you following my Twitter or what? ;) I just posted a picture > of that board, arrived on the doorsteps today. I'll be having a > look. perfect box for MP firewall :)

solidrun marvell macchiatobin

2017-05-31 Thread Hrvoje Popovski
Hi arm gurus, does openbsd support solid-run marvell armada family boards? primary this little cute firewall :) https://www.solid-run.com/marvell-armada-family/armada-8040-community-board/ if there are any interest in this box i'm willing to donate it for development ..

ipsec.conf

2017-05-26 Thread Hrvoje Popovski
Hi all, i having ipsec.conf like this: ike esp from 10.200.136.0/21 to any \ local 10.64.135.246 peer 10.4.57.68 \ main auth hmac-sha1 enc aes group modp1024 \ quick auth hmac-sha1 enc aes group modp1024 \ psk b9278b3051cd17674305833971c22b11514eac51 and with

Re: isakmpd listen address

2017-05-25 Thread Hrvoje Popovski
On 25.5.2017. 20:46, mabi wrote: > Hello, > I can't seem to find an option in isakmpd in order to have it listen only on > one interface or IP address respectively. Is there an option for that I am > not aware of? I just saw the -p option but that's for the port number. > Thanks, > M. > Hi,

Van Jacobson network channels

2017-04-03 Thread Hrvoje Popovski
Hi all, i'm reading some networking stuff and I saw Van Jacobson presentation about net channels concept. For me, as user that doesn't know net internals, this presentation seems quite reasonable. Beside that it's about linux network stack, what net gurus think about VJ net channels ?

Re: splassert: yield message on 5 Feb snapshot (amd64)

2017-02-08 Thread Hrvoje Popovski
On 8.2.2017. 17:51, Scott Vanderbilt wrote: > Updated a machine to latest (5 Feb.) snapshot of amd64. I'm now seeing > the following message after booting that I've not recalled seeing before: > >splassert: yield: want 0 have 1 add sysctl kern.splassert=2 ...

Re: Kernel panic after upgrade -CURRENT

2017-01-28 Thread Hrvoje Popovski
On 29.1.2017. 4:13, kayasaman wrote: > Hi, > A very strange issue... > After the previous update of CURRENT I started to have issues with ftpproxy > not loading some directories, an example being shrubbery.net rancid directory. > Today I attempted an upgrade to see if that might kick things into

Re: Hardware recommendations for compact 1U firewall

2016-12-22 Thread Hrvoje Popovski
On 22.12.2016. 2:17, Predrag Punosevac wrote: > As promissed in one of my earlier e-mails. OpenBSD 6.0 dmesg for > SYS-5018A-FTN4 thank you ...

Re: Hardware recommendations for compact 1U firewall

2016-12-15 Thread Hrvoje Popovski
On 15.12.2016. 20:45, Bryan Vyhmeister wrote: > There is no support for Intel QAT (sometimes called Quick Assist) in > OpenBSD and that's not likely to change anytime soon. Some support is > supposedly coming to FreeBSD (by way of pfSense and some commerical > sponsorship or something) but I have

Re: Hardware recommendations for compact 1U firewall

2016-12-15 Thread Hrvoje Popovski
On 15.12.2016. 12:30, Stuart Henderson wrote: > If you want to cut down on weight+noise at the expense of more cost > and a less powerful cpu, maybe APU2 in a 1U case or something like > supermicro SYS-5018A-FTN4. has anyone dmesg from SYS-5018A-FTN4 box? i'm interesting in intel qat thank you

Re: Routing 10-40 Mpps on OpenBSD

2016-09-11 Thread Hrvoje Popovski
On 11.9.2016. 19:17, K wrote: > All, > > This message is a call for people who are interested to benchmark commodity > hardware with the goal of pushing as much PPS as possible through OpenBSD. > The initial target is to reach 10 Mpps at 64 bytes (or more precisely 84 > bytes with interpacket

Re: openbgpd blackhole community

2016-07-25 Thread Hrvoje Popovski
On 21.7.2016. 11:12, Claudio Jeker wrote: > Just use "community BLACKHOLE" instead of 65535:666 and it will work. > thank you guys

openbgpd blackhole community

2016-07-20 Thread Hrvoje Popovski
Hi all, here at CIX we want to implement BLACKHOLE based on https://tools.ietf.org/html/draft-ietf-grow-blackholing presentation https://www.ietf.org/proceedings/94/slides/slides-94-grow-1.pdf Recommendation is to have Blackhole BGP Community: 65535:666, but when configure that community i'm

Re: Xeon-D 10GE nics

2016-06-06 Thread Hrvoje Popovski
On 14.4.2016. 9:29, Jonathan Gray wrote: > On Tue, Apr 12, 2016 at 01:15:49PM +, Stuart Henderson wrote: >> Does anyone know if the 10GE NICs on Xeon-D SoCs work on OpenBSD yet? >> e.g. "Dual 10G SFP+ from D-1500 SoC" on Supermicro SYS-5018D-FN8T. >> > > The windows driver has: > > 0x10a6

Re: Xeon-D 10GE nics

2016-05-04 Thread Hrvoje Popovski
On 12.4.2016. 15:15, Stuart Henderson wrote: > Does anyone know if the 10GE NICs on Xeon-D SoCs work on OpenBSD yet? > e.g. "Dual 10G SFP+ from D-1500 SoC" on Supermicro SYS-5018D-FN8T. > Hi, dmesg for https://www.supermicro.nl/products/motherboard/Xeon/D/X10SDV-TP8F.cfm OpenBSD 5.9-current

Re: recommendations for 10GBase Ethernet on OpenBSD

2016-04-08 Thread Hrvoje Popovski
On 8.4.2016. 16:22, Steiner Peter wrote: > hello, > > i'm looking for recommendations for 10GBase SFP+ network adapters, > anyone has experience with 10G Ethernet on OpenBSD? > > i found dual SFP+ PCIe devices with the following drivers: > ix - Intel 82598/82599/X540 PCI Express 10Gb Ethernet

kernel compile error

2015-12-28 Thread Hrvoje Popovski
Hi, after fetching source from cvs at 23:40 CET i'm getting this error whilte comliling kernel. cc -Werror -Wall -Wimplicit-function-declaration -Wno-main -Wno-uninitialized -Wframe-larger-than=2047 -mcmode l=kernel -mno-red-zone -mno-sse2 -mno-sse -mno-3dnow -mno-mmx -msoft-float

Re: kernel compile error

2015-12-28 Thread Hrvoje Popovski
On 28.12.2015. 23:44, Hrvoje Popovski wrote: > Hi, > > after fetching source from cvs at 23:40 CET i'm getting this error > whilte comliling kernel. > > > > cc -Werror -Wall -Wimplicit-function-declaration -Wno-main > -Wno-uninitialized -Wframe-larger-than=2047

unlocking em - unable to fill any rx descriptors

2015-10-07 Thread Hrvoje Popovski
Hi all, i have fairly simple setup with receiver connected to em2 and sender connected to em3. Both em are Intel I350. Setup is without pf with these sysctls: kern.pool_debug=1 net.inet.ip.forwarding=1 net.inet.ip.ifq.maxlen=8192 ddb.console=1 with if_em.c revisions 1.307 and 1.306 i can

kernel compile error

2015-09-11 Thread Hrvoje Popovski
cvs update from half an hour ago ... log: cc -Werror -Wall -Wimplicit-function-declaration -Wno-main -Wno-uninitialized -Wframe-larger-than=2047 -mcmodel=kernel -mno-red-zone -mno-sse2 -mno-sse -mno-3dnow -mno-mmx -msoft-float -fno-omit-frame-pointer -fno-builtin-printf -fno-builtin-snprintf

Re: kernel compile error

2015-09-11 Thread Hrvoje Popovski
On 11.9.2015. 12:11, Paul de Weerd wrote: > Did you update config(8) before building? > > http://www.openbsd.org/faq/current.html#20150911 > > Cheers, > > Paul 'WEiRD' de Weerd > yes, yes ... thank you ... now it's compile perfectly > On Fri, Sep 11, 2015

Re: netstat statistics bridge interface

2015-08-27 Thread Hrvoje Popovski
On 27.8.2015. 2:06, Hrvoje Popovski wrote: Hi all, i have configured bridge interface with em2 and em3. Generator is connected on em3 and receiver is connected on em2. I'm generating 1,48Mpps on em3 and getting around 400kpps on box connected to em2 and that is fine but counters

netstat statistics bridge interface

2015-08-26 Thread Hrvoje Popovski
Hi all, i have configured bridge interface with em2 and em3. Generator is connected on em3 and receiver is connected on em2. I'm generating 1,48Mpps on em3 and getting around 400kpps on box connected to em2 and that is fine but counters in netstat seems doubled on total in packets and total out

Re: Possible fix for i217 problem

2015-08-04 Thread Hrvoje Popovski
On 4.8.2015. 23:47, Stuart Henderson wrote: On 2015/08/04 22:40, Stefan Fritsch wrote: someone mentioned to me the i217-LM problems that were reported on misc end of May. It is possible that the patch below helps. This fixes my Dell poweredge T20: em0 at pci0 dev 25 function 0 Intel

Re: Intel C61X / C22X Chipset Support

2015-07-31 Thread Hrvoje Popovski
On 31.7.2015. 19:42, Joe Crivello wrote: Awesome! Thanks so much. So C22X gets detected as an Intel 8 series chipset then (which makes sense). We are initially thinking about using a couple of Super Micro 5018D-MR servers with Intel X520 cards as routers, so the lack of onboard Ethernet

Re: Dell FX2 or Huawei E9000 dmesg(s), anyone?

2015-07-17 Thread Hrvoje Popovski
On 16.7.2015. 1:46, Hrvoje Popovski wrote: On 13.7.2015. 7:52, OpenBSD user wrote: Would anyone care to share amd64 dmesg(s) from Dell FX2 or Huawei E9000? Would be truly grateful! next week i will get access to dell fc630. i'm quite sure that fc630 have dual port QLogic 577xx/578xx 10

Re: Dell FX2 or Huawei E9000 dmesg(s), anyone?

2015-07-15 Thread Hrvoje Popovski
On 13.7.2015. 7:52, OpenBSD user wrote: Would anyone care to share amd64 dmesg(s) from Dell FX2 or Huawei E9000? Would be truly grateful! next week i will get access to dell fc630. i'm quite sure that fc630 have dual port QLogic 577xx/578xx 10 GbE BCM57810 card which is not supported in

Re: ix(4) X710-DA4

2015-06-12 Thread Hrvoje Popovski
On 19.2.2015. 13:08, Jonathan Gray wrote: On Thu, Feb 19, 2015 at 10:11:36AM +0200, Or Elimelech wrote: Hi, I???m purchasing 2 new firewalls and I wonder if the ix(4) driver supports X710-DA4 Have anyone tried this in production? Thanks Someone needs to port Intel's ixl/i40e driver

Re: netstat doubles packet count on output

2015-05-20 Thread Hrvoje Popovski
On 20.5.2015. 10:30, Martin Pieuchot wrote: On 19/05/15(Tue) 22:14, Hrvoje Popovski wrote: Hi all, today i have update test box from cvs and it seems that netstat doubles packet count on output. anyone else sees the same thing? Yep, I introduced a regression during the if_output

netstat doubles packet count on output

2015-05-19 Thread Hrvoje Popovski
Hi all, today i have update test box from cvs and it seems that netstat doubles packet count on output. anyone else sees the same thing? pf disabled box on ix1 generate traffic box on ix0 receive same amount of traffic as in total in packets kern.pool_debug=0 net.inet.ip.forwarding=1

Re: OpenBGPd Route Server

2015-04-15 Thread Hrvoje Popovski
On 15.4.2015. 19:45, Mike Hammett wrote: What do you have $my_ip4_net and $my_ip6_net set to? I assume the IPv4 and IPv6 blocks that the IX is using? yes, that's IX network..

Re: OpenBGPd Route Server

2015-04-15 Thread Hrvoje Popovski
On 15.4.2015. 5:23, Mike Hammett wrote: With the decline of OpenBGPd's popularity among IXPs, it's difficult to track down examples of how IXPs are configuring their servers. I saw a couple presentations in the 2010 - 2011 timeframe with new things that were coming for 32 bit communities

Re: Dell R630 with PERC H730

2015-03-26 Thread Hrvoje Popovski
On 26.3.2015. 11:40, Or Elimelech wrote: Hello Misc I am trying to install OpenBSD 5.6 on the above machine. 1. While using Lifecycle controller and deploy OS I get weird disk layout with MSDos partition which cannot be removed. 2. While trying to init the raid myself through the raid

Re: Dell R630 with PERC H730

2015-03-26 Thread Hrvoje Popovski
On 26.3.2015. 12:40, Or Elimelech wrote: Is this for sure will solve the problem? Is it a known issue? well, dell r630 is really new hardware and there was few issues with h330 and h730 at the beginning of 2015 you could try current just to see will you be able to install openbsd on

Re: Trying to restart pppoe0: Device busy

2015-02-08 Thread Hrvoje Popovski
On 8.2.2015. 22:17, Maximilian Pichler wrote: Hi, I'm trying to restart the pppoe0 interface, so as to renegotiate a new connection to the ISP, but am getting the following error. $ sudo sh /etc/netstart pppoe0 ifconfig: SIOCSSARAMS(SPPPIOSXAUTH): Device busy route: writing to

Re: sudo nohup tcpdump at startup

2015-02-04 Thread Hrvoje Popovski
On 3.2.2015. 5:16, Ted Unangst wrote: fRANz wrote: On Thu, Jan 29, 2015 at 10:54 PM, Christopher Barry christopher.r.ba...@gmail.com wrote: what happens if you source /etc/rc.local instead? as in: [ -f /etc/rc.local ] . /etc/rc.local Hi Christopher, I'm sorry, same behaviour: some

Re: sudo nohup tcpdump at startup

2015-02-04 Thread Hrvoje Popovski
On 4.2.2015. 15:13, Todd C. Miller wrote: On Wed, 04 Feb 2015 15:06:41 +0100, Hrvoje Popovski wrote: is there any problem to just put this in crontab? @reboot /usr/sbin/tcpdump -lnqttti pflog0 2 error.log | /usr/bin/logger -t pf -p local2.info You should not try to run the command

Dell R630 freezes

2014-12-23 Thread Hrvoje Popovski
Hi all, I have Dell R630 with PERC H330 RAID controller and 2 LITEON IT ECT-60 SSD disks. When doing make build, box freezes almost any time. With kern.bufcachepercent=80 make build finishes but then sometimes i can't reboot it from ssh, only reset it from idrac console. Same problem can be

Re: Dell R630 high interrupts on acpi0

2014-12-19 Thread Hrvoje Popovski
On 17.12.2014. 6:34, Philip Guenther wrote: Uh, ACPI *requires* that C1 exist. The halt instruction is defined as entering C1, so not having C1 would mean your CPU lacks a basic manadatory ia32 instruction. Hopefully the BIOS docs explain that you're just disabling deep C-states or something

Re: Dell R630 high interrupts on acpi0

2014-12-16 Thread Hrvoje Popovski
On 16.12.2014. 6:16, Jonathan Matthew wrote: On Sun, Dec 14, 2014 at 06:22:37PM +0100, Hrvoje Popovski wrote: Hi all, I have got two new Dell R630 and have current on them from Sun Dec 14 15:07:17. Installation went great and very fast. The problem is that I see around 11k interrupts on acpi0

Re: Dell R630 high interrupts on acpi0

2014-12-16 Thread Hrvoje Popovski
On 16.12.2014. 6:16, Jonathan Matthew wrote: We just got some r630s too, so I spent some time last week figuring out what's going on here. Something in the AML wants to talk to the intel MEI device. Normally this works, but on the new generation of dell machines (we've seen it on r630s and

  1   2   >