Re: [PATCH] atmodem/sim: added vendor Gemalto

2018-09-24 Thread Giacinto Cifelli
Hi Denis But still, can we strive for self-contained change sets? Just take out > VENDOR_CINTERION use inside the sim driver and change over to > VENDOR_GEMALTO for any modem drivers that need it. That makes things > much easier to follow compared to doing only the sim driver changes now > and

Re: [PATCH] atmodem/sim: added vendor Gemalto

2018-09-24 Thread Denis Kenzior
Hi Giacinto, It is not taken out. It is:        case OFONO_VENDOR_CINTERION:        case OFONO_VENDOR_GEMALTO:                if (g_at_chat_send(sd->chat, "AT^SPIC", gemalto_spic_prefix,                                        gemalto_spic_cb, cbd, g_free) > 0) both are there, and the

Re: [PATCH] atmodem/sim: added vendor Gemalto

2018-09-24 Thread Denis Kenzior
Hi Giacinto, But the VENDOR_CINTERION remains in the code, there are no changes for the plugin. That's exactly the point. You have taken out all VENDOR_CINTERION logic, yet plugins/gemalto.c still sets VENDOR_CINTERION for the sim atom. So now you broke that driver. Your change set is

Re: [PATCH] location-reporting.h: driver properties handling

2018-09-24 Thread Giacinto Cifelli
Hi Denis, On Mon, Sep 24, 2018 at 11:07 PM Denis Kenzior wrote: > Hi Giacinto, > > On 09/23/2018 01:19 AM, Giacinto Cifelli wrote: > > The GNSS receiver configuration is highly proprietary. > > Some are configured through the GNSS port itself, some through other > > ports. The properties

Re: [PATCH 1/2] gemaltomodem: added Gemalto-specific gprs-context atom....

2018-09-24 Thread Giacinto Cifelli
Hi Denis, On Mon, Sep 24, 2018 at 10:50 PM Denis Kenzior wrote: > Hi Giacinto, > > > So until the GPRS_AUTH_METHOD_NONE is actually introduced, you might > > want to just get this upstream with the existing enumeration. E.g. > > just > > assume that if username & password is

[PATCH 3/3] sim800: adding documentation and updating AUTHORS

2018-09-24 Thread Clement Viel
From: clem --- AUTHORS | 1 + doc/sim800-modem.txt | 7 +++ 2 files changed, 8 insertions(+) create mode 100644 doc/sim800-modem.txt diff --git a/AUTHORS b/AUTHORS index 52f46e9..c5fa295 100644 --- a/AUTHORS +++ b/AUTHORS @@ -137,3 +137,4 @@ Varun Gargi Florent Beillonnet

[PATCH 1/3] sim800: adding support for SimCom SIM800 modem

2018-09-24 Thread Clement Viel
From: clem --- Makefile.am | 4 + plugins/sim800.c | 463 +++ 2 files changed, 467 insertions(+) create mode 100644 plugins/sim800.c diff --git a/Makefile.am b/Makefile.am index 6dee4ce..f4d03b6 100644 --- a/Makefile.am +++

Re: commit d37c22be20c83cf370638a9bad243bc5219c5509

2018-09-24 Thread Denis Kenzior
Hi Giacinto, Besides, several modules use the option linux driver, which blocks in case the port doesn't answer. This single call: g_at_chat_unref(port); blocks either 30s or 1 minute, depending on the system. I might step into it twice during my hardware initialization for several 3G models.

Re: MBIM IP configuration

2018-09-24 Thread Denis Kenzior
Hi Giacinto, On 09/24/2018 12:45 AM, Giacinto Cifelli wrote: Dear all, I have stepped into a very slow networks, that takes almost 1 minute to assign an IP address once the MBIM CONNECT DONE is returned. Under these conditions, the call to IP_CONFIGURATION returns all empty values, and the

Re: [PATCH] location-reporting.h: driver properties handling

2018-09-24 Thread Denis Kenzior
Hi Giacinto, On 09/23/2018 01:19 AM, Giacinto Cifelli wrote: The GNSS receiver configuration is highly proprietary. Some are configured through the GNSS port itself, some through other ports. The properties themselves vary among the manufacturers, with no standard available. Besides, ofono

Re: [PATCH] atmodem/sms: added vendor Gemalto support.

2018-09-24 Thread Denis Kenzior
On 09/23/2018 12:31 AM, Giacinto Cifelli wrote: Cinterion and Gemalto overlap for now, but eventually Cinterion will be removed. Yes, but some explanation of why CMMS is being taken out for gemalto (but not cinterion?) devices might be nice. --- drivers/atmodem/sms.c | 18

Re: [PATCH] atmodem/sim: added vendor Gemalto

2018-09-24 Thread Denis Kenzior
Hi Giacinto, On 09/23/2018 12:28 AM, Giacinto Cifelli wrote: also renamed the cinterion_* functions in gemalto_*. Eventually, the vendor cinterion will be removed. --- drivers/atmodem/sim.c | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) This is all great and all, but where

Re: [PATCH] atmodem/cbs: added Gemalto vendor

2018-09-24 Thread Denis Kenzior
Hi Giacinto, On 09/23/2018 12:26 AM, Giacinto Cifelli wrote: --- drivers/atmodem/cbs.c | 1 + 1 file changed, 1 insertion(+) Applied, thanks. Regards, -Denis ___ ofono mailing list ofono@ofono.org https://lists.ofono.org/mailman/listinfo/ofono

Re: [PATCH] lte.h: added ofono_lte_get_modem global function

2018-09-24 Thread Denis Kenzior
Hi Giacinto, On 09/22/2018 11:41 PM, Giacinto Cifelli wrote: this function can be used in the drivers to query the functions ofono_modem_get_* to retrieve modem-specific properties --- include/lte.h | 2 ++ 1 file changed, 2 insertions(+) Both applied after tweaking the commit

Re: [PATCH 1/2] gemaltomodem: added Gemalto-specific gprs-context atom....

2018-09-24 Thread Denis Kenzior
Hi Giacinto, So until the GPRS_AUTH_METHOD_NONE is actually introduced, you might want to just get this upstream with the existing enumeration.  E.g. just assume that if username & password is empty, the auth method is none. I have pushed the new method NONE again, and I

Re: [PATCH] src/lte.c: clarified failed registration message

2018-09-24 Thread Denis Kenzior
Hi Giacinto, On 09/22/2018 04:49 AM, Giacinto Cifelli wrote: --- src/lte.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) Applied, thanks. Regards, -Denis ___ ofono mailing list ofono@ofono.org

Re: commit d37c22be20c83cf370638a9bad243bc5219c5509

2018-09-24 Thread Marcel Holtmann
Hi Giacinto, > > was it necessary to remove entirely the NEED_THREADS flag? > > > > I was going to use it in the Gemalto driver, to speed up the device > > recognition, because for some modules it is hit and miss. > > But only as an optional feature, because in some systems it might be > >