Re: [OMPI packagers] Open MPI v5.0 packaging change: require pandoc

2020-04-14 Thread Marco Atzeri

Am 14.04.2020 um 21:35 schrieb Marco Atzeri:

Am 14.04.2020 um 20:22 schrieb Jeff Squyres (jsquyres) via ompi-packagers:
On Apr 14, 2020, at 12:23 PM, Marco Atzeri  
wrote:



Open MPI packagers --
We would like to require "pandoc" for building Open MPI >=v5.0.x 
from a git clone, at least version v1.12.

Is this ok with all of you?


give me time to try build it.

Currently is not available on cygwin



Ok.  It may be a little annoying, because it is written in Haskell, so 
you have to also have the GNU Haskell compiler.




that also is missing on cygwin.

Let me see if I can come with something usable, but is seems on
the complex side.

Regards
Marco


very complex
https://www.joachim-breitner.de/blog/748-Thoughts_on_bootstrapping_GHC

It is one of the cases where a new system will be almost impossible to 
bootstrap. I saw something similar in GO build system


so for me Pandoc seems a no go.

Regards
Marco

___
ompi-packagers mailing list
ompi-packagers@lists.open-mpi.org
https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers


Re: [OMPI packagers] Open MPI v5.0 packaging change: require pandoc

2020-04-14 Thread Marco Atzeri

Am 14.04.2020 um 20:22 schrieb Jeff Squyres (jsquyres) via ompi-packagers:

On Apr 14, 2020, at 12:23 PM, Marco Atzeri  wrote:



Open MPI packagers --
We would like to require "pandoc" for building Open MPI >=v5.0.x from a git 
clone, at least version v1.12.
Is this ok with all of you?


give me time to try build it.

Currently is not available on cygwin



Ok.  It may be a little annoying, because it is written in Haskell, so you have 
to also have the GNU Haskell compiler.



that also is missing on cygwin.

Let me see if I can come with something usable, but is seems on
the complex side.

Regards
Marco
___
ompi-packagers mailing list
ompi-packagers@lists.open-mpi.org
https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers


Re: [OMPI packagers] Open MPI v5.0 packaging change: require pandoc

2020-04-14 Thread Marco Atzeri

Am 14.04.2020 um 18:02 schrieb Jeff Squyres (jsquyres) via ompi-packagers:

Open MPI packagers --

We would like to require "pandoc" for building Open MPI >=v5.0.x from a git 
clone, at least version v1.12.

Is this ok with all of you?



give me time to try build it.

Currently is not available on cygwin

Regards
Marco
___
ompi-packagers mailing list
ompi-packagers@lists.open-mpi.org
https://rfd.newmexicoconsortium.org/mailman/listinfo/ompi-packagers