commit python3-aiohttp for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python3-aiohttp for openSUSE:Factory 
checked in at 2016-08-03 11:44:59

Comparing /work/SRC/openSUSE:Factory/python3-aiohttp (Old)
 and  /work/SRC/openSUSE:Factory/.python3-aiohttp.new (New)


Package is "python3-aiohttp"

Changes:

--- /work/SRC/openSUSE:Factory/python3-aiohttp/python3-aiohttp.changes  
2016-07-28 23:46:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-aiohttp.new/python3-aiohttp.changes 
2016-08-03 11:45:15.0 +0200
@@ -1,0 +2,11 @@
+Fri Jul 29 06:03:55 UTC 2016 - a...@gmx.de
+
+
+- update to version 0.22.4:
+  * Update CONTRIBUTORS
+  * Pin multidict dependecy < 2.0.0
+
+- changes from version 0.22.3:
+  * Do not filter cookies if unsafe flag provided #1005
+
+---

Old:

  aiohttp-0.22.2.tar.gz

New:

  aiohttp-0.22.4.tar.gz



Other differences:
--
++ python3-aiohttp.spec ++
--- /var/tmp/diff_new_pack.eOeLPr/_old  2016-08-03 11:45:16.0 +0200
+++ /var/tmp/diff_new_pack.eOeLPr/_new  2016-08-03 11:45:16.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python3-aiohttp
-Version:0.22.2
+Version:0.22.4
 Release:0
 Url:https://pypi.python.org/pypi/aiohttp
 Summary:Http client/server for asyncio

++ aiohttp-0.22.2.tar.gz -> aiohttp-0.22.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aiohttp-0.22.2/CHANGES.txt 
new/aiohttp-0.22.4/CHANGES.txt
--- old/aiohttp-0.22.2/CHANGES.txt  2016-07-23 15:31:40.0 +0200
+++ new/aiohttp-0.22.4/CHANGES.txt  2016-07-28 13:32:21.0 +0200
@@ -1,6 +1,12 @@
 CHANGES
 ===
 
+0.22.3 (07-26-2016)
+---
+
+- Do not filter cookies if unsafe flag provided #1005
+
+
 0.22.2 (07-23-2016)
 ---
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aiohttp-0.22.2/CONTRIBUTORS.txt 
new/aiohttp-0.22.4/CONTRIBUTORS.txt
--- old/aiohttp-0.22.2/CONTRIBUTORS.txt 2016-07-23 15:31:40.0 +0200
+++ new/aiohttp-0.22.4/CONTRIBUTORS.txt 2016-07-28 13:32:21.0 +0200
@@ -70,6 +70,7 @@
 Matthieu Hauglustaine
 Michael Ihnatenko
 Mikhail Lukyanchenko
+Misha Behersky
 Morgan Delahaye-Prat
 Moss Collum
 Nicolas Braem
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aiohttp-0.22.2/PKG-INFO new/aiohttp-0.22.4/PKG-INFO
--- old/aiohttp-0.22.2/PKG-INFO 2016-07-23 15:33:07.0 +0200
+++ new/aiohttp-0.22.4/PKG-INFO 2016-07-28 13:33:50.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: aiohttp
-Version: 0.22.2
+Version: 0.22.4
 Summary: http client/server for asyncio
 Home-page: https://github.com/KeepSafe/aiohttp/
 Author: Andrew Svetlov
@@ -150,6 +150,12 @@
 CHANGES
 ===
 
+0.22.3 (07-26-2016)
+---
+
+- Do not filter cookies if unsafe flag provided #1005
+
+
 0.22.2 (07-23-2016)
 ---
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aiohttp-0.22.2/aiohttp/__init__.py 
new/aiohttp-0.22.4/aiohttp/__init__.py
--- old/aiohttp-0.22.2/aiohttp/__init__.py  2016-07-23 15:31:40.0 
+0200
+++ new/aiohttp-0.22.4/aiohttp/__init__.py  2016-07-28 13:32:21.0 
+0200
@@ -1,9 +1,10 @@
-# This relies on each of the submodules having an __all__ variable.
-
-__version__ = '0.22.2'
+__version__ = '0.22.4'
 
+# Deprecated, keep it here for a while for backward compatibility.
 import multidict  # noqa
 
+# This relies on each of the submodules having an __all__ variable.
+
 from multidict import *  # noqa
 from . import hdrs  # noqa
 from .protocol import *  # noqa
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aiohttp-0.22.2/aiohttp/helpers.py 
new/aiohttp-0.22.4/aiohttp/helpers.py
--- old/aiohttp-0.22.2/aiohttp/helpers.py   2016-07-23 15:31:40.0 
+0200
+++ new/aiohttp-0.22.4/aiohttp/helpers.py   2016-07-28 13:32:21.0 
+0200
@@ -701,7 +701,7 @@
 
 hostname = url_parsed.hostname or ""
 
-if is_ip_address(hostname):
+if not self._unsafe and is_ip_address(hostname):
 continue
 
 if name in self._host_only_cookies:
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/aiohttp-0.22.2/aiohttp.egg-info/PKG-INFO 
new/aiohttp-0.22.4/aiohttp.egg-info/PKG-INFO
--- old/aiohttp-0.22.2/aiohttp.egg-info/PKG-INFO2016-07-23 
15:33:06.0 +0200
+++ 

commit python-paramiko for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python-paramiko for openSUSE:Factory 
checked in at 2016-08-03 11:45:11

Comparing /work/SRC/openSUSE:Factory/python-paramiko (Old)
 and  /work/SRC/openSUSE:Factory/.python-paramiko.new (New)


Package is "python-paramiko"

Changes:

--- /work/SRC/openSUSE:Factory/python-paramiko/python-paramiko.changes  
2016-07-14 09:46:21.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-paramiko.new/python-paramiko.changes 
2016-08-03 11:45:21.0 +0200
@@ -1,0 +2,29 @@
+Sun Jul 31 12:15:25 UTC 2016 - mich...@stroeder.com
+
+- update to 2.0.2
+  * [Bug] #758: Apply type definitions to _winapi module from 
+jaraco.windows 3.6.1. This should address issues on Windows platforms 
+that often result in errors like ArgumentError: [...] int too long to 
+convert. Thanks to @swohlerLL for the report and Jason R. Coombs for the 
+patch.
+  * [Bug] #774: Add a _closed private attribute to Channel objects so that 
+they continue functioning when used as proxy sockets under Python 3 (e.g. 
+as direct-tcpip gateways for other Paramiko connections.)
+  * [Bug] #673: (via #681) Fix protocol banner read errors (SSHException) 
+which would occasionally pop up when using ProxyCommand gatewaying. 
+Thanks to @Depado for the initial report and Paul Kapp for the fix.
+
+---
+Sat Jul 23 14:20:34 UTC 2016 - mich...@stroeder.com
+
+- updated homepage URL
+- update to 2.0.1:
+  * [Bug] #537: Fix a bug in BufferedPipe.set_event which could cause 
+deadlocks/hangs when one uses select.select against Channel objects (or 
+otherwise calls Channel.fileno after the channel has closed).
+  * [Bug] #520: (Partial fix) Fix at least one instance of race condition 
+driven threading hangs at end of the Python interpreter session. 
+(Includes a docs update as well - always make sure to .close() your 
+clients!)
+
+---

Old:

  paramiko-2.0.0.tar.gz

New:

  paramiko-2.0.2.tar.gz



Other differences:
--
++ python-paramiko.spec ++
--- /var/tmp/diff_new_pack.wJhlNg/_old  2016-08-03 11:45:23.0 +0200
+++ /var/tmp/diff_new_pack.wJhlNg/_new  2016-08-03 11:45:23.0 +0200
@@ -17,9 +17,9 @@
 
 
 Name:   python-paramiko
-Version:2.0.0
+Version:2.0.2
 Release:0
-Url:https://github.com/paramiko/paramiko/
+Url:http://www.paramiko.org/
 Summary:SSH2 protocol library
 License:LGPL-2.1+
 Group:  Development/Languages/Python

++ paramiko-2.0.0.tar.gz -> paramiko-2.0.2.tar.gz ++
 5070 lines of diff (skipped)




commit pspp for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package pspp for openSUSE:Factory checked in 
at 2016-08-03 11:45:24

Comparing /work/SRC/openSUSE:Factory/pspp (Old)
 and  /work/SRC/openSUSE:Factory/.pspp.new (New)


Package is "pspp"

Changes:

--- /work/SRC/openSUSE:Factory/pspp/pspp.changes2016-04-05 
10:44:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.pspp.new/pspp.changes   2016-08-03 
11:45:37.0 +0200
@@ -1,0 +2,21 @@
+Wed Aug  3 05:45:21 UTC 2016 - opensuse.lietuviu.ka...@gmail.com
+
+- Update to 0.10.2:
+ * CROSSTABS implements a new COUNT subcommand to round case or cell
+   weights.
+ * Help will be opened as HTML in default browser if yelp
+   is not available.
+ * When plotting scatterplots with only one dataset (the simple case)
+   the colour used for the dataset is now black. The previous default
+   from the Tango palette was too faint to see easily.
+ * The varible info dialog could previously only paste a single variable.
+   Now it can paste multiple variables.
+ * Bug fixes, including the following:
+   - T-test with independent samples GUI crashed with string
+ type variable as group variable.
+   - The variable info dialog showed the previous selected variable
+ superimposed with the currently selected one.
+   - The GLM command did not properly deal with missing values. This
+ has been fixed.
+
+---

Old:

  pspp-0.10.1.tar.gz

New:

  pspp-0.10.2.tar.gz



Other differences:
--
++ pspp.spec ++
--- /var/tmp/diff_new_pack.XyX4YQ/_old  2016-08-03 11:45:38.0 +0200
+++ /var/tmp/diff_new_pack.XyX4YQ/_new  2016-08-03 11:45:38.0 +0200
@@ -1,4 +1,4 @@
-# spec file for PSPP 0.10.1
+# spec file for PSPP 0.10.2
 
 # Copyright (c) 2008 Matj Cepl 
 # Copyright (c) 2008 D. Steuer 
@@ -27,14 +27,14 @@
 %endif
 
 Name:   pspp
-Version:0.10.1
+Version:0.10.2
 Release:0
 Summary:A program for statistical analysis of sampled data
  
 Group:  Productivity/Scientific/Math
 License:GPL-3.0+
 URL:http://www.gnu.org/software/pspp/
-Source0:ftp://ftp.gnu.org/pub/gnu/pspp/pspp-0.10.1.tar.gz
+Source0:ftp://ftp.gnu.org/pub/gnu/pspp/pspp-0.10.2.tar.gz
 #ftp://ftp.gnu.org/pub/gnu/pspp/pspp-{version}.tar.gz
 
 BuildRoot:  %{_tmppath}/pspp-root

++ pspp-0.10.1.tar.gz -> pspp-0.10.2.tar.gz ++
/work/SRC/openSUSE:Factory/pspp/pspp-0.10.1.tar.gz 
/work/SRC/openSUSE:Factory/.pspp.new/pspp-0.10.2.tar.gz differ: char 5, line 1




commit docker-bench-security for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package docker-bench-security for 
openSUSE:Factory checked in at 2016-08-03 11:45:09

Comparing /work/SRC/openSUSE:Factory/docker-bench-security (Old)
 and  /work/SRC/openSUSE:Factory/.docker-bench-security.new (New)


Package is "docker-bench-security"

Changes:

--- 
/work/SRC/openSUSE:Factory/docker-bench-security/docker-bench-security.changes  
2016-06-07 23:50:07.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.docker-bench-security.new/docker-bench-security.changes
 2016-08-03 11:45:20.0 +0200
@@ -1,0 +2,8 @@
+Mon Aug  1 12:41:58 UTC 2016 - astie...@suse.com
+
+- Docker Bench for Security v1.1.0:
+  * check for docker 1.12.0
+  * fix early-docker use
+  * mention adjusting volumes
+
+---

Old:

  docker-bench-security-1.0.0~git20160602.zip

New:

  docker-bench-security-1.0.0~git20160729.zip



Other differences:
--
++ docker-bench-security.spec ++
--- /var/tmp/diff_new_pack.tOC8BG/_old  2016-08-03 11:45:21.0 +0200
+++ /var/tmp/diff_new_pack.tOC8BG/_new  2016-08-03 11:45:21.0 +0200
@@ -16,9 +16,9 @@
 #
 
 
-%define commit 4522adb3b28a11d887f1b7ef58d7bd6d61abebca
+%define commit 696d3f2a772d4987adcb5ccf7121db21fb18ac59
 Name:   docker-bench-security
-Version:1.0.0~git20160602
+Version:1.0.0~git20160729
 Release:0
 Summary:Docker Bench for Security
 License:Apache-2.0




commit antlr3c for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package antlr3c for openSUSE:Factory checked 
in at 2016-08-03 11:45:02

Comparing /work/SRC/openSUSE:Factory/antlr3c (Old)
 and  /work/SRC/openSUSE:Factory/.antlr3c.new (New)


Package is "antlr3c"

Changes:

--- /work/SRC/openSUSE:Factory/antlr3c/antlr3c.changes  2016-02-09 
13:33:03.0 +0100
+++ /work/SRC/openSUSE:Factory/.antlr3c.new/antlr3c.changes 2016-08-03 
11:45:17.0 +0200
@@ -1,0 +2,10 @@
+Thu Jun 16 07:23:25 UTC 2016 - jsl...@suse.com
+
+- port patches from home:jirislaby:statica
+  * add baselibs.conf to have 32bit libs too
+  * add fix-LIST-memory-leak.patch
+  * add fix-hash-double-free.patch
+- use standard library versioning. We do not obsolete the old
+  libraries as they are removed via weakremovers.
+
+---

New:

  baselibs.conf
  fix-LIST-memory-leak.patch
  fix-hash-double-free.patch



Other differences:
--
++ antlr3c.spec ++
--- /var/tmp/diff_new_pack.6v16An/_old  2016-08-03 11:45:18.0 +0200
+++ /var/tmp/diff_new_pack.6v16An/_new  2016-08-03 11:45:18.0 +0200
@@ -17,7 +17,7 @@
 #
 
 
-%define soname libantlr3c-3_4
+%define soname libantlr3c3
 Name:   antlr3c
 Version:3.4
 Release:0
@@ -26,8 +26,11 @@
 Group:  Development/Libraries/C and C++
 Url:http://www.antlr3.org/
 Source: http://www.antlr3.org/download/C/lib%{name}-%{version}.tar.gz
+Source1:baselibs.conf
+Patch0: fix-LIST-memory-leak.patch
 Patch1: antlr-64bit.diff
 Patch2: antlr-libversion.diff
+Patch3: fix-hash-double-free.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  gcc
@@ -45,9 +48,6 @@
 %package -n %{soname}
 Summary:C runtime for the ANTLR parsing library
 Group:  System/Libraries
-# From 13.3/TW201501 onwards
-Obsoletes:  libantlr3c3_4 < %{version}
-Provides:   libantlr3c3_4 = %{version}
 
 %description -n %{soname}
 ANTLR, ANother Tool for Language Recognition, is a language tool that provides 
a
@@ -73,8 +73,10 @@
 
 %prep
 %setup -q -n lib%{name}-%{version}
+%patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 autoreconf -fiv
@@ -91,7 +93,7 @@
 
 %files -n %{soname}
 %defattr(-,root,root)
-%{_libdir}/libantlr3c-%{version}.so
+%{_libdir}/libantlr3c.so.*
 
 %files devel
 %defattr(-,root,root,-)

++ antlr-libversion.diff ++
--- /var/tmp/diff_new_pack.6v16An/_old  2016-08-03 11:45:18.0 +0200
+++ /var/tmp/diff_new_pack.6v16An/_new  2016-08-03 11:45:18.0 +0200
@@ -4,19 +4,29 @@
 "-avoid-version" does not count for compatibility guarantees.
 Use one of -version-info, -release or -Wl,--version-script!
 ---
- Makefile.am |2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+ Makefile.am  |2 +-
+ configure.ac |2 ++
+ 2 files changed, 3 insertions(+), 1 deletion(-)
 
-Index: libantlr3c-3.4/Makefile.am
-===
 libantlr3c-3.4.orig/Makefile.am
-+++ libantlr3c-3.4/Makefile.am
+--- a/Makefile.am
 b/Makefile.am
 @@ -62,7 +62,7 @@ include_HEADERS =include/antlr3.h
include/antlr3treeparser.h  
\
antlr3config.h
  
 -libantlr3c_la_LDFLAGS = -avoid-version
-+libantlr3c_la_LDFLAGS = -release ${PACKAGE_VERSION}
++libantlr3c_la_LDFLAGS = -version-info @LIB_VERSION@
  
  INCLUDES = -Iinclude
  
+--- a/configure.ac
 b/configure.ac
+@@ -34,6 +34,8 @@ AC_COPYRIGHT([
+ ])
+ AC_CONFIG_SRCDIR(src/antlr3parser.c)
+ 
++LIB_VERSION=`echo $PACKAGE_VERSION|sed 's@\.@:@g'`
++AC_SUBST([LIB_VERSION])
+ 
+ AC_ARG_ENABLE([debuginfo],
+   [AS_HELP_STRING([--enable-debuginfo], [Compiles debug info into 
the library (default --disable-debuginfo)])],

++ baselibs.conf ++
libantlr3c3
++ fix-LIST-memory-leak.patch ++
>From 26aaa0f97e45025c48139bd39adc8808f9b4e697 Mon Sep 17 00:00:00 2001
From: Jiri Slaby 
Date: Thu, 17 Feb 2011 21:26:57 +0100
Subject: [PATCH] collections: fix a LIST memory leak

When using antlr3 lists, Valgrind reports leaks like this:
==30092== HEAP SUMMARY:
==30092== in use at exit: 80 bytes in 2 blocks
==30092==   total heap usage: 286 allocs, 284 frees, 1,781,381 bytes allocated
==30092==
==30092== 40 bytes in 1 blocks are definitely lost in loss record 1 of 2
==30092==at 0x4C2659D: malloc (in 
/usr/lib64/valgrind/vgpreload_memcheck-amd64-linux.so)
==30092==by 0x4E333B8: antlr3HashPutI (antlr3collections.c:569)

It's because we use HASH as a representation for LIST. The LIST
abstracts from HASH, so a user doesn't 

commit php7 for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package php7 for openSUSE:Factory checked in 
at 2016-08-03 11:45:13

Comparing /work/SRC/openSUSE:Factory/php7 (Old)
 and  /work/SRC/openSUSE:Factory/.php7.new (New)


Package is "php7"

Changes:

--- /work/SRC/openSUSE:Factory/php7/php7.changes2016-06-25 
02:23:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.php7.new/php7.changes   2016-08-03 
11:45:23.0 +0200
@@ -1,0 +2,6 @@
+Mon Aug  1 14:10:20 UTC 2016 - pgaj...@suse.com
+
+- updated to 7.0.9: Several security bugs were fixed in this 
+  release, including the HTTP_PROXY issue.
+
+---

Old:

  php-7.0.8.tar.xz
  php-7.0.8.tar.xz.asc

New:

  php-7.0.9.tar.xz
  php-7.0.9.tar.xz.asc



Other differences:
--
++ php7.spec ++
--- /var/tmp/diff_new_pack.F8onVF/_old  2016-08-03 11:45:25.0 +0200
+++ /var/tmp/diff_new_pack.F8onVF/_new  2016-08-03 11:45:25.0 +0200
@@ -51,7 +51,7 @@
 %define need_libxml2_hack %(if [ -e %{_includedir}/libxml/parser.h ]; then if 
grep -q XML_PARSE_OLDSAX %{_includedir}/libxml/parser.h; then echo 1; else echo 
0; fi; else echo 0; fi)
 
 Name:   php7
-Version:7.0.8
+Version:7.0.9
 Release:0
 Summary:PHP7 Core Files
 License:PHP-3.01
@@ -1081,8 +1081,8 @@
 ./buildconf --force
 
 # export flags
-CFLAGS="$RPM_OPT_FLAGS -O3 -fPIE -fPIC -DPIC -D_GNU_SOURCE 
-fno-strict-aliasing -O0"
-CXXFLAGS="$RPM_OPT_FLAGS -O3 -fPIE -fPIC -DPIC -D_GNU_SOURCE 
-fno-strict-aliasing -O0"
+CFLAGS="$RPM_OPT_FLAGS -O3 -fPIE -fPIC -DPIC -D_GNU_SOURCE 
-fno-strict-aliasing"
+CXXFLAGS="$RPM_OPT_FLAGS -O3 -fPIE -fPIC -DPIC -D_GNU_SOURCE 
-fno-strict-aliasing"
 %if %{with firebird}
 CFLAGS="$CFLAGS -I/usr/include/firebird"
 CXXFLAGS="$CXXFLAGS -I/usr/include/firebird"


++ php-7.0.8.tar.xz -> php-7.0.9.tar.xz ++
/work/SRC/openSUSE:Factory/php7/php-7.0.8.tar.xz 
/work/SRC/openSUSE:Factory/.php7.new/php-7.0.9.tar.xz differ: char 26, line 1





commit yast2-reipl for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package yast2-reipl for openSUSE:Factory 
checked in at 2016-08-03 11:45:22

Comparing /work/SRC/openSUSE:Factory/yast2-reipl (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-reipl.new (New)


Package is "yast2-reipl"

Changes:

--- /work/SRC/openSUSE:Factory/yast2-reipl/yast2-reipl.changes  2016-06-07 
23:48:48.0 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-reipl.new/yast2-reipl.changes 
2016-08-03 11:45:34.0 +0200
@@ -1,0 +2,8 @@
+Tue Aug  2 22:13:21 UTC 2016 - mfi...@suse.com
+
+- bnc#988379
+  - updated message which is shown at the end of installation on
+s390
+- 3.1.11
+
+---

Old:

  yast2-reipl-3.1.10.tar.bz2

New:

  yast2-reipl-3.1.11.tar.bz2



Other differences:
--
++ yast2-reipl.spec ++
--- /var/tmp/diff_new_pack.mVsxVF/_old  2016-08-03 11:45:36.0 +0200
+++ /var/tmp/diff_new_pack.mVsxVF/_new  2016-08-03 11:45:36.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-reipl
-Version:3.1.10
+Version:3.1.11
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-reipl-3.1.10.tar.bz2 -> yast2-reipl-3.1.11.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-reipl-3.1.10/package/yast2-reipl.changes 
new/yast2-reipl-3.1.11/package/yast2-reipl.changes
--- old/yast2-reipl-3.1.10/package/yast2-reipl.changes  2016-06-06 
10:49:37.0 +0200
+++ new/yast2-reipl-3.1.11/package/yast2-reipl.changes  2016-08-03 
07:00:11.0 +0200
@@ -1,4 +1,12 @@
 ---
+Tue Aug  2 22:13:21 UTC 2016 - mfi...@suse.com
+
+- bnc#988379
+  - updated message which is shown at the end of installation on
+s390
+- 3.1.11
+
+---
 Mon Jun  6 08:04:48 UTC 2016 - igonzalezs...@suse.com
 
 - Stop generating autodocs (fate#320356)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-reipl-3.1.10/package/yast2-reipl.spec 
new/yast2-reipl-3.1.11/package/yast2-reipl.spec
--- old/yast2-reipl-3.1.10/package/yast2-reipl.spec 2016-06-06 
10:49:37.0 +0200
+++ new/yast2-reipl-3.1.11/package/yast2-reipl.spec 2016-08-03 
07:00:11.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-reipl
-Version:3.1.10
+Version:3.1.11
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-reipl-3.1.10/src/clients/reipl_bootloader_finish.rb 
new/yast2-reipl-3.1.11/src/clients/reipl_bootloader_finish.rb
--- old/yast2-reipl-3.1.10/src/clients/reipl_bootloader_finish.rb   
2016-06-06 10:49:37.0 +0200
+++ new/yast2-reipl-3.1.11/src/clients/reipl_bootloader_finish.rb   
2016-08-03 07:00:11.0 +0200
@@ -66,7 +66,7 @@
   _(
 "\n" +
   "After shutdown, reload the system\n" +
-  "with an IPL from DASD '%1'.\n"
+  "with an IPL from device '%1'.\n"
   ),
   @dev
 )




commit freeipmi for openSUSE:Factory

2016-08-03 Thread h_root


binvyOYNxfsNd.bin
Description: Binary data


commit qhexedit2 for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package qhexedit2 for openSUSE:Factory 
checked in at 2016-08-03 11:45:17

Comparing /work/SRC/openSUSE:Factory/qhexedit2 (Old)
 and  /work/SRC/openSUSE:Factory/.qhexedit2.new (New)


Package is "qhexedit2"

Changes:

--- /work/SRC/openSUSE:Factory/qhexedit2/qhexedit2.changes  2016-07-09 
09:22:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.qhexedit2.new/qhexedit2.changes 2016-08-03 
11:45:28.0 +0200
@@ -1,0 +2,7 @@
+Mon Aug  1 21:44:40 UTC 2016 - aloi...@gmx.com
+
+- Update to version 0.7.8
+  * Adjust include directory for qt5 in setup.py for Ubuntu 16.04
+  * Initialize values in constructor
+
+---

Old:

  qhexedit2-0.7.7.tar.gz

New:

  qhexedit2-0.7.8.tar.gz



Other differences:
--
++ qhexedit2.spec ++
--- /var/tmp/diff_new_pack.OwJL7S/_old  2016-08-03 11:45:29.0 +0200
+++ /var/tmp/diff_new_pack.OwJL7S/_new  2016-08-03 11:45:29.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   qhexedit2
-Version:0.7.7
+Version:0.7.8
 Release:0
 Summary:Qt-based hex editor
 License:LGPL-2.0

++ qhexedit2-0.7.7.tar.gz -> qhexedit2-0.7.8.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qhexedit2-0.7.7/doc/release.txt 
new/qhexedit2-0.7.8/doc/release.txt
--- old/qhexedit2-0.7.7/doc/release.txt 2016-04-14 19:15:41.0 +0200
+++ new/qhexedit2-0.7.8/doc/release.txt 2016-08-01 22:19:26.0 +0200
@@ -1,3 +1,8 @@
+Release 0.7.8, 2016-08-01
+-
+- Adjust include directory for qt5 in setup.py for Ubuntu 16.04
+- Initialize values in constructor
+
 Release 0.7.7, 2016-04-14
 -
 - Take horizontal scrolling position into account, when calculation cursor
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qhexedit2-0.7.7/setup.py new/qhexedit2-0.7.8/setup.py
--- old/qhexedit2-0.7.7/setup.py2016-04-14 19:15:41.0 +0200
+++ new/qhexedit2-0.7.8/setup.py2016-08-01 22:19:26.0 +0200
@@ -98,7 +98,7 @@
   lib + ".framework", "Headers")]
 else:
 if PyQt_Version == 'PyQt5':
-for qt_inc_dir in ('/usr/include/qt', '/usr/include/qt5'):
+for qt_inc_dir in ('/usr/include/qt', 
'/usr/include/x86_64-linux-gnu/qt5'):
 include_dirs.append(qt_inc_dir)
 include_dirs += [os.path.join(qt_inc_dir, lib) for lib in qt_libs]
 libraries = ["Qt5" + lib[2:] for lib in qt_libs]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qhexedit2-0.7.7/src/qhexedit.cpp 
new/qhexedit2-0.7.8/src/qhexedit.cpp
--- old/qhexedit2-0.7.7/src/qhexedit.cpp2016-04-14 19:15:41.0 
+0200
+++ new/qhexedit2-0.7.8/src/qhexedit.cpp2016-08-01 22:19:26.0 
+0200
@@ -14,6 +14,15 @@
 
 QHexEdit::QHexEdit(QWidget *parent) : QAbstractScrollArea(parent)
 {
+_addressArea = true;
+_addressWidth = 4;
+_asciiArea = true;
+_overwriteMode = true;
+_highlighting = true;
+_readOnly = false;
+_cursorPosition = 0;
+_lastEventSize = 0;
+
 _chunks = new Chunks();
 _undoStack = new UndoStack(_chunks, this);
 #ifdef Q_OS_WIN32
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/qhexedit2-0.7.7/src/qhexedit.h 
new/qhexedit2-0.7.8/src/qhexedit.h
--- old/qhexedit2-0.7.7/src/qhexedit.h  2016-04-14 19:15:41.0 +0200
+++ new/qhexedit2-0.7.8/src/qhexedit.h  2016-08-01 22:19:26.0 +0200
@@ -11,7 +11,7 @@
 /** \mainpage
 QHexEdit is a binary editor widget for Qt.
 
-\version Version 0.7.7
+\version Version 0.7.8
 \image html qhexedit.png
 */
 




commit go for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package go for openSUSE:Factory checked in 
at 2016-08-03 11:45:20

Comparing /work/SRC/openSUSE:Factory/go (Old)
 and  /work/SRC/openSUSE:Factory/.go.new (New)


Package is "go"

Changes:

--- /work/SRC/openSUSE:Factory/go/go.changes2016-07-24 19:53:26.0 
+0200
+++ /work/SRC/openSUSE:Factory/.go.new/go.changes   2016-08-03 
11:45:31.0 +0200
@@ -1,0 +2,11 @@
+Tue Jul 26 15:13:08 UTC 2016 - jmassaguer...@suse.com
+
+- update go go1.6.3 (released 2016/07/17) includes security fixes to the
+net/http/cgi package and net/http package when used 
in
+a CGI environment. This release also adds support for macOS Sierra.
+See the https://github.com/golang/go/issues?q=milestone%3AGo1.6.3;>Go
+1.6.3 milestone on our issue tracker for details.
+
+This fixes: bsc#988487
+
+---

Old:

  go1.6.2.src.tar.gz

New:

  go1.6.3.src.tar.gz



Other differences:
--
++ go.spec ++
--- /var/tmp/diff_new_pack.BCJ9DG/_old  2016-08-03 11:45:33.0 +0200
+++ /var/tmp/diff_new_pack.BCJ9DG/_new  2016-08-03 11:45:33.0 +0200
@@ -54,7 +54,7 @@
 %endif
 
 Name:   go
-Version:1.6.2
+Version:1.6.3
 Release:0
 Summary:A compiled, garbage-collected, concurrent programming language
 License:BSD-3-Clause

++ go1.6.2.src.tar.gz -> go1.6.3.src.tar.gz ++
/work/SRC/openSUSE:Factory/go/go1.6.2.src.tar.gz 
/work/SRC/openSUSE:Factory/.go.new/go1.6.3.src.tar.gz differ: char 143, line 1




commit mksusecd for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package mksusecd for openSUSE:Factory 
checked in at 2016-08-03 11:45:19

Comparing /work/SRC/openSUSE:Factory/mksusecd (Old)
 and  /work/SRC/openSUSE:Factory/.mksusecd.new (New)


Package is "mksusecd"

Changes:

--- /work/SRC/openSUSE:Factory/mksusecd/mksusecd.changes2016-07-15 
12:55:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.mksusecd.new/mksusecd.changes   2016-08-03 
11:45:30.0 +0200
@@ -1,0 +2,7 @@
+Tue Aug  2 12:35:20 UTC 2016 - snw...@suse.com
+
+- catch error when we fail to unpack squashfs images
+- handle modules.order and modules.builtin when updating a kernel
+- 1.41
+
+---

Old:

  mksusecd-1.40.tar.xz

New:

  mksusecd-1.41.tar.xz



Other differences:
--
++ mksusecd.spec ++
--- /var/tmp/diff_new_pack.teUYJy/_old  2016-08-03 11:45:31.0 +0200
+++ /var/tmp/diff_new_pack.teUYJy/_new  2016-08-03 11:45:31.0 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   mksusecd
-Version:1.40
+Version:1.41
 Release:0
 Summary:Create SUSE Linux installation ISOs
 License:GPL-3.0+

++ mksusecd-1.40.tar.xz -> mksusecd-1.41.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mksusecd-1.40/VERSION new/mksusecd-1.41/VERSION
--- old/mksusecd-1.40/VERSION   2016-07-15 10:10:59.0 +0200
+++ new/mksusecd-1.41/VERSION   2016-08-02 14:31:06.0 +0200
@@ -1 +1 @@
-1.40
+1.41
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mksusecd-1.40/changelog new/mksusecd-1.41/changelog
--- old/mksusecd-1.40/changelog 2016-07-15 10:10:59.0 +0200
+++ new/mksusecd-1.41/changelog 2016-08-02 14:31:06.0 +0200
@@ -1,3 +1,7 @@
+2016-08-02:1.41
+   - catch error when we fail to unpack squashfs images
+   - handle modules.order and modules.builtin when updating a kernel
+
 2016-07-14:1.40
- tw support: also sign image files
- sanitize function that removes files from iso
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/mksusecd-1.40/mksusecd new/mksusecd-1.41/mksusecd
--- old/mksusecd-1.40/mksusecd  2016-07-15 10:10:59.0 +0200
+++ new/mksusecd-1.41/mksusecd  2016-08-02 14:31:06.0 +0200
@@ -2848,7 +2848,9 @@
 
   if(-f "$orig_initrd/parts/00_lib") {
 rmdir $unpack_dir;
-system "unsquashfs -n -d $unpack_dir $orig_initrd/parts/00_lib >/dev/null 
2>&1";
+if(system "unsquashfs -n -d $unpack_dir $orig_initrd/parts/00_lib 
>/dev/null 2>&1") {
+  die "parts/00_lib: failed to unpack squashfs image - squashfs tools too 
old?\n";
+}
   }
 
   File::Find::find({
@@ -2965,6 +2967,24 @@
 }
   }
 
+  # copy modules.order & modules.builtin
+
+  if(-f "$kernel->{dir}/lib/modules/$kernel->{version}/modules.builtin") {
+system "cp $kernel->{dir}/lib/modules/$kernel->{version}/modules.builtin 
$kernel->{new_dir}/lib/modules/$kernel->{version}/";
+  }
+
+  if(open my $f, 
"$kernel->{dir}/lib/modules/$kernel->{version}/modules.order") {
+if(open my $w, 
">$kernel->{new_dir}/lib/modules/$kernel->{version}/modules.order") {
+  while(<$f>) {
+chomp;
+s#.*/#initrd/#;
+print $w "$_\n" if -f 
"$kernel->{new_dir}/lib/modules/$kernel->{version}/$_";
+  }
+  close $w;
+}
+close $f;
+  }
+
   system "depmod -a -b $kernel->{new_dir} $kernel->{version}";
 
   # now get firmware files




commit highlight for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package highlight for openSUSE:Factory 
checked in at 2016-08-03 11:45:05

Comparing /work/SRC/openSUSE:Factory/highlight (Old)
 and  /work/SRC/openSUSE:Factory/.highlight.new (New)


Package is "highlight"

Changes:

--- /work/SRC/openSUSE:Factory/highlight/highlight.changes  2016-07-14 
09:50:56.0 +0200
+++ /work/SRC/openSUSE:Factory/.highlight.new/highlight.changes 2016-08-03 
11:45:19.0 +0200
@@ -1,0 +2,9 @@
+Mon Aug  1 10:58:12 UTC 2016 - antoine.belv...@laposte.net
+
+- Update to 3.31:
+  * Revise documentation
+  * GUI: fix minor layout issues
+- Change arguments order for suse_update_desktop_file: GenericName
+  was not set.
+
+---

Old:

  highlight-3.30.tar.bz2

New:

  highlight-3.31.tar.bz2



Other differences:
--
++ highlight.spec ++
--- /var/tmp/diff_new_pack.LafGjN/_old  2016-08-03 11:45:20.0 +0200
+++ /var/tmp/diff_new_pack.LafGjN/_new  2016-08-03 11:45:20.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   highlight
-Version:3.30
+Version:3.31
 Release:0
 Summary:Universal Source Code to Formatted Text Converter
 License:GPL-3.0+
@@ -67,7 +67,7 @@
 
 %install
 %makeinstall install-gui
-%suse_update_desktop_file -r %{name} Utility TextEditor -G "Text converter"
+%suse_update_desktop_file -G "Text converter" -r %{name} Utility TextEditor
 
 L="$PWD/%{name}.lang"
 LDIR="%{_datadir}/%{name}/gui_files/l10n"

++ highlight-3.30.tar.bz2 -> highlight-3.31.tar.bz2 ++
 4350 lines of diff (skipped)




commit git-cola for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package git-cola for openSUSE:Factory 
checked in at 2016-08-03 11:44:53

Comparing /work/SRC/openSUSE:Factory/git-cola (Old)
 and  /work/SRC/openSUSE:Factory/.git-cola.new (New)


Package is "git-cola"

Changes:

--- /work/SRC/openSUSE:Factory/git-cola/git-cola.changes2016-05-03 
10:16:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.git-cola.new/git-cola.changes   2016-08-03 
11:45:12.0 +0200
@@ -1,0 +2,20 @@
+Sun Jul 31 20:21:46 UTC 2016 - marcin.ba...@gmail.com
+
+- Update to 2.7
+- Fixes
+* When repositories stored in non-ASCII, UTF-8-encoded filesystem paths were 
operated upon with LC_ALL=C set in the environment, unicode errors would occur 
when using python2. git cola was made more robust and will now operate 
correctly within this environment.
+https://github.com/git-cola/git-cola/issues/581
+* Support for the GIT_WORK_TREE environment variable was fixed.
+https://github.com/git-cola/git-cola/pull/582
+- Development
+* The unittest.mock module is now used instead of the original mock module 
when running the git cola test suite using Python3.
+https://github.com/git-cola/git-cola/issues/569
+- Packaging
+* git cola is now compatible with PyQt5, PyQt4, and Pyside. git cola 
previously supported PyQt4 only, but will now use whichever library is 
available. Users are not required to upgrade at this time, but PyQt5 support 
can be enabled anytime by making its python modules available.
+https://github.com/git-cola/git-cola/issues/232
+NOTE: We do not yet recommend using PyQt5 because there are known 
exit-on-segfault bugs in Qt5 that have not yet been addressed. git cola is 
sensitive to this bug and is known to crash on exit when using git dag or the 
interactive rebase feature on PyQt5.
+https://bugreports.qt.io/browse/QTBUG-52988
+* PyQt4 is stable and there are no known issues when using it so we recommend 
using it until the Qt5 bugs have been resolved.
+git cola now depends on QtPy and includes a bundled copy of the qtpy library. 
If you are packaging git cola and would prefer to use qtpy from your 
distribution instead of the built-in version then use make NO_VENDOR_LIBS=1 
when building git cola. This will prevent vendored libraries from being 
installed. 
+
+---

Old:

  v2.6.tar.gz

New:

  v2.7.tar.gz



Other differences:
--
++ git-cola.spec ++
--- /var/tmp/diff_new_pack.u3wdYm/_old  2016-08-03 11:45:13.0 +0200
+++ /var/tmp/diff_new_pack.u3wdYm/_new  2016-08-03 11:45:13.0 +0200
@@ -18,7 +18,7 @@
 
 
 Name:   git-cola
-Version:2.6
+Version:2.7
 Release:0
 Summary:Sleek and powerful git GUI
 License:GPL-2.0+
@@ -56,7 +56,7 @@
 %build
 
 %install
-%makeinstall prefix=%{_prefix} DESTDIR=%{buildroot}
+%makeinstall prefix=%{_prefix} DESTDIR=%{buildroot} NO_VENDOR_LIBS=1
 %suse_update_desktop_file %{buildroot}%{_datadir}/applications/git-cola.desktop
 %suse_update_desktop_file %{buildroot}%{_datadir}/applications/git-dag.desktop
 %suse_update_desktop_file 
%{buildroot}%{_datadir}/applications/git-cola-folder-handler.desktop

++ v2.6.tar.gz -> v2.7.tar.gz ++
 13806 lines of diff (skipped)




commit python3-CherryPy for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python3-CherryPy for 
openSUSE:Factory checked in at 2016-08-03 11:44:57

Comparing /work/SRC/openSUSE:Factory/python3-CherryPy (Old)
 and  /work/SRC/openSUSE:Factory/.python3-CherryPy.new (New)


Package is "python3-CherryPy"

Changes:

--- /work/SRC/openSUSE:Factory/python3-CherryPy/python3-CherryPy.changes
2016-07-27 16:13:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-CherryPy.new/python3-CherryPy.changes   
2016-08-03 11:45:14.0 +0200
@@ -1,0 +2,11 @@
+Fri Jul 29 06:08:18 UTC 2016 - a...@gmx.de
+
+- update to version 7.1.0:
+  * # 1458: Implement systemd's socket activation mechanism for
+CherryPy servers, based on work sponsored by Endless Computers.
+
+Socket Activation allows one to setup a system so that systemd
+will sit on a port and start services 'on demand' (a little bit
+like inetd and xinetd used to do).
+
+---

Old:

  CherryPy-7.0.0.tar.gz

New:

  CherryPy-7.1.0.tar.gz



Other differences:
--
++ python3-CherryPy.spec ++
--- /var/tmp/diff_new_pack.xzz8NQ/_old  2016-08-03 11:45:15.0 +0200
+++ /var/tmp/diff_new_pack.xzz8NQ/_new  2016-08-03 11:45:15.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python3-CherryPy
-Version:7.0.0
+Version:7.1.0
 Release:0
 Url:http://www.cherrypy.org
 Summary:Object-Oriented HTTP framework

++ CherryPy-7.0.0.tar.gz -> CherryPy-7.1.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CherryPy-7.0.0/CherryPy.egg-info/PKG-INFO 
new/CherryPy-7.1.0/CherryPy.egg-info/PKG-INFO
--- old/CherryPy-7.0.0/CherryPy.egg-info/PKG-INFO   2016-07-24 
18:16:11.0 +0200
+++ new/CherryPy-7.1.0/CherryPy.egg-info/PKG-INFO   2016-07-25 
22:37:11.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: CherryPy
-Version: 7.0.0
+Version: 7.1.0
 Summary: Object-Oriented HTTP framework
 Home-page: http://www.cherrypy.org
 Author: CherryPy Team
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CherryPy-7.0.0/CherryPy.egg-info/SOURCES.txt 
new/CherryPy-7.1.0/CherryPy.egg-info/SOURCES.txt
--- old/CherryPy-7.0.0/CherryPy.egg-info/SOURCES.txt2016-07-24 
18:16:11.0 +0200
+++ new/CherryPy-7.1.0/CherryPy.egg-info/SOURCES.txt2016-07-25 
22:37:11.0 +0200
@@ -118,6 +118,7 @@
 cherrypy/test/static/dirback.jpg
 cherrypy/test/static/has space.html
 cherrypy/test/static/index.html
+cherrypy/test/static/Слава Україні.html
 cherrypy/tutorial/README.txt
 cherrypy/tutorial/__init__.py
 cherrypy/tutorial/custom_error.html
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CherryPy-7.0.0/PKG-INFO new/CherryPy-7.1.0/PKG-INFO
--- old/CherryPy-7.0.0/PKG-INFO 2016-07-24 18:16:11.0 +0200
+++ new/CherryPy-7.1.0/PKG-INFO 2016-07-25 22:37:11.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: CherryPy
-Version: 7.0.0
+Version: 7.1.0
 Summary: Object-Oriented HTTP framework
 Home-page: http://www.cherrypy.org
 Author: CherryPy Team
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/CherryPy-7.0.0/cherrypy/_cpcompat.py 
new/CherryPy-7.1.0/cherrypy/_cpcompat.py
--- old/CherryPy-7.0.0/cherrypy/_cpcompat.py2016-07-24 18:14:49.0 
+0200
+++ new/CherryPy-7.1.0/cherrypy/_cpcompat.py2016-07-25 22:35:49.0 
+0200
@@ -1,6 +1,6 @@
 """Compatibility code for using CherryPy with various versions of Python.
 
-CherryPy 3.2 is compatible with Python versions 2.3+. This module provides a
+CherryPy 3.2 is compatible with Python versions 2.6+. This module provides a
 useful abstraction over the differences between Python versions, sometimes by
 preferring a newer idiom, sometimes an older one, and sometimes a custom one.
 
@@ -23,8 +23,6 @@
 import six
 
 if six.PY3:
-basestring = (bytes, str)
-
 def ntob(n, encoding='ISO-8859-1'):
 """Return the given native string as a byte string in the given
 encoding.
@@ -49,8 +47,6 @@
 return n
 else:
 # Python 2
-basestring = basestring
-
 def ntob(n, encoding='ISO-8859-1'):
 """Return the given native string as a byte string in the given
 encoding.
@@ -238,14 +234,6 @@
 t.setDaemon(val)
 
 try:
-from email.utils import formatdate
-
-def HTTPDate(timeval=None):
-return formatdate(timeval, usegmt=True)
-except ImportError:
-from rfc822 import formatdate as HTTPDate
-
-try:
 # Python 3
 from urllib.parse import unquote as parse_unquote
 
@@ -291,6 

commit lastpass-cli for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package lastpass-cli for openSUSE:Factory 
checked in at 2016-08-03 11:44:42

Comparing /work/SRC/openSUSE:Factory/lastpass-cli (Old)
 and  /work/SRC/openSUSE:Factory/.lastpass-cli.new (New)


Package is "lastpass-cli"

Changes:

--- /work/SRC/openSUSE:Factory/lastpass-cli/lastpass-cli.changes
2016-04-28 17:01:06.0 +0200
+++ /work/SRC/openSUSE:Factory/.lastpass-cli.new/lastpass-cli.changes   
2016-08-03 11:45:03.0 +0200
@@ -1,0 +2,34 @@
+Sun Jul 31 07:08:23 UTC 2016 - mplus...@suse.com
+
+- Update to version 1.0.0:
+  * New command lpass status shows whether or not the user is
+logged in with agent, from Nick Knudson
+  * lpass add can now be passed --note-type=X in order to add a 
+secure note using a template. Specifying an unknown note
+template will list the available templates.
+  * lpass ls now shows username with --long, from Alli Witheford
+  * Bash completions are now installed with make install, from 
+Eli Schwartz
+  * Fish shell completions supplied by Joar Wanboarg
+  * Initial support for adding (lpass add --app) and editing
+applications
+  * Updates to manpage for ls, passwd, add, and basic usage
+examples
+  * lpass now follows XDG base directory specifications for its
+files on platforms that use it. Set LP_HOME to ~/.lpass to
+keep the previous location
+  * Bugfix: resolved syncing problems on some platforms
+(notably RHEL/CentOS) related to improper multiprocess usage
+of libcurl (github #166)
+  * Bugfix: lpass show no longer crashes when a searched-for field
+is not found (github #167)
+  * Bugfix: lpass no longer exits with an error if the blob is
+empty but otherwise without parsing errors. This fixes the case
+where a new user could not use the application without first
+adding a site elsewhere.
+  * LPASS_LOG_LEVEL learned level=8 with which lpass will also dump
+libcurl verbose logs showing all traffic for debugging (not
+recommended for general use due to potentially sensitive
+headers being logged).
+
+---

Old:

  lastpass-cli-0.9.0.tar.gz

New:

  lastpass-cli-1.0.0.tar.gz



Other differences:
--
++ lastpass-cli.spec ++
--- /var/tmp/diff_new_pack.dmZg6y/_old  2016-08-03 11:45:05.0 +0200
+++ /var/tmp/diff_new_pack.dmZg6y/_new  2016-08-03 11:45:05.0 +0200
@@ -17,19 +17,20 @@
 
 
 Name:   lastpass-cli
-Version:0.9.0
+Version:1.0.0
 Release:0
 Summary:LastPass command line interface tool
 License:GPL-2.0
 Group:  Productivity/Security
 Url:https://github.com/LastPass/lastpass-cli
-Source: 
https://github.com/lastpass/lastpass-cli/archive/v0.9.0.tar.gz#/%{name}-%{version}.tar.gz
+Source: 
https://github.com/lastpass/lastpass-cli/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  asciidoc
 BuildRequires:  libxslt-tools
-BuildRequires:  pkg-config
+BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(libcurl)
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(openssl)
+Recommends: bash-completion
 Recommends: pinentry
 Recommends: xclip
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -43,16 +44,19 @@
 %setup -q
 
 %build
-export CFLAGS="%{optflags}"
+export CFLAGS="%{optflags} -pipe"
 make %{?_smp_mflags} all doc-man
 
 %install
-make %{?_smp_mflags} DESTDIR=%{buildroot} install install-doc
+%make_install install-doc
 
 %files
 %defattr(-,root,root)
 %doc CHANGELOG.md README.md COPYING
 %{_bindir}/lpass
 %{_mandir}/man1/lpass.1%{ext_man}
+%dir %{_datadir}/bash-completion
+%dir %{_datadir}/bash-completion/completions
+%{_datadir}/bash-completion/completions/lpass
 
 %changelog

++ lastpass-cli-0.9.0.tar.gz -> lastpass-cli-1.0.0.tar.gz ++
 2228 lines of diff (skipped)




commit kradio for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package kradio for openSUSE:Factory checked 
in at 2016-08-03 11:44:40

Comparing /work/SRC/openSUSE:Factory/kradio (Old)
 and  /work/SRC/openSUSE:Factory/.kradio.new (New)


Package is "kradio"

Changes:

--- /work/SRC/openSUSE:Factory/kradio/kradio.changes2016-07-12 
23:51:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.kradio.new/kradio.changes   2016-08-03 
11:45:01.0 +0200
@@ -1,0 +2,5 @@
+Mon Jul 25 11:28:39 UTC 2016 - o...@aepfle.de
+
+- Unconditionally build with ffmpeg
+
+---



Other differences:
--
++ kradio.spec ++
--- /var/tmp/diff_new_pack.KA4lYp/_old  2016-08-03 11:45:02.0 +0200
+++ /var/tmp/diff_new_pack.KA4lYp/_new  2016-08-03 11:45:02.0 +0200
@@ -16,7 +16,7 @@
 #
 
 
-%bcond_with ffmpeg
+%bcond_without ffmpeg
 %bcond_with lame
 
 Name:   kradio
@@ -37,9 +37,11 @@
 BuildRequires:  libvorbis-devel
 BuildRequires:  lirc-devel
 %if %{with ffmpeg}
-BuildRequires:  libffmpeg-devel
-BuildRequires:  libmms-devel
+BuildRequires:  pkgconfig(libavcodec)
+BuildRequires:  pkgconfig(libavformat)
+BuildRequires:  pkgconfig(libswresample)
 %endif
+BuildRequires:  libmms-devel
 %if %{with lame}
 BuildRequires:  libmp3lame-devel
 %endif




commit crmsh for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package crmsh for openSUSE:Factory checked 
in at 2016-08-03 11:44:38

Comparing /work/SRC/openSUSE:Factory/crmsh (Old)
 and  /work/SRC/openSUSE:Factory/.crmsh.new (New)


Package is "crmsh"

Changes:

--- /work/SRC/openSUSE:Factory/crmsh/crmsh.changes  2016-06-14 
23:06:54.0 +0200
+++ /work/SRC/openSUSE:Factory/.crmsh.new/crmsh.changes 2016-08-03 
11:44:59.0 +0200
@@ -1,0 +2,10 @@
+Sat Jul 30 22:40:45 UTC 2016 - kgronl...@suse.com
+
+- Update to version 2.2.0+git.1469918297.1b801f6:
+  * high: hb_report: Skip lines without timestamps in log correctly 
(bsc#989810)
+  * high: hb_report: Don't collect logs from journalctl if -M is set 
(bsc#990025)
+  * high: parse: Use original _TARGET_RE
+  * low: Fix a setting example of the alert to become the error
+  * low: scripts: Fix use of non-relative import for ra
+
+---

Old:

  crmsh-2.2.0+git.1464769043.9e4df55.tar.bz2

New:

  crmsh-2.2.0+git.1469918297.1b801f6.tar.bz2



Other differences:
--
++ crmsh.spec ++
--- /var/tmp/diff_new_pack.qd1PBD/_old  2016-08-03 11:45:00.0 +0200
+++ /var/tmp/diff_new_pack.qd1PBD/_new  2016-08-03 11:45:00.0 +0200
@@ -32,13 +32,13 @@
 
 %{!?python_sitelib: %define python_sitelib %(python -c "from 
distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
-%define version_unconverted 2.2.0+git.1464769043.9e4df55
+%define version_unconverted 2.2.0+git.1469918297.1b801f6
 
 Name:   crmsh
 Summary:High Availability cluster command-line interface
 License:GPL-2.0+
 Group:  %{pkg_group}
-Version:2.2.0+git.1464769043.9e4df55
+Version:2.2.0+git.1469918297.1b801f6
 Release:0
 Url:http://crmsh.github.io
 Source0:%{name}-%{version}.tar.bz2

++ _servicedata ++
--- /var/tmp/diff_new_pack.qd1PBD/_old  2016-08-03 11:45:00.0 +0200
+++ /var/tmp/diff_new_pack.qd1PBD/_new  2016-08-03 11:45:00.0 +0200
@@ -1,4 +1,4 @@
 
 
 git://github.com/ClusterLabs/crmsh.git
-  9e4df55617a3255398064d789af1b5180d0de736
\ No newline at end of file
+  1b801f6bca54aa91ca066a057e3b0003715995e7
\ No newline at end of file

++ crmsh-2.2.0+git.1464769043.9e4df55.tar.bz2 -> 
crmsh-2.2.0+git.1469918297.1b801f6.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/crmsh-2.2.0+git.1464769043.9e4df55/crmsh/parse.py 
new/crmsh-2.2.0+git.1469918297.1b801f6/crmsh/parse.py
--- old/crmsh-2.2.0+git.1464769043.9e4df55/crmsh/parse.py   2016-06-01 
10:22:40.0 +0200
+++ new/crmsh-2.2.0+git.1469918297.1b801f6/crmsh/parse.py   2016-07-31 
00:40:44.0 +0200
@@ -40,7 +40,7 @@
 _RA_TYPE_RE = re.compile(r'[a-z0-9_:-]+$', re.IGNORECASE)
 _TAG_RE = re.compile(r"([a-zA-Z_][^\s:]*):?$")
 _ROLE2_RE = re.compile(r"role=(.+)$", re.IGNORECASE)
-_TARGET_RE = re.compile(r'([\w=-]+):$')
+_TARGET_RE = re.compile(r'([^:]+):$')
 _TARGET_ATTR_RE = re.compile(r'attr:([\w-]+)=([\w-]+)$', re.IGNORECASE)
 TERMINATORS = ('params', 'meta', 'utilization', 'operations', 'op', 'rule', 
'attributes')
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/crmsh-2.2.0+git.1464769043.9e4df55/crmsh/scripts.py 
new/crmsh-2.2.0+git.1469918297.1b801f6/crmsh/scripts.py
--- old/crmsh-2.2.0+git.1464769043.9e4df55/crmsh/scripts.py 2016-06-01 
10:22:40.0 +0200
+++ new/crmsh-2.2.0+git.1469918297.1b801f6/crmsh/scripts.py 2016-07-31 
00:40:44.0 +0200
@@ -691,7 +691,7 @@
 
 
 def _process_agent_include(script, include):
-import ra
+from . import ra
 agent = include['agent']
 info = ra.get_ra(agent)
 meta = info.meta()
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/crmsh-2.2.0+git.1464769043.9e4df55/doc/crm.8.adoc 
new/crmsh-2.2.0+git.1469918297.1b801f6/doc/crm.8.adoc
--- old/crmsh-2.2.0+git.1464769043.9e4df55/doc/crm.8.adoc   2016-06-01 
10:22:40.0 +0200
+++ new/crmsh-2.2.0+git.1469918297.1b801f6/doc/crm.8.adoc   2016-07-31 
00:40:44.0 +0200
@@ -2688,8 +2688,8 @@
 to /var/log/cluster-alerts.log
 
 alert alert-2 /srv/pacemaker/example_alert.sh \
-to { /var/log/cluster-alerts.log } \
-meta timeout=60s
+meta timeout=60s \
+to { /var/log/cluster-alerts.log }
 ...
 
 [[cmdhelp_configure_cib,CIB shadow management]]
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/crmsh-2.2.0+git.1464769043.9e4df55/doc/website-v1/crm.conf 
new/crmsh-2.2.0+git.1469918297.1b801f6/doc/website-v1/crm.conf

commit povray for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package povray for openSUSE:Factory checked 
in at 2016-08-03 11:44:51

Comparing /work/SRC/openSUSE:Factory/povray (Old)
 and  /work/SRC/openSUSE:Factory/.povray.new (New)


Package is "povray"

Changes:

--- /work/SRC/openSUSE:Factory/povray/povray.changes2015-04-25 
11:25:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.povray.new/povray.changes   2016-08-03 
11:45:09.0 +0200
@@ -1,0 +2,6 @@
+Sat Jul 16 10:50:18 UTC 2016 - antoine.belv...@laposte.net
+
+- Fix build with GCC 6 (boo#985057):
+  * Add '-std=c++03' to CXXFLAGS 
+
+---



Other differences:
--
++ povray.spec ++
--- /var/tmp/diff_new_pack.iwaSwx/_old  2016-08-03 11:45:12.0 +0200
+++ /var/tmp/diff_new_pack.iwaSwx/_new  2016-08-03 11:45:12.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package povray
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,6 +15,7 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
 %define maj_version 3.7
 %define min_version 0.0
 Name:   povray
@@ -77,7 +78,7 @@
 # work around ICE
 RPM_OPT_FLAGS="%{optflags} -O1"
 %endif
-CXXFLAGS="%{optflags} -fno-strict-aliasing -Wno-multichar" CFLAGS="$CXXFLAGS" \
+CXXFLAGS="%{optflags} -fno-strict-aliasing -Wno-multichar -std=c++03" 
CFLAGS="$CXXFLAGS" \
 %configure \
 COMPILED_BY="SUSE LINUX GmbH, Nuernberg, Germany" \
 --disable-strip \




commit fwts for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package fwts for openSUSE:Factory checked in 
at 2016-08-03 11:44:43

Comparing /work/SRC/openSUSE:Factory/fwts (Old)
 and  /work/SRC/openSUSE:Factory/.fwts.new (New)


Package is "fwts"

Changes:

--- /work/SRC/openSUSE:Factory/fwts/fwts.changes2016-07-20 
09:18:01.0 +0200
+++ /work/SRC/openSUSE:Factory/.fwts.new/fwts.changes   2016-08-03 
11:45:06.0 +0200
@@ -1,0 +2,56 @@
+Sun Jul 31 07:30:53 UTC 2016 - mplus...@suse.com
+
+- Update to version 16.07.00:
+  * --uefi and --acpi options renamed to --uefitests and
+--acpitests
+  * ACPI table tests in the acpitables test have been moved into
+specific ACPI tests.
+  * cpi: acpidump: update TCPA table and acpidump accordingly
+  * acpi: add ACPI TCPA test
+  * acpi: add XENV table test
+  * lib: fwts_framework: Append "tests" to --uefi and --acpi
+  * live-image/fwts-frontend-text: update to --uefitests and
+--acpitests
+  * lib: acpi, acpidump: rename slit tables types
+  * lib: acpi: add in new GICC table fwts_acpi_table_gicc_affinity
+  * acpi: add SRAT table sanity checking (LP: #1464658)
+  * acpi: add BERT table sanity checking (LP: #1464712)
+  * lib: acpi: Add in GAS address types
+  * acpi: add ECDT table sanity checking (LP: #1464716)
+  * lib: acpi: Add support for the SPMI table
+  * acpi: add ACPI SPMI table sanity checking (LP: #1465256)
+  * acpi: add ACPI SLIT table sanity checking (LP: #1465276)
+  * lib: acpi: Add support for the HEST family of ACPI tables
+  * acpi: add ACPI HEST table sanity checking (LP: #1465379)
+  * acpi: Add BOOT table test (LP: #1465435)
+  * acpi: Add DBGP table test (LP: #1465441)
+  * acpi: Add DBG2 table test (LP: #1465710)
+  * acpi: re-orgainise HPET tests
+  * acpi: move MADT test from acpitables into new MADT test
+  * acpi: move GTDT test from acpitables into new GTDT test
+  * acpi: move XSDT test from acpitables into new XSDT test
+  * acpi: move RSDP test from acpitables into new RSDP test
+  * acpi: move RSDT test from acpitables into new RSDT test
+  * acpi: acpitables: remove no-op MCFG test
+  * acpi: move SBST test from acpitables into new SBST test
+  * acpi: move FADT test from acpitables into existing FADT test
+  * acpi: acpitables: remove redundant acpi table checking
+  * acpi: allow various ACPI table tests to run without root access
+  * lib: fwts_acpi_tables: fully pad out fixed up ACPI OEM IDs
+  * acpi: spcr: add missing white space in error messages
+  * acpi: add ACPI ERST test (LP: #1467835)
+  * acpi: correct ACPI BGRT table type
+  * acpi: add ACPI BGRT test (LP: #1467863)
+  * acpi: add ACPI CPEP test (LP: #1467870)
+  * acpi: add ACPI FACS test (LP: #1467966)
+  * acpi: acpidump: add in missing exponent field to SLIC
+  * acpi: add CSRT ACPI Table test (LP: #1470116)
+  * acpi: add LPIT ACPI test (LP: #1470184)
+  * acpi: add WAET ACPI table test (LP: #1470495)
+  * acpi: add SLIC table test (LP: #1470518)
+  * acpi: add MSDM table test (LP: #1470538)
+  * acpi: add UEFI ACPI data table test (LP: #1471698)
+  * bios: os2gap: remove ancient legacy test (LP: #1470573)
+  * lost of bugfixes
+
+---

Old:

  fwts-V16.06.00.tar.gz

New:

  fwts-V16.07.00.tar.gz



Other differences:
--
++ fwts.spec ++
--- /var/tmp/diff_new_pack.DPwaph/_old  2016-08-03 11:45:07.0 +0200
+++ /var/tmp/diff_new_pack.DPwaph/_new  2016-08-03 11:45:07.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   fwts
-Version:16.06.00
+Version:16.07.00
 Release:0
 Summary:Firmware Test Suite
 License:GPL-2.0+

++ fwts-V16.06.00.tar.gz -> fwts-V16.07.00.tar.gz ++
 9143 lines of diff (skipped)




commit when-command for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package when-command for openSUSE:Factory 
checked in at 2016-08-03 11:44:36

Comparing /work/SRC/openSUSE:Factory/when-command (Old)
 and  /work/SRC/openSUSE:Factory/.when-command.new (New)


Package is "when-command"

Changes:

--- /work/SRC/openSUSE:Factory/when-command/when-command.changes
2016-05-17 17:16:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.when-command.new/when-command.changes   
2016-08-03 11:44:54.0 +0200
@@ -1,0 +2,10 @@
+Sat Jul 23 16:15:39 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 0.9.12~beta3:
+  * Add a possibility to reset the success status of condition
+tests so that also tests that have been successful during one
+very long session can be performed again at user's request.
+  * Workaround a potential error when a locale is not supported.
+- Add a missing python3-gobject-Gdk dependency.
+
+---

Old:

  when-command-0.9.11-beta.1.tar.gz

New:

  when-command-0.9.12-beta.3.tar.gz



Other differences:
--
++ when-command.spec ++
--- /var/tmp/diff_new_pack.PVWf7u/_old  2016-08-03 11:44:55.0 +0200
+++ /var/tmp/diff_new_pack.PVWf7u/_new  2016-08-03 11:44:55.0 +0200
@@ -16,9 +16,9 @@
 #
 
 
-%define _version 0.9.11-beta.1
+%define _version 0.9.12-beta.3
 Name:   when-command
-Version:0.9.11~beta1
+Version:0.9.12~beta3
 Release:0
 Summary:Configurable user task scheduler
 License:BSD-3-Clause
@@ -41,6 +41,9 @@
 Requires:   python3-pyinotify
 Recommends: %{name}-lang
 BuildArch:  noarch
+%if 0%{?suse_version} > 1320 || 0%{?sle_version} >= 120200
+Requires:   python3-gobject-Gdk
+%endif
 
 %description
 When is a configurable user task scheduler. It interacts with the

++ when-command-0.9.11-beta.1.tar.gz -> when-command-0.9.12-beta.3.tar.gz 
++
 1973 lines of diff (skipped)
retrying with extended exclude list
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' --exclude Makefile.in --exclude configure --exclude 
config.guess --exclude '*.pot' --exclude mkinstalldirs --exclude aclocal.m4 
--exclude config.sub --exclude depcomp --exclude install-sh --exclude ltmain.sh 
old/when-command-0.9.11-beta.1/po/it.po new/when-command-0.9.12-beta.3/po/it.po
--- old/when-command-0.9.11-beta.1/po/it.po 2016-05-03 19:52:11.0 
+0200
+++ new/when-command-0.9.12-beta.3/po/it.po 2016-06-15 23:35:46.0 
+0200
@@ -7,7 +7,7 @@
 msgstr ""
 "Project-Id-Version: when-command 0.9.1-beta.1\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2016-02-09 19:35+0100\n"
+"POT-Creation-Date: 2016-05-14 21:02+0200\n"
 "PO-Revision-Date: 2015-12-21 14:43+0100\n"
 "Last-Translator: Francesco Garosi \n"
 "Language-Team: Italian\n"
@@ -18,61 +18,73 @@
 "Plural-Forms: nplurals=2; plural=(n != 1);\n"
 "X-Generator: Poedit 1.5.4\n"
 
-#: when-command.py:599
+#: when-command.py:623
 #, python-format
 msgid "Are you sure you want to delete task %s?"
 msgstr "Confermi di voler eliminare il task %s?"
 
-#: when-command.py:600
+#: when-command.py:624
 #, python-format
 msgid "Are you sure you want to delete condition %s?"
 msgstr "Confermi di voler eliminare la condizione %s?"
 
-#: when-command.py:601
+#: when-command.py:625
 #, python-format
 msgid "Are you sure you want to delete signal handler %s?"
 msgstr "Confermi di voler eliminare il gestore di segnali %s?"
 
-#: when-command.py:602
+#: when-command.py:626
+msgid "Are you sure you want to reset condition tests?"
+msgstr "Confermi di voler ripristinare i test delle condizioni?"
+
+#: when-command.py:627
 #, python-format
 msgid "Task %s could not be deleted."
 msgstr "Il task %s non può essere eliminato."
 
-#: when-command.py:603
+#: when-command.py:628
 #, python-format
 msgid "Condition %s could not be deleted."
 msgstr "La condizione %s non può essere eliminata."
 
-#: when-command.py:604
+#: when-command.py:629
 #, python-format
 msgid "Signal handler %s could not be deleted."
 msgstr "Il gestore di segnali %s non può essere eliminato."
 
-#: when-command.py:605
+#: when-command.py:630
 #, python-format
 msgid "Task %s could not be found."
 msgstr "Il task %s non è stato trovato."
 
-#: when-command.py:606
+#: when-command.py:631
 #, python-format
 msgid "Condition %s could not be found."
 msgstr "La condizione %s non è stata trovata."
 
-#: when-command.py:607
+#: when-command.py:632
 #, python-format
 msgid "Signal handler %s could not be found."
 msgstr "Il gestore di segnali %s non è stato trovato."
 
-#: when-command.py:608
+#: when-command.py:633
 #, 

commit scribus for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package scribus for openSUSE:Factory checked 
in at 2016-08-03 11:44:11

Comparing /work/SRC/openSUSE:Factory/scribus (Old)
 and  /work/SRC/openSUSE:Factory/.scribus.new (New)


Package is "scribus"

Changes:

--- /work/SRC/openSUSE:Factory/scribus/scribus.changes  2016-03-26 
15:24:16.0 +0100
+++ /work/SRC/openSUSE:Factory/.scribus.new/scribus.changes 2016-08-03 
11:44:22.0 +0200
@@ -1,0 +2,7 @@
+Thu Jul 28 16:16:26 UTC 2016 - badshah...@gmail.com
+
+- Add scribus.appdata.xml file and install it to the appdata dir;
+  this makes scribus appear in appstores like GNOME Software and
+  KDE Discover. 
+
+---

New:

  scribus.appdata.xml



Other differences:
--
++ scribus.spec ++
--- /var/tmp/diff_new_pack.4nKe4y/_old  2016-08-03 11:44:24.0 +0200
+++ /var/tmp/diff_new_pack.4nKe4y/_new  2016-08-03 11:44:24.0 +0200
@@ -30,6 +30,7 @@
 Source3:%{name}-icon64.png
 Source4:%{name}-icon128.png
 Source5:%{name}-icon256.png
+Source6:%{name}.appdata.xml
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  aspell
 BuildRequires:  aspell-devel
@@ -149,6 +150,9 @@
 %suse_update_desktop_file -i 
%{buildroot}%{_datadir}/mimelnk/application/vnd.scribus.desktop Office 
WordProcessor
 %endif
 
+# INSTALL APPSTREAM METAINFO (SOURCE6)
+install -Dm0644 %{S:6} %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
+
 #update the mime database
 
 %post
@@ -187,6 +191,8 @@
 %dir %{_datadir}/mimelnk/application
 %{_datadir}/mimelnk/application/vnd.scribus.desktop
 %{_datadir}/icons/hicolor/*/apps/%{name}.png
+%dir %{_datadir}/appdata
+%{_datadir}/appdata/%{name}.appdata.xml
 
 %files devel
 %defattr(-,root,root)






++ scribus.appdata.xml ++


  scribus.desktop
  CC0-1.0
  Scribus Page Layout (Development)
  GPL-2.0+
  Open Source Page Layout and Desktop Publishing (DTP)
  http://www.scribus.net/
  
Scribus is a open source page layout program which
produces commercial grade output in PDF and Postscript, primarily,
though not exclusively, for Linux.

While the goals of the program are ease of use and simple
easy-to-understand tools, Scribus support for professional
publishing features, such as CMYK and spot colors, easy PDF creation,
Encapsulated Postscript import and export and creation of color
separations.
  
  

  https://wiki.scribus.net/wiki/images/7/74/Help_rembrandt2.png
  Main Page


  https://wiki.scribus.net/wiki/images/6/6e/Help_rembrandt18.png
  Properties window


  https://wiki.scribus.net/wiki/images/5/56/Help_rembrandt16.png
  Image effects tab

  
  scribus-...@lists.scribus.net




commit devhelp for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package devhelp for openSUSE:Factory checked 
in at 2016-08-03 11:44:01

Comparing /work/SRC/openSUSE:Factory/devhelp (Old)
 and  /work/SRC/openSUSE:Factory/.devhelp.new (New)


Package is "devhelp"

Changes:

--- /work/SRC/openSUSE:Factory/devhelp/devhelp.changes  2016-03-29 
14:32:05.0 +0200
+++ /work/SRC/openSUSE:Factory/.devhelp.new/devhelp.changes 2016-08-03 
11:44:12.0 +0200
@@ -1,0 +2,5 @@
+Mon May  2 20:35:01 UTC 2016 - mgo...@suse.com
+
+- Update to GNOME 3.20  Fate#318572
+
+---



Other differences:
--



commit barbie_seahorse_adventures for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package barbie_seahorse_adventures for 
openSUSE:Factory checked in at 2016-08-03 11:44:28

Comparing /work/SRC/openSUSE:Factory/barbie_seahorse_adventures (Old)
 and  /work/SRC/openSUSE:Factory/.barbie_seahorse_adventures.new (New)


Package is "barbie_seahorse_adventures"

Changes:

--- 
/work/SRC/openSUSE:Factory/barbie_seahorse_adventures/barbie_seahorse_adventures.changes
2014-11-18 22:44:48.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.barbie_seahorse_adventures.new/barbie_seahorse_adventures.changes
   2016-08-03 11:44:45.0 +0200
@@ -1,0 +2,5 @@
+Sat Jul 30 14:41:26 UTC 2016 - mailaen...@opensuse.org
+
+- Add an appdata.xml metadata file.
+
+---

New:

  barbie_seahorse_adventures.appdata.xml



Other differences:
--
++ barbie_seahorse_adventures.spec ++
--- /var/tmp/diff_new_pack.Oq3ezG/_old  2016-08-03 11:44:47.0 +0200
+++ /var/tmp/diff_new_pack.Oq3ezG/_new  2016-08-03 11:44:47.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package barbie_seahorse_adventures
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,6 +26,7 @@
 Source0:http://www.imitationpickles.org/barbie/files/barbie-1.1.tgz
 Source1:%{name}.sh
 Source2:%{name}.desktop
+Source3:%{name}.appdata.xml
 %if 0%{?suse_version}
 BuildRequires:  fdupes
 BuildRequires:  hicolor-icon-theme
@@ -85,6 +86,9 @@
 # install Desktop file
 install -Dm 0644 %{S:2} %{buildroot}%{_datadir}/applications/%{name}.desktop
 
+# install app store metadata
+install -Dm 0644 %{S:3} %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
+
 %if 0%{?suse_version}
 %suse_update_desktop_file %{name}
 %fdupes -s %{buildroot}%{_prefix}
@@ -95,6 +99,8 @@
 %doc *.txt
 %{_bindir}/%{name}
 %{_datadir}/applications/%{name}.desktop
+%dir %{_datadir}/appdata/
+%{_datadir}/appdata/%{name}.appdata.xml
 %{_datadir}/icons/hicolor/
 %{_datadir}/pixmaps/%{name}.png
 %{_datadir}/%{name}




commit q4wine for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package q4wine for openSUSE:Factory checked 
in at 2016-08-03 11:44:25

Comparing /work/SRC/openSUSE:Factory/q4wine (Old)
 and  /work/SRC/openSUSE:Factory/.q4wine.new (New)


Package is "q4wine"

Changes:

--- /work/SRC/openSUSE:Factory/q4wine/q4wine.changes2016-03-17 
16:49:39.0 +0100
+++ /work/SRC/openSUSE:Factory/.q4wine.new/q4wine.changes   2016-08-03 
11:44:42.0 +0200
@@ -1,0 +2,17 @@
+Thu Jul 28 14:14:37 UTC 2016 - lazy.k...@opensuse.org
+
+- Update to 1.3.1.
+  * Added:
++ Allow to execute and create icons for *.bat and *.msi files.
++ Added Chinese (China) and Japanese translations.
+  * Fixed:
++ Renamed 'New' menu option for icon and prefix view to 'New
+icon' and 'New folder' respectively to avoid confusion.
++ Icon description is not exported into *.desktop file.
++ Winetrick's item description label doesn't wrap properly.
++ q4wine-cli does not accept extra app arguments.
++ Translation files moved from i18n to l10n.
++ Hide deprecated prefix options if values are not set.
+- Change the source URL to github.com.
+
+---

Old:

  q4wine-1.3.tar.bz2

New:

  q4wine-1.3.1.tar.gz



Other differences:
--
++ q4wine.spec ++
--- /var/tmp/diff_new_pack.4zxLx9/_old  2016-08-03 11:44:43.0 +0200
+++ /var/tmp/diff_new_pack.4zxLx9/_new  2016-08-03 11:44:43.0 +0200
@@ -16,16 +16,14 @@
 #
 
 
-%define my_fver 1.3
-
 Name:   q4wine
-Version:1.3
+Version:1.3.1
 Release:0
 Summary:Qt4 GUI for WINE
 License:GPL-3.0
 Group:  System/Emulators/PC
 Url:http://q4wine.brezblock.org.ua/
-Source0:
http://downloads.sourceforge.net/%{name}/%{name}-%{my_fver}.tar.bz2
+Source0:
https://github.com/brezerk/q4wine/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
 BuildRequires:  cmake >= 2.8.0
 BuildRequires:  fdupes
 BuildRequires:  fuseiso
@@ -67,7 +65,7 @@
 %lang_package
 
 %prep
-%setup -qn %{name}-%{my_fver}
+%setup -q
 
 %build
 mkdir build
@@ -100,7 +98,7 @@
 %doc AUTHORS ChangeLog COPYING README
 %{_bindir}/%{name}*
 %{_datadir}/%{name}/
-%exclude %{_datadir}/%{name}/i18n/
+%exclude %{_datadir}/%{name}/l10n/
 %{_datadir}/applications/%{name}.desktop
 %{_datadir}/icons/hicolor/*/*/*
 %{_libdir}/lib%{name}*
@@ -108,6 +106,6 @@
 
 %files lang -f %{name}.lang
 %defattr(-,root,root,-)
-%dir %{_datadir}/%{name}/i18n/
+%dir %{_datadir}/%{name}/l10n/
 
 %changelog




commit scummvm for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package scummvm for openSUSE:Factory checked 
in at 2016-08-03 11:44:21

Comparing /work/SRC/openSUSE:Factory/scummvm (Old)
 and  /work/SRC/openSUSE:Factory/.scummvm.new (New)


Package is "scummvm"

Changes:

--- /work/SRC/openSUSE:Factory/scummvm/scummvm.changes  2016-03-26 
15:27:09.0 +0100
+++ /work/SRC/openSUSE:Factory/.scummvm.new/scummvm.changes 2016-08-03 
11:44:38.0 +0200
@@ -1,0 +2,60 @@
+Fri Jul 29 17:51:04 UTC 2016 - mailaen...@opensuse.org
+
+- Update to 1.8.1 (maintenance release)
+  * General:
+- Removed TESTING flag from several supported games.
+- Added Chinese Pinyin translation.
+- Fixed cursor stuttering in the launcher that occured on some systems.
+  * BBVS:
+- Fixed game restart.
+  * CinE:
+- Fixed sound effect loading.
+  * Drascula:
+- Fixed text alignment to be faithful to the original.
+- Fixed character walking off screen.
+- Fixed loading savegames in the Pendulum scene.
+- Fixed wrong background for inventory items during chapter 6 in the
+ Spanish version.
+- Fixed animations speed (they were running two times slower than in the
+ original engine).
+- Fixed noise at start and/or end of speech. This was most noticeable
+ with the Spanish speech.
+- Fixed delay when interacting with the verb menu and the inventory.
+- Fixed possibility to pick up the axe in the castle multiple times.
+  * Gob:
+- Fixed lock up for some games during sound initialization.
+  * KYRA:
+- Fixed potential crash when using swamp snake potion on the rat in Hand
+ of Fate. (NOTE: This fix was included in version 1.8.0, but it was not
+ added to the NEWS file).
+- Fixed missing voice reactions when hitting enemies in CD version of
+ Lands of Lore.
+  * Lab:
+- Fixed lock-up during ending sequence.
+- Improved internal game controls.
+- Fixed lock-up during some in-game animations.
+  * SAGA:
+- Fixed user interface colors in the French and German versions of I Have 
No
+ Mouth and I Must Scream.
+  * SCI:
+- Make cursor workarounds work properly on OpenPandora (and other devices, 
that
+ support touch screen and analog sticks/mouse at the same time)
+- Script patch to fix broken ending battle in multilingual King's Quest 5
+ (French, German + Spanish versions are all broken)
+- Fixed invalid memory access, when loading broken King's Quest 5 credit 
music track
+- Fixed lowres/hires issues in King's Quest 6 when saving, changing the 
lowres/hires
+ setting and restoring the saved game afterwards.
+  * SCUMM:
+- Fixed detection of Maniac Mansion from Day of the Tentacle in the Windows
+ version of ScummVM.
+- Fixed a sound effect not stopping in Loom EGA with AdLib.
+  * Broken Sword 2.5:
+- Added option to use English speech instead of German one when no speech 
is
+ available for the selected language.
+- Fixed resource releasing on game exit.
+- Fixed game restart after language change in-game.
+- Fixed flickering in main Menu.
+- Fixed long save time on Windows.
+- Add appdata.xml.patch
+
+---

Old:

  scummvm-1.8.0.tar.xz

New:

  appdata.xml.patch
  scummvm-1.8.1.tar.xz



Other differences:
--
++ scummvm.spec ++
--- /var/tmp/diff_new_pack.nv5ICD/_old  2016-08-03 11:44:39.0 +0200
+++ /var/tmp/diff_new_pack.nv5ICD/_new  2016-08-03 11:44:39.0 +0200
@@ -20,13 +20,15 @@
 %bcond_with mp3
 
 Name:   scummvm
-Version:1.8.0
+Version:1.8.1
 Release:0
 Summary:Interpreter for several adventure games
 License:GPL-2.0+
 Group:  Amusements/Games/Other
 Url:http://www.scummvm.org/
 Source: 
http://www.scummvm.org/frs/scummvm/%{version}/scummvm-%{version}.tar.xz
+# PATCH-FEATURE-UPSTREAM https://github.com/scummvm/scummvm/pull/797
+Patch0: appdata.xml.patch
 BuildRequires:  desktop-file-utils
 BuildRequires:  gcc-c++
 BuildRequires:  hicolor-icon-theme
@@ -75,6 +77,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e 
%%Y')
 sed -i "s/__DATE__/\"$FAKE_BUILDDATE\"/" base/version.cpp 
backends/plugins/elf/version.cpp
 FAKE_BUILDTIME=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes 
'+%%H:%%M:%%S')
@@ -99,8 +102,6 @@
 
 %install
 %make_install
-# Since desktop-file-utils 0.19 (openSUSE 12.2) it automatically searches for 
%%{buildroot}
-desktop-file-install --dir=%{buildroot}%{_datadir}/applications/ 
dists/scummvm.desktop
 
 %post
 %icon_theme_cache_post
@@ -116,6 +117,8 @@
 %{_datadir}/scummvm

commit albert for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package albert for openSUSE:Factory checked 
in at 2016-08-03 11:44:32

Comparing /work/SRC/openSUSE:Factory/albert (Old)
 and  /work/SRC/openSUSE:Factory/.albert.new (New)


Package is "albert"

Changes:

--- /work/SRC/openSUSE:Factory/albert/albert.changes2016-05-30 
09:58:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.albert.new/albert.changes   2016-08-03 
11:44:52.0 +0200
@@ -1,0 +2,6 @@
+Sat Jul 23 16:15:39 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 0.8.10:
+  * No changelog available.
+
+---

Old:

  albert-0.8.9.tar.gz

New:

  albert-0.8.10.tar.gz



Other differences:
--
++ albert.spec ++
--- /var/tmp/diff_new_pack.SRknTC/_old  2016-08-03 11:44:53.0 +0200
+++ /var/tmp/diff_new_pack.SRknTC/_new  2016-08-03 11:44:53.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   albert
-Version:0.8.9
+Version:0.8.10
 Release:0
 Summary:Desktop agnostic launcher
 License:GPL-3.0+

++ albert-0.8.9.tar.gz -> albert-0.8.10.tar.gz ++
 2515 lines of diff (skipped)




commit ghc-asn1-parse for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package ghc-asn1-parse for openSUSE:Factory 
checked in at 2016-08-03 11:44:19

Comparing /work/SRC/openSUSE:Factory/ghc-asn1-parse (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-asn1-parse.new (New)


Package is "ghc-asn1-parse"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-asn1-parse/ghc-asn1-parse.changes
2015-10-06 13:24:21.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-asn1-parse.new/ghc-asn1-parse.changes   
2016-08-03 11:44:34.0 +0200
@@ -1,0 +2,5 @@
+Sun Jul 10 17:20:10 UTC 2016 - psim...@suse.com
+
+- Update to version 0.9.4 revision 0 with cabal2obs.
+
+---



Other differences:
--
++ ghc-asn1-parse.spec ++
--- /var/tmp/diff_new_pack.AB04br/_old  2016-08-03 11:44:36.0 +0200
+++ /var/tmp/diff_new_pack.AB04br/_new  2016-08-03 11:44:36.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ghc-asn1-parse
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,54 +17,48 @@
 
 
 %global pkg_name asn1-parse
-
-Name:   ghc-asn1-parse
+Name:   ghc-%{pkg_name}
 Version:0.9.4
 Release:0
 Summary:Simple monadic parser for ASN1 stream types
 License:BSD-3-Clause
 Group:  System/Libraries
-
 Url:https://hackage.haskell.org/package/%{pkg_name}
 Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-
 BuildRequires:  ghc-Cabal-devel
-BuildRequires:  ghc-rpm-macros
-# Begin cabal-rpm deps:
 BuildRequires:  ghc-asn1-encoding-devel
 BuildRequires:  ghc-asn1-types-devel
 BuildRequires:  ghc-bytestring-devel
-BuildRequires:  ghc-mtl-devel
-BuildRequires:  ghc-text-devel
-# End cabal-rpm deps
+BuildRequires:  ghc-rpm-macros
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 Simple monadic parser for ASN1 stream types, when ASN1 pattern matching is not
 convenient.
 
-
 %package devel
 Summary:Haskell %{pkg_name} library development files
 Group:  Development/Libraries/Other
+Requires:   %{name} = %{version}-%{release}
 Requires:   ghc-compiler = %{ghc_version}
 Requires(post): ghc-compiler = %{ghc_version}
 Requires(postun): ghc-compiler = %{ghc_version}
-Requires:   %{name} = %{version}-%{release}
 
 %description devel
 This package provides the Haskell %{pkg_name} library development files.
 
-
 %prep
 %setup -q -n %{pkg_name}-%{version}
 
+
 %build
 %ghc_lib_build
 
+
 %install
 %ghc_lib_install
 
+
 %post devel
 %ghc_pkg_recache
 




commit mozjs38 for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package mozjs38 for openSUSE:Factory checked 
in at 2016-08-03 11:44:10

Comparing /work/SRC/openSUSE:Factory/mozjs38 (Old)
 and  /work/SRC/openSUSE:Factory/.mozjs38.new (New)


Package is "mozjs38"

Changes:

--- /work/SRC/openSUSE:Factory/mozjs38/mozjs38.changes  2016-06-14 
23:08:49.0 +0200
+++ /work/SRC/openSUSE:Factory/.mozjs38.new/mozjs38.changes 2016-08-03 
11:44:20.0 +0200
@@ -1,0 +2,5 @@
+Fri Jul 29 15:29:23 UTC 2016 - norm...@linux.vnet.ibm.com
+
+- add _constraints for 7GB memory for ppc64le in Factory:PowerPC
+
+---

New:

  _constraints



Other differences:
--



commit qutebrowser for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package qutebrowser for openSUSE:Factory 
checked in at 2016-08-03 11:44:27

Comparing /work/SRC/openSUSE:Factory/qutebrowser (Old)
 and  /work/SRC/openSUSE:Factory/.qutebrowser.new (New)


Package is "qutebrowser"

Changes:

--- /work/SRC/openSUSE:Factory/qutebrowser/qutebrowser.changes  2016-06-12 
18:55:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.qutebrowser.new/qutebrowser.changes 
2016-08-03 11:44:43.0 +0200
@@ -1,0 +2,54 @@
+Sat Jul 30 15:12:32 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 0.8.1 (changes since 0.7.0):
+  * Add new ":repeat-command" command (mapped to ".") to repeat the
+last command.
+Note that two former default bundings conflict with that
+binding, unbinding them via ":unbind .i" and ":unbind .o" is
+recommended.
+  * Add new "qute:bookmarks" page which displays all bookmarks and
+quickmarks.
+  * Add new ":prompt-open-download" (bound to Ctrl-X) which can be
+used to open a download directly when getting the filename
+prompt.
+  * Add new "{host}" replacement for tab- and window titles which
+evaluates to the current host.
+  * Add new default binding ";t" for ":hint input".
+  * Add new variables "$QUTE_CONFIG_DIR", "$QUTE_DATA_DIR" and
+"$QUTE_DOWNLOAD_DIR" available for userscripts.
+  * Add new option "ui" -> "status-position" to configure the
+position of the status bar (top/bottom).
+  * Add new "--pdf " argument for ":print" WHICH can be
+used to generate a PDF without a dialog.
+  * ":scroll-perc" now prefers a count over the argument given to
+it, which means "gg" can be used with a count.
+  * Aliases can now use ";;" to have an alias which executed
+multiple commands.
+  * ":edit-url" now does nothing if the URL isn't changed in the
+spawned editor.
+  * ":bookmark-add" can now be passed a URL and title to add that
+as a bookmark rather than the current page.
+  * New "taskadd" userscript to add a taskwarrior task annotated
+with the current URL.
+  * ":bookmark-del" and ":quickmark-del" now delete the current
+page's URL if none is given.
+  * Fix compatibility with PyQt 5.7.
+  * Fix some configuration values being lost when a config option
+gets removed from qutebrowser's code.
+  * Fix a crash when downloading with a full drive.
+  * Fix using ":jump-mark" (e.g. '') when the current URL is
+invalid doesn't crash anymore.
+  * Fix a crash when pressing enter without a command.
+  * Remove the ability to display status messages from webpages, as
+well as the related "ui" -> "display-statusbar-messages"
+setting.
+  * Remove the "general" -> "wrap-search" setting as searches now
+always wrap.
+According to a quick straw poll and prior crash logs, almost
+nobody is using "wrap-search = false", and turning off wrapping
+is not possible with QtWebEngine.
+  * Remove ":edit-url" now doesn't accept a count anymore as its
+behaviour was confusing and it doesn't make much sense to add a
+count.
+
+---

Old:

  qutebrowser-0.7.0.tar.gz
  qutebrowser-0.7.0.tar.gz.asc

New:

  qutebrowser-0.8.1.tar.gz
  qutebrowser-0.8.1.tar.gz.asc



Other differences:
--
++ qutebrowser.spec ++
--- /var/tmp/diff_new_pack.oUVZra/_old  2016-08-03 11:44:44.0 +0200
+++ /var/tmp/diff_new_pack.oUVZra/_new  2016-08-03 11:44:44.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   qutebrowser
-Version:0.7.0
+Version:0.8.1
 Release:0
 Summary:Keyboard-driven vim-like browser on Qt5
 License:GPL-3.0+

++ qutebrowser-0.7.0.tar.gz -> qutebrowser-0.8.1.tar.gz ++
 21962 lines of diff (skipped)




commit djvusmooth for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package djvusmooth for openSUSE:Factory 
checked in at 2016-08-03 11:44:23

Comparing /work/SRC/openSUSE:Factory/djvusmooth (Old)
 and  /work/SRC/openSUSE:Factory/.djvusmooth.new (New)


Package is "djvusmooth"

Changes:

--- /work/SRC/openSUSE:Factory/djvusmooth/djvusmooth.changes2015-10-06 
13:25:42.0 +0200
+++ /work/SRC/openSUSE:Factory/.djvusmooth.new/djvusmooth.changes   
2016-08-03 11:44:40.0 +0200
@@ -1,0 +2,10 @@
+Thu Jul 28 14:30:48 UTC 2016 - lazy.k...@opensuse.org
+
+- Update to 0.2.17.
+  * Update the XDG Base Directory Specification URL.
+  * Fix typo in the Polish translation.
+  * Don't hardcode the Python interpreter path in script shebangs;
+use “#!/usr/bin/env python” instead.
+- Correct the source URL.
+
+---

Old:

  djvusmooth-0.2.16.tar.gz
  djvusmooth-0.2.16.tar.gz.asc

New:

  djvusmooth-0.2.17.tar.gz
  djvusmooth-0.2.17.tar.gz.asc



Other differences:
--
++ djvusmooth.spec ++
--- /var/tmp/diff_new_pack.1uPcK8/_old  2016-08-03 11:44:41.0 +0200
+++ /var/tmp/diff_new_pack.1uPcK8/_new  2016-08-03 11:44:41.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package djvusmooth
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,14 +17,14 @@
 
 
 Name:   djvusmooth
-Version:0.2.16
+Version:0.2.17
 Release:0
 Summary:Graphical Text Editor for DjVu
 License:GPL-2.0
 Group:  Productivity/Publishing/Other
 Url:http://jwilk.net/software/djvusmooth
-Source0:
http://pypi.python.org/packages/source/d/%{name}/%{name}-%{version}.tar.gz
-Source1:
http://pypi.python.org/packages/source/d/%{name}/%{name}-%{version}.tar.gz.asc
+Source0:
https://files.pythonhosted.org/packages/source/d/%{name}/%{name}-%{version}.tar.gz
+Source1:
https://files.pythonhosted.org/packages/source/d/%{name}/%{name}-%{version}.tar.gz.asc
 Source2:djvusmooth.png
 Source3:%{name}.keyring
 BuildRequires:  desktop-file-utils

++ djvusmooth-0.2.16.tar.gz -> djvusmooth-0.2.17.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/djvusmooth-0.2.16/PKG-INFO 
new/djvusmooth-0.2.17/PKG-INFO
--- old/djvusmooth-0.2.16/PKG-INFO  2015-09-15 11:18:15.0 +0200
+++ new/djvusmooth-0.2.17/PKG-INFO  2016-07-15 11:46:05.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: djvusmooth
-Version: 0.2.16
+Version: 0.2.17
 Summary: graphical editor for DjVu
 Home-page: http://jwilk.net/software/djvusmooth
 Author: Jakub Wilk
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/djvusmooth-0.2.16/djvusmooth 
new/djvusmooth-0.2.17/djvusmooth
--- old/djvusmooth-0.2.16/djvusmooth2015-08-18 10:06:54.0 +0200
+++ new/djvusmooth-0.2.17/djvusmooth2016-07-15 10:43:20.0 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
 # encoding=UTF-8
 
 # Copyright © 2008 Jakub Wilk 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/djvusmooth-0.2.16/doc/changelog 
new/djvusmooth-0.2.17/doc/changelog
--- old/djvusmooth-0.2.16/doc/changelog 2015-09-15 11:12:16.0 +0200
+++ new/djvusmooth-0.2.17/doc/changelog 2016-07-15 11:33:35.0 +0200
@@ -1,3 +1,12 @@
+djvusmooth (0.2.17) unstable; urgency=low
+
+  * Update the XDG Base Directory Specification URL.
+  * Fix typo in the Polish translation.
+  * Don't hardcode the Python interpreter path in script shebangs; use
+“#!/usr/bin/env python” instead.
+
+ -- Jakub Wilk   Fri, 15 Jul 2016 11:33:34 +0200
+
 djvusmooth (0.2.16) unstable; urgency=low
 
   * Drop support for Python 2.5.
@@ -5,7 +14,7 @@
   * Improve the manual page:
 + Use minus sign instead of hyphen in dates.
   * Remove python-djvulibre version checks.
-This fixes compatiblity with python-djvulibre ≥ 0.5.
+This fixes compatibility with python-djvulibre ≥ 0.5.
 Thanks to Daniel Stender for the bug report.
 https://bitbucket.org/jwilk/djvusmooth/issues/17
 
@@ -237,7 +246,7 @@
 
 djvusmooth (0.1.1) unstable; urgency=low
 
-  * Don't require pkg-config nor develoment files of DjVuLibre.
+  * Don't require pkg-config nor development files of DjVuLibre.
 
  -- Jakub Wilk   Wed, 14 May 2008 11:22:49 +0200
 
@@ -246,4 +255,3 @@
   * Initial 

commit lxc for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package lxc for openSUSE:Factory checked in 
at 2016-08-03 11:44:15

Comparing /work/SRC/openSUSE:Factory/lxc (Old)
 and  /work/SRC/openSUSE:Factory/.lxc.new (New)


Package is "lxc"

Changes:

--- /work/SRC/openSUSE:Factory/lxc/lxc.changes  2016-06-21 12:29:25.0 
+0200
+++ /work/SRC/openSUSE:Factory/.lxc.new/lxc.changes 2016-08-03 
11:44:29.0 +0200
@@ -1,0 +2,45 @@
+Sat Jul 23 07:49:02 UTC 2016 - jeng...@inai.de
+
+- Abolish old macro use. Remove ancient %clean section.
+  Avoid sh invocation for simple ldconfig calls.
+
+---
+Sat Jul  9 11:38:48 UTC 2016 - cbrau...@suse.de
+
+- add lxcfs dependency: lxc relies on lxcfs for a long time now to provide
+  container aware /proc files. The /sys/fs/cgroup part is slowly phased out
+  because we now have cgroup namespaces.
+
+---
+Sat Jul  9 06:01:58 UTC 2016 - cbrau...@suse.de
+
+- Split into packages to follow best practice.
+  * lxc
+  * liblxc1
+  * liblxc-devel
+  Also, we need liblxc1 to be separately installable from LXC for LXD.
+- Tweak descriptions.
+
+---
+Thu Jul  7 21:57:24 UTC 2016 - cbrau...@suse.de
+
+- Update to 2.0.3 (changes since 2.0.1):
+  * apparmor: Refresh generated file
+  * apparmor: add make-rslave to usr.bin.lxc-start
+  * apparmor: Allow bind-mounts and {r}shared/{r}private
+  * apparmor: allow mount move
+  * apparmor: Update mount states handling
+  * core: Drop lxc-devsetup as unneeded by current autodev
+  * core: Fix redefinition of struct in6_addr
+  * core: Include all lxcmntent.h function declarations on Bionic
+  * c/r: c/r: use criu's "full" mode for cgroups
+  * systemd: start containers in foreground when using the lxc@.service
+  * templates: debian: Make sure init is installed
+  * templates: oracle: Fix console login
+  * templates: plamo: Fix various issues
+  * templates: ubuntu: Install apt-transport-https by default
+  * travis: ensure 'make install' doesn't fail
+  * travis: test VPATH builds
+  * upstart: Force lxc-instance to behave like a good Upstart client
+
+---

Old:

  lxc-2.0.1.tar.gz

New:

  lxc-2.0.3.tar.gz



Other differences:
--
++ lxc.spec ++
--- /var/tmp/diff_new_pack.FZsDFk/_old  2016-08-03 11:44:30.0 +0200
+++ /var/tmp/diff_new_pack.FZsDFk/_new  2016-08-03 11:44:30.0 +0200
@@ -16,11 +16,12 @@
 #
 
 
+%defineshlib_version 1
 Name:   lxc
-Version:2.0.1
+Version:2.0.3
 Release:0
 Url:http://linuxcontainers.org/
-Summary:Userspace tools for the Linux kernel containers
+Summary:Userspace tools for Linux kernel containers
 License:LGPL-2.1+
 Group:  System/Management
 Source: http://linuxcontainers.org/downloads/%{name}-%{version}.tar.gz
@@ -49,6 +50,7 @@
 %endif
 
 Requires:   /sbin/setcap
+Requires:   lxcfs
 Requires:   rsync
 
 %{?systemd_requires}
@@ -57,23 +59,35 @@
 Recommends: criu >= 2.0
 
 %description
-It provides commands to create and manage containers. It contains a
-full featured container with the isolation/virtualization of the pids,
-the ipc, the utsname, the mount points, /proc, /sys, the network and it
-takes into account the control groups. It is very light, flexible, and
-provides a set of tools around the container like the monitoring with
-asynchronous events notification, or the freeze of the container. This
-package is useful to create Virtual Private Server, or to run isolated
-applications like bash or sshd.
+LXC provides commands to create and manage containers. Current LXC uses the
+following kernel features to contain processes:
+- Kernel namespaces (ipc, uts, mount, pid, network and user)
+- Apparmor and SELinux profiles
+- Seccomp policies
+- Chroots (using pivot_root)
+- Kernel capabilities
+- CGroups (control groups)
+LXC containers are often considered as something in the middle between a chroot
+and a full fledged virtual machine. The goal of LXC is to create an environment
+as close as possible to a standard Linux installation but without the need for 
a
+separate kernel.
 
-%package devel
-Summary:Development library for lxc
+%package -n liblxc%{shlib_version}
+Summary:LXC container runtime library
+License:LGPL-2.1
+Group:  System/Libraries
+
+%description -n liblxc%{shlib_version}
+Provides the LXC container runtime library.
+
+%package -n liblxc-devel
+Summary:LXC container runtime library development files
 

commit krita for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package krita for openSUSE:Factory checked 
in at 2016-08-03 11:44:13

Comparing /work/SRC/openSUSE:Factory/krita (Old)
 and  /work/SRC/openSUSE:Factory/.krita.new (New)


Package is "krita"

Changes:

--- /work/SRC/openSUSE:Factory/krita/krita.changes  2016-07-26 
13:13:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.krita.new/krita.changes 2016-08-03 
11:44:24.0 +0200
@@ -1,0 +2,6 @@
+Thu Jul 21 16:58:30 UTC 2016 - wba...@tmo.at
+
+- Add kcrash-devel build requirement to enable the crash report
+  dialog (not on 13.2 though as the available kcrash is too old)
+
+---



Other differences:
--
++ krita.spec ++
--- /var/tmp/diff_new_pack.fUxoZu/_old  2016-08-03 11:44:28.0 +0200
+++ /var/tmp/diff_new_pack.fUxoZu/_new  2016-08-03 11:44:28.0 +0200
@@ -1,5 +1,5 @@
 #
-# spec file for package calligra
+# spec file for package krita
 #
 # Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
@@ -29,6 +29,7 @@
 BuildRequires:  OpenEXR-devel
 %if %{suse_version} != 1320
 BuildRequires:  Vc-devel-static
+BuildRequires:  kcrash-devel
 %endif
 BuildRequires:  boost-devel
 BuildRequires:  extra-cmake-modules




commit ghc-appar for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package ghc-appar for openSUSE:Factory 
checked in at 2016-08-03 11:44:17

Comparing /work/SRC/openSUSE:Factory/ghc-appar (Old)
 and  /work/SRC/openSUSE:Factory/.ghc-appar.new (New)


Package is "ghc-appar"

Changes:

--- /work/SRC/openSUSE:Factory/ghc-appar/ghc-appar.changes  2015-09-17 
09:19:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.ghc-appar.new/ghc-appar.changes 2016-08-03 
11:44:31.0 +0200
@@ -1,0 +2,5 @@
+Sun Jul 10 17:04:54 UTC 2016 - psim...@suse.com
+
+- Update to version 0.1.4 revision 0 with cabal2obs.
+
+---



Other differences:
--
++ ghc-appar.spec ++
--- /var/tmp/diff_new_pack.ABTc9P/_old  2016-08-03 11:44:32.0 +0200
+++ /var/tmp/diff_new_pack.ABTc9P/_new  2016-08-03 11:44:32.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ghc-appar
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,41 +15,35 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
-%global pkg_name appar
 
-Name:   ghc-appar
+%global pkg_name appar
+Name:   ghc-%{pkg_name}
 Version:0.1.4
 Release:0
 Summary:A simple applicative parser
-Group:  System/Libraries
-
 License:BSD-3-Clause
+Group:  System/Libraries
 Url:https://hackage.haskell.org/package/%{pkg_name}
 Source0:
https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-
 BuildRequires:  ghc-Cabal-devel
-BuildRequires:  ghc-rpm-macros
-# Begin cabal-rpm deps:
 BuildRequires:  ghc-bytestring-devel
-# End cabal-rpm deps
+BuildRequires:  ghc-rpm-macros
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
 A simple applicative parser in Parsec style.
 
-
 %package devel
 Summary:Haskell %{pkg_name} library development files
 Group:  Development/Libraries/Other
+Requires:   %{name} = %{version}-%{release}
 Requires:   ghc-compiler = %{ghc_version}
 Requires(post): ghc-compiler = %{ghc_version}
 Requires(postun): ghc-compiler = %{ghc_version}
-Requires:   %{name} = %{version}-%{release}
 
 %description devel
 This package provides the Haskell %{pkg_name} library development files.
 
-
 %prep
 %setup -q -n %{pkg_name}-%{version}
 
@@ -65,19 +59,15 @@
 %post devel
 %ghc_pkg_recache
 
-
 %postun devel
 %ghc_pkg_recache
 
-
 %files -f %{name}.files
 %defattr(-,root,root,-)
 %doc LICENSE
 
-
 %files devel -f %{name}-devel.files
 %defattr(-,root,root,-)
 %doc README
 
-
 %changelog




commit syncthing for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package syncthing for openSUSE:Factory 
checked in at 2016-08-03 11:44:05

Comparing /work/SRC/openSUSE:Factory/syncthing (Old)
 and  /work/SRC/openSUSE:Factory/.syncthing.new (New)


Package is "syncthing"

Changes:

--- /work/SRC/openSUSE:Factory/syncthing/syncthing.changes  2016-07-28 
23:47:41.0 +0200
+++ /work/SRC/openSUSE:Factory/.syncthing.new/syncthing.changes 2016-08-03 
11:44:16.0 +0200
@@ -1,0 +2,11 @@
+Thu Jul 28 13:03:46 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 0.14.3:
+  * Devices no longer get stuck in "out of sync" after a
+disconnection.
+  * Syncthing no longer crashes when a connection is lost before
+index sending has started.
+  * Temporary index databases are now created in the home (config)
+directory, not the system temporary directory.
+
+---

Old:

  syncthing-source-v0.14.2.tar.gz
  syncthing-source-v0.14.2.tar.gz.asc

New:

  syncthing-source-v0.14.3.tar.gz
  syncthing-source-v0.14.3.tar.gz.asc



Other differences:
--
++ syncthing.spec ++
--- /var/tmp/diff_new_pack.4rplTD/_old  2016-08-03 11:44:17.0 +0200
+++ /var/tmp/diff_new_pack.4rplTD/_new  2016-08-03 11:44:17.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   syncthing
-Version:0.14.2
+Version:0.14.3
 Release:0
 Summary:FOSS Continuous File Synchronisation
 License:MPL-2.0

++ syncthing-source-v0.14.2.tar.gz -> syncthing-source-v0.14.3.tar.gz ++
/work/SRC/openSUSE:Factory/syncthing/syncthing-source-v0.14.2.tar.gz 
/work/SRC/openSUSE:Factory/.syncthing.new/syncthing-source-v0.14.3.tar.gz 
differ: char 5, line 1

++ syncthing.keyring ++
--- /var/tmp/diff_new_pack.4rplTD/_old  2016-08-03 11:44:17.0 +0200
+++ /var/tmp/diff_new_pack.4rplTD/_new  2016-08-03 11:44:17.0 +0200
@@ -5,7 +5,7 @@
 sub   rsa4096/37C86D31 2015-05-11 [S] [expires: 2025-05-08]
 
 -BEGIN PGP PUBLIC KEY BLOCK-
-Version: GnuPG v2
+Version: GnuPG v1
 
 mQENBFShFd8BCADHQq9byO6uehb51iieKKi2KEwudhkbV74r8ZsGp0Q3asmv6cPl
 EFLKXCs9vm9f0Qn58up44ikd/782Gu7CQoFBM/DGj1SGXpWRj7fd6nnErA5JUiUz
@@ -13,99 +13,36 @@
 grjt9afTlvDOfBN5GBeLYetByvza3JGt9kwn9z1ryhssyVHur+uXvJq7CuXJzImU
 E4QW9fwjeOHFFBQevYMVHhnlVgXGQ/fNmYW+MeXG4GE8viyRuv0asRwMjp+1zpP1
 EvAM/Z8Y9Udv1DvSTjonET3G9fOyNfU3HNcvABEBAAG0NFN5bmN0aGluZyBSZWxl
-YXNlIE1hbmFnZW1lbnQgPHJlbGVhc2VAc3luY3RoaW5nLm5ldD6JARwEEAECAAYF
-AlTL3NcACgkQflBih61J898+oAgA0MFLW3LVxyf9YgB4YWJcJsklt5IAEih0gqM4
-i3bvsC/1fssoP+A/dyBPAdBYvhao1PA93IfmjH9mtkHbHetfWt2D3ua9brFZRKrW
-2luK5CFONddsQ5WB0w75lpk5f0+fWZZWM8uY6IqN6rpmTylNDZNAwmxE91lpK/Em
-fk41NMfqvrU5O8GPPmHekHGgE1P4/ogMFhjAiOMUpXxJ2lvqn183OyYyt/J5agP3
-45Rspv6b7j7OOEqeJ16yM0+IYdo5Kbol/BMrlS6dIaUtwjDgED1W1H8ELgxIs5Ni
-1F2nuuqre3ABAj9lTJVNquh4Blf/nGKSinLKeXPOcO//foHmSYkBHAQQAQgABgUC
-VY6g2QAKCRBEKR9q2+X/P29ZCACvCg/SyTP50FA/26qQR27h0VhIAFehbBzyc4hs
-z3zSiJ6p+UXKpJfUCooxpUyZ8GP2DvFkB+5GTz91ldUR6q0/JZFDlHIgBiOmplrC
-pYVuNzQpw7n5Uy7lHLWJsNLPmhhK26DAg/OBRYgoN1MIKe16dD65o8U+fDDNvek7
-fG0jaVrrrdejAK94ClWEYW5SVRilAB8HWMH/1pmaAM0+ry2RhnAneiMO/IO+XGkF
-W6+mHpKW5Br55N94G+FiCzIuNHYANLj2vtXyTijSr0RduCOQlIqayimwL02Z044h
-d+VsxVp+kD+5fS5OQSD2/gG0C6mrtNFH9hC51UF7eE+UN/y0iQE4BBMBAgAiBQJU
-oRXfAhsDBgsJCAcDAgYVCAIJCgsEFgIDAQIeAQIXgAAKCRDSbm7QAGVKPl67CACp
-PVLIIOkf+v7X6IXU41fYKXjJ/gabz+W6EwBFnUwxdGs4NOmgLdHp4K1ZG8Bu9DX/
-Simw3Eg2VCbNZGVatUyb6NyZ0fg8NGvQHBL2Psw0XBrh5iI3XouULWjLFQfvG80d
-Jrl9WEcNDIZ3B4OG7xM1na1kR2a+9ba1Sk5tr/8VtgXdSiZs1L/w9g4zC9zS+0pG
-2TB5qk1hPYzaEmo5cXSLGUTNEG80RBJAvefyDWmbytZ/I2NX6G2OagMdpJ86eki8
-fE2pjfEXAAgIZFeNzZxQnW94YROlttsSuwRcA0r6FL5vsYvTSVi4OlFj1UgD7ehG
-/0XbVJV8dOWsEeh8zf3UiQIcBBABAgAGBQJUoRXtAAoJEEn1rsC85STHcx8P/RCA
-wZzkyXQs0Oxk1GY1EG3cNpd2poCLyYiBVcI978zSFSwDnAgHo94wYmaVMPQf9jps
-92N6jHm+FNED+RKQTwjZpFYmfx74PUeWsVqG577F08sUzASai+yCeFuD6yqHiFt4
-ozbY+W+ZOPg6TCrZmeyNbtseQknpOr8w8UcWqqSyCRaXVBkQSn3lcZm9kEGyKkJg
-wWRhGiuSAnxXoDRmGXclaoOxf7a95jDjlp7jtWhYah0Do7WZhuE36Y63ay2djOKm
-0X9DA+nZDp7YRr2V7WOgce4K16prZE+ffPmEZt2CuPSrwogDqYvZwsT5dySdFc/T
-GlsdmPDg8zf7DmKLOj8Zz3ZT98VUgjssXXoI6m6PSEMHoNxHLlc5MoRVnSDosQOa
-odvBNVrp/sCNUdBPb30hV171SXkkP1oZPnxgyhJCcYqfyKAqNeNQzSo/8Cd8UrNN
-706rU8Df7j3SLAm1kUqhupi9QDoIuujXxYk+lrua7vxfuqdFzyQ+QC95heIchYQL
-QP6CgGBrOhVh6Pum5uQQbpJUkDCWwrfP0+CxP0FhSrSSzHpziAgK8AcKkqPFlzY8
-i450XUKTE1Liht+iUsjFnS5jKuBQUiAo5Dijkf+EQpiEfoS+JuJX43PxRMjHtIyg
-MfDbuMM6aKlB8oLJY8BI5n8w3Se0tjERtNBB87u3iQIcBBABAgAGBQJVneULAAoJ
-ECngR5uZyKOXhjkQAIbWQyXer4hxjSkWgb7s45zQZZzXGqlZr45QNjWGAtaGc6dL
-ynrY+fXtnpvPz8hQmnV7+segHUAFNh15seHN6+xRsafx5xbH1j4SbOIyWUqz9Tio
-oEVx8GoPvf4dVDHjqLWIahuT54b7gsYQM2AJ4OGCDYRihaqMSXmkzqMgWcatjpDQ

commit sysbench for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package sysbench for openSUSE:Factory 
checked in at 2016-08-03 11:43:42

Comparing /work/SRC/openSUSE:Factory/sysbench (Old)
 and  /work/SRC/openSUSE:Factory/.sysbench.new (New)


Package is "sysbench"

Changes:

--- /work/SRC/openSUSE:Factory/sysbench/sysbench.changes2016-06-14 
23:08:02.0 +0200
+++ /work/SRC/openSUSE:Factory/.sysbench.new/sysbench.changes   2016-08-03 
11:43:53.0 +0200
@@ -1,0 +2,6 @@
+Fri Jul 22 07:05:46 UTC 2016 - mplus...@suse.com
+
+- Update to version 0.5.0+git.20160721:
+  * Fixes #57: Race condition in sb_timer_value()
+
+---

Old:

  sysbench-0.5.0+git.20160610.tar.xz

New:

  sysbench-0.5.0+git.20160721.tar.xz



Other differences:
--
++ sysbench.spec ++
--- /var/tmp/diff_new_pack.BZOHRC/_old  2016-08-03 11:43:54.0 +0200
+++ /var/tmp/diff_new_pack.BZOHRC/_new  2016-08-03 11:43:54.0 +0200
@@ -16,9 +16,9 @@
 #
 
 
-%define version_unconverted 0.5.0+git.20160610
+%define version_unconverted 0.5.0+git.20160721
 Name:   sysbench
-Version:0.5.0+git.20160610
+Version:0.5.0+git.20160721
 Release:0
 Summary:A MySQL benchmarking tool
 License:GPL-2.0
@@ -58,9 +58,12 @@
 %install
 %make_install
 help2man ./sysbench/sysbench > sysbench.1
-install -D -m 0644 sysbench.1 %{buildroot}%{_mandir}/man1/sysbench.1
-install -D -m 0755 sysbench-example-tests/sysbench-example-test   
%{buildroot}%{_datadir}/sysbench/sysbench-example-test
-install -D -m 0755 sysbench-example-tests/sysbench-example-all-tests  
%{buildroot}%{_datadir}/sysbench/sysbench-example-all-tests
+install -D -p -m 0644 sysbench.1 \
+  %{buildroot}%{_mandir}/man1/sysbench.1
+install -D -p -m 0755 sysbench-example-tests/sysbench-example-test \
+  %{buildroot}%{_datadir}/sysbench/sysbench-example-test
+install -D -p -m 0755 sysbench-example-tests/sysbench-example-all-tests \
+  %{buildroot}%{_datadir}/sysbench/sysbench-example-all-tests
 rm -rf %{buildroot}%{_datadir}/doc/sysbench
 
 %files

++ sysbench-0.5.0+git.20160610.tar.xz -> sysbench-0.5.0+git.20160721.tar.xz 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/sysbench-0.5.0+git.20160610/sysbench/sb_timer.c 
new/sysbench-0.5.0+git.20160721/sysbench/sb_timer.c
--- old/sysbench-0.5.0+git.20160610/sysbench/sb_timer.c 2016-06-12 
11:31:03.0 +0200
+++ new/sysbench-0.5.0+git.20160721/sysbench/sb_timer.c 2016-07-21 
11:27:35.0 +0200
@@ -130,11 +130,16 @@
 }
 
 
-/* get the current timer value in nanoseconds */
+/*
+   get the current timer value in nanoseconds without affecting is state, i.e.
+   is safe to be used concurrently on a shared timer.
+*/
 
 
 unsigned long long  sb_timer_value(sb_timer_t *t)
 {
+  struct timespec ts;
+
   switch (t->state) {
 case TIMER_INITIALIZED:
   log_text(LOG_WARNING, "timer was never started");
@@ -148,9 +153,8 @@
   abort();
   }
 
-  sb_timer_update(t);
-
-  return t->elapsed;
+  SB_GETTIME();
+  return TIMESPEC_DIFF(ts, t->time_start) + t->queue_time;
 }
 
 




commit psi+ for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package psi+ for openSUSE:Factory checked in 
at 2016-08-03 11:43:49

Comparing /work/SRC/openSUSE:Factory/psi+ (Old)
 and  /work/SRC/openSUSE:Factory/.psi+.new (New)


Package is "psi+"

Changes:

--- /work/SRC/openSUSE:Factory/psi+/psi+.changes2016-06-19 
10:49:23.0 +0200
+++ /work/SRC/openSUSE:Factory/.psi+.new/psi+.changes   2016-08-03 
11:44:04.0 +0200
@@ -1,0 +2,8 @@
+Fri Jul 29 11:17:21 UTC 2016 - jsl...@suse.com
+
+- obsolete deleted psi (bnc#990894)
+- update to 20160727
+  * updated translations
+  * some bugfixes
+
+---

Old:

  psi+-20160607.tar.xz

New:

  psi+-20160727.tar.xz



Other differences:
--
++ psi+.spec ++
--- /var/tmp/diff_new_pack.nvY6aq/_old  2016-08-03 11:44:05.0 +0200
+++ /var/tmp/diff_new_pack.nvY6aq/_new  2016-08-03 11:44:05.0 +0200
@@ -20,11 +20,11 @@
 %define with_qt5 1
 %endif
 
-%define version_unconverted 20160607
+%define version_unconverted 20160727
 
 Name:   psi+
 Url:https://github.com/psi-plus
-Version:20160607
+Version:20160727
 Release:0
 Summary:Jabber client using Qt
 License:GPL-2.0+
@@ -70,6 +70,7 @@
 Requires:   %{name}-icons = %{version}
 Requires:   %{name}-sounds = %{version}
 Requires:   %{name}-themes = %{version}
+Obsoletes:  psi
 
 %define iconspath %{_datadir}/psi-plus/iconsets
 %define pluginspath %{_libdir}/psi-plus/plugins

++ psi+-20160607.tar.xz -> psi+-20160727.tar.xz ++
/work/SRC/openSUSE:Factory/psi+/psi+-20160607.tar.xz 
/work/SRC/openSUSE:Factory/.psi+.new/psi+-20160727.tar.xz differ: char 26, line 
1

++ psi-plus-l10n-1.tar.xz ++
 1839 lines of diff (skipped)




commit paraview for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package paraview for openSUSE:Factory 
checked in at 2016-08-03 11:43:38

Comparing /work/SRC/openSUSE:Factory/paraview (Old)
 and  /work/SRC/openSUSE:Factory/.paraview.new (New)


Package is "paraview"

Changes:

--- /work/SRC/openSUSE:Factory/paraview/paraview.changes2016-06-25 
02:22:40.0 +0200
+++ /work/SRC/openSUSE:Factory/.paraview.new/paraview.changes   2016-08-03 
11:43:43.0 +0200
@@ -1,0 +2,15 @@
+Fri Jul 29 05:13:00 UTC 2016 - f...@grueninger.de
+
+- update to version 5.1.2
+  * Rendering translucent geometries: fixed client-server configurations
+when rendering remotely and resolved issues with multiple windows/views
+were present.
+  * Exodus reader: Fixed bug in Exodus reader which was causing the reader to
+improperly read files with no timesteps.
+  * Fixed the “?” button to show filter documentation.
+  * Add option to Ghost Cells Generator filter to specify the number of ghost
+levels to generate.
+  * Cinema Fixed SpecB was not revolving the camera around the data centroid.
+- adjust require-only-cmake-3_0.patch
+
+---
@@ -13 +28 @@
-- add require-only-cmake-3_0.patch to lower required CMake verstion
+- add require-only-cmake-3_0.patch to lower required CMake version

Old:

  ParaView-v5.1.0.tar.gz

New:

  ParaView-v5.1.2.tar.gz



Other differences:
--
++ paraview.spec ++
--- /var/tmp/diff_new_pack.YX75NR/_old  2016-08-03 11:43:45.0 +0200
+++ /var/tmp/diff_new_pack.YX75NR/_new  2016-08-03 11:43:45.0 +0200
@@ -18,7 +18,7 @@
 
 %define major_ver 5.1
 Name:   paraview
-Version:5.1.0
+Version:5.1.2
 Release:0
 Summary:Data analysis and visualization application
 License:BSD-3-Clause

++ ParaView-v5.1.0.tar.gz -> ParaView-v5.1.2.tar.gz ++
/work/SRC/openSUSE:Factory/paraview/ParaView-v5.1.0.tar.gz 
/work/SRC/openSUSE:Factory/.paraview.new/ParaView-v5.1.2.tar.gz differ: char 5, 
line 1

++ require-only-cmake-3_0.patch ++
--- /var/tmp/diff_new_pack.YX75NR/_old  2016-08-03 11:43:45.0 +0200
+++ /var/tmp/diff_new_pack.YX75NR/_new  2016-08-03 11:43:45.0 +0200
@@ -4,7 +4,7 @@
  #  SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  #
  #==
--cmake_minimum_required(VERSION 3.5)
+-cmake_minimum_required(VERSION 3.3)
 +cmake_minimum_required(VERSION 3.0)
  
  project(ParaView)




commit fontawesome-fonts for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package fontawesome-fonts for 
openSUSE:Factory checked in at 2016-08-03 11:43:57

Comparing /work/SRC/openSUSE:Factory/fontawesome-fonts (Old)
 and  /work/SRC/openSUSE:Factory/.fontawesome-fonts.new (New)


Package is "fontawesome-fonts"

Changes:

--- /work/SRC/openSUSE:Factory/fontawesome-fonts/fontawesome-fonts.changes  
2016-02-12 11:22:45.0 +0100
+++ /work/SRC/openSUSE:Factory/.fontawesome-fonts.new/fontawesome-fonts.changes 
2016-08-03 11:44:11.0 +0200
@@ -1,0 +2,18 @@
+Fri Jul 29 12:39:11 UTC 2016 - p...@cervinka.net
+
+- Updated to version 4.6.3
+   * Fixed  fa-instagram 
+   * Updated google plus icon
+- Changes in version 4.6.2
+   * Updated pied-piper logo
+   * New icon fa-first-order
+- Changes in version 4.6.1
+   * Fixed aria-hidden attribute
+   * Fixed invalid US-ASCII character "\xC3"
+- Changes in major version 4.6.0
+   * 30 new icons
+   * New Icon Category: Accessibility
+   * Fixes in CSS, SCSS and Less
+   * Fixed icon "1px size taller" issue introduced in 4.5.0
+
+---

Old:

  font-awesome-4.5.0.zip

New:

  font-awesome-4.6.3.zip



Other differences:
--
++ fontawesome-fonts.spec ++
--- /var/tmp/diff_new_pack.FnyafQ/_old  2016-08-03 11:44:12.0 +0200
+++ /var/tmp/diff_new_pack.FnyafQ/_new  2016-08-03 11:44:12.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   fontawesome-fonts
-Version:4.5.0
+Version:4.6.3
 Release:0
 Summary:Iconic font set
 License:OFL-1.1




commit gnome-mpv for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package gnome-mpv for openSUSE:Factory 
checked in at 2016-08-03 11:43:45

Comparing /work/SRC/openSUSE:Factory/gnome-mpv (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-mpv.new (New)


Package is "gnome-mpv"

Changes:

--- /work/SRC/openSUSE:Factory/gnome-mpv/gnome-mpv.changes  2016-05-30 
09:56:50.0 +0200
+++ /work/SRC/openSUSE:Factory/.gnome-mpv.new/gnome-mpv.changes 2016-08-03 
11:43:58.0 +0200
@@ -1,0 +2,6 @@
+Fri Jul 29 10:31:00 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 0.10:
+  * No changelog available.
+
+---

Old:

  gnome-mpv-0.9.tar.xz

New:

  gnome-mpv-0.10.tar.xz



Other differences:
--
++ gnome-mpv.spec ++
--- /var/tmp/diff_new_pack.EN2bfl/_old  2016-08-03 11:44:00.0 +0200
+++ /var/tmp/diff_new_pack.EN2bfl/_new  2016-08-03 11:44:00.0 +0200
@@ -18,7 +18,7 @@
 
 %define _name   GnomeMpv
 Name:   gnome-mpv
-Version:0.9
+Version:0.10
 Release:0
 Summary:Simple GTK+ frontend for MPV
 License:GPL-3.0+

++ gnome-mpv-0.9.tar.xz -> gnome-mpv-0.10.tar.xz ++
 13098 lines of diff (skipped)




commit osc for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package osc for openSUSE:Factory checked in 
at 2016-08-03 11:44:04

Comparing /work/SRC/openSUSE:Factory/osc (Old)
 and  /work/SRC/openSUSE:Factory/.osc.new (New)


Package is "osc"

Changes:

--- /work/SRC/openSUSE:Factory/osc/osc.changes  2016-06-25 02:22:09.0 
+0200
+++ /work/SRC/openSUSE:Factory/.osc.new/osc.changes 2016-08-03 
11:44:13.0 +0200
@@ -1,0 +2,13 @@
+Fri Jul 29 14:05:52 UTC 2016 - adr...@suse.de
+
+- 0.155.0
+  - osc service runall: runs all service local, independend of the mode
+This allows to create local files even when disabled or
+just created at buildtime
+  - support snapcraft.yaml build descriptions
+  - "osc add" of a directory offers to create an archive for uploading it
+  - support usage or preinstall images in local builds
+  - revision control options for "meta prj"
+  - bugfixes and documentation updates
+
+---

Old:

  osc-0.154.0.tar.gz

New:

  osc-0.155.0.tar.gz



Other differences:
--
++ osc.spec ++
--- /var/tmp/diff_new_pack.gGO23M/_old  2016-08-03 11:44:14.0 +0200
+++ /var/tmp/diff_new_pack.gGO23M/_new  2016-08-03 11:44:14.0 +0200
@@ -16,10 +16,10 @@
 #
 
 
-%define version_unconverted 0.154.0
+%define version_unconverted 0.155.0
 
 Name:   osc
-Version:0.154.0
+Version:0.155.0
 Release:0
 Summary:Open Build Service Commander
 License:GPL-2.0+

++ PKGBUILD ++
--- /var/tmp/diff_new_pack.gGO23M/_old  2016-08-03 11:44:14.0 +0200
+++ /var/tmp/diff_new_pack.gGO23M/_new  2016-08-03 11:44:14.0 +0200
@@ -1,5 +1,5 @@
 pkgname=osc
-pkgver=0.154.0
+pkgver=0.155.0
 pkgrel=0
 pkgdesc="Open Build Service client"
 arch=('i686' 'x86_64')

++ _service ++
--- /var/tmp/diff_new_pack.gGO23M/_old  2016-08-03 11:44:14.0 +0200
+++ /var/tmp/diff_new_pack.gGO23M/_new  2016-08-03 11:44:14.0 +0200
@@ -1,7 +1,7 @@
 
   
-0.154.0
-0.154.0
+0.155.0
+0.155.0
 git://github.com/openSUSE/osc.git
 git
   

++ debian.changelog ++
--- /var/tmp/diff_new_pack.gGO23M/_old  2016-08-03 11:44:14.0 +0200
+++ /var/tmp/diff_new_pack.gGO23M/_new  2016-08-03 11:44:14.0 +0200
@@ -1,4 +1,4 @@
-osc (0.154.0) unstable; urgency=low
+osc (0.155.0) unstable; urgency=low
   - Update to 0.135.0
 
  -- Adrian Schroeter   Wed, 28 Jun 2012 10:00:00 +0200

++ osc-0.154.0.tar.gz -> osc-0.155.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/osc-0.154.0/NEWS new/osc-0.155.0/NEWS
--- old/osc-0.154.0/NEWS2016-04-11 10:49:56.0 +0200
+++ new/osc-0.155.0/NEWS2016-07-29 16:03:59.0 +0200
@@ -1,3 +1,13 @@
+0.155
+  - osc service runall: runs all service local, independend of the mode
+This allows to create local files even when disabled or
+just created at buildtime
+  - support snapcraft.yaml build descriptions
+  - "osc add" of a directory offers to create an archive for uploading it
+  - support usage or preinstall images in local builds
+  - revision control options for "meta prj"
+  - bugfixes and documentation updates
+
 0.154
   - switch to new obs_scm service when adding git URL's
   - set OSC_VERSION environment for source services
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/osc-0.154.0/dist/osc.complete 
new/osc-0.155.0/dist/osc.complete
--- old/osc-0.154.0/dist/osc.complete   2016-04-11 10:49:56.0 +0200
+++ new/osc-0.155.0/dist/osc.complete   2016-07-29 16:03:59.0 +0200
@@ -91,7 +91,7 @@
 lnkprj=$(command sed -rn 
'/ 
/dev/null)
 fi
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/osc-0.154.0/osc/babysitter.py 
new/osc-0.155.0/osc/babysitter.py
--- old/osc-0.154.0/osc/babysitter.py   2016-04-11 10:49:56.0 +0200
+++ new/osc-0.155.0/osc/babysitter.py   2016-07-29 16:03:59.0 +0200
@@ -78,7 +78,7 @@
 return 1
 except KeyboardInterrupt:
 print('interrupted!', file=sys.stderr)
-return 1
+return 130
 except oscerr.UserAbort:
 print('aborted.', file=sys.stderr)
 return 1
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/osc-0.154.0/osc/build.py new/osc-0.155.0/osc/build.py
--- old/osc-0.154.0/osc/build.py2016-04-11 10:49:56.0 +0200
+++ new/osc-0.155.0/osc/build.py2016-07-29 16:03:59.0 +0200
@@ -33,6 +33,11 @@
 
 from .conf 

commit libtorrent-rasterbar for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libtorrent-rasterbar for 
openSUSE:Factory checked in at 2016-08-03 11:44:07

Comparing /work/SRC/openSUSE:Factory/libtorrent-rasterbar (Old)
 and  /work/SRC/openSUSE:Factory/.libtorrent-rasterbar.new (New)


Package is "libtorrent-rasterbar"

Changes:

--- 
/work/SRC/openSUSE:Factory/libtorrent-rasterbar/libtorrent-rasterbar.changes
2016-07-27 16:12:25.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.libtorrent-rasterbar.new/libtorrent-rasterbar.changes
   2016-08-03 11:44:18.0 +0200
@@ -1,0 +2,7 @@
+Fri Jul 29 12:14:17 UTC 2016 - norm...@linux.vnet.ibm.com
+
+- new libtorrent-rasterbar-1.1.0-add_ppc64le_as_64_bit_system_libraries.patch
+  to allow ppc64le build.
+  provided upstream https://github.com/arvidn/libtorrent/pull/967
+
+---

New:

  libtorrent-rasterbar-1.1.0-add_ppc64le_as_64_bit_system_libraries.patch



Other differences:
--
++ libtorrent-rasterbar.spec ++
--- /var/tmp/diff_new_pack.iGAbZ7/_old  2016-08-03 11:44:19.0 +0200
+++ /var/tmp/diff_new_pack.iGAbZ7/_new  2016-08-03 11:44:19.0 +0200
@@ -37,6 +37,8 @@
 Patch2: %{name}-1.1.0-python-fixes.patch
 # PATCH-FIX-UPSTREAM libtorrent-rasterbar-1.1.0-fix-invalid-input-crash.patch 
boo#983228 -- Fix crash on invalid input in http_parser (commit 3624ce6).
 Patch3: %{name}-1.1.0-fix-invalid-input-crash.patch
+# PATCH-FIX-UPSTREAM 
libtorrent-rasterbar-1.1.0-add_ppc64le_as_64_bit_system_libraries.patch -- Fix 
configure error on ppc64le (commit 487cb44).
+Patch4: %{name}-1.1.0-add_ppc64le_as_64_bit_system_libraries.patch
 BuildRequires:  boost-devel >= 1.54
 BuildRequires:  gcc-c++
 BuildRequires:  pkgconfig
@@ -137,6 +139,7 @@
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 export CFLAGS="%{optflags} -fno-strict-aliasing"


++ libtorrent-rasterbar-1.1.0-add_ppc64le_as_64_bit_system_libraries.patch 
++
From: Michel Normand 
Subject: libtorrent rasterbar 1.1.0 add ppc64le as 64 bit system libraries
Date: Fri, 29 Jul 2016 14:10:01 +0200

libtorrent rasterbar 1.1.0 add ppc64le as 64 bit system libraries

local patch waiting for upstream pull request
https://github.com/arvidn/libtorrent/pull/967

Signed-off-by: Michel Normand 
---
 configure |2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Index: libtorrent-rasterbar-1.1.0/configure
===
--- libtorrent-rasterbar-1.1.0.orig/configure
+++ libtorrent-rasterbar-1.1.0/configure
@@ -16821,7 +16821,7 @@ $as_echo_n "checking for boostlib >= $bo
 libsubdirs="lib"
 ax_arch=`uname -m`
 case $ax_arch in
-  x86_64|ppc64|s390x|sparc64|aarch64)
+  x86_64|ppc64|ppc64le|s390x|sparc64|aarch64)
 libsubdirs="lib64 lib lib64"
 ;;
 esac



commit libuv for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libuv for openSUSE:Factory checked 
in at 2016-08-03 11:43:30

Comparing /work/SRC/openSUSE:Factory/libuv (Old)
 and  /work/SRC/openSUSE:Factory/.libuv.new (New)


Package is "libuv"

Changes:

--- /work/SRC/openSUSE:Factory/libuv/libuv.changes  2016-02-01 
19:57:45.0 +0100
+++ /work/SRC/openSUSE:Factory/.libuv.new/libuv.changes 2016-08-03 
11:43:31.0 +0200
@@ -1,0 +2,5 @@
+Wed Jul 27 22:00:21 UTC 2016 - jeng...@inai.de
+
+- Trim filler words from description
+
+---



Other differences:
--
++ libuv.spec ++
--- /var/tmp/diff_new_pack.KH0B4z/_old  2016-08-03 11:43:33.0 +0200
+++ /var/tmp/diff_new_pack.KH0B4z/_new  2016-08-03 11:43:33.0 +0200
@@ -20,7 +20,7 @@
 Name:   libuv
 Version:1.8.0
 Release:0
-Summary:Cross-platform asychronous I/O
+Summary:Asychronous I/O support library
 License:MIT
 Group:  Development/Libraries/C and C++
 Url:https://github.com/libuv/libuv
@@ -32,18 +32,18 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-libuv is a multi-platform support library with a focus on asynchronous I/O. It
-was primarily developed for use by Node.js, but it's also used by Mozilla's
-Rust language, Luvit, Julia, pyuv, and others.
+libuv is a support library with a focus on asynchronous I/O. It was
+primarily developed for use by Node.js, but it is also used by
+Mozilla's Rust language, Luvit, Julia, pyuv, and others.
 
 %package -n libuv%{somajor}
-Summary:Cross-platform asychronous I/O
+Summary:Asychronous I/O support library
 Group:  System/Libraries
 
 %description -n libuv%{somajor}
-libuv is a multi-platform support library with a focus on asynchronous I/O. It
-was primarily developed for use by Node.js, but it's also used by Mozilla's
-Rust language, Luvit, Julia, pyuv, and others.
+libuv is a support library with a focus on asynchronous I/O. It was
+primarily developed for use by Node.js, but it is also used by
+Mozilla's Rust language, Luvit, Julia, pyuv, and others.
 
 %packagedevel
 Summary:Development libraries for libuv
@@ -52,11 +52,11 @@
 Requires:   libuv%{somajor} = %{version}
 
 %descriptiondevel
-Development files for libuv
+Development files for libuv.
 
-libuv is a multi-platform support library with a focus on asynchronous I/O. It
-was primarily developed for use by Node.js, but it's also used by Mozilla's
-Rust language, Luvit, Julia, pyuv, and others.
+libuv is a support library with a focus on asynchronous I/O. It was
+primarily developed for use by Node.js, but it is also used by
+Mozilla's Rust language, Luvit, Julia, pyuv, and others.
 
 %prep
 %setup -q




commit epson-inkjet-printer-escpr for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package epson-inkjet-printer-escpr for 
openSUSE:Factory checked in at 2016-08-03 11:43:13

Comparing /work/SRC/openSUSE:Factory/epson-inkjet-printer-escpr (Old)
 and  /work/SRC/openSUSE:Factory/.epson-inkjet-printer-escpr.new (New)


Package is "epson-inkjet-printer-escpr"

Changes:

--- 
/work/SRC/openSUSE:Factory/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr.changes
2015-11-13 23:36:17.0 +0100
+++ 
/work/SRC/openSUSE:Factory/.epson-inkjet-printer-escpr.new/epson-inkjet-printer-escpr.changes
   2016-08-03 11:43:15.0 +0200
@@ -1,0 +2,5 @@
+Tue Jul 19 13:38:46 CEST 2016 - jsm...@suse.de
+
+- Removed no longer valid URLs from the package description.
+
+---



Other differences:
--
++ epson-inkjet-printer-escpr.spec ++
--- /var/tmp/diff_new_pack.mMuxuo/_old  2016-08-03 11:43:16.0 +0200
+++ /var/tmp/diff_new_pack.mMuxuo/_new  2016-08-03 11:43:16.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package epson-inkjet-printer-escpr
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -63,30 +63,17 @@
 The ESC/P-R driver works as a filter program
 used with CUPS.
 
-It offers high quality printing with Seiko Epson color
-inkjet printers.
+It offers high quality printing with Seiko Epson
+color inkjet printers.
 
-This driver can only be used with printers that support
-the Epson ESC/P-R language.
+This driver can only be used with printers that
+support the Epson ESC/P-R language.
 
-For a list of supported printers by a currently installed
-package see the PPD files in this directory:
+For a list of supported printers by a currently
+installed package see the PPD files in this directory:
 
 /usr/share/cups/model/manufacturer-PPDs/epson-inkjet-printer-escpr
 
-For a list of supported printers by the newest available version
-at the upstream project visit:
-
-http://avasys.jp/english/linux_e/
-
-In particular regarding the ESC/P-R driver see:
-
-http://avasys.jp/eng/linux_driver/download/lsb/epson-inkjet/escpr/
-
-Regarding "What's ESC/P-R?" have a look at:
-
-http://global.epson.com/innovation/universal_printing/index.html
-
 
 %prep
 # Be quiet when unpacking:




commit armagetron for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package armagetron for openSUSE:Factory 
checked in at 2016-08-03 11:43:24

Comparing /work/SRC/openSUSE:Factory/armagetron (Old)
 and  /work/SRC/openSUSE:Factory/.armagetron.new (New)


Package is "armagetron"

Changes:

--- /work/SRC/openSUSE:Factory/armagetron/armagetron.changes2016-07-01 
09:59:46.0 +0200
+++ /work/SRC/openSUSE:Factory/.armagetron.new/armagetron.changes   
2016-08-03 11:43:28.0 +0200
@@ -1,0 +2,5 @@
+Wed Jun 29 12:35:21 UTC 2016 - jeng...@inai.de
+
+- Replace ancient package names
+
+---



Other differences:
--
++ armagetron.spec ++
--- /var/tmp/diff_new_pack.sxcYMU/_old  2016-08-03 11:43:31.0 +0200
+++ /var/tmp/diff_new_pack.sxcYMU/_new  2016-08-03 11:43:31.0 +0200
@@ -37,8 +37,7 @@
 %if 0%{?suse_version} > 1315
 BuildRequires:  llvm-clang
 %endif
-Requires(post): fileutils
-Requires(post): sh-utils
+Requires(post): coreutils
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description




commit aria2 for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package aria2 for openSUSE:Factory checked 
in at 2016-08-03 11:43:23

Comparing /work/SRC/openSUSE:Factory/aria2 (Old)
 and  /work/SRC/openSUSE:Factory/.aria2.new (New)


Package is "aria2"

Changes:

--- /work/SRC/openSUSE:Factory/aria2/aria2.changes  2016-06-19 
10:50:47.0 +0200
+++ /work/SRC/openSUSE:Factory/.aria2.new/aria2.changes 2016-08-03 
11:43:23.0 +0200
@@ -1,0 +2,37 @@
+Wed Jul 27 22:04:15 UTC 2016 - jeng...@inai.de
+
+- Trim filler phrases from description.
+  Explicitly add BR:pkgconfig so pkgconfigdeps.sh can autocreate
+  pkgconfig() symbols.
+
+---
+Mon Jul 25 13:57:04 UTC 2016 - mplus...@suse.com
+
+- Update to version 1.25.0:
+  * Update third-party libraries for binary releases
+  * Send have message without too much delay
+  * Also send bitfield rather than have messages if bitfield 
+message is equal to or less than the sum of have messages 
+which otherwise would be sent.
+  * Fix bug that causes bogus EOF connection failure in BitTorrent 
+downloads
+  * Fix frequent interested/not interested message transmission
+  * Fix frequent choke/unchoke message transmission
+  * Try to use available URI if all pooled requests are sleeping
+  * Update expat in OSX build
+  * aria2mon: Add --secret option
+  * Set server status error on network failure in server
+performance profile
+  * Disable AI_ADDRCONFIG if no IPv4/IPv6 address is configured for
+any interface
+  * Russian manual: Update aria2c.rst
+  * Apply --retry-wait on 503 only
+  * Ensure that lowest speed check is done even when download speed 
+is 0
+  * Document that -o is always relative to -d option
+  * Allow larger ut_metadata size
+  * mingw: Change FD_SETSIZE to 32768
+  * Fix compile error on OS X
+- Add aria2-no-return-in-nonvoid-function.patch
+
+---

Old:

  aria2-1.24.0.tar.xz

New:

  aria2-1.25.0.tar.xz
  aria2-no-return-in-nonvoid-function.patch



Other differences:
--
++ aria2.spec ++
--- /var/tmp/diff_new_pack.PDB1KA/_old  2016-08-03 11:43:24.0 +0200
+++ /var/tmp/diff_new_pack.PDB1KA/_new  2016-08-03 11:43:24.0 +0200
@@ -18,7 +18,7 @@
 
 %define somajor 0
 Name:   aria2
-Version:1.24.0
+Version:1.25.0
 Release:0
 Summary:Parallelizing Multi-Protocol Utility for Downloading Files
 License:SUSE-GPL-2.0-with-openssl-exception
@@ -26,9 +26,12 @@
 Url:https://aria2.github.io
 Source0:
https://github.com/aria2/aria2/releases/download/release-%{version}/aria2-%{version}.tar.xz
 Source1:%{name}.changes
+# PATCH-FIX-UPSTREAM aria2-no-return-in-nonvoid-function.patch
+Patch0: aria2-no-return-in-nonvoid-function.patch
 BuildRequires:  bison
 BuildRequires:  gcc-c++
 BuildRequires:  gmp-devel
+BuildRequires:  pkg-config
 BuildRequires:  pkgconfig(cppunit)
 BuildRequires:  pkgconfig(gnutls)
 BuildRequires:  pkgconfig(libcares)
@@ -45,13 +48,11 @@
 %endif
 
 %description
-aria2 is a utility for downloading files. It has completely new design
-concept from its predecessor, Aria, and is written from scratch. aria2 has
-a segmented downloading engine in its core. It can download one file from
-multiple URLs or multiple connections from one URL. This results in very
-high speed downloading, much faster than ordinary browsers. This engine in
-was implemented in a single-thread model. The architecture is clean and easy
-to extend.
+aria2 is a utility for downloading files. It has a segmented
+downloading engine in its core. It can download one file from
+multiple URLs or multiple connections from one URL. This can be used
+to speed up downloads with certain networks. The engine in was
+implemented in a single-thread model.
 
 aria2 currently supports HTTP, FTP, and BitTorrent.
 
@@ -62,35 +63,31 @@
 Group:  System/Libraries
 
 %description -n lib%{name}-%{somajor}
-aria2 is a utility for downloading files. It has completely new design
-concept from its predecessor, Aria, and is written from scratch. aria2 has
-a segmented downloading engine in its core. It can download one file from
-multiple URLs or multiple connections from one URL. This results in very
-high speed downloading, much faster than ordinary browsers. This engine in
-was implemented in a single-thread model. The architecture is clean and easy
-to extend.
+aria2 is a utility for downloading files. It has a segmented
+downloading engine in its core. It can download one file from
+multiple URLs or multiple connections from one URL. This can be used
+to speed up downloads with 

commit PlotDigitizer for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package PlotDigitizer for openSUSE:Factory 
checked in at 2016-08-03 11:43:50

Comparing /work/SRC/openSUSE:Factory/PlotDigitizer (Old)
 and  /work/SRC/openSUSE:Factory/.PlotDigitizer.new (New)


Package is "PlotDigitizer"

Changes:

--- /work/SRC/openSUSE:Factory/PlotDigitizer/PlotDigitizer.changes  
2015-12-23 08:50:44.0 +0100
+++ /work/SRC/openSUSE:Factory/.PlotDigitizer.new/PlotDigitizer.changes 
2016-08-03 11:44:06.0 +0200
@@ -1,0 +2,5 @@
+Fri Jul 29 00:22:58 UTC 2016 - badshah...@gmail.com
+
+- Add appdata file as source and install it to the appdata dir.
+
+---

New:

  PlotDigitizer.appdata.xml



Other differences:
--
++ PlotDigitizer.spec ++
--- /var/tmp/diff_new_pack.UHpgud/_old  2016-08-03 11:44:07.0 +0200
+++ /var/tmp/diff_new_pack.UHpgud/_new  2016-08-03 11:44:07.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package PlotDigitizer
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -28,6 +28,7 @@
 Source2:PlotDigitizer.desktop
 # MRJAdapter from PlotDigitizer 2.5.1 source archive
 Source3:MRJAdapter_1.0.8_Src.zip
+Source4:PlotDigitizer.appdata.xml
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 BuildRequires:  ant
@@ -103,6 +104,8 @@
 install -Dm 644 %{name}.desktop 
%{buildroot}%{_datadir}/applications/%{name}.desktop
 install -Dm 644 Resources/images/%{name}Icon64x64.png 
%{buildroot}%{_datadir}/pixmaps/%{name}.png
 
+install -Dm0644 %{S:4} %{buildroot}%{_datadir}/appdata/%{name}.appdata.xml
+
 %files
 %defattr(-, root, root)
 %doc LesserGPL_license.txt README.txt
@@ -110,5 +113,7 @@
 %{_datadir}/%{name}
 %{_datadir}/applications/%{name}.desktop
 %{_datadir}/pixmaps/%{name}.png
+%dir %{_datadir}/appdata
+%{_datadir}/appdata/%{name}.appdata.xml
 
 %changelog


++ PlotDigitizer.appdata.xml ++


  PlotDigitizer.desktop
  CC0-1.0
  PlotDigitizer PlotDigitizer
  LGPL-2.1 and GPL-2.0
  Ditigize scanned plots of functional data
  http://plotdigitizer.sourceforge.net
  
Plot Digitizer is a Java program used to digitize scanned plots of 
functional data. Often data is found presented in reports and references as 
functional X-Y type scatter or line plots. In order to use this data, it must 
somehow be digitized. This program will allow you to take a scanned image of a 
plot (in GIF, JPEG, or PNG format) and quickly digitize values off the plot 
just by clicking the mouse on each data point. The numbers can then be saved to 
a text file and used where ever you need them. Plot Digitizer works with both 
linear and logarithmic axis scales. Besides digitizing points off of data 
plots, this program can be used to digitize other types of scanned data (such 
as scaled drawings or orthographic photos).
Plot Digitizer has some handy features to make digitizing plots 
easier:

  Recalibrate the Y axis without having to recalibrate the X axis 
(multiple sets of data are commonly plotted with the same X axis).
  Insert points between two already digitized points by right clicking 
and choosing "Insert" from the pop-up menu.
  Delete points by right-clicking on the points and choosing 
"Delete".
  Compute the length of a digitized curve and you can compute the area 
of a digitized polygon.
  Move points by clicking and dragging them.
  Zoom images in and out.
  Save calibrations for an image for later use.
  Unlimited undo/redo.
  Semi-automatically digitize lines off a plot.

  
  jhuwa...@users.sourceforge.net





commit geany-plugins for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package geany-plugins for openSUSE:Factory 
checked in at 2016-08-03 11:43:35

Comparing /work/SRC/openSUSE:Factory/geany-plugins (Old)
 and  /work/SRC/openSUSE:Factory/.geany-plugins.new (New)


Package is "geany-plugins"

Changes:

--- /work/SRC/openSUSE:Factory/geany-plugins/geany-plugins.changes  
2016-02-22 08:57:29.0 +0100
+++ /work/SRC/openSUSE:Factory/.geany-plugins.new/geany-plugins.changes 
2016-08-03 11:43:38.0 +0200
@@ -1,0 +2,50 @@
+Wed Jul 20 00:02:03 UTC 2016 - badshah...@gmail.com
+
+- Update to version 1.28:
+  + General:
+- Rename plugin GeanySendMail to SendMail
+  (gh#geany/geany-plugins#43).
+- Fix some inconsistency in plugins' READMEs
+  (gh#geany/geany-plugins#453).
+  + Windows build: Update dependencies shipped with the package.
+  + Addons:
+- tasks: Strip comment-closing sequence from task text
+  (gh#geany/geany-plugins#416).
+- tasks: Do not extract tokens from non-comments
+  (gh#geany/geany-plugins#416).
+  + Debugger: Fix escaping target executable path if it contains
+non-ASCII (gh#geany/geany-plugins#416,
+gh#geany/geany-plugins#451).
+  + GeanyGenDoc: Fix build with old rst2html
+(gh#geany/geany-plugins#414).
+  + GeanyLaTeX:
+- Fix a conditional end of undo action. Without an undo-action
+  might run forever (gh#geany/geany-plugins#416).
+- Improve support for GTK3 (gh#geany/geany-plugins#410).
+  + GeanyLipsum: Add ellipsis to menu item requiring further user
+input (gh#geany/geany-plugins#452).
+  + GeanyMacro: Fix GTK3 support (gh#geany/geany-plugins#410).
+  + GeanyNumberedBookmarks: Fix GTK3 support
+(gh#geany/geany-plugins#410).
+  + GeanyPrj: Fix GTK3 support (gh#geany/geany-plugins#410).
+  + GeanyPy: Fix build with current Geany
+(gh#geany/geany-plugins#363).
+  + PairTagHighlighter: Fix a crash when the tag name is missing
+(gh#geany/geany-plugins#442, gh#geany/geany-plugins#446,
+gh#geany/geany-plugins#447).
+  + Prettyprinter: Fix several memory leaks
+(gh#geany/geany-plugins#364).
+  + ProjectOrganizer: Fix duplicated tab in Project Properties.
+  + Scope: Fix dependency checks on Windows
+(gh#geany/geany-plugins#409).
+  + Shiftcolumn: Fix handling of end-to-start selections
+(gh#geany/geany-plugins#366).
+- Changes from version 1.27: See
+  /usr/share/doc/packages/geany-plugins/NEWS or online at
+  https://github.com/geany/geany-plugins/blob/1.27.0/NEWS.
+- Update file list:
+  + geanylatex, geanymacro, geanynumberedbookmarks, geanyprj
+are GTK3 compatible now.
+  + New plugin: lineoperations.
+
+---

Old:

  geany-plugins-1.26.tar.bz2

New:

  geany-plugins-1.28.tar.bz2



Other differences:
--
++ geany-plugins.spec ++
--- /var/tmp/diff_new_pack.YexX8U/_old  2016-08-03 11:43:39.0 +0200
+++ /var/tmp/diff_new_pack.YexX8U/_new  2016-08-03 11:43:39.0 +0200
@@ -19,7 +19,7 @@
 %define gtk3_enable 0
 
 Name:   geany-plugins
-Version:1.26
+Version:1.28
 Release:0
 # FIXME: Files listed inside the conditional "%if %%{gtk3_enable}" are 
disabled because they do not build when compiled against gtk3. On next update, 
try enabling each of these disabled libs and check if they build with gtk3 or 
not. When all of them compile against gtk3, remove the macro and conditional.
 # FIXME: gendoc requires ctpl (http://ctpl.tuxfamily.org/)
@@ -108,10 +108,11 @@
 %{_libdir}/geany-plugins/geanylua/libgeanylua.so
 %{_libdir}/geany/geanyminiscript.so
 %{_libdir}/geany/geanypg.so
-%{_libdir}/geany/geanysendmail.so
+%{_libdir}/geany/sendmail.so
 %{_libdir}/geany/geanyvc.so
 %{_libdir}/geany/geniuspaste.so
 %{_libdir}/geany/git-changebar.so
+%{_libdir}/geany/lineoperations.so
 %{_libdir}/geany/overview.so
 %{_libdir}/geany/pairtaghighlighter.so
 %{_libdir}/geany/pohelper.so
@@ -123,14 +124,14 @@
 %{_libdir}/geany/treebrowser.so
 %{_libdir}/geany/updatechecker.so
 %{_libdir}/geany/xmlsnippets.so
-
-%if %{gtk3_enable}
-%{_libdir}/geany/debugger.so
-%{_libdir}/geany/devhelp.so
 %{_libdir}/geany/geanylatex.so
 %{_libdir}/geany/geanymacro.so
 %{_libdir}/geany/geanynumberedbookmarks.so
 %{_libdir}/geany/geanyprj.so
+
+%if %{gtk3_enable}
+%{_libdir}/geany/debugger.so
+%{_libdir}/geany/devhelp.so
 %{_libdir}/geany/markdown.so
 %{_libdir}/geany/multiterm.so
 %{_libdir}/geany/scope.so

++ geany-plugins-1.26.tar.bz2 -> geany-plugins-1.28.tar.bz2 ++
 135001 lines of diff (skipped)




commit openCryptoki for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package openCryptoki for openSUSE:Factory 
checked in at 2016-08-03 11:43:47

Comparing /work/SRC/openSUSE:Factory/openCryptoki (Old)
 and  /work/SRC/openSUSE:Factory/.openCryptoki.new (New)


Package is "openCryptoki"

Changes:

--- /work/SRC/openSUSE:Factory/openCryptoki/openCryptoki.changes
2016-07-12 23:52:29.0 +0200
+++ /work/SRC/openSUSE:Factory/.openCryptoki.new/openCryptoki.changes   
2016-08-03 11:44:01.0 +0200
@@ -1,0 +2,6 @@
+Tue Jul 19 17:07:16 UTC 2016 - mp...@suse.com
+
+- Added ocki-3.5-create-missing-tpm-token-lock-directory.patch
+  (bsc#989602).
+
+---

New:

  ocki-3.5-create-missing-tpm-token-lock-directory.patch



Other differences:
--
++ openCryptoki.spec ++
--- /var/tmp/diff_new_pack.VXxEXW/_old  2016-08-03 11:44:03.0 +0200
+++ /var/tmp/diff_new_pack.VXxEXW/_new  2016-08-03 11:44:03.0 +0200
@@ -70,6 +70,7 @@
 Patch6: ocki-3.5-icsf-sessionhandle-missing-fix.patch
 Patch7: ocki-3.5-icsf-reasoncode-2028-added.patch
 Patch8: ocki-3.5-added-NULLreturn-check.patch
+Patch9: ocki-3.5-create-missing-tpm-token-lock-directory.patch
 
 Url:https://sourceforge.net/projects/opencryptoki/
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -156,6 +157,7 @@
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 cp %{SOURCE2} .
 

++ ocki-3.5-create-missing-tpm-token-lock-directory.patch ++
commit aeea198cb8ea640cd37735365ee51a03aca67036
Author: Vineetha Pai 
Date:   Mon Jul 18 15:41:24 2016 -0400

create missing tpm lock directory from tpm stdll.
tpm token does not use common/utility function to create token lock
directory. Hence the patch to create missing lock directories was not
working on tpm token. Modified the tpm stdll code to create the token
lock directory if it is missing on the system.
Signed-off-by: Vineetha Pai 

diff --git a/usr/lib/pkcs11/tpm_stdll/tpm_specific.c 
b/usr/lib/pkcs11/tpm_stdll/tpm_specific.c
index e7978d3..2a20d7d 100644
--- a/usr/lib/pkcs11/tpm_stdll/tpm_specific.c
+++ b/usr/lib/pkcs11/tpm_stdll/tpm_specific.c
@@ -44,6 +44,7 @@
 #include 
 #include 
 #include 
+#include 
 
 #include 
 #include 
@@ -3393,10 +3394,13 @@ int
 token_specific_creatlock(void)
 {
CK_BYTE lockfile[PATH_MAX];
+   CK_BYTE lockdir[PATH_MAX];
struct passwd *pw = NULL;
struct stat statbuf;
mode_t mode = (S_IRUSR|S_IWUSR|S_IXUSR);
int lockfd;
+   int ret = -1;
+   struct group *grp;
 
/* get userid */
if ((pw = getpwuid(getuid())) == NULL) {
@@ -3404,6 +3408,45 @@ token_specific_creatlock(void)
return -1;
}
 
+   /** create lock subdir for each token if it doesn't exist.
+* The root /var/lock/opencryptoki directory should be created in 
slotmgr
+* daemon **/
+   sprintf(lockdir, "%s/%s", LOCKDIR_PATH, SUB_DIR);
+
+   ret = stat(lockdir, );
+   if (ret != 0 && errno == ENOENT) {
+   /* dir does not exist, try to create it */
+   ret  = mkdir(lockdir, S_IRWXU|S_IRWXG);
+   if (ret != 0) {
+   OCK_SYSLOG(LOG_ERR,
+   "Directory(%s) missing: %s\n",
+   lockdir,
+   strerror(errno));
+   goto err;
+   }
+   grp = getgrnam("pkcs11");
+   if (grp == NULL) {
+   fprintf(stderr, "getgrname(pkcs11): %s",
+   strerror(errno));
+   goto err;
+   }
+   /* set ownership to euid, and pkcs11 group */
+   if (chown(lockdir, geteuid(), grp->gr_gid) != 0) {
+   fprintf(stderr, "Failed to set owner:group \
+   ownership\
+   on %s directory", lockdir);
+   goto err;
+   }
+   /* mkdir does not set group permission right, so
+** trying explictly here again */
+   if (chmod(lockdir, S_IRWXU|S_IRWXG) != 0){
+   fprintf(stderr, "Failed to change \
+   permissions\
+   on %s directory", lockdir);
+   goto err;
+   }
+   }
+
/* create user-specific directory */
sprintf(lockfile, "%s/%s/%s", LOCKDIR_PATH, SUB_DIR, pw->pw_name);
 



commit qdevicemonitor for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package qdevicemonitor for openSUSE:Factory 
checked in at 2016-08-03 11:43:33

Comparing /work/SRC/openSUSE:Factory/qdevicemonitor (Old)
 and  /work/SRC/openSUSE:Factory/.qdevicemonitor.new (New)


Package is "qdevicemonitor"

Changes:

--- /work/SRC/openSUSE:Factory/qdevicemonitor/qdevicemonitor.changes
2016-07-14 09:48:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.qdevicemonitor.new/qdevicemonitor.changes   
2016-08-03 11:43:34.0 +0200
@@ -1,0 +2,12 @@
+Thu Jul 28 11:18:43 UTC 2016 - jeng...@inai.de
+
+- Improve summary/description
+
+---
+Sat Jul 23 16:15:39 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 1.0.1:
+  * No changelog available.
+- Remove qdevicemonitor.desktop: available upstream.
+
+---

Old:

  qdevicemonitor-1.0.0.tar.gz
  qdevicemonitor.desktop

New:

  qdevicemonitor-1.0.1.tar.gz



Other differences:
--
++ qdevicemonitor.spec ++
--- /var/tmp/diff_new_pack.mILKwm/_old  2016-08-03 11:43:35.0 +0200
+++ /var/tmp/diff_new_pack.mILKwm/_new  2016-08-03 11:43:35.0 +0200
@@ -17,30 +17,31 @@
 
 
 Name:   qdevicemonitor
-Version:1.0.0
+Version:1.0.1
 Release:0
-Summary:Log viewer for Android, iOS and text files
+Summary:Log viewer for Android and iOS logs and text files
 License:GPL-3.0+
 Group:  System/Monitoring
 Url:https://github.com/alopatindev/qdevicemonitor
 Source: 
https://github.com/alopatindev/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
-Source1:%{name}.desktop
-Source2:%{name}.appdata.xml
+Source1:%{name}.appdata.xml
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  pkgconfig
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(Qt5Core)
 BuildRequires:  pkgconfig(Qt5Gui)
 BuildRequires:  pkgconfig(Qt5Widgets)
+BuildRequires:  pkgconfig(libudev)
 Requires:   android-tools
 Requires:   imobiledevice-tools
 Requires:   usbmuxd
 
 %description
-An application to view logs for Android, iOS and text files.
+An application to retrieve and view Android and iOS logs,
+as well as local text files.
 
 Key Features:
- * Logs can be taken from Android, iOS or from text file.
+ * Logs can be taken from Android, iOS or from text files.
  * Filtering support (RegExp):
- automatic filter history that is used as autocomplete;
- prefixes pid:, tid:, tag: or text: (Android only).
@@ -53,8 +54,7 @@
 
 %prep
 %setup -q
-cp -f %{SOURCE1} icons/%{name}.desktop
-cp -f %{SOURCE2} icons/%{name}.appdata.xml
+cp -f %{SOURCE1} icons/%{name}.appdata.xml
 
 %build
 pushd %{name}/

++ qdevicemonitor-1.0.0.tar.gz -> qdevicemonitor-1.0.1.tar.gz ++
 9869 lines of diff (skipped)





commit gmusicbrowser for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package gmusicbrowser for openSUSE:Factory 
checked in at 2016-08-03 11:44:08

Comparing /work/SRC/openSUSE:Factory/gmusicbrowser (Old)
 and  /work/SRC/openSUSE:Factory/.gmusicbrowser.new (New)


Package is "gmusicbrowser"

Changes:

--- /work/SRC/openSUSE:Factory/gmusicbrowser/gmusicbrowser.changes  
2015-08-31 22:59:03.0 +0200
+++ /work/SRC/openSUSE:Factory/.gmusicbrowser.new/gmusicbrowser.changes 
2016-08-03 11:44:19.0 +0200
@@ -1,0 +2,6 @@
+Fri Jul 29 14:46:21 UTC 2016 - sor.ale...@meowr.ru
+
+- Add gmusicbrowser-1.1.15-fix-perl-5.24.patch from upstream: fix
+  an error with perl 5.24 (commit 853840e).
+
+---

New:

  gmusicbrowser-1.1.15-fix-perl-5.24.patch



Other differences:
--
++ gmusicbrowser.spec ++
--- /var/tmp/diff_new_pack.Lonadi/_old  2016-08-03 11:44:20.0 +0200
+++ /var/tmp/diff_new_pack.Lonadi/_new  2016-08-03 11:44:20.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gmusicbrowser
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,6 +24,8 @@
 Group:  Productivity/Multimedia/Sound/Players
 Url:http://gmusicbrowser.org/
 Source: http://gmusicbrowser.org/download/%{name}-%{version}.tar.gz
+# PATCH-FIX-UPSTREAM gmusicbrowser-1.1.15-fix-perl-5.24.patch -- Fix an error 
with perl 5.24 (commit 853840e).
+Patch0: %{name}-1.1.15-fix-perl-5.24.patch
 BuildRequires:  fdupes
 BuildRequires:  hicolor-icon-theme
 BuildRequires:  perl
@@ -76,6 +78,8 @@
 
 %prep
 %setup -q
+%patch0 -p1
+
 # Trim Unity actions.
 lines=$(( $(grep -m1 -no '^Actions=' %{name}.desktop | sed 
's/^\([[:digit:]]*\):.*$/\1/') - 1 ))
 head -n $lines %{name}.desktop > %{name}.desktop.new

++ gmusicbrowser-1.1.15-fix-perl-5.24.patch ++
--- a/gmusicbrowser_list.pm
+++ b/gmusicbrowser_list.pm
@@ -7998,7 +7998,7 @@ sub Make
unless ($notnow)
{   #warn "$key ---found in ($code,@deps)\n";
if (ref $code)
-   {   my ($func,my @keys)=@$code; #warn " -> 
($func, @keys)\n";
+   {   my ($func, @keys)=@$code; #warn " -> 
($func, @keys)\n";
my $out=join ',',map "'$_'", @keys;
my $in= join ',',map "'$_'", @deps; 
$in=~s#\?##g;
$out= @keys>1 ? "\@var{$out}" : 
"\$var{$out}";
--- a/gmusicbrowser.pl
+++ b/gmusicbrowser.pl
@@ -8977,7 +8977,7 @@ sub Set
 
($cmd,my $pattern)= split /:/,$cmd,2;
$pattern='' unless defined $pattern;
-   my ($basecmd,my $prop)= 
Songs::filter_properties($field,"$cmd:$pattern");
+   my ($basecmd, $prop)= Songs::filter_properties($field,"$cmd:$pattern");
if (!$prop)
{   $cmd=  Songs::Field_property($field,'default_filter');
($basecmd,$prop)= Songs::filter_properties($field,$cmd);



commit ansible for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package ansible for openSUSE:Factory checked 
in at 2016-08-03 11:43:53

Comparing /work/SRC/openSUSE:Factory/ansible (Old)
 and  /work/SRC/openSUSE:Factory/.ansible.new (New)


Package is "ansible"

Changes:

--- /work/SRC/openSUSE:Factory/ansible/ansible.changes  2016-06-02 
09:39:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.ansible.new/ansible.changes 2016-08-03 
11:44:08.0 +0200
@@ -1,0 +2,7 @@
+Tue Jun 28 06:25:44 UTC 2016 - mich...@stroeder.com
+
+- update to 2.1.1.0
+  (see /usr/share/doc/packages/ansible/CHANGELOG.md for details)
+- changed download link to https://releases.ansible.com
+
+---

Old:

  ansible-2.1.0.0.tar.gz

New:

  ansible-2.1.1.0.tar.gz



Other differences:
--
++ ansible.spec ++
--- /var/tmp/diff_new_pack.dEkKHx/_old  2016-08-03 11:44:09.0 +0200
+++ /var/tmp/diff_new_pack.dEkKHx/_new  2016-08-03 11:44:09.0 +0200
@@ -19,13 +19,13 @@
 
 
 Name:   ansible
-Version:2.1.0.0
+Version:2.1.1.0
 Release:0
 Summary:Radically simple IT automation
 License:GPL-3.0
 Group:  Development/Languages/Python
 Url:http://ansible.com/
-Source: 
https://pypi.io/packages/source/a/ansible/ansible-%{version}.tar.gz
+Source: https://releases.ansible.com/ansible/ansible-%{version}.tar.gz
 
 Source99:   ansible-rpmlintrc
 

++ ansible-2.1.0.0.tar.gz -> ansible-2.1.1.0.tar.gz ++
 8360 lines of diff (skipped)




commit nlopt for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package nlopt for openSUSE:Factory checked 
in at 2016-08-03 11:43:55

Comparing /work/SRC/openSUSE:Factory/nlopt (Old)
 and  /work/SRC/openSUSE:Factory/.nlopt.new (New)


Package is "nlopt"

Changes:

--- /work/SRC/openSUSE:Factory/nlopt/nlopt.changes  2016-01-16 
11:57:07.0 +0100
+++ /work/SRC/openSUSE:Factory/.nlopt.new/nlopt.changes 2016-08-03 
11:44:10.0 +0200
@@ -1,0 +2,8 @@
+Thu Jun 23 09:19:01 UTC 2016 - badshah...@gmail.com
+
+- Use %requires_eq octave-cli instead of Requires, octave installs
+  its files to versioned dirs, so it is important for nlopt to
+  be rebuilt for every version update of octave. Making the
+  Requires version dependent achieves this.
+
+---



Other differences:
--
++ nlopt.spec ++
--- /var/tmp/diff_new_pack.dypCcK/_old  2016-08-03 11:44:11.0 +0200
+++ /var/tmp/diff_new_pack.dypCcK/_new  2016-08-03 11:44:11.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package nlopt
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -79,7 +79,7 @@
 %package -n octave-nlopt_optimize
 Summary:Octave interface to nonlinear optimization libray
 Group:  Productivity/Scientific/Math
-Requires:   octave-cli
+%requires_eq  octave-cli
 
 %description -n octave-nlopt_optimize
 NLopt is a free/open-source library for nonlinear optimization,




commit seamonkey for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package seamonkey for openSUSE:Factory 
checked in at 2016-08-03 11:43:40

Comparing /work/SRC/openSUSE:Factory/seamonkey (Old)
 and  /work/SRC/openSUSE:Factory/.seamonkey.new (New)


Package is "seamonkey"

Changes:

--- /work/SRC/openSUSE:Factory/seamonkey/seamonkey.changes  2016-07-21 
08:18:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.seamonkey.new/seamonkey.changes 2016-08-03 
11:43:46.0 +0200
@@ -1,0 +2,9 @@
+Tue Jul 26 04:44:49 UTC 2016 - badshah...@gmail.com
+
+- Add appstream metainfo files as a tar.bz2 source
+  (seamonkey-appdata.tar.bz2) and install these appdata.xml files
+  to the appdata dir (/usr/share/appdata); with these appdata
+  files installed, seamonkey shows up in appstores like GNOME
+  software and KDE Discover.
+
+---

New:

  seamonkey-appdata.tar.bz2



Other differences:
--
++ seamonkey.spec ++
--- /var/tmp/diff_new_pack.cHOLGX/_old  2016-08-03 11:43:51.0 +0200
+++ /var/tmp/diff_new_pack.cHOLGX/_new  2016-08-03 11:43:51.0 +0200
@@ -79,6 +79,7 @@
 Source8:find-external-requires.sh
 Source9:create-tar.sh
 Source10:   compare-locales.tar.bz2
+Source11:   seamonkey-appdata.tar.bz2
 Patch1: mozilla-nongnome-proxies.patch
 Patch2: mozilla-shared-nss-db.patch
 Patch3: mozilla-language.patch
@@ -181,9 +182,9 @@
 
 %prep
 %if %localize
-%setup -n seamonkey -b 1 -b 5 -b 10 -q
+%setup -n seamonkey -b 1 -b 5 -b 10 -b 11 -q
 %else
-%setup -n seamonkey -b 1 -q
+%setup -n seamonkey -b 1 -b11 -q
 %endif
 # mozilla patches
 pushd mozilla
@@ -383,6 +384,10 @@
 %fdupes $RPM_BUILD_ROOT%{progdir}
 %fdupes $RPM_BUILD_ROOT%{_datadir}
 
+#INSTALL APPDATA FILES
+mkdir -p %{buildroot}%{_datadir}/appdata
+install -m0644 -t %{buildroot}%{_datadir}/appdata/ $RPM_BUILD_DIR/*.appdata.xml
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 rm -rf %{_tmppath}/translations.*
@@ -417,6 +422,8 @@
 %{progdir}/seamonkey-bin
 %{_datadir}/applications/*.desktop
 %{_datadir}/pixmaps/*.png
+%dir %{_datadir}/appdata
+%{_datadir}/appdata/*.appdata.xml
 
 %files irc
 %defattr(-,root,root)





commit jaxodraw for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package jaxodraw for openSUSE:Factory 
checked in at 2016-08-03 11:43:19

Comparing /work/SRC/openSUSE:Factory/jaxodraw (Old)
 and  /work/SRC/openSUSE:Factory/.jaxodraw.new (New)


Package is "jaxodraw"

Changes:

--- /work/SRC/openSUSE:Factory/jaxodraw/jaxodraw.changes2015-07-14 
17:46:10.0 +0200
+++ /work/SRC/openSUSE:Factory/.jaxodraw.new/jaxodraw.changes   2016-08-03 
11:43:20.0 +0200
@@ -1,0 +2,7 @@
+Tue Jul 26 03:19:53 UTC 2016 - badshah...@gmail.com
+
+- Update jaxodraw.appdata.xml in keeping with updated appstream
+  specifications; also update description, summary, other info
+  in the metadata.
+
+---



Other differences:
--
++ jaxodraw.spec ++
--- /var/tmp/diff_new_pack.ETnHw9/_old  2016-08-03 11:43:21.0 +0200
+++ /var/tmp/diff_new_pack.ETnHw9/_new  2016-08-03 11:43:21.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package jaxodraw
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -22,9 +22,9 @@
 Version:%{major}.%{minor}
 Release:0
 Summary:A Java-based GUI for drawing Feynman diagrams
-# The xslt files in the manual are Apache-2.0 licensed, GPL-2.0+ for 
everything else
 License:GPL-2.0+ and Apache-2.0
 Group:  Productivity/Scientific/Physics
+# The xslt files in the manual are Apache-2.0 licensed, GPL-2.0+ for 
everything else
 Url:http://jaxodraw.sourceforge.net
 Source0:
http://download.sourceforge.net/%{name}/%{name}-%{major}-%{minor}-src.tar.gz
 Source1:
http://sourceforge.net/projects/jaxodraw/files/installer_files/installer-2.0-1.tar.gz
@@ -79,9 +79,9 @@
 License:LPPL-1.3c
 Group:  Productivity/Scientific/Physics
 # In order to compile documents one needs a LaTeX compiler
-Requires:   tex(latex)
 Requires:   %{name} = %{version}
 Requires:   texlive-pst-tools
+Requires:   tex(latex)
 Requires(pre):  texlive
 Requires(post): coreutils
 Requires(postun): coreutils


++ jaxodraw.appdata.xml ++
--- /var/tmp/diff_new_pack.ETnHw9/_old  2016-08-03 11:43:21.0 +0200
+++ /var/tmp/diff_new_pack.ETnHw9/_new  2016-08-03 11:43:21.0 +0200
@@ -1,23 +1,39 @@
-
-
-
-
+
+
   jaxodraw.desktop
   CC0-1.0
-  Create and edit Feynman diagrams
+  JaxoDraw
+  GPL-2.0+ and Apache-2.0
+  A Java-based GUI for drawing Feynman diagrams
+  http://jaxodraw.sourceforge.net
   
+JaxoDraw is a Java program for drawing Feynman diagrams. It has a
+complete graphical user interface that allows to carry out all actions
+in a mouse click-and-drag fashion. Fine-tuning of the diagrams is
+possible through keyboard short-cuts. Graphs may be exported to a
+variety of image formats, including (encapsulated) postscript, and can
+be saved in XML files to be used in later sessions.
 
-  Jaxodraw is an application for creating and editing Feynman diagrams,
-  with the ability to export to LaTeX.
-  Feynman diagrams are a specific diagram scheme to represent the 
mathematical
-  expressions that describe the behavior of subatomic particles.
-
+The main feature of JaxoDraw is the possibility of generating
+LaTeX code that makes use of J. Vermaseren's axodraw package to
+compile. In fact the main motivation for writing JaxoDraw was to
+create a graphical user interface for the axodraw package. In that
+way, we combine the power of LaTeX with the easiness of a
+what-you-see-is-what-you-get interface.
   
-  http://jaxodraw.sourceforge.net/
   
-  http://jaxodraw.sourceforge.net/images/general.png
+
+  http://jaxodraw.sourceforge.net/images/jaxo2.png
+  Jaxodraw GUI
+
+
+  http://jaxodraw.sourceforge.net/images/general.png
+  Preview and export diagrams from Jaxodraw
+
+
+  http://jaxodraw.sourceforge.net/images/tabbing.png
+  Tabs in Jaxodraw
+
   
-
+  lukas_theu...@users.sourceforge.net
+




commit texmaker for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package texmaker for openSUSE:Factory 
checked in at 2016-08-03 11:43:21

Comparing /work/SRC/openSUSE:Factory/texmaker (Old)
 and  /work/SRC/openSUSE:Factory/.texmaker.new (New)


Package is "texmaker"

Changes:

--- /work/SRC/openSUSE:Factory/texmaker/texmaker.changes2015-11-08 
11:27:00.0 +0100
+++ /work/SRC/openSUSE:Factory/.texmaker.new/texmaker.changes   2016-08-03 
11:43:22.0 +0200
@@ -1,0 +2,17 @@
+Tue Jul 26 02:50:25 UTC 2016 - badshah...@gmail.com
+
+- Add texmaker-appdata.patch to install an appstream metadata
+  file.
+- Remove references to %{buildroot} during the %build stage,
+  this is no loger required.
+- Pass METAINFODIR=%{_datadir}/appdata to install the metainfo
+  to openSUSE's currently preferred metainfo dir; the default
+  upstream specification for appdata recommends
+  /usr/share/metainfo instead, and is also the default metainfo
+  path set in texmaker-appdata.patch.
+- Run fdupes only inside the %{_datadir}/texmaker dir to prevent
+  /usr/share/pixmaps/texmaker.png from becoming a link; if this
+  happens, appstream generator fails to extract the icon and
+  promptly fails to generate the appdata.
+
+---

New:

  texmaker-appdata.patch



Other differences:
--
++ texmaker.spec ++
--- /var/tmp/diff_new_pack.pQrcT1/_old  2016-08-03 11:43:23.0 +0200
+++ /var/tmp/diff_new_pack.pQrcT1/_new  2016-08-03 11:43:23.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package texmaker
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -26,6 +26,8 @@
 Source: http://www.xm1math.net/texmaker/texmaker-%{version}.tar.bz2
 # PATCH-FIX-UPSTREAM texmaker-correct-doc-location.patch badshah...@gmail.com 
-- Handle doc files in the spec file rather than placing them in %%{_datadir} 
during compilation
 Patch1: texmaker-correct-doc-location.patch
+# PATCH-FIX-UPSTREAM texmaker-appdata.patch badshah...@gmail.com -- Install 
appstream metainfo file; patch sent upstream
+Patch2: texmaker-appdata.patch
 BuildRequires:  fdupes
 BuildRequires:  update-desktop-files
 %if 0%{?suse_version} == 1315
@@ -58,6 +60,7 @@
 %prep
 %setup -q
 %patch1 -p1
+%patch2 -p1
 
 %build
 %if 0%{?suse_version} == 1315
@@ -70,17 +73,20 @@
 LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
 DYLD_LIBRARY_PATH=$QTDIR/lib:$DYLD_LIBRARY_PATH
 export QTDIR PATH LD_LIBRARY_PATH DYLD_LIBRARY_PATH
-PREFIX=%{buildroot}%{_prefix}
+PREFIX=%{_prefix}
+
 %if 0%{?suse_version} == 1315
-qmake QMAKE_CXXFLAGS="%optflags -fvisibility=hidden 
-fvisibility-inlines-hidden" -unix texmaker.pro
+qmake QMAKE_CXXFLAGS="%optflags -fvisibility=hidden 
-fvisibility-inlines-hidden" \
+  METAINFODIR="%{_datadir}/appdata" -unix texmaker.pro
 %else
-qmake-qt5 QMAKE_CXXFLAGS="%optflags -fvisibility=hidden 
-fvisibility-inlines-hidden" -unix texmaker.pro
+qmake-qt5 QMAKE_CXXFLAGS="%optflags -fvisibility=hidden 
-fvisibility-inlines-hidden" \
+  METAINFODIR="%{_datadir}/appdata" -unix texmaker.pro
 %endif
-make %{?_smp_mflags} INSTALL_ROOT=%{buildroot}
+make %{?_smp_mflags}
 
 %install
 make INSTALL_ROOT=%{buildroot} install
-%fdupes %{buildroot}%{_datadir}/
+%fdupes %{buildroot}%{_datadir}/%{name}/
 
 %files
 %defattr(-,root,root,-)
@@ -89,5 +95,7 @@
 %{_datadir}/applications/texmaker.desktop
 %{_datadir}/pixmaps/texmaker.png
 %{_datadir}/texmaker/
+%dir %{_datadir}/appdata
+%{_datadir}/appdata/%{name}.appdata.xml
 
 %changelog

++ texmaker-appdata.patch ++
Index: texmaker-4.5/utilities/texmaker.appdata.xml
===
--- /dev/null
+++ texmaker-4.5/utilities/texmaker.appdata.xml
@@ -0,0 +1,26 @@
+
+
+  texmaker.desktop
+  CC0-1.0
+  Texmaker LaTeX Editor
+  GPL-2.0 and BSD-3-Clause
+  Free cross-platform LaTeX editor
+  http://www.xm1math.net/texmaker/
+  
+Texmaker is a free LaTeX editor, that integrates many tools
+needed to develop documents with LaTeX, in just one application.
+Texmaker runs on unix, macosx and windows systems and is released
+under the GPL license .
+  
+  
+
+  http://www.xm1math.net/texmaker/texmakertop_big.png
+  Source editor and PDF preview side by side
+
+
+  http://www.xm1math.net/texmaker/sidebyside_big.png
+  Two documents side by side
+
+  
+  pbrac...@xm1math.net
+
Index: texmaker-4.5/texmaker.pro
===
--- 

commit octave for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package octave for openSUSE:Factory checked 
in at 2016-08-03 11:43:44

Comparing /work/SRC/openSUSE:Factory/octave (Old)
 and  /work/SRC/openSUSE:Factory/.octave.new (New)


Package is "octave"

Changes:

--- /work/SRC/openSUSE:Factory/octave/octave.changes2016-06-21 
12:29:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.octave.new/octave.changes   2016-08-03 
11:43:56.0 +0200
@@ -1,0 +2,18 @@
+Fri Jul 29 06:10:33 UTC 2016 - dmitr...@opensuse.org
+
+- Use original appdata file
+- Fix SLE12 build
+
+---
+Thu Jul 28 05:40:50 UTC 2016 - badshah...@gmail.com
+
+- Update to version 4.0.3:
+  * Bug fix release, see
+http://www.gnu.org/software/octave/fixes-4-0-3.html for a full
+list of fixes.
+- Add appdata file as source, and install it to
+  /usr/share/appdata; this makes octave appear on appstores like
+  gnome-software and KDE Discover.
+- Rebase octave-gcc6.patch for current version.
+
+---

Old:

  octave-4.0.2.tar.xz

New:

  octave-4.0.3.tar.xz



Other differences:
--
++ octave.spec ++
--- /var/tmp/diff_new_pack.vLMbOh/_old  2016-08-03 11:43:58.0 +0200
+++ /var/tmp/diff_new_pack.vLMbOh/_new  2016-08-03 11:43:58.0 +0200
@@ -45,7 +45,7 @@
 %endif
 
 Name:   octave
-Version:4.0.2
+Version:4.0.3
 Release:0
 # Required for RC builds, in this case version contains ~rc, src_ver -rc
 %define src_ver %{version}
@@ -265,6 +265,10 @@
 %if %{?with_gui}
 mv %{buildroot}/%{_datadir}/applications/*octave.desktop 
%{buildroot}/%{_datadir}/applications/octave.desktop
 %suse_update_desktop_file -r octave "Science;Math"
+# appdata
+mv %{buildroot}%{_datadir}/appdata/*octave.appdata.xml 
%{buildroot}%{_datadir}/appdata/octave.appdata.xml
+sed -i 's/www.octave.org-octave.desktop/octave.desktop/' 
%{buildroot}%{_datadir}/appdata/octave.appdata.xml
+sed -i 's/screenshot.png/screenshot-2016.png/' 
%{buildroot}%{_datadir}/appdata/octave.appdata.xml
 %else
 rm -rf %{buildroot}/%{_datadir}/icons/hicolor/
 rm -rf %{buildroot}/%{_datadir}/appdata/

++ octave-4.0.2.tar.xz -> octave-4.0.3.tar.xz ++
/work/SRC/openSUSE:Factory/octave/octave-4.0.2.tar.xz 
/work/SRC/openSUSE:Factory/.octave.new/octave-4.0.3.tar.xz differ: char 26, 
line 1

++ octave-gcc6.patch ++
--- /var/tmp/diff_new_pack.vLMbOh/_old  2016-08-03 11:43:58.0 +0200
+++ /var/tmp/diff_new_pack.vLMbOh/_new  2016-08-03 11:43:58.0 +0200
@@ -1,6 +1,7 @@
-diff -up octave-4.0.0/libinterp/corefcn/pr-output.cc.abs 
octave-4.0.0/libinterp/corefcn/pr-output.cc
 octave-4.0.0/libinterp/corefcn/pr-output.cc.abs2015-05-23 
08:21:53.0 -0600
-+++ octave-4.0.0/libinterp/corefcn/pr-output.cc2016-02-21 
08:59:30.966291273 -0700
+Index: octave-4.0.3/libinterp/corefcn/pr-output.cc
+===
+--- octave-4.0.3.orig/libinterp/corefcn/pr-output.cc
 octave-4.0.3/libinterp/corefcn/pr-output.cc
 @@ -21,7 +21,7 @@ along with Octave; see the file COPYING.
  */
  
@@ -25,9 +26,10 @@
  template 
  /* static */ inline void
  octave_print_internal_template (std::ostream& os, const intNDArray& nda,
-diff -up octave-4.0.0/liboctave/cruft/Faddeeva/Faddeeva.hh.gnulib 
octave-4.0.0/liboctave/cruft/Faddeeva/Faddeeva.hh
 octave-4.0.0/liboctave/cruft/Faddeeva/Faddeeva.hh.gnulib   2015-05-23 
08:21:53.0 -0600
-+++ octave-4.0.0/liboctave/cruft/Faddeeva/Faddeeva.hh  2016-02-19 
19:50:04.693811663 -0700
+Index: octave-4.0.3/liboctave/cruft/Faddeeva/Faddeeva.hh
+===
+--- octave-4.0.3.orig/liboctave/cruft/Faddeeva/Faddeeva.hh
 octave-4.0.3/liboctave/cruft/Faddeeva/Faddeeva.hh
 @@ -27,6 +27,7 @@
  #ifndef FADDEEVA_HH
  #define FADDEEVA_HH 1
@@ -36,24 +38,3 @@
  #include 
  
  namespace Faddeeva {
-diff -up octave-4.0.1/libgnu/math.in.h.signbit octave-4.0.1/libgnu/math.in.h
 octave-4.0.1/libgnu/math.in.h.signbit  2015-05-14 01:31:01.0 
-0600
-+++ octave-4.0.1/libgnu/math.in.h  2016-03-23 17:34:43.719131933 -0600
-@@ -1,6 +1,6 @@
- /* A GNU-like .
- 
--   Copyright (C) 2002-2003, 2007-2015 Free Software Foundation, Inc.
-+   Copyright (C) 2002-2003, 2007-2016 Free Software Foundation, Inc.
- 
-This program is free software: you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-@@ -2205,7 +2205,8 @@ _GL_WARN_REAL_FLOATING_DECL (isnan);
- 
- 
- #if @GNULIB_SIGNBIT@
--# if @REPLACE_SIGNBIT_USING_GCC@
-+# if (@REPLACE_SIGNBIT_USING_GCC@ \
-+   

commit xmlrpc-c for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package xmlrpc-c for openSUSE:Factory 
checked in at 2016-08-03 11:43:17

Comparing /work/SRC/openSUSE:Factory/xmlrpc-c (Old)
 and  /work/SRC/openSUSE:Factory/.xmlrpc-c.new (New)


Package is "xmlrpc-c"

Changes:

--- /work/SRC/openSUSE:Factory/xmlrpc-c/xmlrpc-c.changes2015-11-18 
22:34:46.0 +0100
+++ /work/SRC/openSUSE:Factory/.xmlrpc-c.new/xmlrpc-c.changes   2016-08-03 
11:43:18.0 +0200
@@ -1,0 +2,5 @@
+Wed Jul 27 10:16:05 UTC 2016 - sch...@suse.de
+
+- narrowing.patch: fix invalid narrowing conversion
+
+---

New:

  narrowing.patch



Other differences:
--
++ xmlrpc-c.spec ++
--- /var/tmp/diff_new_pack.TZTDDp/_old  2016-08-03 11:43:19.0 +0200
+++ /var/tmp/diff_new_pack.TZTDDp/_new  2016-08-03 11:43:19.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package xmlrpc-c
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -28,6 +28,7 @@
 #SVN-Clone:http://svn.code.sf.net/p/xmlrpc-c/code/stable/
 #Snapshot: r2540
 Source: 
http://sourceforge.net/projects/xmlrpc-c/files/Xmlrpc-c%20Super%20Stable/%{version}/%{name}-%{version}.tgz
+Patch:  narrowing.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  gcc-c++
@@ -194,6 +195,7 @@
 
 %prep
 %setup -q 
+%patch -p1
 
 %build
 export CFLAGS_PERSONAL="%{optflags}"

++ narrowing.patch ++
Index: xmlrpc-c-1.33.18/src/cpp/base64.cpp
===
--- xmlrpc-c-1.33.18.orig/src/cpp/base64.cpp
+++ xmlrpc-c-1.33.18/src/cpp/base64.cpp
@@ -14,7 +14,7 @@ using namespace xmlrpc_c;
 
 namespace {
 
-char const table_a2b_base64[] = {
+signed char const table_a2b_base64[] = {
 -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1,
 -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,-1,
 -1,-1,-1,-1, -1,-1,-1,-1, -1,-1,-1,62, -1,-1,-1,63,



commit checkpolicy for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package checkpolicy for openSUSE:Factory 
checked in at 2016-08-03 11:43:15

Comparing /work/SRC/openSUSE:Factory/checkpolicy (Old)
 and  /work/SRC/openSUSE:Factory/.checkpolicy.new (New)


Package is "checkpolicy"

Changes:

--- /work/SRC/openSUSE:Factory/checkpolicy/checkpolicy.changes  2016-07-20 
09:17:32.0 +0200
+++ /work/SRC/openSUSE:Factory/.checkpolicy.new/checkpolicy.changes 
2016-08-03 11:43:17.0 +0200
@@ -1,0 +2,5 @@
+Thu Jul 21 13:02:06 UTC 2016 - jeng...@inai.de
+
+- Trim/update description
+
+---



Other differences:
--
++ checkpolicy.spec ++
--- /var/tmp/diff_new_pack.Snh6Q5/_old  2016-08-03 11:43:18.0 +0200
+++ /var/tmp/diff_new_pack.Snh6Q5/_new  2016-08-03 11:43:18.0 +0200
@@ -32,18 +32,13 @@
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 
 %description
-Security-enhanced Linux is a feature of the Linux(R) kernel and a
-number of utilities with enhanced security functionality designed to
-add mandatory access controls to Linux.  The Security-enhanced Linux
-kernel contains new architectural components originally developed to
-improve the security of the Flask operating system. These architectural
-components provide general support for the enforcement of many kinds of
-mandatory access control policies, including those based on the
-concepts of Type Enforcement(R), Role-based Access Control, and
-Multi-level Security.
+checkpolicy is the SELinux policy compiler. It uses libsepol to
+generate the binary policy.
 
-This package contains checkpolicy, the SELinux policy compiler. Only
-required for building policies.
+(Security-enhanced Linux is a feature of the kernel and some
+utilities that implement mandatory access control policies, such as
+Type Enforcement, Role-based Access Control and Multi-Level
+Security.)
 
 %prep
 %setup -q




commit python-XlsxWriter for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python-XlsxWriter for 
openSUSE:Factory checked in at 2016-08-03 11:42:45

Comparing /work/SRC/openSUSE:Factory/python-XlsxWriter (Old)
 and  /work/SRC/openSUSE:Factory/.python-XlsxWriter.new (New)


Package is "python-XlsxWriter"

Changes:

--- /work/SRC/openSUSE:Factory/python-XlsxWriter/python-XlsxWriter.changes  
2016-06-07 23:46:23.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-XlsxWriter.new/python-XlsxWriter.changes 
2016-08-03 11:42:47.0 +0200
@@ -1,0 +2,18 @@
+Fri Jul 22 16:23:41 UTC 2016 - sor.ale...@meowr.ru
+
+- Update to version 0.9.3 (changes since 0.8.7):
+  * Add workbook :func:`set_custom_property` method to set custom
+document properties.
+  * Fix for :func:`insert_image` issue when handling images with
+zero dpi.
+  * Add :ref:`trendline properties `:
+  ``intercept``, ``display_equation`` and ``display_r_squared``.
+  * Documented used of font rotation in chart :ref:`data labels
+`.
+  * Add workbook :func:`set_size` method to set the workbook window
+size.
+  * Add check to :func:`add_table` to prevent duplicate header
+names which leads to a corrupt Excel file.
+- Fix SLE 11 build.
+
+---

Old:

  XlsxWriter-0.8.7.tar.gz

New:

  XlsxWriter-0.9.3.tar.gz



Other differences:
--
++ python-XlsxWriter.spec ++
--- /var/tmp/diff_new_pack.Q39bzY/_old  2016-08-03 11:42:48.0 +0200
+++ /var/tmp/diff_new_pack.Q39bzY/_new  2016-08-03 11:42:48.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python-XlsxWriter
-Version:0.8.7
+Version:0.9.3
 Release:0
 Summary:Python module for writing OOXML spreadsheet files
 License:BSD-2-Clause
@@ -26,12 +26,17 @@
 Source: 
https://files.pythonhosted.org/packages/source/X/XlsxWriter/XlsxWriter-%{version}.tar.gz
 BuildRequires:  python-devel
 BuildRequires:  python-setuptools
-Provides:   python-xlsxwriter = %{version}
-Obsoletes:  python-xlsxwriter < %{version}
 Requires(post): update-alternatives
 Requires(postun): update-alternatives
-BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+# python-xlsxwriter was last used in openSUSE Leap 42.1.
+Provides:   python-xlsxwriter = %{version}
+Obsoletes:  python-xlsxwriter < %{version}
+%if 0%{?suse_version} >= 1120
 BuildArch:  noarch
+%else
+BuildRoot:  %{_tmppath}/%{name}-%{version}-build
+%py_requires
+%endif
 
 %description
 XlsxWriter is a Python module for writing files in the Microsoft
@@ -46,30 +51,32 @@
 python2 setup.py build
 
 %install
-python2 setup.py install --root=%{buildroot}
+python2 setup.py install \
+  --root=%{buildroot} --prefix=%{_prefix}
 
-# Prepare for update-alternatives usage
+# Prepare for update-alternatives usage.
 mkdir -p %{buildroot}%{_sysconfdir}/alternatives
-mv %{buildroot}%{_bindir}/vba_extract.py 
%{buildroot}%{_bindir}/vba_extract-%{py_ver}
-ln -s -f %{_sysconfdir}/alternatives/vba_extract 
%{buildroot}%{_bindir}/vba_extract
-# create a dummy target for /etc/alternatives/vba_extract
+mv %{buildroot}%{_bindir}/vba_extract.py \
+  %{buildroot}%{_bindir}/vba_extract-%{py_ver}
+ln -sf %{_sysconfdir}/alternatives/vba_extract 
%{buildroot}%{_bindir}/vba_extract
+# Create a dummy target for /etc/alternatives/vba_extract.
 touch %{buildroot}%{_sysconfdir}/alternatives/vba_extract
 
 %post
-"%_sbindir/update-alternatives" \
+"%{_sbindir}/update-alternatives" \
--install %{_bindir}/vba_extract vba_extract 
%{_bindir}/vba_extract-%{py_ver} 30
 
 %postun
 if [ $1 -eq 0 ] ; then
-"%_sbindir/update-alternatives" --remove vba_extract 
%{_bindir}/vba_extract-%{py_ver}
+"%{_sbindir}/update-alternatives" --remove vba_extract 
%{_bindir}/vba_extract-%{py_ver}
 fi
 
 %files
 %defattr(-,root,root)
 %doc Changes LICENSE.txt README.rst
+%ghost %{_sysconfdir}/alternatives/vba_extract
 %{_bindir}/vba_extract
 %{_bindir}/vba_extract-%{py_ver}
-%ghost %{_sysconfdir}/alternatives/vba_extract
 %{python_sitelib}/xlsxwriter/
 %{python_sitelib}/XlsxWriter-%{version}-py*.egg-info
 

++ XlsxWriter-0.8.7.tar.gz -> XlsxWriter-0.9.3.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XlsxWriter-0.8.7/Changes new/XlsxWriter-0.9.3/Changes
--- old/XlsxWriter-0.8.7/Changes2016-05-14 16:25:32.0 +0200
+++ new/XlsxWriter-0.9.3/Changes2016-07-09 00:15:36.0 +0200
@@ -1,4 +1,50 @@
 
+Release 0.9.3 - July 8 2016
+---
+
+* Added check to :func:`add_table` to prevent duplicate header names which
+  leads to a corrupt Excel file.
+  Issue `#362 

commit haproxy for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package haproxy for openSUSE:Factory checked 
in at 2016-08-03 11:43:11

Comparing /work/SRC/openSUSE:Factory/haproxy (Old)
 and  /work/SRC/openSUSE:Factory/.haproxy.new (New)


Package is "haproxy"

Changes:

--- /work/SRC/openSUSE:Factory/haproxy/haproxy.changes  2016-06-14 
23:07:09.0 +0200
+++ /work/SRC/openSUSE:Factory/.haproxy.new/haproxy.changes 2016-08-03 
11:43:12.0 +0200
@@ -1,0 +2,76 @@
+Tue Jul 19 01:50:28 UTC 2016 - mrueck...@suse.de
+
+- update to 1.6.7
+  - MINOR: new function my_realloc2 = realloc + free upon failure
+  - CLEANUP: fixed some usages of realloc leading to memory leak
+  - Revert "BUG/MINOR: ssl: fix potential memory leak in
+ssl_sock_load_dh_params()"
+  - BUG/MEDIUM: dns: fix alignment issues in the DNS response
+parser
+  - BUG/MINOR: Fix endiness issue in DNS header creation code
+- changes from 1.6.6
+  - BUG/MAJOR: fix listening IP address storage for frontends
+  - BUG/MINOR: fix listening IP address storage for frontends
+(cont)
+  - DOC: Fix typo so fetch is properly parsed by Cyril's converter
+  - BUG/MAJOR: http: fix breakage of "reqdeny" causing random
+crashes
+  - BUG/MEDIUM: stick-tables: fix breakage in table converters
+  - BUG/MEDIUM: dns: unbreak DNS resolver after header fix
+  - BUILD: fix build on Solaris 11
+  - CLEANUP: connection: fix double negation on memcmp()
+  - BUG/MEDIUM: stats: show servers state may show an servers from
+another backend
+  - BUG/MEDIUM: fix risk of segfault with "show tls-keys"
+  - BUG/MEDIUM: sticktables: segfault in some configuration error
+cases
+  - BUG/MEDIUM: lua: converters doesn't work
+  - BUG/MINOR: http: add-header: header name copied twice
+  - BUG/MEDIUM: http: add-header: buffer overwritten
+  - BUG/MINOR: ssl: fix potential memory leak in
+ssl_sock_load_dh_params()
+  - BUG/MINOR: http: url32+src should use the big endian version of
+url32
+  - BUG/MINOR: http: url32+src should check cli_conn before using
+it
+  - DOC: http: add documentation for url32 and url32+src
+  - BUG/MINOR: fix http-response set-log-level parsing error
+  - MINOR: systemd: Use variable for config and pidfile paths
+  - MINOR: systemd: Perform sanity check on config before reload
+(cherry picked from commit
+68535bddf305fdd22f1449a039939b57245212e7)
+  - BUG/MINOR: init: always ensure that global.rlimit_nofile
+matches actual limits
+  - BUG/MINOR: init: ensure that FD limit is raised to the max
+allowed
+  - BUG/MEDIUM: external-checks: close all FDs right after the
+fork()
+  - BUG/MAJOR: external-checks: use asynchronous signal delivery
+  - BUG/MINOR: external-checks: do not unblock undesired signals
+  - BUILD/MEDIUM: rebuild everything when an include file is
+changed
+  - BUILD/MEDIUM: force a full rebuild if some build options change
+  - BUG/MINOR: srv-state: fix incorrect output of state file
+  - BUG/MINOR: ssl: close ssl key file on error
+  - BUG/MINOR: http: fix misleading error message for response
+captures
+  - BUG/BUILD: don't automatically run "make" on "make install"
+  - DOC: add missing doc for
+http-request deny [deny_status ]
+- drop patches which were pulled from git before
+  0001-BUG-MAJOR-fix-listening-IP-address-storage-for-front.patch
+  0002-BUG-MINOR-fix-listening-IP-address-storage-for-front.patch
+  0003-DOC-Fix-typo-so-fetch-is-properly-parsed-by-Cyril-s-.patch
+  0004-BUG-MAJOR-http-fix-breakage-of-reqdeny-causing-rando.patch
+  0005-BUG-MEDIUM-stick-tables-fix-breakage-in-table-conver.patch
+  0006-BUG-MEDIUM-dns-unbreak-DNS-resolver-after-header-fix.patch
+  0007-BUILD-fix-build-on-Solaris-11.patch
+  0008-CLEANUP-connection-fix-double-negation-on-memcmp.patch
+  0009-BUG-MEDIUM-stats-show-servers-state-may-show-an-serv.patch
+  0010-BUG-MEDIUM-fix-risk-of-segfault-with-show-tls-keys.patch
+  0011-BUG-MEDIUM-sticktables-segfault-in-some-configuratio.patch
+  0012-BUG-MEDIUM-lua-converters-doesn-t-work.patch
+  0013-BUG-MINOR-http-add-header-header-name-copied-twice.patch
+  0014-BUG-MEDIUM-http-add-header-buffer-overwritten.patch
+
+---

Old:

  0001-BUG-MAJOR-fix-listening-IP-address-storage-for-front.patch
  0002-BUG-MINOR-fix-listening-IP-address-storage-for-front.patch
  0003-DOC-Fix-typo-so-fetch-is-properly-parsed-by-Cyril-s-.patch
  0004-BUG-MAJOR-http-fix-breakage-of-reqdeny-causing-rando.patch
  0005-BUG-MEDIUM-stick-tables-fix-breakage-in-table-conver.patch
  0006-BUG-MEDIUM-dns-unbreak-DNS-resolver-after-header-fix.patch
  0007-BUILD-fix-build-on-Solaris-11.patch
  0008-CLEANUP-connection-fix-double-negation-on-memcmp.patch
  0009-BUG-MEDIUM-stats-show-servers-state-may-show-an-serv.patch
  

commit squid for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package squid for openSUSE:Factory checked 
in at 2016-08-03 11:42:56

Comparing /work/SRC/openSUSE:Factory/squid (Old)
 and  /work/SRC/openSUSE:Factory/.squid.new (New)


Package is "squid"

Changes:

--- /work/SRC/openSUSE:Factory/squid/squid.changes  2016-07-14 
09:47:39.0 +0200
+++ /work/SRC/openSUSE:Factory/.squid.new/squid.changes 2016-08-03 
11:42:59.0 +0200
@@ -1,0 +2,9 @@
+Mon Jul 18 08:05:42 UTC 2016 - adam.ma...@suse.de
+
+- Remove no-op option from configure
+  --enable-ntlm-fail-open has been removed more than 4 years ago in 
+  squid 3.3.0.1 and apparently it wasn't useful for 10 years prior
+  to that already
+  http://www.squid-cache.org/mail-archive/squid-dev/201207/0072.html
+
+---



Other differences:
--
++ squid.spec ++
--- /var/tmp/diff_new_pack.NwCHwy/_old  2016-08-03 11:43:01.0 +0200
+++ /var/tmp/diff_new_pack.NwCHwy/_new  2016-08-03 11:43:01.0 +0200
@@ -183,7 +183,6 @@
--enable-auth-negotiate \
--enable-auth-digest \

--enable-external-acl-helpers=LDAP_group,eDirectory_userip,file_userip,kerberos_ldap_group,session,unix_group,wbinfo_group
 \
-   --enable-ntlm-fail-open \
--enable-stacktraces \
--enable-x-accelerator-vary \
--with-default-user=%{name} \




commit python-concurrentloghandler for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python-concurrentloghandler for 
openSUSE:Factory checked in at 2016-08-03 11:42:44

Comparing /work/SRC/openSUSE:Factory/python-concurrentloghandler (Old)
 and  /work/SRC/openSUSE:Factory/.python-concurrentloghandler.new (New)


Package is "python-concurrentloghandler"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-concurrentloghandler/python-concurrentloghandler.changes
  2013-09-27 18:00:20.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-concurrentloghandler.new/python-concurrentloghandler.changes
 2016-08-03 11:42:45.0 +0200
@@ -1,0 +2,9 @@
+Wed Jul 20 17:05:26 UTC 2016 - antoine.belv...@laposte.net
+
+- Fix build (boo#985412):
+  * Use --record-rpm instead of --record for listing files
+installed with setup.py
+  * Fix ConcurrentLogHandler-0.9.1-testpath.patch: py files were
+not installed.
+
+---



Other differences:
--
++ python-concurrentloghandler.spec ++
--- /var/tmp/diff_new_pack.4FhfTS/_old  2016-08-03 11:42:46.0 +0200
+++ /var/tmp/diff_new_pack.4FhfTS/_new  2016-08-03 11:42:46.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-concurrentloghandler
 #
-# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,11 +20,11 @@
 
 Name:   python-concurrentloghandler
 Version:0.9.1
-Release:1
+Release:0
 Summary:Concurrent logging handler
-Url:http://pypi.python.org/pypi/ConcurrentLogHandler
 License:Apache-2.0
 Group:  Development/Libraries/Python
+Url:http://pypi.python.org/pypi/ConcurrentLogHandler
 Source: 
https://pypi.python.org/packages/source/C/ConcurrentLogHandler/%{modname}-%{version}.tar.gz
 Patch0: %modname-0.9.1-testpath.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -51,7 +51,7 @@
 python setup.py build
 
 %install
-python setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT 
--install-data=%_defaultdocdir/%name --record=INSTALLED_FILES
+python setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT 
--install-data=%_defaultdocdir/%name --record-rpm=INSTALLED_FILES
 
 %files -f INSTALLED_FILES
 %defattr(-,root,root)

++ ConcurrentLogHandler-0.9.1-testpath.patch ++
--- /var/tmp/diff_new_pack.4FhfTS/_old  2016-08-03 11:42:46.0 +0200
+++ /var/tmp/diff_new_pack.4FhfTS/_new  2016-08-03 11:42:46.0 +0200
@@ -1,10 +1,9 @@
 --- setup.py
 +++ setup.py
-@@ -261,14 +261,7 @@
- "cloghandler",
+@@ -262,13 +262,7 @@ setup(name='ConcurrentLogHandler',
  "portalocker",
  ],
--  package_dir={ '' : 'src', },
+   package_dir={ '' : 'src', },
 -  data_files=[
 -('tests', ["stresstest.py"]),
 -('docs', [
@@ -12,7 +11,7 @@
 -'LICENSE',
 -]),
 -  ],
-+  data_files=[ ],
++  data_files=[],
url="http://launchpad.net/python-concurrent-log-handler;,
license = "http://www.apache.org/licenses/LICENSE-2.0;,
description=doc.pop(0),




commit bind-dyndb-ldap for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package bind-dyndb-ldap for openSUSE:Factory 
checked in at 2016-08-03 11:42:47

Comparing /work/SRC/openSUSE:Factory/bind-dyndb-ldap (Old)
 and  /work/SRC/openSUSE:Factory/.bind-dyndb-ldap.new (New)


Package is "bind-dyndb-ldap"

Changes:

--- /work/SRC/openSUSE:Factory/bind-dyndb-ldap/bind-dyndb-ldap.changes  
2015-07-02 22:47:25.0 +0200
+++ /work/SRC/openSUSE:Factory/.bind-dyndb-ldap.new/bind-dyndb-ldap.changes 
2016-08-03 11:42:51.0 +0200
@@ -1,0 +2,7 @@
+Sat Jul 23 01:34:38 UTC 2016 - r...@fthiessen.de
+
+- Update to 10.0
+- Added fix-initializers.patch to fix missing-field-initializers
+  for gcc < 5.
+
+---

Old:

  bind-dyndb-ldap-7.0.tar.bz2
  bind-dyndb-ldap-7.0.tar.bz2.asc

New:

  bind-dyndb-ldap-10.0.tar.bz2
  bind-dyndb-ldap-10.0.tar.bz2.asc
  fix-initializers.patch



Other differences:
--
++ bind-dyndb-ldap.spec ++
--- /var/tmp/diff_new_pack.TadYFS/_old  2016-08-03 11:42:52.0 +0200
+++ /var/tmp/diff_new_pack.TadYFS/_new  2016-08-03 11:42:52.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package bind-dyndb-ldap
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -17,7 +17,7 @@
 
 
 Name:   bind-dyndb-ldap
-Version:7.0
+Version:10.0
 Release:0
 Summary:LDAP back-end plug-in for BIND
 License:GPL-2.0+
@@ -26,11 +26,15 @@
 Source0:
https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.bz2
 Source1:
https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar.bz2.asc
 Source2:%{name}.keyring
+# PATCH-FIX-UPSTREAM fix-initializers.patch -- Fix initializers, needed for 
gcc < 5
+Patch0: fix-initializers.patch
 BuildRequires:  bind-devel >= 9.10.0
 BuildRequires:  cyrus-sasl-devel
 BuildRequires:  krb5-devel
 BuildRequires:  libtool
 BuildRequires:  openldap2-devel
+BuildRequires:  pkgconfig
+BuildRequires:  pkgconfig(uuid)
 Requires:   bind >= 9.10.1
 
 %description
@@ -40,6 +44,9 @@
 
 %prep
 %setup -q
+%if 0%{?suse_version} <= 1320
+%patch0 -p1
+%endif
 # If building by osc, remove date and time from the code:
 if test -f %{_sourcedir}/%{name}.changes ; then
LANG=C sed -i "$(date +'s/compiled at " __TIME__ " " __DATE__/last 
change %%T %%b %%e %%Y"/' -r %{_sourcedir}/%{name}.changes)" src/zone_manager.c
@@ -53,13 +60,13 @@
 
 %install
 %make_install
-rm %{buildroot}/usr/lib/bind/ldap.la
+rm %{buildroot}%{_prefix}/lib/bind/ldap.la
 install -m0644 COPYING %{buildroot}%{_docdir}/%{name}/
 
 %files
 %defattr(-,root,root,-)
 %doc %{_docdir}/%{name}
-%dir /usr/lib/bind
-/usr/lib/bind/ldap.so
+%dir %{_prefix}/lib/bind
+%{_prefix}/lib/bind/ldap.so
 
 %changelog

++ bind-dyndb-ldap-7.0.tar.bz2 -> bind-dyndb-ldap-10.0.tar.bz2 ++
 32912 lines of diff (skipped)

++ fix-initializers.patch ++
diff -Nur bind-dyndb-ldap-10.0/src/empty_zones.c new/src/empty_zones.c
--- bind-dyndb-ldap-10.0/src/empty_zones.c  2016-06-21 12:36:48.0 
+0200
+++ new/src/empty_zones.c   2016-07-23 16:48:13.850536143 +0200
@@ -303,7 +303,8 @@
 {
isc_result_t result;
isc_boolean_t first = ISC_TRUE;
-   empty_zone_search_t eziter = {}; /* init with zeroes */
+   empty_zone_search_t eziter;
+memset(, 0, sizeof(eziter)); /* init with zeroes */
char name_char[DNS_NAME_FORMATSIZE];
char ezname_char[DNS_NAME_FORMATSIZE];
 
diff -Nur bind-dyndb-ldap-10.0/src/mldap.c new/src/mldap.c
--- bind-dyndb-ldap-10.0/src/mldap.c2016-06-21 12:36:48.0 +0200
+++ new/src/mldap.c 2016-07-23 16:51:43.637160454 +0200
@@ -478,7 +478,7 @@
isc_result_t result;
dns_dbnode_t *rbt_node = NULL;
metadb_iter_t *iter = NULL;
-   isc_uint32_t node_generation;
+   isc_uint32_t node_generation = 0;
isc_uint32_t cur_generation;
metadb_node_t metadb_node;
DECLARE_BUFFERED_NAME(name);



commit docker for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package docker for openSUSE:Factory checked 
in at 2016-08-03 11:42:38

Comparing /work/SRC/openSUSE:Factory/docker (Old)
 and  /work/SRC/openSUSE:Factory/.docker.new (New)


Package is "docker"

Changes:

--- /work/SRC/openSUSE:Factory/docker/docker.changes2016-07-15 
12:54:24.0 +0200
+++ /work/SRC/openSUSE:Factory/.docker.new/docker.changes   2016-08-03 
11:42:40.0 +0200
@@ -1,0 +2,5 @@
+Tue Jul 19 17:03:32 UTC 2016 - jmassaguer...@suse.com
+
+- remove kernel dependency (bsc#987198)
+
+---
@@ -30 +35 @@
-* Update Docker to 1.11.2. Changelog from upstream:
+* Update Docker to 1.11.2. (bsc#989566) Changelog from upstream:



Other differences:
--
++ docker.spec ++
--- /var/tmp/diff_new_pack.aV7aQ7/_old  2016-08-03 11:42:41.0 +0200
+++ /var/tmp/diff_new_pack.aV7aQ7/_new  2016-08-03 11:42:41.0 +0200
@@ -67,7 +67,6 @@
 Requires:   git-core >= 1.7
 Requires:   iproute2 >= 3.5
 Requires:   iptables >= 1.4
-Requires:   kernel >= 3.8.0
 Requires:   lvm2 >= 2.2.89
 Requires:   procps
 Requires:   tar >= 1.26




commit docker-compose for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package docker-compose for openSUSE:Factory 
checked in at 2016-08-03 11:43:04

Comparing /work/SRC/openSUSE:Factory/docker-compose (Old)
 and  /work/SRC/openSUSE:Factory/.docker-compose.new (New)


Package is "docker-compose"

Changes:

--- /work/SRC/openSUSE:Factory/docker-compose/docker-compose.changes
2016-04-22 16:23:23.0 +0200
+++ /work/SRC/openSUSE:Factory/.docker-compose.new/docker-compose.changes   
2016-08-03 11:43:07.0 +0200
@@ -1,0 +2,88 @@
+Mon Jul 25 07:38:06 UTC 2016 - tboer...@suse.com
+
+- Updated fix-requirements.patch for new code base
+- Update to version 1.7.1
+  * 1.7.1
++ Fixed a bug where the output of docker-compose config for v1 files would
+  be an invalid configuration file.
++ Fixed a bug where docker-compose config would not check the validity of
+  links.
++ Fixed an issue where docker-compose help would not output a list of
+  available commands and generic options as expected.
++ Fixed an issue where filtering by service when using docker-compose logs
+  would not apply for newly created services.
++ Fixed a bug where unchanged services would sometimes be recreated in in
+  the up phase when using Compose with Python 3.
++ Fixed an issue where API errors encountered during the up phase would not
+  be recognized as a failure state by Compose.
++ Fixed a bug where Compose would raise a NameError because of an undefined
+  exception name on non-Windows platforms.
++ Fixed a bug where the wrong version of docker-py would sometimes be
+  installed alongside Compose.
++ Fixed a bug where the host value output by docker-machine config default
+  would not be recognized as valid options by the docker-compose command 
line.
++ Fixed an issue where Compose would sometimes exit unexpectedly while
+  reading events broadcasted by a Swarm cluster.
++ Corrected a statement in the docs about the location of the .env file,
+  which is indeed read from the current directory, instead of in the same 
location as the Compose file.
+  * 1.7.0
++ docker-compose logs no longer follows log output by default. It now
+  matches the behaviour of docker logs and exits after the current logs are
+  printed. Use -f to get the old default behaviour.
++ Booleans are no longer allows as values for mappings in the Compose file
+  (for keys environment, labels and extra_hosts). Previously this was a
+  warning. Boolean values should be quoted so they become string values.
++ Compose now looks for a .env file in the directory where it's run and
+  reads any environment variables defined inside, if they're not already 
set
+  in the shell environment. This lets you easily set defaults for variables
+  used in the Compose file, or for any of the COMPOSE_* or DOCKER_*
+  variables.
++ Added a --remove-orphans flag to both docker-compose up and 
docker-compose
+  down to remove containers for services that were removed from the Compose
+  file.
++ Added a --all flag to docker-compose rm to include containers created by
+  docker-compose run. This will become the default behavior in the next
+  version of Compose.
++ Added support for all the same TLS configuration flags used by the docker
+  client: --tls, --tlscert, --tlskey, etc.
++ Compose files now support the tmpfs and shm_size options.
++ Added the --workdir flag to docker-compose run
++ docker-compose logs now shows logs for new containers that are created
+  after it starts.
++ The COMPOSE_FILE environment variable can now contain multiple files,
+  separated by the host system's standard path separator (: on Mac/Linux, ;
+  on Windows).
++ You can now specify a static IP address when connecting a service to a
+  network with the ipv4_address and ipv6_address options.
++ Added --follow, --timestamp, and --tail flags to the docker-compose logs
+  command.
++ docker-compose up, and docker-compose start will now start containers in
+  parallel where possible.
++ docker-compose stop now stops containers in reverse dependency order
+  instead of all at once.
++ Added the --build flag to docker-compose up to force it to build a new
+  image. It now shows a warning if an image is automatically built when the
+  flag is not used.
++ Added the docker-compose exec command for executing a process in a 
running
+  container.
++ docker-compose down now removes containers created by docker-compose run.
++ A more appropriate error is shown when a timeout is hit during up when
+  using a tty.
++ Fixed a bug in docker-compose down where it would abort if some resources
+  had 

commit libisofs for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libisofs for openSUSE:Factory 
checked in at 2016-08-03 11:42:16

Comparing /work/SRC/openSUSE:Factory/libisofs (Old)
 and  /work/SRC/openSUSE:Factory/.libisofs.new (New)


Package is "libisofs"

Changes:

--- /work/SRC/openSUSE:Factory/libisofs/libisofs.changes2016-07-27 
16:29:02.0 +0200
+++ /work/SRC/openSUSE:Factory/.libisofs.new/libisofs.changes   2016-08-03 
11:42:18.0 +0200
@@ -1,0 +2,29 @@
+Wed Jul 27 21:46:36 UTC 2016 - asterios.dra...@gmail.com
+
+- Update to 1.4.4:
+  * Bug fix: HFS+ production could cause MBR partition of type 0xEE
+without GPT.
+  * Bug fix: Protective MBR was not produced if no System Area data
+are given.
+  * Bug fix: Protective MBR was not recognized if partition is
+appended.
+  * Bug fix: The HFS+ filesystem was not marked in GPT of GRUB2
+hybrid layout.
+  * Bug fix: HFS+ directories could announce more children than
+they actually have.
+  * Bug fix: At image loading time GRUB2 MBR was not recognized if
+the partition table is not the protective one as described by
+UEFI.
+  * Bug fix: Oversized text in ISO_SYSAREA_REPORT_DOC_ALPHA.
+  * New pseudo path for El Torito boot images:
+--interval:appened_partition_N:all::
+  * New bit15 with options of iso_write_opts_set_system_area() to
+enforce MBR bootable/active flag.
+  * New API calls iso_write_opts_set_appended_as_apm(),
+iso_write_opts_set_part_like_isohybrid().
+  * Introduced image size tolerance of 300 kB in order to recognize
+SUN Disk Label that was generated by genisoimage -B "...".
+  * Added "extern C" to libisofs.h
+  * Removed option --silent from libtool runs.
+
+---

Old:

  libisofs-1.4.2.tar.gz

New:

  libisofs-1.4.4.tar.gz



Other differences:
--
++ libisofs.spec ++
--- /var/tmp/diff_new_pack.UY8yr8/_old  2016-08-03 11:42:19.0 +0200
+++ /var/tmp/diff_new_pack.UY8yr8/_new  2016-08-03 11:42:19.0 +0200
@@ -18,7 +18,7 @@
 
 %define so_ver 6
 Name:   libisofs
-Version:1.4.2
+Version:1.4.4
 Release:0
 Summary:Library for Creating ISO-9660 Filesystems
 License:GPL-2.0+ and LGPL-2.0+

++ libisofs-1.4.2.tar.gz -> libisofs-1.4.4.tar.gz ++
 2704 lines of diff (skipped)




commit virt-viewer for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package virt-viewer for openSUSE:Factory 
checked in at 2016-08-03 11:42:54

Comparing /work/SRC/openSUSE:Factory/virt-viewer (Old)
 and  /work/SRC/openSUSE:Factory/.virt-viewer.new (New)


Package is "virt-viewer"

Changes:

--- /work/SRC/openSUSE:Factory/virt-viewer/virt-viewer.changes  2016-07-20 
09:17:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.virt-viewer.new/virt-viewer.changes 
2016-08-03 11:42:56.0 +0200
@@ -1,0 +2,6 @@
+Fri Jul 22 13:41:25 UTC 2016 - jeng...@inai.de
+
+- Use source URL
+- Remove redundant %clean section
+
+---

Old:

  virt-viewer-4.0.tar.bz2

New:

  virt-viewer-4.0.tar.gz



Other differences:
--
++ virt-viewer.spec ++
--- /var/tmp/diff_new_pack.zlltjP/_old  2016-08-03 11:42:58.0 +0200
+++ /var/tmp/diff_new_pack.zlltjP/_new  2016-08-03 11:42:58.0 +0200
@@ -29,7 +29,7 @@
 Version:4.0
 Release:0
 Url:http://www.virt-manager.org
-Source0:virt-viewer-4.0.tar.bz2
+Source: 
https://virt-manager.org/download/sources/virt-viewer/%name-%version.tar.gz
 Patch1: 35e489d5-fix-display-of-guest-name-in-title-for-vnc.patch
 Patch2: a62827d2-close-when-seeing-domain-stop-event.patch
 Patch50:netcat.patch
@@ -96,9 +96,6 @@
 %makeinstall
 %{find_lang} %{name}
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files -f %{name}.lang
 %defattr(-,root,root,-)
 %doc COPYING AUTHORS ChangeLog




commit yast2-bootloader for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package yast2-bootloader for 
openSUSE:Factory checked in at 2016-08-03 11:42:35

Comparing /work/SRC/openSUSE:Factory/yast2-bootloader (Old)
 and  /work/SRC/openSUSE:Factory/.yast2-bootloader.new (New)


Package is "yast2-bootloader"

Changes:

--- /work/SRC/openSUSE:Factory/yast2-bootloader/yast2-bootloader.changes
2016-07-16 22:12:44.0 +0200
+++ /work/SRC/openSUSE:Factory/.yast2-bootloader.new/yast2-bootloader.changes   
2016-08-03 11:42:37.0 +0200
@@ -1,0 +2,7 @@
+Mon Jul 18 14:56:27 UTC 2016 - jreidin...@suse.com
+
+- do not fail tests when run in environment connected by serial
+  console (bnc#989405)
+- 3.1.199
+
+---

Old:

  yast2-bootloader-3.1.198.tar.bz2

New:

  yast2-bootloader-3.1.199.tar.bz2



Other differences:
--
++ yast2-bootloader.spec ++
--- /var/tmp/diff_new_pack.9wtnrO/_old  2016-08-03 11:42:38.0 +0200
+++ /var/tmp/diff_new_pack.9wtnrO/_new  2016-08-03 11:42:38.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-bootloader
-Version:3.1.198
+Version:3.1.199
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ yast2-bootloader-3.1.198.tar.bz2 -> yast2-bootloader-3.1.199.tar.bz2 
++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-bootloader-3.1.198/package/yast2-bootloader.changes 
new/yast2-bootloader-3.1.199/package/yast2-bootloader.changes
--- old/yast2-bootloader-3.1.198/package/yast2-bootloader.changes   
2016-07-15 12:18:52.0 +0200
+++ new/yast2-bootloader-3.1.199/package/yast2-bootloader.changes   
2016-07-18 17:25:07.0 +0200
@@ -1,4 +1,11 @@
 ---
+Mon Jul 18 14:56:27 UTC 2016 - jreidin...@suse.com
+
+- do not fail tests when run in environment connected by serial
+  console (bnc#989405)
+- 3.1.199
+
+---
 Wed Jul 13 08:49:50 UTC 2016 - jreidin...@suse.com
 
 - fix writing default boot entry when it is located in grub2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/yast2-bootloader-3.1.198/package/yast2-bootloader.spec 
new/yast2-bootloader-3.1.199/package/yast2-bootloader.spec
--- old/yast2-bootloader-3.1.198/package/yast2-bootloader.spec  2016-07-15 
12:18:52.0 +0200
+++ new/yast2-bootloader-3.1.199/package/yast2-bootloader.spec  2016-07-18 
17:25:07.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   yast2-bootloader
-Version:3.1.198
+Version:3.1.199
 Release:0
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-bootloader-3.1.198/test/grub2base_test.rb 
new/yast2-bootloader-3.1.199/test/grub2base_test.rb
--- old/yast2-bootloader-3.1.198/test/grub2base_test.rb 2016-07-15 
12:18:52.0 +0200
+++ new/yast2-bootloader-3.1.199/test/grub2base_test.rb 2016-07-18 
17:25:07.0 +0200
@@ -120,11 +120,47 @@
   allow(Yast::Arch).to receive(:architecture).and_return("s390_64")
 end
 
-it "proposes console terminal" do
+context "with TERM=\"linux\"" do
+  before do
+allow(ENV).to receive(:"[]").with("TERM").and_return("linux")
+  end
+
+  it "proposes to use serial terminal" do
+subject.propose
+
+expect(subject.grub_default.terminal).to eq :serial
+  end
+end
+
+context "on other TERM" do
+  before do
+allow(ENV).to receive(:"[]").with("TERM").and_return("xterm")
+  end
+
+  it "proposes to use console terminal" do
+subject.propose
+
+expect(subject.grub_default.terminal).to eq :console
+  end
+end
+  end
+
+  context "on ppc" do
+before do
+  allow(Yast::Arch).to receive(:architecture).and_return("ppc64")
+end
+
+it "proposes to use console terminal" do
   subject.propose
 
   expect(subject.grub_default.terminal).to eq :console
 end
+
+it "sets GFXPAYLOAD_LINUX to text" do
+  subject.propose
+
+  expect(subject.grub_default.generic_get("GRUB_GFXPAYLOAD_LINUX")).to 
eq "text"
+end
   end
 
   context "otherwise" do
@@ -213,7 +249,7 @@
 
 context "with TERM=\"linux\"" do
   before do
-ENV["TERM"] = "linux"
+allow(ENV).to receive(:"[]").with("TERM").and_return("linux")
   end
 
   it 

commit python-discid for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python-discid for openSUSE:Factory 
checked in at 2016-08-03 11:42:51

Comparing /work/SRC/openSUSE:Factory/python-discid (Old)
 and  /work/SRC/openSUSE:Factory/.python-discid.new (New)


Package is "python-discid"

Changes:

--- /work/SRC/openSUSE:Factory/python-discid/python-discid.changes  
2016-07-24 19:52:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-discid.new/python-discid.changes 
2016-08-03 11:42:54.0 +0200
@@ -1,0 +2,5 @@
+Sun Jul 24 00:10:11 UTC 2016 - r...@fthiessen.de
+
+- Update to current upstream release 1.1.0
+
+---

Old:

  discid-1.0.2.tar.gz

New:

  discid-1.1.0.tar.gz



Other differences:
--
++ python-discid.spec ++
--- /var/tmp/diff_new_pack.D4g9WH/_old  2016-08-03 11:42:55.0 +0200
+++ /var/tmp/diff_new_pack.D4g9WH/_new  2016-08-03 11:42:55.0 +0200
@@ -21,13 +21,13 @@
 %define modname discid
 
 Name:   python-%{modname}
-Version:1.0.2
+Version:1.1.0
 Release:0
 Summary:Python binding of Libdiscid
 License:LGPL-3.0+
 Group:  Development/Libraries/Python
 Url:https://python-discid.readthedocs.org/
-Source: 
http://pypi.python.org/packages/source/d/%{modname}/%{modname}-%{version}.tar.gz
+Source: 
https://pypi.python.org/packages/source/d/%{modname}/%{modname}-%{version}.tar.gz
 # no automatic requires since libdiscid is not linked
 Requires:   libdiscid0 >= 0.2.2
 BuildRequires:  libdiscid0 >= 0.2.2

++ discid-1.0.2.tar.gz -> discid-1.1.0.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/discid-1.0.2/CHANGES.rst new/discid-1.1.0/CHANGES.rst
--- old/discid-1.0.2/CHANGES.rst2013-06-27 16:38:20.0 +0200
+++ new/discid-1.1.0/CHANGES.rst2013-10-09 22:19:51.0 +0200
@@ -1,6 +1,15 @@
 Changelog
 =
 
+Changes in 1.1.0 (2013-10-09):
+--
+ * feature :issue:`36` add :attr:`Disc.toc_string`
+ * :issue:`38` remove :class:`DiscId` (deprecated since 0.5.0)
+
+Changes in 1.0.3 (2013-10-06):
+--
+ * fix: :issue:`37` test_emptyness: Assertion disc->success failed
+
 Changes in 1.0.2 (2013-06-27):
 --
  * revert code to version 1.0.0 (see :issue:`35`)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/discid-1.0.2/PKG-INFO new/discid-1.1.0/PKG-INFO
--- old/discid-1.0.2/PKG-INFO   2013-06-27 16:45:08.0 +0200
+++ new/discid-1.1.0/PKG-INFO   2013-10-09 22:23:50.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: discid
-Version: 1.0.2
+Version: 1.1.0
 Summary: Python binding of Libdiscid
 Home-page: https://python-discid.readthedocs.org/
 Author: Johannes Dewender
@@ -67,5 +67,8 @@
 Classifier: Programming Language :: Python :: 2.6
 Classifier: Programming Language :: Python :: 2.7
 Classifier: Programming Language :: Python :: 3
+Classifier: Programming Language :: Python :: 3.1
+Classifier: Programming Language :: Python :: 3.2
+Classifier: Programming Language :: Python :: 3.3
 Classifier: Topic :: Multimedia :: Sound/Audio :: CD Audio :: CD Ripping
 Classifier: Topic :: Software Development :: Libraries :: Python Modules
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/discid-1.0.2/discid/__init__.py 
new/discid-1.1.0/discid/__init__.py
--- old/discid-1.0.2/discid/__init__.py 2013-06-27 16:38:29.0 +0200
+++ new/discid-1.1.0/discid/__init__.py 2013-10-09 22:19:29.0 +0200
@@ -30,11 +30,10 @@
 from discid.disc import read, put, Disc, DiscError, TOCError
 from discid.track import Track
 from discid.libdiscid import get_default_device
-from discid.deprecated import DiscId
 import discid.libdiscid
 import discid.disc
 
-__version__ = "1.0.2"
+__version__ = "1.1.0"
 
 
 # these contants are defined here so sphinx can catch the "docstrings"
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/discid-1.0.2/discid/deprecated.py 
new/discid-1.1.0/discid/deprecated.py
--- old/discid-1.0.2/discid/deprecated.py   2013-06-27 15:51:06.0 
+0200
+++ new/discid-1.1.0/discid/deprecated.py   1970-01-01 01:00:00.0 
+0100
@@ -1,37 +0,0 @@
-# Copyright (C) 2013  Johannes Dewender
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is 

commit python-docker-py for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python-docker-py for 
openSUSE:Factory checked in at 2016-08-03 11:43:01

Comparing /work/SRC/openSUSE:Factory/python-docker-py (Old)
 and  /work/SRC/openSUSE:Factory/.python-docker-py.new (New)


Package is "python-docker-py"

Changes:

--- /work/SRC/openSUSE:Factory/python-docker-py/python-docker-py.changes
2016-03-07 13:29:58.0 +0100
+++ /work/SRC/openSUSE:Factory/.python-docker-py.new/python-docker-py.changes   
2016-08-03 11:43:03.0 +0200
@@ -1,0 +2,39 @@
+Mon Jul 25 08:47:05 UTC 2016 - tboer...@suse.com
+
+- Updated runtime and test deps matching setup.py and test-requirements.txt
+- update to 1.8.1:
+  * Fixed a bug where calling login() against the default registry would fail
+with the 1.10.x engine
+  * Fixed a bug where values in environment files would be parsed incorrectly 
if
+they contained an equal sign.
+  * Switched to a better supported backport of the match_hostname function,
+fixing dependency issues in some environments.
+- update to 1.8.0:
+  * Added Client.update_container method (Update resource configs of a
+container)
+  * Added support for gzipped context in Client.build
+  * Added ability to specify IP address when connecting a container to a 
network
+  * Added tmpfs support to Client.create_host_config
+  * Added support for the changes param in Client.commit
+  * Added support for the follow param in Client.logs
+  * Added support for the check_duplicate param in Client.create_network
+  * Added support for the decode param in Client.push and Client.pull
+  * Added docker.from_env shortcut function. Instantiates a client with
+kwargs_from_env
+  * kwargs_from_env now supports an optional environment parameter. If present,
+values will be fetched from this dictionary instead of os.environ
+  * Fixed a bug where TLS verification would fail when using IP addresses in 
the
+certificate's subjectAltName fields
+  * Fixed an issue where the default TLS version in TLSConfig would break in
+some environments. docker-py now uses TLSv1 by default This setting can be
+overridden using the ssl_version param in kwargs_from_env or the TLSConfig
+constructor
+  * Fixed a bug where tcp hosts would fail to connect to TLS-enabled endpoints
+  * Fixed a bug where loading a valid docker configuration file would fail
+  * Fixed a bug where some environment variables specified through
+create_container would be improperly formatted
+  * Fixed a bug where using the unix socket connection would raise an error in
+some edge-case situations
+  * Default API version is now 1.22 (introduced in Docker 1.10.0)
+
+---
@@ -5,5 +44,10 @@
-  * Added support for the since param in Client.logs (introduced in API 
version 1.19)
-  * Added support for the DOCKER_CONFIG environment variable when looking up 
auth config
-  * Added support for the stream param in Client.stats (when set to False, 
allows user to retrieve a single snapshot instead of a constant data stream)
-  * Added support for the mem_swappiness, oom_kill_disable params in 
Client.create_host_config
-  * Added support for build arguments in Client.build through the buildargs 
param.
+  * Added support for the since param in Client.logs (introduced in API version
+1.19)
+  * Added support for the DOCKER_CONFIG environment variable when looking up
+auth config
+  * Added support for the stream param in Client.stats (when set to False,
+allows user to retrieve a single snapshot instead of a constant data 
stream)
+  * Added support for the mem_swappiness, oom_kill_disable params in
+Client.create_host_config
+  * Added support for build arguments in Client.build through the buildargs
+param.
@@ -14,2 +58,4 @@
-  * Added support for unspecified transfer protocol in base_url when TLS is 
enabled.
-  * Fixed a bug where TLS verification was improperly executed when providing 
a custom CA certificate.
+  * Added support for unspecified transfer protocol in base_url when TLS is
+enabled.
+  * Fixed a bug where TLS verification was improperly executed when providing a
+custom CA certificate.
@@ -17,0 +64 @@
+

Old:

  docker-py-1.7.2.tar.gz

New:

  docker-py-1.8.1.tar.gz



Other differences:
--
++ python-docker-py.spec ++
--- /var/tmp/diff_new_pack.sNIBxf/_old  2016-08-03 11:43:04.0 +0200
+++ /var/tmp/diff_new_pack.sNIBxf/_new  2016-08-03 11:43:04.0 +0200
@@ -18,13 +18,13 @@
 
 %define upstream_name docker-py
 Name:   python-docker-py
-Version:1.7.2
+Version:1.8.1
 Release:0
 Summary:Docker API Client
 License:

commit at-spi2-core for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package at-spi2-core for openSUSE:Factory 
checked in at 2016-08-03 11:42:21

Comparing /work/SRC/openSUSE:Factory/at-spi2-core (Old)
 and  /work/SRC/openSUSE:Factory/.at-spi2-core.new (New)


Package is "at-spi2-core"

Changes:

--- /work/SRC/openSUSE:Factory/at-spi2-core/at-spi2-core.changes
2016-07-27 16:06:58.0 +0200
+++ /work/SRC/openSUSE:Factory/.at-spi2-core.new/at-spi2-core.changes   
2016-08-03 11:42:23.0 +0200
@@ -1,0 +2,6 @@
+Wed Jul 27 16:56:37 UTC 2016 - mgo...@suse.com
+
+- Update at-spi2-core-session-management.patch: fix uninitialized
+  variable (bsc#984109).
+
+---
@@ -31,0 +38,6 @@
+Thu Apr 14 12:57:07 UTC 2016 - mgo...@suse.com
+
+- Update to GNOME 3.20  Fate#318572
+- Drop at-spi2-core-null-event-source.patch: fixed upstream.
+
+---
@@ -255,0 +268,6 @@
+
+---
+Mon Mar 17 16:13:00 UTC 2014 - mgo...@suse.com
+
+- Add at-spi2-core-null-event-source.patch -- avoid crashing if
+  an event's source is set to NULL (bgo#726243).



Other differences:
--
++ at-spi2-core-session-management.patch ++
--- /var/tmp/diff_new_pack.LIeAB6/_old  2016-08-03 11:42:24.0 +0200
+++ /var/tmp/diff_new_pack.LIeAB6/_new  2016-08-03 11:42:24.0 +0200
@@ -104,7 +104,7 @@
 +  A11yBusLauncher *app = user_data;
 +  GVariant   *values;
 +  GError *error = NULL;
-+gboolean is_running;
++gboolean is_running = FALSE;
 +
 +  proxy = G_DBUS_PROXY (source_object);
 +  values = g_dbus_proxy_call_finish (proxy, res, );




commit hwinfo for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package hwinfo for openSUSE:Factory checked 
in at 2016-08-03 11:42:04

Comparing /work/SRC/openSUSE:Factory/hwinfo (Old)
 and  /work/SRC/openSUSE:Factory/.hwinfo.new (New)


Package is "hwinfo"

Changes:

--- /work/SRC/openSUSE:Factory/hwinfo/hwinfo.changes2016-07-20 
09:16:59.0 +0200
+++ /work/SRC/openSUSE:Factory/.hwinfo.new/hwinfo.changes   2016-08-03 
11:42:05.0 +0200
@@ -1,0 +2,6 @@
+Thu Jul 28 13:54:59 UTC 2016 - snw...@suse.com
+
+- fix input device name detection for usb devices (bsc#989633)
+- 21.30
+
+---

Old:

  hwinfo-21.29.tar.xz

New:

  hwinfo-21.30.tar.xz



Other differences:
--
++ hwinfo.spec ++
--- /var/tmp/diff_new_pack.NrGa9h/_old  2016-08-03 11:42:06.0 +0200
+++ /var/tmp/diff_new_pack.NrGa9h/_new  2016-08-03 11:42:06.0 +0200
@@ -36,7 +36,7 @@
 Group:  Hardware/Other
 # Until migration to github this should be correct url
 Url:http://gitorious.org/opensuse/hwinfo
-Version:21.29
+Version:21.30
 Release:0
 Source: %{name}-%{version}.tar.xz
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build

++ hwinfo-21.29.tar.xz -> hwinfo-21.30.tar.xz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hwinfo-21.29/VERSION new/hwinfo-21.30/VERSION
--- old/hwinfo-21.29/VERSION2016-07-14 10:59:21.0 +0200
+++ new/hwinfo-21.30/VERSION2016-07-28 15:50:17.0 +0200
@@ -1 +1 @@
-21.29
+21.30
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hwinfo-21.29/changelog new/hwinfo-21.30/changelog
--- old/hwinfo-21.29/changelog  2016-07-14 10:59:21.0 +0200
+++ new/hwinfo-21.30/changelog  2016-07-28 15:50:17.0 +0200
@@ -1,3 +1,6 @@
+2016-07-28:21.30
+   - fix input device name detection for usb devices (bsc #989633)
+
 2016-07-14:21.29
- refine last patch a bit (bsc #960507)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/hwinfo-21.29/src/hd/usb.c 
new/hwinfo-21.30/src/hd/usb.c
--- old/hwinfo-21.29/src/hd/usb.c   2016-07-14 10:59:21.0 +0200
+++ new/hwinfo-21.30/src/hd/usb.c   2016-07-28 15:50:17.0 +0200
@@ -569,41 +569,48 @@
   s
 );
 
-for(hd = hd_data->hd; hd; hd = hd->next) {
-  if(
-hd->module == hd_data->module &&
-hd->sysfs_id &&
-s &&
-!strcmp(s, hd->sysfs_id)
-  ) {
-t = NULL;
-str_printf(, 0, "/dev/input/%s", sf_cdev_name);
-
-if(strncmp(sf_cdev_name, "mouse", sizeof "mouse" - 1)) {
-  if(!hd->unix_dev_name) {
-hd->unix_dev_name = t;
-hd->unix_dev_num = dev_num;
-  }
-}
-else {
-  free_mem(hd->unix_dev_name);
-  free_mem(hd->unix_dev_name2);
-
-  hd->unix_dev_name2 = t;
-  hd->unix_dev_num2 = dev_num;
-
-  dev_num.major = 13;
-  dev_num.minor = 63;
-  hd->unix_dev_name = new_str(DEV_MICE);
+/* find device (matching sysfs path) */
+hd = hd_find_sysfs_id(hd_data, s);
+
+/* not found? - retry one level up */
+if(!hd) {
+  char *ns = new_str(s), *nt;
+  if((nt = strrchr(ns, '/'))) {
+*nt = 0;
+hd = hd_find_sysfs_id(hd_data, ns);
+  }
+  free_mem(ns);
+}
+
+/* when we have it, add input device name */
+if(hd) {
+  t = NULL;
+  str_printf(, 0, "/dev/input/%s", sf_cdev_name);
+
+  if(strncmp(sf_cdev_name, "mouse", sizeof "mouse" - 1)) {
+if(!hd->unix_dev_name) {
+  hd->unix_dev_name = t;
   hd->unix_dev_num = dev_num;
+}
+  }
+  else {
+free_mem(hd->unix_dev_name);
+free_mem(hd->unix_dev_name2);
+
+hd->unix_dev_name2 = t;
+hd->unix_dev_num2 = dev_num;
+
+dev_num.major = 13;
+dev_num.minor = 63;
+hd->unix_dev_name = new_str(DEV_MICE);
+hd->unix_dev_num = dev_num;
 
-  // make it a mouse, #216091
-  if(hd->base_class.id == bc_none) {
-hd->base_class.id = bc_mouse;
-hd->sub_class.id = sc_mou_usb;
-hd->compat_vendor.id = MAKE_ID(TAG_SPECIAL, 0x0200);
-hd->compat_device.id = MAKE_ID(TAG_SPECIAL, 0x001);
-  }
+// make it a mouse, #216091
+if(hd->base_class.id == bc_none) {
+  hd->base_class.id = bc_mouse;
+  hd->sub_class.id = sc_mou_usb;
+  hd->compat_vendor.id = MAKE_ID(TAG_SPECIAL, 0x0200);
+  hd->compat_device.id = MAKE_ID(TAG_SPECIAL, 0x001);
 }
  

commit libburn for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libburn for openSUSE:Factory checked 
in at 2016-08-03 11:42:10

Comparing /work/SRC/openSUSE:Factory/libburn (Old)
 and  /work/SRC/openSUSE:Factory/.libburn.new (New)


Package is "libburn"

Changes:

--- /work/SRC/openSUSE:Factory/libburn/libburn.changes  2016-07-27 
16:28:55.0 +0200
+++ /work/SRC/openSUSE:Factory/.libburn.new/libburn.changes 2016-08-03 
11:42:12.0 +0200
@@ -1,0 +2,14 @@
+Wed Jul 27 21:34:55 UTC 2016 - asterios.dra...@gmail.com
+
+- Update to 1.4.4:
+  * Bug fix: Option drive_scsi_dev_family=sg did not convert
+/dev/sr* to /dev/sg*
+  * Bug fix: burn_make_input_sheet_v07t() falsly recognized double
+byte encoding. Affected cdrskin option: cdtext_to_v07t=
+  * Bug fix: Double free at end of run if
+burn_write_opts_set_leadin_text() is used. Affected cdrskin
+option: textfile=
+  * Bug fix: DVD book type of DVD+RW DL and DVD+R DL was reported
+wrong.
+
+---

Old:

  libburn-1.4.2.pl01.tar.gz

New:

  libburn-1.4.4.tar.gz



Other differences:
--
++ libburn.spec ++
--- /var/tmp/diff_new_pack.PTGrm6/_old  2016-08-03 11:42:12.0 +0200
+++ /var/tmp/diff_new_pack.PTGrm6/_new  2016-08-03 11:42:12.0 +0200
@@ -18,7 +18,7 @@
 
 %define so_ver 4
 Name:   libburn
-Version:1.4.2.pl01
+Version:1.4.4
 Release:0
 Summary:Library for Writing Preformatted Data onto Optical Media
 License:GPL-2.0+
@@ -61,7 +61,7 @@
 its drives without using the normal block device I/O.
 
 %prep
-%setup -q -n %{name}-1.4.2
+%setup -q
 
 %build
 %configure --disable-static

++ libburn-1.4.2.pl01.tar.gz -> libburn-1.4.4.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libburn-1.4.2/ChangeLog new/libburn-1.4.4/ChangeLog
--- old/libburn-1.4.2/ChangeLog 2016-01-29 12:26:19.0 +0100
+++ new/libburn-1.4.4/ChangeLog 2016-07-01 14:14:40.0 +0200
@@ -1,7 +1,17 @@
 
+libburn-1.4.4.tar.gz Fri Jul 01 2016
+===
+* Bug fix: Option drive_scsi_dev_family=sg did not convert /dev/sr* to /dev/sg*
+* Bug fix: burn_make_input_sheet_v07t() falsly recognized double byte encoding.
+   Affected cdrskin option: cdtext_to_v07t=
+* Bug fix: Double free at end of run if burn_write_opts_set_leadin_text() is
+   used. Affected cdrskin option: textfile=
+* Bug fix: DVD book type of DVD+RW DL and DVD+R DL was reported wrong.
+   Thanks to Etienne Bergeron.
+
 libburn-1.4.2.pl01.tar.gz Fri Jan 29 2016
 ===
-* Bug fix: cdrskin "failed to attach fifo" when burning from stdin.
+* Bug fix: cdrskin "failed to attach fifo" when burning from stdin. 
Regression of 1.4.2, rev 5522.
 
 libburn-1.4.2.tar.gz Sat Nov 28 2015
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libburn-1.4.2/Makefile.am 
new/libburn-1.4.4/Makefile.am
--- old/libburn-1.4.2/Makefile.am   2016-01-29 12:10:12.0 +0100
+++ new/libburn-1.4.4/Makefile.am   2016-07-01 14:04:16.0 +0200
@@ -12,7 +12,7 @@
 
 # Build libraries
 libburn_libburn_la_LDFLAGS = \
-   -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+   -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) $(LIBLDFLAGS)
 # This causes undesired .o names
 # configure.ac appends -D options to variable CFLAG
 ### libburn_libburn_la_CFLAGS = $(LIBBURN_DVD_OBS_64K)
@@ -114,9 +114,9 @@
 test_poll_LDADD = $(libburn_libburn_la_OBJECTS) $(LIBBURN_EXTRALIBS)
 test_poll_SOURCES = test/poll.c
 
-##  cdrskin construction site - ts A60816 - B51128
+##  cdrskin construction site - ts A60816 - B60701
 cdrskin_cdrskin_CPPFLAGS = -Ilibburn
-cdrskin_cdrskin_CFLAGS = -DCdrskin_libburn_1_4_2
+cdrskin_cdrskin_CFLAGS = -DCdrskin_libburn_1_4_4
 
 # cdrskin_cdrskin_LDADD = $(libburn_libburn_la_OBJECTS) $(LIBBURN_EXTRALIBS)
 # ts A80123, change proposed by Simon Huggins to cause dynamic libburn linking
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/libburn-1.4.2/Makefile.in 
new/libburn-1.4.4/Makefile.in
--- old/libburn-1.4.2/Makefile.in   2016-01-29 12:42:58.0 +0100
+++ new/libburn-1.4.4/Makefile.in   2016-07-01 14:22:00.0 +0200
@@ -328,6 +328,7 @@
 LIBBURN_ARCH_LIBS = @LIBBURN_ARCH_LIBS@
 LIBCDIO_CFLAGS = @LIBCDIO_CFLAGS@
 LIBCDIO_LIBS = @LIBCDIO_LIBS@
+LIBLDFLAGS = @LIBLDFLAGS@
 LIBOBJS = @LIBOBJS@
 LIBS = @LIBS@
 LIBTOOL = @LIBTOOL@
@@ -434,7 +435,7 @@
 
 # Build libraries
 

commit pidgin for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package pidgin for openSUSE:Factory checked 
in at 2016-08-03 11:41:58

Comparing /work/SRC/openSUSE:Factory/pidgin (Old)
 and  /work/SRC/openSUSE:Factory/.pidgin.new (New)


Package is "pidgin"

Changes:

--- /work/SRC/openSUSE:Factory/pidgin/pidgin.changes2016-07-21 
07:41:34.0 +0200
+++ /work/SRC/openSUSE:Factory/.pidgin.new/pidgin.changes   2016-08-03 
11:41:59.0 +0200
@@ -1,0 +2,6 @@
+Fri Jul 22 19:13:38 UTC 2016 - jeng...@inai.de
+
+- Drop additional pkgconfig require (already implicitly detected),
+  but explicitly buildrequire it for /usr/lib/rpm/pkgconfigdeps.sh.
+
+---



Other differences:
--
++ pidgin.spec ++
--- /var/tmp/diff_new_pack.W3KD0G/_old  2016-08-03 11:42:00.0 +0200
+++ /var/tmp/diff_new_pack.W3KD0G/_new  2016-08-03 11:42:00.0 +0200
@@ -65,6 +65,7 @@
 BuildRequires:  meanwhile-devel
 BuildRequires:  mozilla-nspr-devel
 BuildRequires:  ncurses-devel
+BuildRequires:  pkg-config
 BuildRequires:  python-devel
 BuildRequires:  silc-toolkit-devel
 BuildRequires:  startup-notification-devel
@@ -197,7 +198,6 @@
 Requires:   glib2-devel
 Requires:   libpurple = %{version}
 Requires:   libxml2-devel
-Requires:   pkgconfig
 
 %description -n libpurple-devel
 The libpurple-devel package contains the header files, developer
@@ -241,7 +241,6 @@
 Requires:   glibc-devel
 Requires:   libpurple-devel = %{version}
 Requires:   ncurses-devel
-Requires:   pkgconfig
 
 %description -n finch-devel
 The finch-devel package contains the header files, developer





commit gnome-online-accounts for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package gnome-online-accounts for 
openSUSE:Factory checked in at 2016-08-03 11:41:46

Comparing /work/SRC/openSUSE:Factory/gnome-online-accounts (Old)
 and  /work/SRC/openSUSE:Factory/.gnome-online-accounts.new (New)


Package is "gnome-online-accounts"

Changes:

--- 
/work/SRC/openSUSE:Factory/gnome-online-accounts/gnome-online-accounts.changes  
2016-07-18 21:18:34.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.gnome-online-accounts.new/gnome-online-accounts.changes
 2016-08-03 11:41:47.0 +0200
@@ -1,0 +2,8 @@
+Thu Jul 28 13:12:42 UTC 2016 - zai...@opensuse.org
+
+- Update to version 3.20.3:
+  + Bugs fixed: bgo#756431, bgo#762155, bgo#766733, bgo#768808,
+bgo#768845.
+  + Updated translations.
+
+---

Old:

  gnome-online-accounts-3.20.2.tar.xz

New:

  gnome-online-accounts-3.20.3.tar.xz



Other differences:
--
++ gnome-online-accounts.spec ++
--- /var/tmp/diff_new_pack.FpHmvl/_old  2016-08-03 11:41:48.0 +0200
+++ /var/tmp/diff_new_pack.FpHmvl/_new  2016-08-03 11:41:48.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   gnome-online-accounts
-Version:3.20.2
+Version:3.20.3
 Release:0
 Summary:GNOME service to access online accounts
 License:LGPL-2.0+

++ gnome-online-accounts-3.20.2.tar.xz -> 
gnome-online-accounts-3.20.3.tar.xz ++
 10327 lines of diff (skipped)




commit caribou for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package caribou for openSUSE:Factory checked 
in at 2016-08-03 11:41:53

Comparing /work/SRC/openSUSE:Factory/caribou (Old)
 and  /work/SRC/openSUSE:Factory/.caribou.new (New)


Package is "caribou"

Changes:

--- /work/SRC/openSUSE:Factory/caribou/caribou.changes  2016-06-03 
16:27:36.0 +0200
+++ /work/SRC/openSUSE:Factory/.caribou.new/caribou.changes 2016-08-03 
11:41:54.0 +0200
@@ -1,0 +2,10 @@
+Mon Jul 25 09:27:25 UTC 2016 - zai...@opensuse.org
+
+- Update to version 0.4.21:
+  + bgo#768104: Initialize Clutter explicitly in antler code.
+  + bgo#768105: Fix theme parsing error for antler keyboard
+style.css.
+  + bgo#767664: Add missing python3 compatibility.
+  + Updated translations.
+
+---

Old:

  caribou-0.4.20.tar.xz

New:

  caribou-0.4.21.tar.xz



Other differences:
--
++ caribou.spec ++
--- /var/tmp/diff_new_pack.6laP9f/_old  2016-08-03 11:41:55.0 +0200
+++ /var/tmp/diff_new_pack.6laP9f/_new  2016-08-03 11:41:55.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   caribou
-Version:0.4.20
+Version:0.4.21
 Release:0
 # FIXME: Stop hiding the .desktop file with %%suse_update_desktop_file -u if 
launching caribou finally works
 Summary:On-screen Keyboard for GNOME

++ caribou-0.4.20.tar.xz -> caribou-0.4.21.tar.xz ++
 22248 lines of diff (skipped)




commit gtk-vnc for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package gtk-vnc for openSUSE:Factory checked 
in at 2016-08-03 11:41:07

Comparing /work/SRC/openSUSE:Factory/gtk-vnc (Old)
 and  /work/SRC/openSUSE:Factory/.gtk-vnc.new (New)


Package is "gtk-vnc"

Changes:

--- /work/SRC/openSUSE:Factory/gtk-vnc/gtk-vnc.changes  2015-03-30 
19:15:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.gtk-vnc.new/gtk-vnc.changes 2016-08-03 
11:41:09.0 +0200
@@ -1,0 +2,7 @@
+Thu Apr 14 22:17:36 UTC 2016 - mgo...@suse.com
+
+- Update to GNOME 3.20  Fate#318572
+- Drop gtk-vnc-Enable-double-buffering-on-GTK3.patch: fixed
+  upstream.
+
+---
@@ -24,0 +32,6 @@
+
+---
+Mon Feb  2 09:30:35 UTC 2015 - fezh...@suse.com
+
+- Add gtk-vnc-Enable-double-buffering-on-GTK3.patch to fix the
+  toolbar displaying problem. (boo#890568)
gtk-vnc2.changes: same change



Other differences:
--
++ gtk-vnc.spec ++
--- /var/tmp/diff_new_pack.8DkysV/_old  2016-08-03 11:41:11.0 +0200
+++ /var/tmp/diff_new_pack.8DkysV/_new  2016-08-03 11:41:11.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package gtk-vnc
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed

gtk-vnc2.spec: same change



commit shared-mime-info for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package shared-mime-info for 
openSUSE:Factory checked in at 2016-08-03 11:41:17

Comparing /work/SRC/openSUSE:Factory/shared-mime-info (Old)
 and  /work/SRC/openSUSE:Factory/.shared-mime-info.new (New)


Package is "shared-mime-info"

Changes:

--- /work/SRC/openSUSE:Factory/shared-mime-info/shared-mime-info.changes
2016-07-01 09:57:43.0 +0200
+++ /work/SRC/openSUSE:Factory/.shared-mime-info.new/shared-mime-info.changes   
2016-08-03 11:41:18.0 +0200
@@ -7,0 +8,8 @@
+Wed May  4 16:32:45 UTC 2016 - mgo...@suse.com
+
+- Update to GNOME 3.20  Fate#318572
+
+- Drop shared-mime-info-disable-fdatasync-in-installation.patch:
+  fixed upstream.
+
+---
@@ -27,0 +36,13 @@
+
+---
+Mon Dec 14 10:16:24 UTC 2015 - fezh...@suse.com
+
+- Disable fdatasync() during installation time or when
+  PKGSYSTEM_ENABLE_FSYNC is set (bsc#862596) (fdo#70366)
+  - Add shared-mime-info-disable-fdatasync-in-installation.patch
+
+---
+Sat Nov 21 11:26:14 UTC 2015 - fezh...@suse.com
+
+- Backport the fix from openSUSE:Factory to fix the slow 
+  installation issue (bsc#862596) (fdo#70366) 



Other differences:
--



commit deja-dup for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package deja-dup for openSUSE:Factory 
checked in at 2016-08-03 11:41:01

Comparing /work/SRC/openSUSE:Factory/deja-dup (Old)
 and  /work/SRC/openSUSE:Factory/.deja-dup.new (New)


Package is "deja-dup"

Changes:

--- /work/SRC/openSUSE:Factory/deja-dup/deja-dup.changes2016-05-04 
08:18:17.0 +0200
+++ /work/SRC/openSUSE:Factory/.deja-dup.new/deja-dup.changes   2016-08-03 
11:41:02.0 +0200
@@ -6 +6 @@
-with unicode characters.
+with unicode characters (boo#990937).



Other differences:
--



commit kfilemetadata5 for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package kfilemetadata5 for openSUSE:Factory 
checked in at 2016-08-03 11:40:21

Comparing /work/SRC/openSUSE:Factory/kfilemetadata5 (Old)
 and  /work/SRC/openSUSE:Factory/.kfilemetadata5.new (New)


Package is "kfilemetadata5"

Changes:

--- /work/SRC/openSUSE:Factory/kfilemetadata5/kfilemetadata5.changes
2016-07-15 12:34:37.0 +0200
+++ /work/SRC/openSUSE:Factory/.kfilemetadata5.new/kfilemetadata5.changes   
2016-08-03 11:40:23.0 +0200
@@ -1,0 +2,5 @@
+Mon Jul 25 11:28:39 UTC 2016 - o...@aepfle.de
+
+- Build with ffmpeg unconditional
+
+---



Other differences:
--
++ kfilemetadata5.spec ++
--- /var/tmp/diff_new_pack.OQ7xtA/_old  2016-08-03 11:40:24.0 +0200
+++ /var/tmp/diff_new_pack.OQ7xtA/_new  2016-08-03 11:40:24.0 +0200
@@ -16,6 +16,7 @@
 #
 
 
+%bcond_without ffmpeg
 %bcond_without lang
 %define _tar_path 5.24
 Name:   kfilemetadata5
@@ -30,7 +31,7 @@
 Source1:baselibs.conf
 Patch0: ffmpeg-buildrequires.patch
 BuildRequires:  extra-cmake-modules >= %{_tar_path}
-%if 0%{?suse_version} > 1314 && "%{suse_version}" != "1320"
+%if %{with ffmpeg}
 BuildRequires:  pkgconfig(libavcodec)
 BuildRequires:  pkgconfig(libavformat)
 BuildRequires:  pkgconfig(libavutil)




commit libqt4 for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libqt4 for openSUSE:Factory checked 
in at 2016-08-03 11:40:52

Comparing /work/SRC/openSUSE:Factory/libqt4 (Old)
 and  /work/SRC/openSUSE:Factory/.libqt4.new (New)


Package is "libqt4"

Changes:

--- /work/SRC/openSUSE:Factory/libqt4/libqt4-devel-doc.changes  2016-02-17 
12:14:35.0 +0100
+++ /work/SRC/openSUSE:Factory/.libqt4.new/libqt4-devel-doc.changes 
2016-08-03 11:40:54.0 +0200
@@ -1,0 +2,10 @@
+Fri Jun 24 05:12:34 UTC 2016 - lbeltr...@kde.org
+
+- Add fix-gcc6-detection.diff to fix GCC6 detection (boo#986350)
+
+---
+Thu Jun  2 16:35:38 UTC 2016 - matwey.korni...@gmail.com
+
+- Enable libqt4-devel-32bit to fix boo#982826
+
+---
libqt4-sql-plugins.changes: same change



Other differences:
--
++ libqt4-devel-doc.spec ++
--- /var/tmp/diff_new_pack.0AKZJU/_old  2016-08-03 11:40:59.0 +0200
+++ /var/tmp/diff_new_pack.0AKZJU/_new  2016-08-03 11:40:59.0 +0200
@@ -118,6 +118,8 @@
 Patch166:   0001-Fix-exclusion-of-anonymous-ciphers.patch
 # PATCH-FIX-OPENSUSE disable-insecure-ciphers-bnc865241.diff -- Disable 
insecure ciphers (rc4, aecdh, adh, exp-adh, <128 bits)
 Patch167:   disable-rc4-ciphers-bnc865241.diff
+# PATCH-FIX-OPENSUSE fix-gcc6-detection.diff -- Fix GCC6 detection
+Patch168:   fix-gcc6-detection.diff
 
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
   %define common_options --opensource -fast -no-separate-debug-info -shared 
-xkb -openssl-linked -xrender -xcursor -dbus-linked -xfixes -xrandr -xinerama 
-sm -no-nas-sound -no-rpath -system-libjpeg -system-libpng -accessibility -cups 
-stl -nis -system-zlib -prefix /usr -L %{_libdir} -libdir %{_libdir} -docdir 
%_docdir/%{base_name} -examplesdir %{_libdir}/qt4/examples -demosdir 
%{_libdir}/qt4/demos -plugindir %plugindir -translationdir 
%{_datadir}/qt4/translations -iconv -sysconfdir /etc/settings -datadir 
%{_datadir}/qt4/ -no-pch -reduce-relocations -exceptions -system-libtiff -glib 
-optimized-qmake -no-webkit -no-xmlpatterns -system-sqlite -qt3support 
-no-sql-mysql -importdir %plugindir/imports  -xsync -xinput -gtkstyle
@@ -203,6 +205,7 @@
 %patch165 -p1
 %patch166 -p1
 %patch167 -p1
+%patch168 -p1
 
 # be sure not to use them
 rm -rf src/3rdparty/{libjpeg,freetype,libpng,zlib,libtiff,fonts}

libqt4-sql-plugins.spec: same change








commit inst-source-utils for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package inst-source-utils for 
openSUSE:Factory checked in at 2016-08-03 11:40:29

Comparing /work/SRC/openSUSE:Factory/inst-source-utils (Old)
 and  /work/SRC/openSUSE:Factory/.inst-source-utils.new (New)


Package is "inst-source-utils"

Changes:

--- /work/SRC/openSUSE:Factory/inst-source-utils/inst-source-utils.changes  
2016-06-05 14:20:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.inst-source-utils.new/inst-source-utils.changes 
2016-08-03 11:40:30.0 +0200
@@ -1,0 +2,6 @@
+Tue Jul 26 12:07:52 CEST 2016 - r...@suse.de
+
+- ABXML: add diskusage data to susedata xml structure
+  (fate#320517) 
+
+---



Other differences:
--
++ inst-source-utils.spec ++
--- /var/tmp/diff_new_pack.IA1IdY/_old  2016-08-03 11:40:31.0 +0200
+++ /var/tmp/diff_new_pack.IA1IdY/_new  2016-08-03 11:40:31.0 +0200
@@ -20,7 +20,7 @@
 Summary:Utilities for creating customized installation sources
 License:GPL-2.0+
 Group:  System/YaST
-Version:2016.5.2
+Version:2016.7.26
 Release:0
 Url:http://en.opensuse.org/Inst-source-utils
 BuildArch:  noarch

++ inst-source-utils.tar.bz2 ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/inst-source-utils/usr/share/inst-source-utils/modules/ABXML.pm 
new/inst-source-utils/usr/share/inst-source-utils/modules/ABXML.pm
--- old/inst-source-utils/usr/share/inst-source-utils/modules/ABXML.pm  
2016-05-02 17:44:32.0 +0200
+++ new/inst-source-utils/usr/share/inst-source-utils/modules/ABXML.pm  
2016-07-26 12:03:01.0 +0200
@@ -289,6 +289,15 @@
[[ 'keyword' =>
'_content',
]],
+   [ 'diskusage' =>
+   [ 'dirs' =>
+   [[ 'dir' =>
+   'name',
+   'size',
+   'count',
+   ]],
+   ],
+   ],
]],
 ];
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/inst-source-utils/usr/share/inst-source-utils/modules/RPMQ.pm 
new/inst-source-utils/usr/share/inst-source-utils/modules/RPMQ.pm
--- old/inst-source-utils/usr/share/inst-source-utils/modules/RPMQ.pm   
2016-05-03 11:56:58.0 +0200
+++ new/inst-source-utils/usr/share/inst-source-utils/modules/RPMQ.pm   
2016-07-26 12:03:01.0 +0200
@@ -30,6 +30,7 @@
 #  @val = RPMQ::rpmq($filename, $tag);
 # 2004-11-25, mls   add support for signature header queries
 
+require Data::Dumper;
 package RPMQ;
 
 my %STAG = (




commit k3b for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package k3b for openSUSE:Factory checked in 
at 2016-08-03 11:40:43

Comparing /work/SRC/openSUSE:Factory/k3b (Old)
 and  /work/SRC/openSUSE:Factory/.k3b.new (New)


Package is "k3b"

Changes:

--- /work/SRC/openSUSE:Factory/k3b/k3b.changes  2016-07-03 12:26:45.0 
+0200
+++ /work/SRC/openSUSE:Factory/.k3b.new/k3b.changes 2016-08-03 
11:40:44.0 +0200
@@ -1,0 +2,6 @@
+Mon Jul 25 11:28:39 UTC 2016 - o...@aepfle.de
+
+- Build with ffmpeg unconditional
+- Remove unused ffmpeg pkgs
+
+---



Other differences:
--
++ k3b.spec ++
--- /var/tmp/diff_new_pack.erJs27/_old  2016-08-03 11:40:45.0 +0200
+++ /var/tmp/diff_new_pack.erJs27/_new  2016-08-03 11:40:45.0 +0200
@@ -16,6 +16,8 @@
 #
 
 
+%bcond_without ffmpeg
+
 Name:   k3b
 Version:2.0.3
 Release:0
@@ -46,13 +48,9 @@
 BuildRequires:  libvorbis-devel
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(taglib)
-%if 0%{?suse_version} > 1310 && 0%{?is_opensuse}
+%if %{with ffmpeg}
 BuildRequires:  pkgconfig(libavcodec)
-BuildRequires:  pkgconfig(libavdevice)
 BuildRequires:  pkgconfig(libavformat)
-BuildRequires:  pkgconfig(libavutil)
-BuildRequires:  pkgconfig(libpostproc)
-BuildRequires:  pkgconfig(libswscale)
 %endif
 Requires:   %{_bindir}/cdrdao
 Requires:   %{_bindir}/cdrecord




commit python-sip for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python-sip for openSUSE:Factory 
checked in at 2016-08-03 11:40:36

Comparing /work/SRC/openSUSE:Factory/python-sip (Old)
 and  /work/SRC/openSUSE:Factory/.python-sip.new (New)


Package is "python-sip"

Changes:

--- /work/SRC/openSUSE:Factory/python-sip/python-sip.changes2016-07-21 
07:41:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-sip.new/python-sip.changes   
2016-08-03 11:40:38.0 +0200
@@ -1,0 +2,6 @@
+Tue Jul 26 17:26:51 UTC 2016 - ter...@gmail.com
+
+- Update to 4.18.1
+  * Bug fixes
+
+---
--- /work/SRC/openSUSE:Factory/python-sip/python3-sip.changes   2016-07-21 
07:41:28.0 +0200
+++ /work/SRC/openSUSE:Factory/.python-sip.new/python3-sip.changes  
2016-08-03 11:40:38.0 +0200
@@ -1,0 +2,6 @@
+Tue Jul 26 17:27:37 UTC 2016 - ter...@gmail.com
+
+- Update to 4.18.1
+  * Bug fixes
+
+---

Old:

  sip-4.18.tar.gz

New:

  sip-4.18.1.tar.gz



Other differences:
--
++ python-sip.spec ++
--- /var/tmp/diff_new_pack.z3cfxr/_old  2016-08-03 11:40:39.0 +0200
+++ /var/tmp/diff_new_pack.z3cfxr/_new  2016-08-03 11:40:39.0 +0200
@@ -18,7 +18,7 @@
 
 %define python_sip_api 11.3
 Name:   python-sip
-Version:4.18
+Version:4.18.1
 Release:0
 Summary:SIP tool to use python sip bindings
 License:GPL-2.0 or GPL-3.0 or SUSE-SIP

++ python3-sip.spec ++
--- /var/tmp/diff_new_pack.z3cfxr/_old  2016-08-03 11:40:39.0 +0200
+++ /var/tmp/diff_new_pack.z3cfxr/_new  2016-08-03 11:40:39.0 +0200
@@ -21,7 +21,7 @@
 %define py3_incdir %{_includedir}/python3.2mu
 %endif
 Name:   python3-sip
-Version:4.18
+Version:4.18.1
 Release:0
 Summary:SIP tool to use python sip bindings
 License:GPL-2.0 or GPL-3.0 or SUSE-SIP

++ sip-4.18.tar.gz -> sip-4.18.1.tar.gz ++
 6310 lines of diff (skipped)




commit python3-coverage for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python3-coverage for 
openSUSE:Factory checked in at 2016-08-03 11:39:51

Comparing /work/SRC/openSUSE:Factory/python3-coverage (Old)
 and  /work/SRC/openSUSE:Factory/.python3-coverage.new (New)


Package is "python3-coverage"

Changes:

--- /work/SRC/openSUSE:Factory/python3-coverage/python3-coverage.changes
2016-06-02 12:38:16.0 +0200
+++ /work/SRC/openSUSE:Factory/.python3-coverage.new/python3-coverage.changes   
2016-08-03 11:39:52.0 +0200
@@ -1,0 +2,50 @@
+Fri Jul 29 06:02:21 UTC 2016 - a...@gmx.de
+
+- update to version 4.2:
+  * BACKWARD INCOMPATIBILITY: the coverage combine command now ignores
+an existing .coverage data file. It used to include that file in
+its combining. This caused confusing results, and extra tox
+“clean” steps. If you want the old behavior, use the new coverage
+combine --append option.
+  * Since concurrency=multiprocessing uses subprocesses, options
+specified on the coverage.py command line will not be communicated
+down to them. Only options in the configuration file will apply to
+the subprocesses. Previously, the options didn’t apply to the
+subprocesses, but there was no indication. Now it is an error to
+use --concurrency=multiprocessing and other run-affecting options
+on the command line. This prevents failures like those reported in
+issue 495.
+  * The concurrency option can now take multiple values, to support
+programs using multiprocessing and another library such as
+eventlet. This is only possible in the configuration file, not
+from the command line. The configuration file is the only way for
+sub-processes to all run with the same options. Fixes issue
+484. Thanks to Josh Williams for prototyping.
+  * Using a concurrency setting of multiprocessing now implies
+--parallel so that the main program is measured similarly to the
+sub-processes.
+  * When using automatic subprocess measurement, running coverage
+commands would create spurious data files. This is now fixed,
+thanks to diagnosis and testing by Dan Riti. Closes issue 492.
+  * A new configuration option, report:sort, controls what column of
+the text report is used to sort the rows. Thanks to Dan
+Wandschneider, this closes issue 199.
+  * The HTML report has a more-visible indicator for which column is
+being sorted. Closes issue 298, thanks to Josh Williams.
+  * Filtering the HTML report is now faster, thanks to Ville Skyttä.
+  * If the HTML report cannot find the source for a file, the message
+now suggests using the -i flag to allow the report to
+continue. Closes issue 231, thanks, Nathan Land.
+  * When reports are ignoring errors, there’s now a warning if a file
+cannot be parsed, rather than being silently ignored. Closes issue
+396. Thanks, Matthew Boehm.
+  * A new option for coverage debug is available: coverage debug
+config shows the current configuration. Closes issue 454, thanks
+to Matthew Boehm.
+  * Running coverage as a module (python -m coverage) no longer shows
+the program name as __main__.py. Fixes issue 478. Thanks, Scott
+Belden.
+  * The test_helpers module has been moved into a separate
+pip-installable package: unittest-mixins.
+
+---

Old:

  coverage-4.1.tar.gz

New:

  coverage-4.2.tar.gz



Other differences:
--
++ python3-coverage.spec ++
--- /var/tmp/diff_new_pack.jzDLW8/_old  2016-08-03 11:39:53.0 +0200
+++ /var/tmp/diff_new_pack.jzDLW8/_new  2016-08-03 11:39:53.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python3-coverage
-Version:4.1
+Version:4.2
 Release:0
 Url:http://nedbatchelder.com/code/coverage/%{version}
 Summary:Code coverage measurement for Python

++ coverage-4.1.tar.gz -> coverage-4.2.tar.gz ++
 5687 lines of diff (skipped)




commit chromaprint for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package chromaprint for openSUSE:Factory 
checked in at 2016-08-03 11:39:38

Comparing /work/SRC/openSUSE:Factory/chromaprint (Old)
 and  /work/SRC/openSUSE:Factory/.chromaprint.new (New)


Package is "chromaprint"

Changes:

--- /work/SRC/openSUSE:Factory/chromaprint/chromaprint.changes  2016-04-07 
13:35:30.0 +0200
+++ /work/SRC/openSUSE:Factory/.chromaprint.new/chromaprint.changes 
2016-08-03 11:39:40.0 +0200
@@ -1,0 +2,5 @@
+Thu Jul 28 09:00:34 UTC 2016 - o...@aepfle.de
+
+- Remove unused Provides libchromaprint-with-ffmpeg
+
+---



Other differences:
--
++ chromaprint.spec ++
--- /var/tmp/diff_new_pack.LczsPp/_old  2016-08-03 11:39:41.0 +0200
+++ /var/tmp/diff_new_pack.LczsPp/_new  2016-08-03 11:39:41.0 +0200
@@ -55,9 +55,6 @@
 Summary:Audio Fingerprinting Library
 License:LGPL-2.1+
 Group:  System/Libraries
-%if %{with ffmpeg}
-Provides:   libchromaprint-with-ffmpeg = %{version}
-%endif
 
 %description -n libchromaprint%{soname}
 Chromaprint is the core component of the Acoustid project. It's a client-side
@@ -71,9 +68,6 @@
 Requires:   fftw3-devel
 Requires:   libchromaprint%{soname} = %{version}
 Requires:   libtag-devel
-%if %{with ffmpeg}
-Provides:   libchromaprint-devel-with-ffmpeg = %{version}
-%endif
 
 %description -n libchromaprint-devel
 Chromaprint is the core component of the Acoustid project. It's a client-side




commit python-sphinx_rtd_theme for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python-sphinx_rtd_theme for 
openSUSE:Factory checked in at 2016-08-03 11:39:27

Comparing /work/SRC/openSUSE:Factory/python-sphinx_rtd_theme (Old)
 and  /work/SRC/openSUSE:Factory/.python-sphinx_rtd_theme.new (New)


Package is "python-sphinx_rtd_theme"

Changes:

--- 
/work/SRC/openSUSE:Factory/python-sphinx_rtd_theme/python-sphinx_rtd_theme.changes
  2015-05-18 22:25:56.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-sphinx_rtd_theme.new/python-sphinx_rtd_theme.changes
 2016-08-03 11:39:29.0 +0200
@@ -1,0 +2,10 @@
+Mon Jul 18 12:50:06 UTC 2016 - dmuel...@suse.com
+
+- update license
+
+---
+Mon Jul 18 12:32:47 UTC 2016 - tbecht...@suse.com
+
+- Use pypi.io for Source url
+
+---



Other differences:
--
++ python-sphinx_rtd_theme.spec ++
--- /var/tmp/diff_new_pack.PXzA87/_old  2016-08-03 11:39:30.0 +0200
+++ /var/tmp/diff_new_pack.PXzA87/_new  2016-08-03 11:39:30.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package python-sphinx_rtd_theme
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,10 +20,10 @@
 Version:0.1.8
 Release:0
 Summary:ReadTheDocs.org theme for Sphinx
-License:MIT
+License:MIT and Apache-2.0 and OFL-1.1
 Group:  Development/Languages/Python
 Url:https://github.com/snide/sphinx_rtd_theme/
-Source: 
https://pypi.python.org/packages/source/s/sphinx_rtd_theme/sphinx_rtd_theme-%{version}.tar.gz
+Source: 
https://pypi.io/packages/source/s/sphinx_rtd_theme/sphinx_rtd_theme-%{version}.tar.gz
 BuildRequires:  python-devel
 BuildRequires:  python-setuptools
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
@@ -49,7 +49,7 @@
 
 %files
 %defattr(-,root,root,-)
-%doc LICENSE README.rst
+%doc LICENSE OFL-License.txt Apache-License-2.0.txt README.rst
 %{python_sitelib}/*
 
 %changelog




commit mt-st for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package mt-st for openSUSE:Factory checked 
in at 2016-08-03 11:39:20

Comparing /work/SRC/openSUSE:Factory/mt-st (Old)
 and  /work/SRC/openSUSE:Factory/.mt-st.new (New)


Package is "mt-st"

Changes:

New Changes file:

--- /dev/null   2016-07-07 10:01:34.856033756 +0200
+++ /work/SRC/openSUSE:Factory/.mt-st.new/mt-st.changes 2016-08-03 
11:39:21.0 +0200
@@ -0,0 +1,152 @@
+---
+Wed Jun 29 06:14:40 UTC 2016 - sv...@svalx.net
+
+- Update to version 1.3:
+  * add more density codes (Kai Mäkisara)
+  * check for overflow when using k, M or G suffixes (Kai Mäkisara)
+  * allow negative argument for mkpartition, supported by Linux 4.6 
+and later (Kai Mäkisara)
+  * fix compilation with musl libc (Felix Janda)
+  * allow configuring the default tape device and installation 
+paths (e.g. /bin vs. /usr/bin) at build/install time (Iustin 
+Pop)
+  * code cleanups from the SUSE package (Alexey Svistunov)
+  * update the supplied example file (Alexey Svistunov)
+  * fix config file parsing bug in stinit (Iustin Pop)
+- Add keyring file
+- Removed all patches - fixed upstream
+- Using DEFTAPE and EXEC_PREFIX variables in specfile
+- Merged Martin Pluskal changes from devel package
+
+---
+Thu Mar 10 07:50:17 UTC 2016 - sv...@svalx.net
+
+- Add Provides/Obsoletes tags to specfile
+
+---
+Thu Mar 3 10:12:20 UTC 2016 - sv...@svalx.net
+
+- Remove rename-mt-to-mtst.patch, 'mt' binary name is no longer conflicts with 
cpio
+- Add mt-default-device.patch -- change mt default device from /dev/tape to 
/dev/nst0
+- Specfile cleanup
+- Rename package to canonical name 'mt-st'
+
+---
+Thu Feb 25 10:16:29 UTC 2016 - sv...@svalx.net
+
+- Update to version 1.2
+  * many updates to density codes (SDLT, LTO 5,6 and 7, etc.) (various people)
+  * multiple man page updates (various people)
+  * improve default tape device handling in mt: check that it actually is a 
character device,
+in order to show better error messages when /dev/tape is a different type 
(e.g. directory when using udev)
+  * small bug fix in stinit in parsing the input file (David Binderman)
+  * improve build system by allowing easier customisation of build flags and 
installation directory
+(via DESTDIR, not prefix) and by sanitising the creation of the dist 
archive (Iustin Pop)
+  * sanitise the source code to get rid of GCC warnings (Jan Christoph 
Nordholz, Iustin Pop)
+  * add stshowoptions alias to stshowopt (Ivo De Decker)
+  * expand the provided stinit.def.examples file (Suggested by Ralf-Peter 
Rohbeck)
+  * improve the --help output of stinit (Dan Horák)
+  * change of maintainership to Iustin Pop ius...@k1024.org
+- Split mt-st-1.1.patch on to change-path-to-binary.patch, 
fix-mans-install.patch and rename-mt-to-mtst.patch,
+  improve Makefile flexible
+- Rebase mt-st-codecleanup.patch
+- Add default template stinit.def configuration file
+- Add %{?_smp_mflags} for build
+- Change URL and Source paths in specfile to recent
+- Add udev rule for stinit
+- Add gpg signature of source tarball
+- Add Ultrium LTO-3 definitions to examples
+- Clean specfile by spec-cleaner utility
+
+---
+Mon Nov 11 22:42:52 UTC 2011 - tbehr...@suse.com
+
+- Update to version 1.1
+  * unused defines removed from mtio.h (compiles also with distributions no
+having linux/qic117.h)
+  * add support for MT_ST_SILI to mt and stinit
+  * add command showoptions for kernels >= 2.6.26
+
+- removed obsolete mt-st-0.9b-local_qic117_h.patch (changes are
+  upstream)
+
+- updated mt-st-0.9b.patch to mt-st-1.1.patch
+
+---
+Fri Sep 30 15:39:52 UTC 2011 - u...@suse.com
+
+- cross-build fix: use %__cc macro
+
+---
+Wed Mar 14 16:32:27 CET 2007 - p...@suse.de
+
+- Update to 0.9b:
+  Changes since 0.7:
+  - add local copy of qic117.h missing from recent kernels.
+  - only stinit changed
+  - more density codes
+  - put man page into /usr/share/man/man1
+  - documentation cleanup
+  - add some density translations
+  - counts can use the k, M, or G postfix
+
+---
+Sat Nov 11 10:31:02 CET 2006 - o...@suse.de
+
+- fix doc file permission
+
+---
+Wed Jan 25 21:38:26 CET 2006 - m...@suse.de
+
+- converted neededforbuild to BuildRequires
+

commit ekiga for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package ekiga for openSUSE:Factory checked 
in at 2016-08-03 11:40:07

Comparing /work/SRC/openSUSE:Factory/ekiga (Old)
 and  /work/SRC/openSUSE:Factory/.ekiga.new (New)


Package is "ekiga"

Changes:

--- /work/SRC/openSUSE:Factory/ekiga/ekiga.changes  2015-10-28 
17:15:41.0 +0100
+++ /work/SRC/openSUSE:Factory/.ekiga.new/ekiga.changes 2016-08-03 
11:40:09.0 +0200
@@ -1,0 +2,8 @@
+Thu Jul 28 17:51:33 UTC 2016 - badshah...@gmail.com
+
+- Add ekiga-appdata.patch to translate and install appstream
+  metainfo file; appdata taken from upstream git.
+- Patch touches autotool files, run autoreconf -fi before
+  configure; introduces BuildRequires on libtool.
+
+---

New:

  ekiga-appdata.patch



Other differences:
--
++ ekiga.spec ++
--- /var/tmp/diff_new_pack.tzkZCU/_old  2016-08-03 11:40:10.0 +0200
+++ /var/tmp/diff_new_pack.tzkZCU/_new  2016-08-03 11:40:10.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package ekiga
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -28,6 +28,8 @@
 Source: 
http://download.gnome.org/sources/ekiga/4.0/%{name}-%{version}.tar.xz
 # PATCH-FIX-UPSTREAM boost-configure.patch sch...@suse.de -- AX_BOOST_BASE: 
add aarch64 to the list of lib64 architectures
 Patch0: boost-configure.patch
+# PATCH-FIX-UPSTREAM ekiga-appdata.patch badshah...@gmail.com -- Add, 
translate and install appstream metainfo file taken from upstream git
+Patch1: ekiga-appdata.patch
 BuildRequires:  boost-devel
 BuildRequires:  cyrus-sasl-devel
 BuildRequires:  dbus-1-glib-devel
@@ -49,6 +51,8 @@
 BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
 BuildRequires:  pkgconfig(xv)
+# Required for Patch1
+BuildRequires:  libtool
 Requires:   gnome-icon-theme
 Recommends: %{name}-lang
 Provides:   gnomemeeting = %{version}
@@ -98,9 +102,11 @@
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 translation-update-upstream
 
 %build
+autoreconf -fi
 %configure \
 --disable-schemas-install \
 --disable-scrollkeeper \
@@ -166,6 +172,8 @@
 %{_libdir}/ekiga/%{version}/plugins/libgmresource_list.so
 %{_libdir}/ekiga/%{version}/plugins/libgmxcap.so
 %{_mandir}/man1/ekiga.1*
+%dir %{_datadir}/appdata
+%{_datadir}/appdata/%{name}.appdata.xml
 
 %if %{with_gstreamer_0_10}
 %files -n ekiga-plugins-gstreamer

++ ekiga-appdata.patch ++
Index: ekiga-4.0.1/Makefile.am
===
--- ekiga-4.0.1.orig/Makefile.am
+++ ekiga-4.0.1/Makefile.am
@@ -18,6 +18,10 @@ DESKTOP_FILE=@PACKAGE_NAME@.desktop
 SCHEMAS_IN_IN_FILE = @package_n...@.schemas.in.in
 SCHEMAS_FILE = @PACKAGE_NAME@.schemas
 
+APPDATAdir = $(datadir)/appdata
+APPDATA_IN_FILES = ekiga.appdata.xml.in
+APPDATA_DATA = $(APPDATA_IN_FILES:.appdata.xml.in=.appdata.xml)
+@INTLTOOL_XML_RULE@
 
 ### Win32 files
 WIN32_DIST = \
@@ -59,7 +63,8 @@ EXTRA_DIST = \
 LICENSE \
 MAINTAINERS \
$(SCHEMAS_FILE) \
-   $(WIN32_DIST)
+   $(WIN32_DIST)   \
+   $(APPDATA_IN_FILES)
 
 Applicationsdir = $(datadir)/applications
 Applications_DATA = $(DESKTOP_FILE)
@@ -93,3 +98,4 @@ install-data-local: install-schemas
 else
 install-data-local:
 endif
+
Index: ekiga-4.0.1/ekiga.appdata.xml.in
===
--- /dev/null
+++ ekiga-4.0.1/ekiga.appdata.xml.in
@@ -0,0 +1,27 @@
+
+
+
+
+  ekiga.desktop
+  CC0-1.0
+  GPL-2.0+
+  Ekiga Softphone
+  Talk to and see people over the Internet
+  
+<_p>
+  Ekiga is a VoIP, IP Telephony, and Video Conferencing application
+  that allows you to make audio and video calls to remote users with
+  SIP or H.323 compatible hardware and software.  It supports many
+  audio and video codecs and all modern VoIP features for both SIP and
+  H.323.  Ekiga is the first Open Source application to support both
+  H.323 and SIP, as well as audio and video.
+
+  
+  http://ekiga.org/
+  
+http://wiki.ekiga.org/images/c/cb/250px-Ekiga_in_a_call.png
+
+  
+  ekiga-devel-l...@gnome.org
+
+
Index: ekiga-4.0.1/po/POTFILES.in
===
--- ekiga-4.0.1.orig/po/POTFILES.in
+++ 

commit hdf5 for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package hdf5 for openSUSE:Factory checked in 
at 2016-08-03 11:39:33

Comparing /work/SRC/openSUSE:Factory/hdf5 (Old)
 and  /work/SRC/openSUSE:Factory/.hdf5.new (New)


Package is "hdf5"

Changes:

--- /work/SRC/openSUSE:Factory/hdf5/hdf5.changes2016-06-03 
16:35:10.0 +0200
+++ /work/SRC/openSUSE:Factory/.hdf5.new/hdf5.changes   2016-08-03 
11:39:34.0 +0200
@@ -1,0 +2,6 @@
+Tue Jul 26 15:50:22 UTC 2016 - adr...@suse.de
+
+- update to 1.10.0-patch1
+  
https://www.hdfgroup.org/ftp/HDF5/releases/hdf5-1.10/hdf5-1.10.0-patch1/src/hdf5-1.10.0-patch1-RELEASE.txt
+
+---

Old:

  hdf5-1.8.17.tar.bz2

New:

  hdf5-1.10.0-patch1.tar.bz2



Other differences:
--
++ hdf5.spec ++
--- /var/tmp/diff_new_pack.HiDHPU/_old  2016-08-03 11:39:36.0 +0200
+++ /var/tmp/diff_new_pack.HiDHPU/_new  2016-08-03 11:39:36.0 +0200
@@ -27,22 +27,24 @@
 
 # TODO: The so numbers autodetected by update_so_version.sh
 # do not match the so numbers that are actually buit.
-%define sonum 10
-%define sonum_CXX 12
-%define sonum_F 10
-%define sonum_HL 10
-%define sonum_HL_CXX 11
-%define sonum_HL_F 10
-%define sonum_TOOLS 10
+%define sonum 100
+%define sonum_CXX 100
+%define sonum_F 100
+%define sonum_HL 100
+%define sonum_HL_CXX 100
+%define sonum_HL_F 100
+%define sonum_TOOLS 100
 
 Name:   hdf5
-Version:1.8.17
+Version:1.10.0
 Release:0
+%define short_ver 1.10
+%define src_ver %{version}-patch1
 Summary:Command-line programs for the HDF5 scientific data format
 License:BSD-3-Clause
 Group:  Productivity/Scientific/Other
 Url:http://www.hdfgroup.org/HDF5/
-Source0:
http://www.hdfgroup.org/ftp/HDF5/releases/hdf5-%{version}/src/hdf5-%{version}.tar.bz2
+Source0:
http://www.hdfgroup.org/ftp/HDF5/releases/hdf5-%{short_ver}/hdf5-%{src_ver}/src/hdf5-%{src_ver}.tar.bz2
 Source1000: baselibs.conf
 Source1001: baselibs.conf.in
 Source1002: update_so_version.sh
@@ -765,7 +767,7 @@
 This package provides examples of HDF5 library use.
 
 %prep
-%setup -q
+%setup -q -n %name-%version-patch1
 %patch0 -p1 -b .LD_LIBRARY_PATH
 %patch1 -p0 -b .non_void_return
 %patch2 -p0 -b .abort_unknown_host_config
@@ -816,7 +818,7 @@
   --enable-shared \
   --enable-cxx \
   --enable-threadsafe \
-  --enable-production \
+  --enable-build-mode=production \
   --with-pthread
 
 make V=1 %{?_smp_mflags}
@@ -845,7 +847,7 @@
   --enable-shared \
   --enable-threadsafe \
   --enable-parallel \
-  --enable-production \
+  --enable-build-mode=production \
   --with-pthread
 
 make %{?_smp_mflags}
@@ -940,10 +942,12 @@
 %defattr(-,root,root)
 %{_bindir}/gif2h5
 %{_bindir}/h52gif
+%{_bindir}/h5clear
 %{_bindir}/h5copy
 %{_bindir}/h5debug
 %{_bindir}/h5diff
 %{_bindir}/h5dump
+%{_bindir}/h5format_convert
 %{_bindir}/h5import
 %{_bindir}/h5jam
 %{_bindir}/h5ls
@@ -954,12 +958,12 @@
 %{_bindir}/h5repart
 %{_bindir}/h5stat
 %{_bindir}/h5unjam
+%{_bindir}/h5watch
 
 %files -n libhdf5-%{sonum}
 %defattr(-,root,root)
 %doc COPYING ACKNOWLEDGMENTS README.txt
-%doc release_docs/HISTORY-1_0-1_8_0_rc3.txt
-%doc release_docs/HISTORY-1_8.txt
+%doc release_docs/HISTORY-1_8_0-1_10_0.txt
 %doc release_docs/RELEASE.txt
 %defattr(0755,root,root)
 %{_libdir}/libhdf5.so.%{sonum}
@@ -1006,6 +1010,9 @@
 
 %files devel
 %defattr(-,root,root)
+%doc release_docs/HISTORY-1_0-1_8_0_rc3.txt
+%doc release_docs/RELEASE.txt
+%doc ACKNOWLEDGMENTS README.txt
 %{_bindir}/h5c++
 %{_bindir}/h5cc
 %{_bindir}/h5fc
@@ -1027,10 +1034,12 @@
 %defattr(-,root,root)
 %{_libdir}/mpi/gcc/openmpi/bin/gif2h5
 %{_libdir}/mpi/gcc/openmpi/bin/h52gif
+%{_libdir}/mpi/gcc/openmpi/bin/h5clear
 %{_libdir}/mpi/gcc/openmpi/bin/h5copy
 %{_libdir}/mpi/gcc/openmpi/bin/h5debug
 %{_libdir}/mpi/gcc/openmpi/bin/h5diff
 %{_libdir}/mpi/gcc/openmpi/bin/h5dump
+%{_libdir}/mpi/gcc/openmpi/bin/h5format_convert
 %{_libdir}/mpi/gcc/openmpi/bin/h5import
 %{_libdir}/mpi/gcc/openmpi/bin/h5jam
 %{_libdir}/mpi/gcc/openmpi/bin/h5ls
@@ -1043,13 +1052,11 @@
 %{_libdir}/mpi/gcc/openmpi/bin/h5stat
 %{_libdir}/mpi/gcc/openmpi/bin/h5unjam
 %{_libdir}/mpi/gcc/openmpi/bin/ph5diff
+%{_libdir}/mpi/gcc/openmpi/bin/h5watch
 
 %files -n libhdf5-%{sonum}-openmpi
 %defattr(-,root,root)
 %doc COPYING ACKNOWLEDGMENTS README.txt
-%doc release_docs/HISTORY-1_0-1_8_0_rc3.txt
-%doc release_docs/HISTORY-1_8.txt
-%doc release_docs/RELEASE.txt
 %defattr(0755,root,root)
 %{_libdir}/mpi/gcc/openmpi/%{_lib}/libhdf5.so.%{sonum}
 %{_libdir}/mpi/gcc/openmpi/%{_lib}/libhdf5.so.%{sonum}.*
@@ -1113,10 +1120,7 @@
 
 %files -n libhdf5-%{sonum}-mvapich2
 %defattr(-,root,root)
-%doc COPYING 

commit freerdp for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package freerdp for openSUSE:Factory checked 
in at 2016-08-03 11:39:44

Comparing /work/SRC/openSUSE:Factory/freerdp (Old)
 and  /work/SRC/openSUSE:Factory/.freerdp.new (New)


Package is "freerdp"

Changes:

--- /work/SRC/openSUSE:Factory/freerdp/freerdp.changes  2016-05-24 
09:34:17.0 +0200
+++ /work/SRC/openSUSE:Factory/.freerdp.new/freerdp.changes 2016-08-03 
11:39:45.0 +0200
@@ -8,0 +9 @@
+- Update to GNOME 3.20.2 FATE#318572
@@ -13,2 +14,4 @@
-  + libfreerdp-codec: fix xcrush decompression, revert remote control fix
-  + KB3153731: May 2016 DST update for Azerbaijan, Chile, Haiti and Morocco
+  + libfreerdp-codec: fix xcrush decompression, revert remote
+control fix
+  + KB3153731: May 2016 DST update for Azerbaijan, Chile, Haiti and
+Morocco
@@ -20,2 +23,2 @@
-- Update to version 2.0.0, git master branch id a7ca42e (FATE#319661),
-  no upstream changelog available.
+- Update to version 2.0.0, git master branch id a7ca42e
+  (FATE#319661), no upstream changelog available.
@@ -26 +29,2 @@
-scripts need to migrate to the new interfaces to avoid breakages.
+scripts need to migrate to the new interfaces to avoid
+breakages.
@@ -50,2 +54 @@
-  backported from upstream commit:
-  
https://github.com/FreeRDP/FreeRDP/commit/f1d6afca6ae620f9855a33280bdc6f3ad9153be0#diff-b6d68bbca6e0f5875c57ef225cd65c45
+  backported from upstream commit f1d6afc
@@ -76 +79,2 @@
-- Added patch for issue #811 fixing divide key (/) on keypad for 1.0x series
+- Added patch for issue #811 fixing divide key (/) on keypad for
+  1.0x series,
@@ -81 +85,2 @@
-  FreeRDP 1.0.2 is a maintenance release which contains several bug and 
stability fixes.
+  FreeRDP 1.0.2 is a maintenance release which contains several bug
+  and stability fixes.
@@ -83 +88,2 @@
-* new parameter --from-stdin - prompts for unspecified arguments username, 
password, domain and host.
+  * new parameter --from-stdin - prompts for unspecified arguments
+username, password, domain and host.
@@ -98 +104 @@
-* xfreerdp-server
+  * xfreerdp-server:
@@ -102 +108 @@
-* smartcard
+  * smartcard:
@@ -105 +111 @@
-* libfreerdp-codec
+  * libfreerdp-codec:
@@ -108 +114 @@
-* libfreerdp-gdi
+  * libfreerdp-gdi:
@@ -111,2 +117,3 @@
-* plugin
-* ignore CHANNEL_FLAG_SUSPEND/CHANNEL_FLAG_RESUME to prevent possible crash
+  * plugin:
+  * ignore CHANNEL_FLAG_SUSPEND/CHANNEL_FLAG_RESUME to prevent
+possible crash
@@ -117,2 +124,2 @@
-* If windows input language is set to german pressing the divde key (/) on the 
keypad
-  results in minus (-) (see issue #811) 
+  * If windows input language is set to german pressing the divde
+key (/) on the keypad results in minus (-) (see issue #811)
@@ -243 +250,2 @@
-- fix bnc#688484 by passing --with-sound=alsa and alsa-devel in BuildRequires
+- fix bnc#688484 by passing --with-sound=alsa and alsa-devel in
+  BuildRequires
@@ -248,2 +256,2 @@
-- rewrote most of the spec file (wrong group, wrong subpackages, ldconfig
-  called on devel package, shlibs inj devel package, ...)
+- rewrote most of the spec file (wrong group, wrong subpackages,
+  ldconfig called on devel package, shlibs inj devel package, ...)
@@ -253 +261,2 @@
-+ fix buffer overflow when local timezone doesn't fit in 32 bytes
++ fix buffer overflow when local timezone doesn't fit in 32
+  bytes



Other differences:
--



commit python3-setuptools for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package python3-setuptools for 
openSUSE:Factory checked in at 2016-08-03 11:39:58

Comparing /work/SRC/openSUSE:Factory/python3-setuptools (Old)
 and  /work/SRC/openSUSE:Factory/.python3-setuptools.new (New)


Package is "python3-setuptools"

Changes:

--- /work/SRC/openSUSE:Factory/python3-setuptools/python3-setuptools.changes
2016-07-27 16:30:42.0 +0200
+++ 
/work/SRC/openSUSE:Factory/.python3-setuptools.new/python3-setuptools.changes   
2016-08-03 11:39:59.0 +0200
@@ -1,0 +2,8 @@
+Fri Jul 29 05:58:10 UTC 2016 - a...@gmx.de
+
+- update to version 25.1.1:
+  * #686: Fix issue in sys.path ordering by pkg_resources when rewrite
+technique is "raw".
+  * #699: Fix typo in msvc support.
+
+---

Old:

  setuptools-25.1.0.tar.gz

New:

  setuptools-25.1.1.tar.gz



Other differences:
--
++ python3-setuptools.spec ++
--- /var/tmp/diff_new_pack.wDa57z/_old  2016-08-03 11:40:00.0 +0200
+++ /var/tmp/diff_new_pack.wDa57z/_new  2016-08-03 11:40:00.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   python3-setuptools
-Version:25.1.0
+Version:25.1.1
 Release:0
 Url:http://pypi.python.org/pypi/setuptools
 Summary:Easily download, build, install, upgrade, and uninstall Python 
packages

++ setuptools-25.1.0.tar.gz -> setuptools-25.1.1.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools-25.1.0/CHANGES.rst 
new/setuptools-25.1.1/CHANGES.rst
--- old/setuptools-25.1.0/CHANGES.rst   2016-07-25 19:14:54.0 +0200
+++ new/setuptools-25.1.1/CHANGES.rst   2016-07-28 21:01:16.0 +0200
@@ -2,6 +2,13 @@
 CHANGES
 ===
 
+v25.1.1
+---
+
+* #686: Fix issue in sys.path ordering by pkg_resources when
+  rewrite technique is "raw".
+* #699: Fix typo in msvc support.
+
 v25.1.0
 ---
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools-25.1.0/PKG-INFO 
new/setuptools-25.1.1/PKG-INFO
--- old/setuptools-25.1.0/PKG-INFO  2016-07-25 19:16:04.0 +0200
+++ new/setuptools-25.1.1/PKG-INFO  2016-07-28 21:01:42.0 +0200
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: setuptools
-Version: 25.1.0
+Version: 25.1.1
 Summary: Easily download, build, install, upgrade, and uninstall Python 
packages
 Home-page: https://github.com/pypa/setuptools
 Author: Python Packaging Authority
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/setuptools-25.1.0/pkg_resources/__init__.py 
new/setuptools-25.1.1/pkg_resources/__init__.py
--- old/setuptools-25.1.0/pkg_resources/__init__.py 2016-07-25 
19:14:54.0 +0200
+++ new/setuptools-25.1.1/pkg_resources/__init__.py 2016-07-28 
21:01:16.0 +0200
@@ -947,11 +947,17 @@
 
 return needed
 
-def subscribe(self, callback):
-"""Invoke `callback` for all distributions (including existing ones)"""
+def subscribe(self, callback, existing=True):
+"""Invoke `callback` for all distributions
+
+If `existing=True` (default),
+call on all existing ones, as well.
+"""
 if callback in self.callbacks:
 return
 self.callbacks.append(callback)
+if not existing:
+return
 for dist in self:
 callback(dist)
 
@@ -2503,11 +2509,11 @@
 for line in self.get_metadata_lines(name):
 yield line
 
-def activate(self, path=None):
+def activate(self, path=None, replace=False):
 """Ensure distribution is importable on `path` (default=sys.path)"""
 if path is None:
 path = sys.path
-self.insert_on(path, replace=True)
+self.insert_on(path, replace=replace)
 if path is sys.path:
 fixup_namespace_packages(self.location)
 for pkg in self._get_metadata('namespace_packages.txt'):
@@ -2585,7 +2591,24 @@
 return self.get_entry_map(group).get(name)
 
 def insert_on(self, path, loc=None, replace=False):
-"""Insert self.location in path before its nearest parent directory"""
+"""Ensure self.location is on path
+
+If replace=False (default):
+- If location is already in path anywhere, do nothing.
+- Else:
+  - If it's an egg and its parent directory is on path,
+insert just ahead of the parent.
+  - Else: add to the end of path.
+If replace=True:
+- If location is already on path anywhere (not eggs)
+  or higher priority 

commit perl-XML-LibXML for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package perl-XML-LibXML for openSUSE:Factory 
checked in at 2016-08-03 11:39:02

Comparing /work/SRC/openSUSE:Factory/perl-XML-LibXML (Old)
 and  /work/SRC/openSUSE:Factory/.perl-XML-LibXML.new (New)


Package is "perl-XML-LibXML"

Changes:

--- /work/SRC/openSUSE:Factory/perl-XML-LibXML/perl-XML-LibXML.changes  
2016-07-07 15:08:14.0 +0200
+++ /work/SRC/openSUSE:Factory/.perl-XML-LibXML.new/perl-XML-LibXML.changes 
2016-08-03 11:39:03.0 +0200
@@ -1,0 +2,28 @@
+Mon Jul 25 05:57:54 UTC 2016 - co...@suse.com
+
+- updated to 2.0128
+   see /usr/share/doc/packages/perl-XML-LibXML/Changes
+
+  2.0128  2016-07-24
+  - Hopefully add the .pod files again as they were missing from 2.0127.
+  - https://github.com/shlomif/perl-XML-LibXML/issues/3
+  - Thanks to Paul Howarth for the report.
+  - This was caused by ExtUtils::Manifest just warning that the files
+  referenced in the "MANIFEST" file were not present and still
+  continuing to prepare the archive as usual. A 
"do-what-I-don't-want-to"
+  thing.
+
+---
+Sat Jul 23 06:01:52 UTC 2016 - co...@suse.com
+
+- updated to 2.0127
+   see /usr/share/doc/packages/perl-XML-LibXML/Changes
+
+  2.0127  2016-07-22
+  - Make sure t/release-kwalitee.t and other tests do not run by default.
+  - Only with AUTHOR_TESTING or RELEASE_TESTING specified.
+  - Thanks to Lance Wicks for the pull request.
+  - https://rt.cpan.org/Ticket/Display.html?id=115586
+  - https://rt.cpan.org/Ticket/Display.html?id=115859
+
+---

Old:

  XML-LibXML-2.0126.tar.gz

New:

  XML-LibXML-2.0128.tar.gz



Other differences:
--
++ perl-XML-LibXML.spec ++
--- /var/tmp/diff_new_pack.XGgQQk/_old  2016-08-03 11:39:04.0 +0200
+++ /var/tmp/diff_new_pack.XGgQQk/_new  2016-08-03 11:39:04.0 +0200
@@ -17,7 +17,7 @@
 
 
 Name:   perl-XML-LibXML
-Version:2.0126
+Version:2.0128
 Release:0
 %define cpan_name XML-LibXML
 Summary:Perl Binding for libxml2

++ XML-LibXML-2.0126.tar.gz -> XML-LibXML-2.0128.tar.gz ++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XML-LibXML-2.0126/Changes 
new/XML-LibXML-2.0128/Changes
--- old/XML-LibXML-2.0126/Changes   2016-06-24 18:15:37.0 +0200
+++ new/XML-LibXML-2.0128/Changes   2016-07-24 11:05:01.0 +0200
@@ -1,5 +1,21 @@
 Revision history for Perl extension XML::LibXML
 
+2.0128  2016-07-24
+- Hopefully add the .pod files again as they were missing from 2.0127.
+- https://github.com/shlomif/perl-XML-LibXML/issues/3
+- Thanks to Paul Howarth for the report.
+- This was caused by ExtUtils::Manifest just warning that the files
+referenced in the "MANIFEST" file were not present and still
+continuing to prepare the archive as usual. A "do-what-I-don't-want-to"
+thing.
+
+2.0127  2016-07-22
+- Make sure t/release-kwalitee.t and other tests do not run by default.
+- Only with AUTHOR_TESTING or RELEASE_TESTING specified.
+- Thanks to Lance Wicks for the pull request.
+- https://rt.cpan.org/Ticket/Display.html?id=115586
+- https://rt.cpan.org/Ticket/Display.html?id=115859
+
 2.0126  2016-06-24
 - Workaround RT#114638:
 - 2.9.4 broke XSD Schema support.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XML-LibXML-2.0126/LibXML.pm 
new/XML-LibXML-2.0128/LibXML.pm
--- old/XML-LibXML-2.0126/LibXML.pm 2016-06-24 18:16:20.0 +0200
+++ new/XML-LibXML-2.0128/LibXML.pm 2016-07-24 11:00:40.0 +0200
@@ -29,7 +29,7 @@
 use IO::Handle; # for FH reads called as methods
 
 BEGIN {
-$VERSION = "2.0126"; # VERSION TEMPLATE: DO NOT CHANGE
+$VERSION = "2.0128"; # VERSION TEMPLATE: DO NOT CHANGE
 $ABI_VERSION = 2;
 require Exporter;
 require DynaLoader;
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XML-LibXML-2.0126/LibXML.pod 
new/XML-LibXML-2.0128/LibXML.pod
--- old/XML-LibXML-2.0126/LibXML.pod2016-06-24 18:17:16.0 +0200
+++ new/XML-LibXML-2.0128/LibXML.pod2016-07-24 11:05:45.0 +0200
@@ -505,7 +505,7 @@
 
 =head1 VERSION
 
-2.0126
+2.0128
 
 =head1 COPYRIGHT
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/XML-LibXML-2.0126/META.json 
new/XML-LibXML-2.0128/META.json
--- old/XML-LibXML-2.0126/META.json 2016-06-24 18:20:02.0 +0200
+++ 

commit libdlm for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libdlm for openSUSE:Factory checked 
in at 2016-08-03 11:38:15

Comparing /work/SRC/openSUSE:Factory/libdlm (Old)
 and  /work/SRC/openSUSE:Factory/.libdlm.new (New)


Package is "libdlm"

Changes:

--- /work/SRC/openSUSE:Factory/libdlm/libdlm.changes2015-05-06 
11:17:38.0 +0200
+++ /work/SRC/openSUSE:Factory/.libdlm.new/libdlm.changes   2016-08-03 
11:38:17.0 +0200
@@ -1,0 +2,31 @@
+Mon Jul 25 06:54:31 UTC 2016 - z...@suse.com
+
+- Update to v4.0.6
+ * In v4.0.4, there's a stupid and severe bug so that upstream
+   released v4.0.5 soon with an urgent fix
+ * Upstream merged our fix for bsc#977201 with release v4.0.6,
+   so I still use the 2 below bugs for this updates:
+ * bsc#967332: libdlm: package update to v4.0.4
+ * bsc#977201: output of `dlm_tool ls` should distinguish causes
+   for "wait fencing" message
+
+- Drop patches
+ * bnc#875122dlm_controld-fix-long-name-in-log-entry.patch
+ * build-dlm_stonith.patch
+
+- Rename patches more readable
+ * remove: Makefile-for-diff-arch.patch, remove-sd-notify.patch,
+   bnc#874705nodes-without-quorum.patch
+ * add: 0001-makefile-for-diff-arch.patch,
+   0002-remove-sd-notify.patch,
+   0003-bnc#874705-nodes-without-quorum.patch
+
+
+---
+Mon Feb 15 06:15:03 UTC 2016 - z...@suse.com
+
+- Update to V4.0.4
+ * Remove build-dlm_stonith.patch
+ * Reove bnc#875122dlm_controld-fix-long-name-in-log-entry.patch
+
+---

Old:

  Makefile-for-diff-arch.patch
  bnc#874705nodes-without-quorum.patch
  bnc#875122dlm_controld-fix-long-name-in-log-entry.patch
  build-dlm_stonith.patch
  libdlm-4.0.2.tar.gz
  remove-sd-notify.patch

New:

  0001-makefile-for-diff-arch.patch
  0002-remove-sd-notify.patch
  0003-bnc#874705-nodes-without-quorum.patch
  libdlm-4.0.6.tar.gz



Other differences:
--
++ libdlm.spec ++
--- /var/tmp/diff_new_pack.Jgim8E/_old  2016-08-03 11:38:18.0 +0200
+++ /var/tmp/diff_new_pack.Jgim8E/_new  2016-08-03 11:38:18.0 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package libdlm
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -29,15 +29,13 @@
 Summary:Application interface to the kernel's distributed lock manager
 License:GPL-2.0 and GPL-2.0+ and LGPL-2.1+
 Group:  Productivity/Clustering/HA
-Version:4.0.2
+Version:4.0.6
 Release:0
 Url:http://sources.redhat.com/cluster/wiki
-Source: libdlm-4.0.2.tar.gz
-Patch1: Makefile-for-diff-arch.patch
-Patch2: build-dlm_stonith.patch
-Patch3: remove-sd-notify.patch
-Patch4: bnc#875122dlm_controld-fix-long-name-in-log-entry.patch
-Patch5: bnc#874705nodes-without-quorum.patch
+Source: libdlm-4.0.6.tar.gz
+Patch1: 0001-makefile-for-diff-arch.patch
+Patch2: 0002-remove-sd-notify.patch
+Patch3: 0003-bnc#874705-nodes-without-quorum.patch
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildRequires:  glib2-devel
 BuildRequires:  libcorosync-devel
@@ -79,8 +77,6 @@
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
 ###
 
 %build

++ 0001-makefile-for-diff-arch.patch ++
Index: a/dlm_controld/Makefile
===
--- a/dlm_controld/Makefile
+++ b/dlm_controld/Makefile
@@ -1,6 +1,11 @@
 DESTDIR=
 PREFIX=/usr
-LIBNUM=/lib64
+cpu_bit=$(shell getconf LONG_BIT)
+ifeq ($(cpu_bit),64)
+   LIBNUM=/lib64
+else
+   LIBNUM=/lib
+endif
 BINDIR=$(PREFIX)/sbin
 LIBDIR=$(PREFIX)/$(LIBNUM)
 HDRDIR=$(PREFIX)/include 
Index: libdlm-4.0.2/libdlm/Makefile
===
--- libdlm-4.0.2.orig/libdlm/Makefile
+++ libdlm-4.0.2/libdlm/Makefile
@@ -1,6 +1,11 @@
 DESTDIR=
 PREFIX=/usr
-LIBNUM=/lib64
+cpu_bit=$(shell getconf LONG_BIT)
+ifeq ($(cpu_bit),64)
+   LIBNUM=/lib64
+else
+   LIBNUM=/lib
+endif
 LIBDIR=$(PREFIX)/$(LIBNUM)
 HDRDIR=$(PREFIX)/include 
 MANDIR=$(PREFIX)/share/man
++ 0002-remove-sd-notify.patch ++
Index: a/dlm_controld/Makefile
===
--- a/dlm_controld/Makefile
+++ b/dlm_controld/Makefile
@@ -6,7 +6,7 @@ LIBDIR=$(PREFIX)/$(LIBNUM)
 HDRDIR=$(PREFIX)/include 
 MANDIR=$(PREFIX)/share/man
 
-USE_SD_NOTIFY=yes

commit libinput for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libinput for openSUSE:Factory 
checked in at 2016-08-03 11:38:48

Comparing /work/SRC/openSUSE:Factory/libinput (Old)
 and  /work/SRC/openSUSE:Factory/.libinput.new (New)


Package is "libinput"

Changes:

--- /work/SRC/openSUSE:Factory/libinput/libinput.changes2016-07-16 
22:12:04.0 +0200
+++ /work/SRC/openSUSE:Factory/.libinput.new/libinput.changes   2016-08-03 
11:38:50.0 +0200
@@ -1,0 +2,12 @@
+Mon Jul 18 06:27:39 UTC 2016 - jeng...@inai.de
+
+- Update to new upstrem release 1.4.0
+* Mode support for graphics tablets. On many tablets, buttons,
+  rings and strips can be used in virtualised modes, reflected by
+  physical LEDs on the touchpad. For example, a ring may send
+  scroll events when in mode 0 but zoom events in mode 1.
+* Ssupport for rotation on some relative devices. This is
+  particularly useful for trackballs that may be permanently
+  placed at a nonzero rotation angle.
+
+---

Old:

  libinput-1.3.3.tar.xz
  libinput-1.3.3.tar.xz.sig

New:

  libinput-1.4.0.tar.xz
  libinput-1.4.0.tar.xz.sig



Other differences:
--
++ libinput.spec ++
--- /var/tmp/diff_new_pack.SxINvx/_old  2016-08-03 11:38:51.0 +0200
+++ /var/tmp/diff_new_pack.SxINvx/_new  2016-08-03 11:38:51.0 +0200
@@ -18,7 +18,7 @@
 
 Name:   libinput
 %define lname  libinput10
-Version:1.3.3
+Version:1.4.0
 Release:0
 Summary:Input device and event processing library
 License:MIT

++ libinput-1.3.3.tar.xz -> libinput-1.4.0.tar.xz ++
 14237 lines of diff (skipped)




commit openldap2 for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package openldap2 for openSUSE:Factory 
checked in at 2016-08-03 11:38:24

Comparing /work/SRC/openSUSE:Factory/openldap2 (Old)
 and  /work/SRC/openSUSE:Factory/.openldap2.new (New)


Package is "openldap2"

Changes:

--- /work/SRC/openSUSE:Factory/openldap2/openldap2.changes  2016-06-29 
15:08:49.0 +0200
+++ /work/SRC/openSUSE:Factory/.openldap2.new/openldap2.changes 2016-08-03 
11:38:26.0 +0200
@@ -1,0 +2,6 @@
+Thu Jun 23 22:46:29 UTC 2016 - jeng...@inai.de
+
+- Test for user/group existence before trying to add them.
+  Summary spello update.
+
+---



Other differences:
--
++ openldap2.spec ++
--- /var/tmp/diff_new_pack.99PBmp/_old  2016-08-03 11:38:27.0 +0200
+++ /var/tmp/diff_new_pack.99PBmp/_new  2016-08-03 11:38:27.0 +0200
@@ -134,7 +134,7 @@
 to do any programming.
 
 %package -n libldap-data
-Summary:Configuration file for system-wide defaults for all usages of 
libldap.
+Summary:Configuration file for system-wide defaults for all uses of 
libldap
 Group:  Productivity/Networking/LDAP
 %if 0%{?suse_version} != 1110
 BuildArch:  noarch
@@ -170,14 +170,10 @@
 %if 0%{?suse_version} > 1110
 BuildArch:  noarch
 %endif
+
 %description doc
 The OpenLDAP Admin Guide plus a set of OpenLDAP related IETF internet drafts.
 
-Authors:
-
-The OpenLDAP Project 
-
-
 %package client
 Summary:OpenLDAP client utilities
 Group:  Productivity/Networking/LDAP/Clients
@@ -426,8 +422,8 @@
 rm -f  ${RPM_BUILD_ROOT}%{_libdir}/lib*.la
 
 %pre
-/usr/sbin/groupadd -g 70 -o -r ldap || :
-/usr/sbin/useradd -r -o -g ldap -u 76 -s /bin/false -c "User for OpenLDAP" -d 
/var/lib/ldap ldap || :
+getent group ldap >/dev/null || /usr/sbin/groupadd -g 70 -o -r ldap || :
+getent passwd ldap >/dev/null || /usr/sbin/useradd -r -o -g ldap -u 76 -s 
/bin/false -c "User for OpenLDAP" -d /var/lib/ldap ldap || :
 if /usr/bin/chkconfig ldap 2>&1 | grep -q on; then
 touch %{_rundir}/enable_slapd_service
 fi




commit libdrm for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libdrm for openSUSE:Factory checked 
in at 2016-08-03 11:38:32

Comparing /work/SRC/openSUSE:Factory/libdrm (Old)
 and  /work/SRC/openSUSE:Factory/.libdrm.new (New)


Package is "libdrm"

Changes:

--- /work/SRC/openSUSE:Factory/libdrm/libdrm.changes2016-05-03 
09:34:19.0 +0200
+++ /work/SRC/openSUSE:Factory/.libdrm.new/libdrm.changes   2016-08-03 
11:38:33.0 +0200
@@ -1,0 +2,13 @@
+Mon Jul 25 11:56:07 UTC 2016 - tobias.johannes.klausm...@mni.thm.de
+
+- Update to version 2.4.70:
+  More bugfixes on top of 2.4.69!
+
+---
+Sun Jul 24 22:30:52 UTC 2016 - tobias.johannes.klausm...@mni.thm.de
+
+- Update to version 2.4.69:
+  A new libdrm release, in order to use the new vc4 ioctl in Mesa. A few 
+  bugfixes on top as well.
+
+---

Old:

  libdrm-2.4.68.tar.bz2

New:

  libdrm-2.4.70.tar.bz2



Other differences:
--
++ libdrm.spec ++
--- /var/tmp/diff_new_pack.4ENpFY/_old  2016-08-03 11:38:34.0 +0200
+++ /var/tmp/diff_new_pack.4ENpFY/_new  2016-08-03 11:38:34.0 +0200
@@ -18,7 +18,7 @@
 
 Name:   libdrm
 Url:http://dri.freedesktop.org/
-Version:2.4.68
+Version:2.4.70
 Release:0
 Provides:   libdrm23 = %{version}
 Obsoletes:  libdrm23 < %{version}

++ libdrm-2.4.68.tar.bz2 -> libdrm-2.4.70.tar.bz2 ++
 6573 lines of diff (skipped)




commit libquicktime for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package libquicktime for openSUSE:Factory 
checked in at 2016-08-03 11:38:37

Comparing /work/SRC/openSUSE:Factory/libquicktime (Old)
 and  /work/SRC/openSUSE:Factory/.libquicktime.new (New)


Package is "libquicktime"

Changes:

--- /work/SRC/openSUSE:Factory/libquicktime/libquicktime.changes
2016-02-23 16:52:26.0 +0100
+++ /work/SRC/openSUSE:Factory/.libquicktime.new/libquicktime.changes   
2016-08-03 11:38:38.0 +0200
@@ -1,0 +2,5 @@
+Mon Jul 25 12:44:39 UTC 2016 - o...@aepfle.de
+
+- Convert buildconditionals for faac, faad, lame and x264
+
+---



Other differences:
--
++ libquicktime.spec ++
--- /var/tmp/diff_new_pack.ml7GgS/_old  2016-08-03 11:38:39.0 +0200
+++ /var/tmp/diff_new_pack.ml7GgS/_new  2016-08-03 11:38:39.0 +0200
@@ -16,6 +16,12 @@
 #
 
 
+%bcond_withfaac
+%bcond_withfaad
+%bcond_without ffmpeg
+%bcond_withlame
+%bcond_withx264
+
 %define soname 0
 %define cvs  20150223
 Name:   libquicktime
@@ -43,18 +49,26 @@
 BuildRequires:  pkg-config
 BuildRequires:  schroedinger-devel
 BuildRequires:  pkgconfig(gl)
+%if %{with ffmpeg}
 BuildRequires:  pkgconfig(libavcodec)
 BuildRequires:  pkgconfig(libswscale)
+%endif
 BuildRequires:  pkgconfig(x11)
 BuildRequires:  pkgconfig(xaw7)
 BuildRequires:  pkgconfig(xext)
 BuildRequires:  pkgconfig(xt)
 BuildRequires:  pkgconfig(xv)
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
-%if 0%{?BUILD_ORIG}
+%if %{with faac}
 BuildRequires:  libfaac-devel
+%endif
+%if %{with faad}
 BuildRequires:  libfaad2-devel
+%endif
+%if %{with lame}
 BuildRequires:  libmp3lame-devel
+%endif
+%if %{with x264}
 BuildRequires:  libx264-devel
 %endif
 
@@ -134,11 +148,19 @@
 %{_libdir}/libquicktime/lqt_schroedinger.so
 %{_libdir}/libquicktime/lqt_videocodec.so
 %{_libdir}/libquicktime/lqt_vorbis.so
+%if %{with ffmpeg}
 %{_libdir}/libquicktime/lqt_ffmpeg.so
-%if 0%{?BUILD_ORIG}
+%endif
+%if %{with faac}
 %{_libdir}/libquicktime/lqt_faac.so
+%endif
+%if %{with faad}
 %{_libdir}/libquicktime/lqt_faad2.so
+%endif
+%if %{with lame}
 %{_libdir}/libquicktime/lqt_lame.so
+%endif
+%if %{with x264}
 %{_libdir}/libquicktime/lqt_x264.so
 %endif
 




commit publicsuffix for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package publicsuffix for openSUSE:Factory 
checked in at 2016-08-03 11:38:55

Comparing /work/SRC/openSUSE:Factory/publicsuffix (Old)
 and  /work/SRC/openSUSE:Factory/.publicsuffix.new (New)


Package is "publicsuffix"

Changes:

--- /work/SRC/openSUSE:Factory/publicsuffix/publicsuffix.changes
2016-07-12 23:44:22.0 +0200
+++ /work/SRC/openSUSE:Factory/.publicsuffix.new/publicsuffix.changes   
2016-08-03 11:38:56.0 +0200
@@ -1,0 +2,12 @@
+Mon Aug  1 08:29:27 UTC 2016 - astie...@suse.com
+
+- 2016-07-31 update:
+  * Add meteorapp.com
+  * Add Drud domains
+  * Add backplaneapp.io
+  * Add gitlab.io
+  * Add static.land
+  * Add stackspace.space
+  * Add browsersafetymark.io
+
+---



Other differences:
--
++ publicsuffix.spec ++
--- /var/tmp/diff_new_pack.8jaSaJ/_old  2016-08-03 11:38:57.0 +0200
+++ /var/tmp/diff_new_pack.8jaSaJ/_new  2016-08-03 11:38:57.0 +0200
@@ -18,13 +18,13 @@
 
 
 Name:   publicsuffix
-Version:20160703
+Version:20160731
 Release:0
 Summary:Cross-vendor public domain suffix database
 License:MPL-2.0
 Group:  Productivity/Networking/Other
 Url:https://publicsuffix.org/
-Source0:
https://raw.githubusercontent.com/publicsuffix/list/e9f8e87dae08840d3a4369e3d5197fa4607484bb/public_suffix_list.dat
+Source0:
https://raw.githubusercontent.com/publicsuffix/list/f5dc88f0ad8a07c33028bae2f5379dd6e55d3b1a/public_suffix_list.dat
 Source1:
https://raw.githubusercontent.com/publicsuffix/list/master/LICENSE
 BuildRoot:  %{_tmppath}/%{name}-%{version}-build
 BuildArch:  noarch

++ public_suffix_list.dat ++
--- /var/tmp/diff_new_pack.8jaSaJ/_old  2016-08-03 11:38:57.0 +0200
+++ /var/tmp/diff_new_pack.8jaSaJ/_new  2016-08-03 11:38:57.0 +0200
@@ -2,6 +2,11 @@
 // License, v. 2.0. If a copy of the MPL was not distributed with this
 // file, You can obtain one at https://mozilla.org/MPL/2.0/.
 
+// Please pull this list from, and only from 
https://publicsuffix.org/list/public_suffix_list.dat , 
+// rather than any other VCS sites. Pulling from any other URL is not 
guaranteed to be supported.
+
+// Instructions on pulling and using this list can be found at 
https://publicsuffix.org/list/ .
+
 // ===BEGIN ICANN DOMAINS===
 
 // ac : https://en.wikipedia.org/wiki/.ac
@@ -10653,12 +10658,12 @@
 us-gov-west-1.compute.amazonaws.com
 us-west-1.compute.amazonaws.com
 us-west-2.compute.amazonaws.com
-us-east-1.amazonaws.com
 compute-1.amazonaws.com
 z-1.compute-1.amazonaws.com
 z-2.compute-1.amazonaws.com
+us-east-1.amazonaws.com
 compute.amazonaws.com.cn
-cn-north-1.compute.amazonaws.com.cn 
+cn-north-1.compute.amazonaws.com.cn
 
 // Amazon Elastic Beanstalk : https://aws.amazon.com/elasticbeanstalk/
 // Submitted by Adam Stein 
@@ -10694,15 +10699,19 @@
 
 // Association potager.org : https://potager.org/
 // Submitted by Lunar 
-potager.org
+pimienta.org
 poivron.org
+potager.org
 sweetpepper.org
-pimienta.org
 
 // AVM : https://avm.de
 // Submitted by Andreas Weise 
 myfritz.net
 
+// backplane : https://www.backplane.io
+// Submitted by Anthony Voutas 
+backplaneapp.io
+
 // BetaInABox
 // Submitted by Adrian 
 betainabox.com
@@ -10711,6 +10720,10 @@
 // Submitted by Axel Fontaine 
 boxfuse.io
 
+// BrowserSafetyMark
+// Submitted by Dave Tharp 
+browsersafetymark.io
+
 // callidomus: https://www.callidomus.com/
 // Submitted by Marcus Popp 
 mycd.eu
@@ -10854,6 +10867,11 @@
 // Submitted by Ricardo Padilha 
 mydrobo.com
 
+// Drud Holdings, LLC. : https://www.drud.com/
+// Submitted by Kevin Bridges 
+drud.io
+drud.us
+
 // DuckDNS : http://www.duckdns.org/
 // Submitted by Richard Harper 
 duckdns.org
@@ -11265,6 +11283,10 @@
 gist.githubcloud.com
 *.githubcloudusercontent.com
 
+// GitLab, Inc.
+// Submitted by Alex Hanselka 
+gitlab.io
+
 // GlobeHosting, Inc.
 // Submitted by Zoltan Egresi 
 ro.com
@@ -11387,6 +11409,11 @@
 // Submitted by Damien Tournoud 
 *.magentosite.cloud
 
+// Meteor Development Group : https://www.meteor.com/hosting
+// Submitted by Pierre Carrier 
+meteorapp.com
+eu.meteorapp.com
+
 // Michau Enterprises Limited : http://www.co.pl/
 co.pl
 
@@ -11614,10 +11641,20 @@
 alpha.bounty-full.com
 beta.bounty-full.com
 
+// staticland : 

commit wget for openSUSE:Factory

2016-08-03 Thread h_root
Hello community,

here is the log from the commit of package wget for openSUSE:Factory checked in 
at 2016-08-03 11:38:43

Comparing /work/SRC/openSUSE:Factory/wget (Old)
 and  /work/SRC/openSUSE:Factory/.wget.new (New)


Package is "wget"

Changes:

--- /work/SRC/openSUSE:Factory/wget/wget.changes2016-06-13 
21:52:18.0 +0200
+++ /work/SRC/openSUSE:Factory/.wget.new/wget.changes   2016-08-03 
11:38:44.0 +0200
@@ -1,0 +2,13 @@
+Thu Jul 28 15:37:37 UTC 2016 - josef.moell...@suse.com
+
+- Save/restore errno within CLOSE_FINISH and CLOSE_INVALIDATE.
+  (wget-errno-clobber.patch, boo#983660)
+
+---
+Fri Jul 22 12:34:02 UTC 2016 - dims...@opensuse.org
+
+- Update wget-libproxy.patch: use libproxy's px_proxy_factory_free
+  instead of regular free in order to ensure the module destructors
+  are correctly running (boo#967601).
+
+---

New:

  wget-errno-clobber.patch



Other differences:
--
++ wget.spec ++
--- /var/tmp/diff_new_pack.alabR5/_old  2016-08-03 11:38:45.0 +0200
+++ /var/tmp/diff_new_pack.alabR5/_new  2016-08-03 11:38:45.0 +0200
@@ -32,6 +32,7 @@
 Patch6: wget-1.14-no-ssl-comp.patch
 # PATCH-FIX-OPENSUSE fix pod syntax for perl 5.18 co...@suse.de
 Patch7: wget-fix-pod-syntax.diff
+Patch8: wget-errno-clobber.patch
 BuildRequires:  automake
 BuildRequires:  gpgme-devel >= 0.4.2
 BuildRequires:  libcares-devel
@@ -77,6 +78,7 @@
 %endif
 %patch6
 %patch7 -p1
+%patch8 -p1
 
 %build
 %if 0%{?suse_version} > 1110


++ wget-errno-clobber.patch ++
Index: wget-1.18/src/http.c
===
--- wget-1.18.orig/src/http.c
+++ wget-1.18/src/http.c
@@ -1516,6 +1516,7 @@ persistent_available_p (const char *host
active, registered connection".  */
 
 #define CLOSE_FINISH(fd) do {   \
+  int errno_sav = errno;\
   if (!keep_alive)  \
 {   \
   if (pconn_active && (fd) == pconn.socket) \
@@ -1524,14 +1525,17 @@ persistent_available_p (const char *host
   fd_close (fd);\
   fd = -1;  \
 }   \
+  errno = errno_sav;\
 } while (0)
 
 #define CLOSE_INVALIDATE(fd) do {   \
+  int errno_sav = errno;\
   if (pconn_active && (fd) == pconn.socket) \
 invalidate_persistent ();   \
   else  \
 fd_close (fd);  \
   fd = -1;  \
+  errno = errno_sav;\
 } while (0)
 
 struct http_stat
++ wget-libproxy.patch ++
--- /var/tmp/diff_new_pack.alabR5/_old  2016-08-03 11:38:45.0 +0200
+++ /var/tmp/diff_new_pack.alabR5/_new  2016-08-03 11:38:45.0 +0200
@@ -90,7 +90,7 @@
 +  }
 +  for(i=0;proxies[i];i++) free(proxies[i]);
 +  free(proxies);
-+  free(pf);
++  px_proxy_factory_free(pf);
 +
 +if (!proxy || !*proxy)
 +  return NULL;





  1   2   >