Re: [osg-submissions] support for Texture2DMultisample

2010-04-28 Thread Kai Xia
Hi, I checked with the new version, and test it in my deferred shading project, I use Texture2DMultiSampler as one attachment(diffuse color) in MRT, during the program initializing, two FBO status error turn up: FRAMEBUFFER_UNSUPPORTED 0x8CDD

Re: [osg-submissions] replaced non-portable asprintf()

2010-04-28 Thread Ulrich Hertlein
Hi Mark, On 28/04/10 5:38 , Mark Brand wrote: const char* user_home = xine_get_homedir(); if(user_home) { -char* cfgfile = NULL; -int result = asprintf((cfgfile), %s/.xine/config, user_home); -if

Re: [osg-submissions] replaced non-portable asprintf()

2010-04-28 Thread Mark Brand
const char* user_home = xine_get_homedir(); if(user_home) { -char* cfgfile = NULL; -int result = asprintf((cfgfile), %s/.xine/config, user_home); -if (result0) xine_config_load(_xine, cfgfile); +

Re: [osg-submissions] support for Texture2DMultisample

2010-04-28 Thread Marcin Hajder
Hi Kai, I tested that on my Geforce 8600 GT and it works just fine. What you want to do is: 1) Create Texture2DMultisample object and indicate number of samples, for example: ref_ptrTexture2DMultisample tex2DMS = new Texture2DMultisample(4,false); 2) Attach to camera. Since you will use

Re: [osg-submissions] replaced non-portable asprintf()

2010-04-28 Thread Robert Osfield
Hi Mark, I've just reviewed your code change and it's far less readable than the original code so I see this as a step backwards for maintainability. Ulrich's suggestion of using std::string is reasonable, and looking at online usage of xine_config_load it looks like this method doesn't assume

[osg-submissions] small fixes of Notify and KeySwitchMatrixManipulator

2010-04-28 Thread Wang Rui
Hi Robert, Two small bugs were just found when I was writing examples for my book in process: a wrong definition of the OSG_FATAL macro, and wrong logic inside the KeySwitchMatrixManipulator::getDistance() function. I believe both were slips. Cheers, Wang Rui Notify Description: Binary data

Re: [osg-submissions] GeometryTerrain patch allowing contour generation

2010-04-28 Thread Hartwig Wiesmann
Hi Robert, this is a copy and paste problem and it seems to be that my makefile did not re-compile the code after the change and so the error was undetected. masterTextureLocator should be replaced by masterLocator. Then, everything compiles and the code should also be OK. Thank you! Cheers,

Re: [osg-submissions] DAE plugin: Bug introduced in revision 11341

2010-04-28 Thread Robert Osfield
Thanks John and Michael, fix now merged and submitted to svn/trunk. On Tue, Apr 27, 2010 at 3:30 PM, Michael Platings mplati...@gmail.com wrote: Good spot John. The next line is also unnecessary and can be removed as well (attached, plus some minor code beautifying) On 27 April 2010 13:29,

Re: [osg-submissions] The osgManipulator serializers

2010-04-28 Thread Robert Osfield
Hi Wang Rui, Many thanks for the wrappers and the fix to osgTerrain serializers, all now merged and submitted to svn/trunk. Cheers, Robert. ps. a cool aspect of wrapper work is fix all the inconsistencies in some of the heaaders :-) On Wed, Apr 28, 2010 at 12:29 PM, Wang Rui wangra...@gmail.com

Re: [osg-submissions] Fix for osgDB::getFileExtension

2010-04-28 Thread Robert Osfield
Thanks Farshid, change looks good to me, now merged and submitted to svn/trunk ;-) On Fri, Apr 23, 2010 at 5:34 PM, Farshid Lashkari fla...@gmail.com wrote: Hi Robert, There's a subtle bug in osgDB::getFileExtension where it returns an incorrect value if the filename does not contain an