[issue28838] Uniformize argument names of "call" functions (C API)

2016-12-06 Thread STINNER Victor
STINNER Victor added the comment: I pushed a change which is rename.patch with fixes on comments in abstract.h. It seems like comments were no more revelant or moved to random places. I moved many comments, rewrote some of them, etc. Some comments were wrong like "This is the equivalent of

[issue28838] Uniformize argument names of "call" functions (C API)

2016-12-06 Thread Roundup Robot
Roundup Robot added the comment: New changeset e6ad41a3f3bd by Victor Stinner in branch 'default': Uniformize argument names of "call" functions https://hg.python.org/cpython/rev/e6ad41a3f3bd -- nosy: +python-dev ___ Python tracker

[issue28838] Uniformize argument names of "call" functions (C API)

2016-12-06 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: Added comments on Rietveld. I think we can keep "func" instead of "callable" in the source code for decreasing the number of changes. -- ___ Python tracker

[issue28838] Uniformize argument names of "call" functions (C API)

2016-12-06 Thread STINNER Victor
STINNER Victor added the comment: rename.patch: Big patch to rename function parameters. -- Added file: http://bugs.python.org/file45776/rename.patch ___ Python tracker

[issue28838] Uniformize argument names of "call" functions (C API)

2016-12-05 Thread Nick Coghlan
Nick Coghlan added the comment: As long as the C API docs also get updated, +1 for: * 'o' -> 'obj' * 'callable_object' -> 'callable' * 'func' -> 'callable' (when the function actually accepts an arbitrary callable) * 'method' -> 'name' (assuming 'Method' appears in the function name)

[issue28838] Uniformize argument names of "call" functions (C API)

2016-12-05 Thread Eric V. Smith
Eric V. Smith added the comment: I withdraw my concern. I was thinking it would affect the caller, but of course it won't. Apologies. -- ___ Python tracker

[issue28838] Uniformize argument names of "call" functions (C API)

2016-12-05 Thread STINNER Victor
STINNER Victor added the comment: So, what do you think of renaming argument like: * Replace "callable_object" and "func" with "callable" * Replace "method" with "name" * Rename "o" to "obj" (ex: in "PyCallable_Check(PyObject *o)") I prefer "callable_object" over "callable" because it's

[issue28838] Uniformize argument names of "call" functions (C API)

2016-12-01 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: > * Callable object: callable, o, callable_object => func The original names better describes the argument type in functions like PyObject_Call(). It works not just with functions, but with arbitrary callables. For example it is used with type objects for

[issue28838] Uniformize argument names of "call" functions (C API)

2016-11-30 Thread Eric V. Smith
Eric V. Smith added the comment: Isn't this just a lot of churn for not a lot of benefit? I'm all for consistency, but you'll break patches on the bug tracker and externally maintained patches. -- nosy: +eric.smith ___ Python tracker

[issue28838] Uniformize argument names of "call" functions (C API)

2016-11-30 Thread STINNER Victor
STINNER Victor added the comment: Serhiy: Can you please elaborate "Other changes looks not well justified too."? -- ___ Python tracker ___

[issue28838] Uniformize argument names of "call" functions (C API)

2016-11-30 Thread Nick Coghlan
Nick Coghlan added the comment: Independently of anything else, any changes made to the parameter names in the implementation should be reflected in the API docs: https://docs.python.org/3/c-api/object.html#c.PyCallable_Check A style guide addition to PEP 7 would also be useful as a record of

[issue28838] Uniformize argument names of "call" functions (C API)

2016-11-30 Thread STINNER Victor
Changes by STINNER Victor : -- title: Uniformize argument names of "call" functions -> Uniformize argument names of "call" functions (C API) ___ Python tracker