[U2] UV win 2008 Workgroup - ED / COPY very slow

2012-12-11 Thread Manu Fernandes
Hi group,

Using Universe 11.1.9 on win2008/workgroup logged as Administrator, I get a 
perf trouble when using ED, COPY, BUILD.INDEX, the process use 10 seconds to 
start.

After look inside, I detect each one use uv's subroutine -PERMISSIONS which 
seems check the user's write right on the file to update.

The execution of these subr (non documented) use 10 seconds.

I suspect a security/rights problem but where ?

Any suggestions ?

Thanks
Manu Fernandes



___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] UV win 2008 Workgroup - ED / COPY very slow

2012-12-11 Thread Wjhonson
There's some kind of temp file that is used to hold data 
 

 

 

-Original Message-
From: Manu Fernandes e...@infodata.lu
To: u2-users u2-users@listserver.u2ug.org
Sent: Tue, Dec 11, 2012 8:20 am
Subject: [U2] UV win 2008 Workgroup - ED / COPY very slow


Hi group,

Using Universe 11.1.9 on win2008/workgroup logged as Administrator, I get a 
perf trouble when using ED, COPY, BUILD.INDEX, the process use 10 seconds to 
start.

After look inside, I detect each one use uv's subroutine -PERMISSIONS which 
seems check the user's write right on the file to update.

The execution of these subr (non documented) use 10 seconds.

I suspect a security/rights problem but where ?

Any suggestions ?

Thanks
Manu Fernandes



___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users

 
___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] UV win 2008 Workgroup - ED / COPY very slow

2012-12-11 Thread Bill Haskett

Manu:

Have you checked with U2 support?  What have they said?

Bill Haskett


- Original Message -
*From:* e...@infodata.lu
*To:* u2-users@listserver.u2ug.org u2-users@listserver.u2ug.org
*Date:* 12/11/2012 8:20 AM
*Subject:* [U2] UV win 2008 Workgroup - ED / COPY very slow

Hi group,

Using Universe 11.1.9 on win2008/workgroup logged as Administrator, I get a 
perf trouble when using ED, COPY, BUILD.INDEX, the process use 10 seconds to 
start.

After look inside, I detect each one use uv's subroutine -PERMISSIONS which 
seems check the user's write right on the file to update.

The execution of these subr (non documented) use 10 seconds.

I suspect a security/rights problem but where ?

Any suggestions ?

Thanks
Manu Fernandes



___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Creating XML nodes with a namespace prefix

2012-12-11 Thread Bill Haskett

Hey Gregor.  Could you put that on the wiki? If not, could I?

Thanks,

Bill


- Original Message -
*From:* gregor.sc...@pentanasolutions.com
*To:* U2 Users List u2-users@listserver.u2ug.org
*Date:* 12/10/2012 10:11 PM
*Subject:* [U2] Creating XML nodes with a namespace prefix

If anyone has tried to use the UV XDOM api to create nodes with a namespace 
prefix (and failed), there is a non-obvious method you need to use.
We recently had a need to do this, and with the help of Rocket U2 support we 
were able to achieve the required XML output.
I have documented the method here for those inclined to use the XDOM API in 
this way, as it is obscure enough to not be obvious:
http://gdoesu2.wordpress.com/2012/12/10/creating-xml-elements-with-a-namespace-prefix/

Regards,

Gregor



This email and any attachments to it are confidential.
You must not use, disclose or act on the email if you are not the intended
recipient.  Liability limited by a scheme approved under Professional
Standards Legislation.
___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Creating XML nodes with a namespace prefix

2012-12-11 Thread Gregor Scott
Of course it can go on a wiki - I documented it so people know there is a way.

Which wiki - pickwiki or the U2Ug wiki?

-Original Message-
From: u2-users-boun...@listserver.u2ug.org 
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Bill Haskett
Sent: Wednesday, 12 December 2012 4:03 AM
To: U2 Users List
Subject: Re: [U2] Creating XML nodes with a namespace prefix

Hey Gregor.  Could you put that on the wiki? If not, could I?

Thanks,

Bill


- Original Message -
*From:* gregor.sc...@pentanasolutions.com
*To:* U2 Users List u2-users@listserver.u2ug.org
*Date:* 12/10/2012 10:11 PM
*Subject:* [U2] Creating XML nodes with a namespace prefix
 If anyone has tried to use the UV XDOM api to create nodes with a namespace 
 prefix (and failed), there is a non-obvious method you need to use.
 We recently had a need to do this, and with the help of Rocket U2 support we 
 were able to achieve the required XML output.
 I have documented the method here for those inclined to use the XDOM API in 
 this way, as it is obscure enough to not be obvious:
 http://gdoesu2.wordpress.com/2012/12/10/creating-xml-elements-with-a-n
 amespace-prefix/

 Regards,

 Gregor



 This email and any attachments to it are confidential.
 You must not use, disclose or act on the email if you are not the
 intended recipient.  Liability limited by a scheme approved under
 Professional Standards Legislation.
 ___
 U2-Users mailing list
 U2-Users@listserver.u2ug.org
 http://listserver.u2ug.org/mailman/listinfo/u2-users

___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users
--
Message  protected by DealerGuard: e-mail anti-virus, anti-spam and content 
filtering.
http://www.pentanasolutions.com

Click here to report this message as spam:
https://login.mailguard.com.au/report/1G8tWp4vQS/2WPyIlohSCEKEzA6lDGi0k/0


This email and any attachments to it are confidential.
You must not use, disclose or act on the email if you are not the intended
recipient.  Liability limited by a scheme approved under Professional
Standards Legislation.
___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Creating XML nodes with a namespace prefix

2012-12-11 Thread Bill Haskett

I'm thinking the pickwiki, as I'm not sure the U2UG wiki works.

Bill


- Original Message -
*From:* gregor.sc...@pentanasolutions.com
*To:* U2 Users List u2-users@listserver.u2ug.org
*Date:* 12/11/2012 2:33 PM
*Subject:* Re: [U2] Creating XML nodes with a namespace prefix

Of course it can go on a wiki - I documented it so people know there is a way.

Which wiki - pickwiki or the U2Ug wiki?

-Original Message-
From: u2-users-boun...@listserver.u2ug.org 
[mailto:u2-users-boun...@listserver.u2ug.org] On Behalf Of Bill Haskett
Sent: Wednesday, 12 December 2012 4:03 AM
To: U2 Users List
Subject: Re: [U2] Creating XML nodes with a namespace prefix

Hey Gregor.  Could you put that on the wiki? If not, could I?

Thanks,

Bill


- Original Message -
*From:* gregor.sc...@pentanasolutions.com
*To:* U2 Users List u2-users@listserver.u2ug.org
*Date:* 12/10/2012 10:11 PM
*Subject:* [U2] Creating XML nodes with a namespace prefix

If anyone has tried to use the UV XDOM api to create nodes with a namespace 
prefix (and failed), there is a non-obvious method you need to use.
We recently had a need to do this, and with the help of Rocket U2 support we 
were able to achieve the required XML output.
I have documented the method here for those inclined to use the XDOM API in 
this way, as it is obscure enough to not be obvious:
http://gdoesu2.wordpress.com/2012/12/10/creating-xml-elements-with-a-n
amespace-prefix/

Regards,

Gregor


___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Creating XML nodes with a namespace prefix

2012-12-11 Thread Tony Gravagno
Hey Gregor, your blog is inspiring, will need to spend some time
there.

Over the weekend I wrote a XPath-like parser to extract data out of
XML documents like you explain how to build them. At some point I'll
probably FOSS this at PickWiki. I invite you to post to PickWiki, or
at least link to your blog in key spots where others provide XML info.
Email me if you need assistance.

All: One thing frustrates me about content that's hosted in private
websites and Not hosted in the wiki. People have a tendency to post
content and then stop paying for their domain. So huge repositories of
valuable code and wisdom get lost. PickWiki links to a few sites that
were lost like this. Either the people died or lost interest or
re-hosted somewhere and didn't bother to tell anyone. If you have code
or info of value, post it to PickWiki  - or at least make sure there
are plans to share your published information in the event of your
untimely STOP/END.

Tony Gravagno
Nebula Research and Development
TG@ remove.pleaseNebula-RnD.com
http://Nebula-RnD.com/blog
Visit http://PickWiki.com! Contribute!
http://Twitter.com/TonyGravagno
http://groups.google.com/group/mvdbms

 From: Gregor Scott 
 Of course it can go on a wiki - I documented it so people know there
is
 a way.
 
 Which wiki - pickwiki or the U2Ug wiki?


http://gdoesu2.wordpress.com/2012/12/10/creating-xml-elements-with-a-n
amespace-prefix/


___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Problem with openpath in UniVerse on windows server

2012-12-11 Thread David Jordan
Has anyone had a similar problem.   Our application uses openpath to read some 
csv files from a directory on windows server 2008R2.

However a couple of sites, only the owner is able to open the directory with 
openpath, all other users fail.   Even with the users given administration 
rights, it still fails.   This is not a problem with all sites, just 2 of them.

I run into the same problem with openseq.

I tried even setting Authorisation in the program to the owner name and still 
no luck.   I am not sure what else to try.

Regards

David Jordan
___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Problem with openpath in UniVerse on windows server

2012-12-11 Thread Wjhonson
The file is open somewhere else.
 

 

 

-Original Message-
From: David Jordan da...@dacono.com.au
To: U2 Users List u2-users@listserver.u2ug.org
Sent: Tue, Dec 11, 2012 6:35 pm
Subject: Re: [U2] Problem with openpath in UniVerse on windows server


Has anyone had a similar problem.   Our application uses openpath to read some 
csv files from a directory on windows server 2008R2.

However a couple of sites, only the owner is able to open the directory with 
openpath, all other users fail.   Even with the users given administration 
rights, it still fails.   This is not a problem with all sites, just 2 of them.

I run into the same problem with openseq.

I tried even setting Authorisation in the program to the owner name and still 
no 
luck.   I am not sure what else to try.

Regards

David Jordan
___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users

 
___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Problem with openpath in UniVerse on windows server

2012-12-11 Thread Allen Egerton
On 12/11/2012 9:34 PM, David Jordan wrote:
 Has anyone had a similar problem.   Our application uses openpath to read 
 some csv files from a directory on windows server 2008R2.
 
 However a couple of sites, only the owner is able to open the directory with 
 openpath, all other users fail.   Even with the users given administration 
 rights, it still fails.   This is not a problem with all sites, just 2 of 
 them.
 
 I run into the same problem with openseq.
 
 I tried even setting Authorisation in the program to the owner name and still 
 no luck.   I am not sure what else to try.

Are the other sites, (those without issue) also running 2008R2?  And are
affected and non-affected sites running same version of Universe?

-- 
allen

___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Problem with openpath in UniVerse on windows server

2012-12-11 Thread David Jordan
They are all running on Rel 11 on Windows 2008R2.   The file is not open by 
another application.  It is to do with the directory owner being the only one 
able to access the file.  Even the same user copying a file to that directory, 
cannot read it from UniVerse.

Regards

David Jordan

Managing Director

___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


Re: [U2] Problem with openpath in UniVerse on windows server

2012-12-11 Thread Bill Haskett
I'm thinking you have to do more than just change the properties.  You 
have to actually share the directory.


Untitled Page

Bill Haskett
*/Fav Icon Advantos Systems, Inc./*
P.O. Box 3545  |  Lacey, WA  98509
? Tel: 760-944-5570 x7002 (CA)  | ? Fax: 760-655-1583
The Property Management Advantage.

- Original Message -
*From:* da...@dacono.com.au
*To:* U2 Users List u2-users@listserver.u2ug.org
*Date:* 12/11/2012 8:31 PM
*Subject:* Re: [U2] Problem with openpath in UniVerse on windows server

They are all running on Rel 11 on Windows 2008R2.   The file is not open by 
another application.  It is to do with the directory owner being the only one 
able to access the file.  Even the same user copying a file to that directory, 
cannot read it from UniVerse.

Regards

David Jordan

Managing Director

___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users


___
U2-Users mailing list
U2-Users@listserver.u2ug.org
http://listserver.u2ug.org/mailman/listinfo/u2-users