Re: [ovirt-users] not receiveing email

2014-12-20 Thread Arman Khalatyan
I got same trouble, emails where in spam due to the time They had 14Dec
instead of 16,17 or 15th dec.
Now it looks good.
a.



***

Dr. Arman Khalatyan eScience -SuperComputing Leibniz-Institut für
Astrophysik Potsdam (AIP) An der Sternwarte 16, 14482 Potsdam, Germany

***


On Fri, Dec 19, 2014 at 3:50 AM, lucas castro lucascastrobor...@gmail.com
wrote:

 Thanks, I've checked, it was on spam.
 I say sorry!

 On Thu, Dec 18, 2014 at 8:03 PM, Itamar Heim ih...@redhat.com wrote:

 On 12/18/2014 07:58 PM, knarra wrote:

 On 12/18/2014 07:48 PM, lucas castro wrote:

 Hey folks,
 Is there any problem on the mailing list?
 since Dec 15 I've not received mail anymore.

 --
 contatos:
 Celular: ( 99 ) 9143-5954 - Vivo
 skype: lucasd3castro
 msn: lucascastrobor...@hotmail.com mailto:lucascastroborges@
 hotmail.com


 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users

 Hi Lucas,

  There is absolutely no problem with the mailing list.I am able to
 receive the mails.

 Thanks
 kasturi.


 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users


 the problem is for gmail.com users which flags it as spam



 --
 contatos:
 Celular: ( 99 ) 9143-5954 - Vivo
 skype: lucasd3castro
 msn: lucascastrobor...@hotmail.com

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] CPU Type

2014-12-20 Thread Brent Hartzell
Hello,

 

Is there a way to add Xeon or another class of CPU Type to oVirt? We have
some test hosts, which use a combo of the following CPU types:

 

Xeon L5420

Xeon E5430

Xeon E5420

 

The only two CPU Types that will work in oVirt are Conroe  Penryn. Inside
of a VM, it reports Core 2 Duo.

 

Host reports:

model name  : Intel(R) Xeon(R) CPU   E5430  @ 2.66GHz

 

 

VM reports:

model name  : Intel Core 2 Duo P9xxx (Penryn Class Core 2)

 

 

//

 

Is there a way to have the VM report the correct CPU? It doesn't appear to
cause any performance or other issues, but seems to be just a display issue.
My concern though, is that we may not be able to add other servers with
different Intels to the same cluster, for example, new hosts with E5- or
E3- processors. Can someone confirm this wouldn't be an issue?

 

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] [STORAGE] Adding posix compliant FS

2014-12-20 Thread Nir Soffer
- Original Message -
 From: Julian De Marchi jul...@jdcomputers.com.au
 To: Vered Volansky ve...@redhat.com
 Cc: users@ovirt.org
 Sent: Wednesday, December 17, 2014 4:29:36 PM
 Subject: Re: [ovirt-users] [STORAGE] Adding posix compliant FS
 
 On 17/12/14 21:38, Vered Volansky wrote:
  Hi Julian,
 
 Hey Vered,
 
  IIUC the you have a self-created lvm, to which you're trying to connect as
  posix using ovirt.
  If that's the case please try to manually change the device's permissions
  to 36:36 under /dev/your_VG.
  If that doesn't work try the actual device it's mapped to (which is what
  vdsm actually tries to mount).
  If that also doesn't work please send us the output of:
  ls -lh /dev/your_VG .
 
 Still failed mate after a chmod 36:36. The thing is though, it _does_
 mount the device for a moment before failing and unmounting it...
 
 [root@blade01 ~]# ls /dev/VolGroup/lv_images -lh
 lrwxrwxrwx 1 root root 7 Dec 15 16:52 /dev/VolGroup/lv_images - ../dm-2
 [root@blade01 ~]# ls /dev/dm-2 -lh
 brw-rw 1 vdsm kvm 253, 2 Dec 15 16:52 /dev/dm-2

Hi Julian,

It is not clear what are you trying to do - is this lv on shared storage, and 
accessed
by multiple hosts or use only one host?

If the lv is shared, you cannot create a file system and mount it on multiple 
hosts (unless you
are using cluster file system).

If this local storage for one host, you should create a file system and mount 
it, and then
you can use the mountpoint as local storage.

Please describe in details what are you trying to do and how did you create the 
storage
domain in the engine side.

Nir
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Cannot activate storage domain

2014-12-20 Thread SATHEESARAN

Hi Brent,

From your logs, I could able to see that gluster mount has become 
read-only.

This happens only two circumstances,
1. Client-side quorum is enabled on that volume and its not met
2. Client-side quorum is enabled on that volume and the first brick of 
the replica pair went down.


I think you would have met the second scenario.
Client-side quorum is enabled on gluster volume to prevent network 
partition problems which would lead to split-brain scenarios.
If you want to restore your storage domain, you can disable client-side 
quorum momentarily using RHEVM UI

or using gluster cli. ( # gluster volume reset vol-name quorum-type )

Hope that helps.

-- Satheesaran S



On 12/19/2014 01:09 PM, Sahina Bose wrote:

[+Sas - thanks for the link to virt-store usecase article inline]

On 12/18/2014 06:56 PM, Brent Hartzell wrote:

Hello,

I had actually gotten this sorted out, somewhat. If I disable server 
quorum
on the volume, the storage domain will activate. The volume is/was 
optimized

for virt store via oVirt. The brick in question was not the first brick
added to the volume through oVirt however, it appears that it may 
have been
the first brick in the replica being used, but I'm not certain how to 
find

this out.


The recommended setting is to have both client and server side quorum 
turned on. But turning on server-side quorum with a 2-way replica 
volume would mean that your volume goes offline when one of the bricks 
goes down.


gluster volume info command will give you information about the 
volume topology. So will the bricks sub-tab for Volume in oVirt. The 
order in which the bricks are listed, is the order of the replica sets.


Disabling quorum allowed me to get the VM's affected back online 
however, is
this the recommended procedure? I tried to use replace-brick with 
another

node but it failed because the failed brick was not available. Would we
leave quorum disabled until that brick gets replaced? IE - rebuild the
server with the same hostname/IP file structure and rebalance the 
cluster?


http://www.gluster.org/community/documentation/index.php/Virt-store-usecase 
- for recommendations on volume tunables.


You could add another brick to your volume to make it a replica 3 and 
then turn on quorum?


For help on recovering your volume, I suggest you write to 
gluster-us...@gluster.org







While that happened, I read somewhere about this happening with a 
replica 2
- I've created a new volume with replica 3 and plan to test this 
again. Is
there any info you can point me to for how to handle this when it 
happens or

what the correct procedure is when a first brick fails?






-Original Message-
From: Sahina Bose [mailto:sab...@redhat.com]
Sent: Thursday, December 18, 2014 3:51 AM
To: Vered Volansky; Brent Hartzell
Cc: users@ovirt.org
Subject: Re: [ovirt-users] Cannot activate storage domain


On 12/18/2014 01:35 PM, Vered Volansky wrote:

Adding Sahina.

- Original Message -

From: Brent Hartzell brent.hartz...@outlook.com
To: users@ovirt.org
Sent: Thursday, December 18, 2014 3:38:11 AM
Subject: [ovirt-users] Cannot activate storage domain



Have the following:



6 hosts - virt + Gluster shared



Gluster volume is distributed-replicate - replica 2



Shutting down servers one at a time all work except for 1 brick. If
we shut down one specific brick (1 brick per host) - we're unable to
activate the storage domain. VM's that were actively running from
other bricks continue to run. Whatever was running form that specific
brick fails to run, gets paused etc.



Error log shows the entry below. I'm not certain what it's saying is
read only.nothing is read only that I can find.





2014-12-17 19:57:13,362 ERROR
[org.ovirt.engine.core.vdsbroker.vdsbroker.SpmStatusVDSCommand]
(DefaultQuartzScheduler_Worker-47) [4e9290a2] Command
SpmStatusVDSCommand(HostName = U23.domainame.net, HostId =
0db58e46-68a3-4ba0-a8aa-094893c045a1, storagePoolId =
7ccd6ea9-7d80-4170-afa1-64c10c185aa6) execution failed. Exception:
VDSErrorException: VDSGenericException: VDSErrorException: Failed to
SpmStatusVDS, error = [Errno 30] Read-only file system, code = 100

2014-12-17 19:57:13,363 INFO
[org.ovirt.engine.core.vdsbroker.irsbroker.IrsProxyData]
(DefaultQuartzScheduler_Worker-47) [4e9290a2]
hostFromVds::selectedVds - U23.domainname.net, spmStatus returned 
null!






According to Ovirt/Gluster, if a brick goes down, the VM should be
able to be restarted from another brick without issue. This does not
appear to be the case. If we take other bricks offline, it appears to

work as expected.

Something with this specific brick cases everything to break which
then makes any VM's that were running from the brick unable to start.
Do you have the recommended options for using volume as virt store 
turned
on? Is client-side quorum turned on for the volume? Is the brick that 
causes

the issue, the first brick in the replica set?



___
Users 

[ovirt-users] Two new plugins for oVirt

2014-12-20 Thread Lucas Vandroux
Dear all,


We developed 2 new plugins for the oVirt-Engine.


The first one is to interact with the engine-manage-domains tool directly from 
WebAdmin: https://github.com/ovirt-china/manage-domains-plugin


The second one is to schedule automatic backups of your vms: 
https://github.com/ovirt-china/vm-backup-scheduler


Maybe they can help you.


Best regards,


Lucas Vandroux for the oVirt-China Team (http://ovirt-china.org/)___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] Change host hostname/ip

2014-12-20 Thread Zenon D'Elee
Hello,

I have a hosted ovirt infra with only one host and one storage. I don't
know how to change the host ip address in the ovirt web manager (grey). Do
I have to use the ovirt-engine-rename command line on the ovirt vm ? Do I
have to put the host in maintenance ?

Thank you for helping.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] CPU Type

2014-12-20 Thread Itamar Heim

On 12/20/2014 06:31 PM, Brent Hartzell wrote:

Hello,

Is there a way to add “Xeon” or another class of CPU Type to oVirt? We
have some test hosts, which use a combo of the following CPU types:

Xeon L5420

Xeon E5430

Xeon E5420

The only two CPU Types that will work in oVirt are Conroe  Penryn.
Inside of a VM, it reports “Core 2 Duo”.

Host reports:

model name  : Intel(R) Xeon(R) CPU   E5430  @ 2.66GHz

VM reports:

model name  : Intel Core 2 Duo P9xxx (Penryn Class Core 2)

//

Is there a way to have the VM report the correct CPU? It doesn’t appear
to cause any performance or other issues, but seems to be just a display
issue. My concern though, is that we may not be able to add other
servers with different Intels to the same cluster, for example, new
hosts with E5- or E3- processors. Can someone confirm this
wouldn’t be an issue?



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users



you can set the VM to use the host cpu (it won't be migratable, but you 
can check if it makes any difference before checking other alternatives)

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Server 2012 R2 + Intel Conroe Cluster

2014-12-20 Thread Itamar Heim

On 12/17/2014 01:16 AM, Nathan Llaneza wrote:

Hey All,

I think I have found a bug in oVirt 3.4.4. We just bought a new server
that supports the Conroe CPU model, and I am trying to install Server
2012 R2 without luck. I keep getting error code 0x00C4. The problem
is while Windows is still to load into its pre-installation environment
it cashes and then immediately resets. This is a continuous loop. I have
found a way to install Server 2012 R2. Move the cluster away from the
Conroe Family (in my case Penryn). Thanks for all you do.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users



michal - wasn't there something about win2012R2 with conroe? if so, 
can't we fix warn/block on this somehow (osinfo field of blacklisted 
cpus)?

___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] [RFI] oVirt 3.6 Planning

2014-12-20 Thread Blaster

On 12/12/2014 10:08 AM, Itamar Heim wrote:


If your existing raw images are from an ovirt storage domain you can 
keep it as is and import the entire storage domain or specific vms 
from it.
That's a new 3.5 feature. Mind you yii must first upgrade the storage 
domain to 3.5 before reinstalling




Thanks for the tip.  This didn't work for me this time.  My AIO setup 
started out with 3.2, upgraded all the way up to 3.5,  I was missing the 
OVF files, so I couldn't import the storage domain.  So I bit the bullet 
one more time and did it the hard way (created new VMs, disks, then 
copied over the old image).  This time I created a storage domain for 
each VM so I can import them into a new setup individually.


Btw, what does the (master) designation by one of the storage domains 
mean?  When I deleted one that was a master, it just moved to another 
domain.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Can and How to move a VM from VMware to oVirt

2014-12-20 Thread Blaster

On 12/9/2014 3:59 AM, zhangjian2011 wrote:

Hi,

I want to move a windows VM(managed by VMware Player in Windows7 host)
to oVirt, can and how can i do it?

Thanks.

This is the procedure I've used several times from ESXi, should be the 
same with any vmdk.


Shutdown guest on ESXi  (or use GhettoVCB to make a snapshot backup if you 
don’t want an outtage)
NFS copy guest from ESXi server to temp storage somewhere
qemu-img convert guest.vmdk -O raw guest.raw
Create an oVirt guest with the appropriate OS type
Add a disk of the same GB to the guest
After oVirt finishes creating the disk, copy the guest.raw file over the disk 
image oVirt made
boot guest and install qemu-agent, ovirt-agent, spice-agent (or better yet, do 
this before you shutdown on ESXi)
remove VMware tools.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Change host hostname/ip

2014-12-20 Thread knarra

On 12/20/2014 01:10 AM, Zenon D'Elee wrote:

Hello,

I have a hosted ovirt infra with only one host and one storage. I 
don't know how to change the host ip address in the ovirt web manager 
(grey). Do I have to use the ovirt-engine-rename command line on the 
ovirt vm ? Do I have to put the host in maintenance ?


Thank you for helping.


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Hi Zenon,

Renaming a host is possible in ovirt by clicking on the edit button 
. AFAIK, IP address of a host which is added to ovirt web manager cannot 
be changed, it has to be added as a new host to the web manager.


Thanks
kasturi.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] [RFI] oVirt 3.6 Planning

2014-12-20 Thread Itamar Heim

On 12/21/2014 07:56 AM, Blaster wrote:

On 12/12/2014 10:08 AM, Itamar Heim wrote:


If your existing raw images are from an ovirt storage domain you can
keep it as is and import the entire storage domain or specific vms
from it.
That's a new 3.5 feature. Mind you yii must first upgrade the storage
domain to 3.5 before reinstalling



Thanks for the tip.  This didn't work for me this time.  My AIO setup
started out with 3.2, upgraded all the way up to 3.5,  I was missing the
OVF files, so I couldn't import the storage domain.  So I bit the bullet
one more time and did it the hard way (created new VMs, disks, then
copied over the old image).  This time I created a storage domain for
each VM so I can import them into a new setup individually.

Btw, what does the (master) designation by one of the storage domains
mean?  When I deleted one that was a master, it just moved to another
domain.



the pool needs a master domain. if one doesn't exist, it is re-created.
this should hopefully go away in 3.6.
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users