Re: [ovirt-users] iSCSI multipathing setup troubles

2017-07-03 Thread Vinícius Ferrão
I've found this on RHV manual, which should apply to oVirt:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.5/html/Administration_Guide/sect-Preparing_and_Adding_Block_Storage.html#Configuring_iSCSI_Multipathing

Let me know if works, because I'm considering a migration to oVirt and I will 
have the same issue.

V.

Sent from my iPhone

On 3 Jul 2017, at 11:42, Matthias Leopold 
> 
wrote:

hi,

i'm trying to use iSCSI multipathing for a LUN shared by a Hitachi SAN. i can't 
figure out how this is supposed to work, maybe my setup isn't applicable at 
all...

our storage admin shared the same LUN for me on two targets, which are located 
in two logical networks connected to different switches (i asked him to do so). 
on the oVirt hypervisor side there is only one bonded interface for storage 
traffic, so i configured two VLAN interfaces located in these networks on the 
bond interface.

now i create the storage domain logging in to one of the targets connecting 
through its logical network. when i try to create a "second" storage domain for 
the same LUN logging in to the second target, oVirt tells me "LUN is already in 
use". i understand this, but now i can't configure an oVirt "iSCSI Bond" in any 
way.

how is this supposed to work?
right now the only working setup i can think of would be an iSCSI target that 
uses a redundant bond interface (with only one IP addresss) to which my 
hypervisors connect through different routed networks (using either dedicated 
network cards or vlan interfaces). is that correct?

i feel like i'm missing something, but i couldn't find any examples for real 
world IP setups for iSCSI multipathing.

thanks for explaining
matthias
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


[ovirt-users] iSCSI multipathing setup troubles

2017-07-03 Thread Matthias Leopold

hi,

i'm trying to use iSCSI multipathing for a LUN shared by a Hitachi SAN. 
i can't figure out how this is supposed to work, maybe my setup isn't 
applicable at all...


our storage admin shared the same LUN for me on two targets, which are 
located in two logical networks connected to different switches (i asked 
him to do so). on the oVirt hypervisor side there is only one bonded 
interface for storage traffic, so i configured two VLAN interfaces 
located in these networks on the bond interface.


now i create the storage domain logging in to one of the targets 
connecting through its logical network. when i try to create a "second" 
storage domain for the same LUN logging in to the second target, oVirt 
tells me "LUN is already in use". i understand this, but now i can't 
configure an oVirt "iSCSI Bond" in any way.


how is this supposed to work?
right now the only working setup i can think of would be an iSCSI target 
that uses a redundant bond interface (with only one IP addresss) to 
which my hypervisors connect through different routed networks (using 
either dedicated network cards or vlan interfaces). is that correct?


i feel like i'm missing something, but i couldn't find any examples for 
real world IP setups for iSCSI multipathing.


thanks for explaining
matthias
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users