Re: [ovirt-users] Upgrade to 3.5.1

2015-02-03 Thread Sahina Bose


On 02/02/2015 08:12 PM, Demeter Tibor wrote:

Hi Sahina,

Unfortunately my compute nodes and gluster nodes are on same servers. 
I running my VMs on the gluster nodes and vica-versa.
Also, my ovirt portal is running on the first node, that is an gluster 
and compute node too.


Is this hosted-engine setup? Have you looked at 
http://www.ovirt.org/Hosted_Engine_Howto#Upgrade_Hosted_Engine ?




I have a gluster based installation with three servers, two for 
replicaVMs, one for VMs-s only.


If you're upgrading from oVirt 3.5 to 3.5.1 - there's no new dependency 
on glusterfs. So, you could decide not to upgrade glusterfs and just 
upgrade the vdsm on the nodes.




This is a productive environment, so I'm affraid so much of 
upgrading...:(.I don't want glusterfs mistakes, split-brains, etc..)


Also, I could make little downtime for upgrading, but I'm need to know 
what is the trustable upgrade procedure. Is there an official upgrade 
documentation for ovirt, that is contain the glusterfs upgrde methods?


There are separate documentations - for oVirt upgrade and glusterfs 
upgrade. No mechanism to upgrade glusterfs on nodes from within oVirt.







My cluster level is 3.5.

Thanks a lot.

Tibor





On 02/01/2015 04:40 PM, Demeter Tibor wrote:

Hi,

Is glusterfs 3.6 is neccessary for ovirt 3.5.1?
I have 3.5.2 at this moment.

3.6 neccessary for upgade ?


If you only want to upgrade the engine to oVirt 3.5.1 - you don't
need to upgrade the gluster nodes. I understand that your gluster
nodes are separate from the virt nodes. That is, you do not have
any cluster enabled with both virt + gluster service.

glusterfs 3.6 is not necessary to upgrade engine to oVirt 3.5.1.
It would only be required if you were upgrading the cluster level
(the compatibility version) which in turn would require newer vdsm
versions and gluster versions. But in your case, I think you
already have your cluster running with glusterfs 3.5.2. What is
the cluster compatibility version?


I'm worried what will happed with my gluster volumes after the
upgrade... :(

Plese help me.

Also, how can I upgrade the nodes? Need i'm to a yum upgrade
on the compute nodes?


By upgrade the nodes - you mean only the compute nodes? yum
upgrade on each node should work.
You can also move the Host to maintenance mode and click on
Reinstall or upgrade from engine.



Thanks.

Tibor




Hi,

No, I have only one replica beetwen two nodes.
The third node is only a host for vms and that using this
replica.

Thanks
Tibor





On 01/22/2015 08:03 PM, Demeter Tibor wrote:

Hello,

I have an ovirt 3.5.0 cluster with three nodes and
we using glusterfs for serving backend storage for
VM-s. Glusterfs are on same servers with ovirt.
We have Gluster 3.5.1 on all of nodes.

How can I upgrade to ovirt 3.5.1 with new
glusterfs? I don't want data inconsistency/data
loss/split brains?


Do you have a replica 3 volume setup across these 3 nodes?

Glusterfs supports rolling upgrade for replica volumes.
But there are some issues to upgrade from 3.5 to 3.6
versions (depending on version used)
Adding gluster-users  Pranith for recommended procedures.


thanks
sahina


Need I update gluster version to the latest?
How I need to upgrade the nodes ?  Is there any
whitepaper about this?

*
*

*
*

Thanks in advance,


Tibor



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users




___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users






___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 3.5.1

2015-02-02 Thread Demeter Tibor
Hi Sahina, 

Unfortunately my compute nodes and gluster nodes are on same servers. I running 
my VMs on the gluster nodes and vica-versa. 
Also, my ovirt portal is running on the first node, that is an gluster and 
compute node too. 

I have a gluster based installation with three servers, two for replicaVMs, 
one for VMs-s only. 

This is a productive environment, so I'm affraid so much of upgrading...:(.I 
don't want glusterfs mistakes, split-brains, etc..) 

Also, I could make little downtime for upgrading, but I'm need to know what is 
the trustable upgrade procedure. Is there an official upgrade documentation for 
ovirt, that is contain the glusterfs upgrde methods? 

My cluster level is 3.5. 

Thanks a lot. 

Tibor 

- Eredeti üzenet -

 On 02/01/2015 04:40 PM, Demeter Tibor wrote:

  Hi,
 

  Is glusterfs 3.6 is neccessary for ovirt 3.5.1?
 
  I have 3.5.2 at this moment.
 

  3.6 neccessary for upgade ?
 

 If you only want to upgrade the engine to oVirt 3.5.1 - you don't need to
 upgrade the gluster nodes. I understand that your gluster nodes are separate
 from the virt nodes. That is, you do not have any cluster enabled with both
 virt + gluster service.

 glusterfs 3.6 is not necessary to upgrade engine to oVirt 3.5.1. It would
 only be required if you were upgrading the cluster level (the compatibility
 version) which in turn would require newer vdsm versions and gluster
 versions. But in your case, I think you already have your cluster running
 with glusterfs 3.5.2. What is the cluster compatibility version?

  I'm worried what will happed with my gluster volumes after the upgrade...
  :(
 

  Plese help me.
 

  Also, how can I upgrade the nodes? Need i'm to a yum upgrade on the
  compute
  nodes?
 

 By upgrade the nodes - you mean only the compute nodes? yum upgrade on each
 node should work.
 You can also move the Host to maintenance mode and click on Reinstall or
 upgrade from engine.

  Thanks.
 

  Tibor
 

  - Eredeti üzenet -
 

   Hi,
  
 

   No, I have only one replica beetwen two nodes.
  
 
   The third node is only a host for vms and that using this replica.
  
 

   Thanks
  
 
   Tibor
  
 

   - Eredeti üzenet -
  
 

On 01/22/2015 08:03 PM, Demeter Tibor wrote:
   
  
 

 Hello,

   
  
 

 I have an ovirt 3.5.0 cluster with three nodes and we using glusterfs
 for
 serving backend storage for VM-s. Glusterfs are on same servers with
 ovirt.

   
  
 
 We have Gluster 3.5.1 on all of nodes.

   
  
 

 How can I upgrade to ovirt 3.5.1 with new glusterfs? I don't want
 data
 inconsistency/data loss/split brains?

   
  
 

Do you have a replica 3 volume setup across these 3 nodes?
   
  
 

Glusterfs supports rolling upgrade for replica volumes.
   
  
 
But there are some issues to upgrade from 3.5 to 3.6 versions
(depending
on
version used)
   
  
 
Adding gluster-users  Pranith for recommended procedures.
   
  
 

thanks
   
  
 
sahina
   
  
 

 Need I update gluster version to the latest?

   
  
 
 How I need to upgrade the nodes ? Is there any whitepaper about this?

   
  
 

 Thanks in advance,

   
  
 

 Tibor

   
  
 

 ___

   
  
 
 Users mailing list Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users

   
  
 

   ___
  
 
   Users mailing list
  
 
   Users@ovirt.org
  
 
   http://lists.ovirt.org/mailman/listinfo/users
  
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 3.5.1

2015-02-02 Thread Sahina Bose


On 02/01/2015 04:40 PM, Demeter Tibor wrote:

Hi,

Is glusterfs 3.6 is neccessary for ovirt 3.5.1?
I have 3.5.2 at this moment.

3.6 neccessary for upgade ?



If you only want to upgrade the engine to oVirt 3.5.1 - you don't need 
to upgrade the gluster nodes. I understand that your gluster nodes are 
separate from the virt nodes. That is, you do not have any cluster 
enabled with both virt + gluster service.


glusterfs 3.6 is not necessary to upgrade engine to oVirt 3.5.1. It 
would only be required if you were upgrading the cluster level (the 
compatibility version) which in turn would require newer vdsm versions 
and gluster versions. But in your case, I think you already have your 
cluster running with glusterfs 3.5.2. What is the cluster compatibility 
version?



I'm worried what will happed with my gluster volumes after the 
upgrade... :(


Plese help me.

Also, how can I upgrade the nodes? Need i'm to a yum upgrade on the 
compute nodes?


By upgrade the nodes - you mean only the compute nodes? yum upgrade on 
each node should work.
You can also move the Host to maintenance mode and click on Reinstall or 
upgrade from engine.





Thanks.

Tibor




Hi,

No, I have only one replica beetwen two nodes.
The third node is only a host for vms and that using this replica.

Thanks
Tibor




On 01/22/2015 08:03 PM, Demeter Tibor wrote:

Hello,

I have an ovirt 3.5.0 cluster with three nodes and we
using glusterfs for serving backend storage for VM-s.
Glusterfs are on same servers with ovirt.
We have Gluster 3.5.1 on all of nodes.

How can I upgrade to ovirt 3.5.1 with new glusterfs? I
don't want data inconsistency/data loss/split brains?


Do you have a replica 3 volume setup across these 3 nodes?

Glusterfs supports rolling upgrade for replica volumes.
But there are some issues to upgrade from 3.5 to 3.6 versions
(depending on version used)
Adding gluster-users  Pranith for recommended procedures.


thanks
sahina


Need I update gluster version to the latest?
How I need to upgrade the nodes ?  Is there any whitepaper
about this?

*
*

*
*

Thanks in advance,


Tibor



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users




___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users




___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 3.5.1

2015-02-01 Thread Demeter Tibor
Hi, 

Is glusterfs 3.6 is neccessary for ovirt 3.5.1? 
I have 3.5.2 at this moment. 

3.6 neccessary for upgade ? 

I'm worried what will happed with my gluster volumes after the upgrade... :( 

Plese help me. 

Also, how can I upgrade the nodes? Need i'm to a yum upgrade on the compute 
nodes? 

Thanks. 

Tibor 

- Eredeti üzenet -

 Hi,

 No, I have only one replica beetwen two nodes.
 The third node is only a host for vms and that using this replica.

 Thanks
 Tibor

 - Eredeti üzenet -

  On 01/22/2015 08:03 PM, Demeter Tibor wrote:
 

   Hello,
  
 

   I have an ovirt 3.5.0 cluster with three nodes and we using glusterfs for
   serving backend storage for VM-s. Glusterfs are on same servers with
   ovirt.
  
 
   We have Gluster 3.5.1 on all of nodes.
  
 

   How can I upgrade to ovirt 3.5.1 with new glusterfs? I don't want data
   inconsistency/data loss/split brains?
  
 

  Do you have a replica 3 volume setup across these 3 nodes?
 

  Glusterfs supports rolling upgrade for replica volumes.
 
  But there are some issues to upgrade from 3.5 to 3.6 versions (depending on
  version used)
 
  Adding gluster-users  Pranith for recommended procedures.
 

  thanks
 
  sahina
 

   Need I update gluster version to the latest?
  
 
   How I need to upgrade the nodes ? Is there any whitepaper about this?
  
 

   Thanks in advance,
  
 

   Tibor
  
 

   ___
  
 
   Users mailing list Users@ovirt.org
   http://lists.ovirt.org/mailman/listinfo/users
  
 

 ___
 Users mailing list
 Users@ovirt.org
 http://lists.ovirt.org/mailman/listinfo/users
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 3.5.1

2015-01-23 Thread Demeter Tibor
Hi, 

No, I have only one replica beetwen two nodes. 
The third node is only a host for vms and that using this replica. 

Thanks 
Tibor 

- Eredeti üzenet -

 On 01/22/2015 08:03 PM, Demeter Tibor wrote:

  Hello,
 

  I have an ovirt 3.5.0 cluster with three nodes and we using glusterfs for
  serving backend storage for VM-s. Glusterfs are on same servers with ovirt.
 
  We have Gluster 3.5.1 on all of nodes.
 

  How can I upgrade to ovirt 3.5.1 with new glusterfs? I don't want data
  inconsistency/data loss/split brains?
 

 Do you have a replica 3 volume setup across these 3 nodes?

 Glusterfs supports rolling upgrade for replica volumes.
 But there are some issues to upgrade from 3.5 to 3.6 versions (depending on
 version used)
 Adding gluster-users  Pranith for recommended procedures.

 thanks
 sahina

  Need I update gluster version to the latest?
 
  How I need to upgrade the nodes ? Is there any whitepaper about this?
 

  Thanks in advance,
 

  Tibor
 

  ___
 
  Users mailing list Users@ovirt.org
  http://lists.ovirt.org/mailman/listinfo/users
 
___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 3.5.1

2015-01-22 Thread Sahina Bose


On 01/22/2015 08:03 PM, Demeter Tibor wrote:

Hello,

I have an ovirt 3.5.0 cluster with three nodes and we using glusterfs 
for serving backend storage for VM-s. Glusterfs are on same servers 
with ovirt.

We have Gluster 3.5.1 on all of nodes.

How can I upgrade to ovirt 3.5.1 with new glusterfs? I don't want data 
inconsistency/data loss/split brains?


Do you have a replica 3 volume setup across these 3 nodes?

Glusterfs supports rolling upgrade for replica volumes.
But there are some issues to upgrade from 3.5 to 3.6 versions (depending 
on version used)

Adding gluster-users  Pranith for recommended procedures.


thanks
sahina



Need I update gluster version to the latest?
How I need to upgrade the nodes ?  Is there any whitepaper about this?

*
*

*
*

Thanks in advance,


Tibor



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


Re: [ovirt-users] Upgrade to 3.5.1

2015-01-22 Thread Sahina Bose

Sorry, wrong ML earlier

On 01/23/2015 12:33 PM, Sahina Bose wrote:


On 01/22/2015 08:03 PM, Demeter Tibor wrote:

Hello,

I have an ovirt 3.5.0 cluster with three nodes and we using glusterfs 
for serving backend storage for VM-s. Glusterfs are on same servers 
with ovirt.

We have Gluster 3.5.1 on all of nodes.

How can I upgrade to ovirt 3.5.1 with new glusterfs? I don't want 
data inconsistency/data loss/split brains?


Do you have a replica 3 volume setup across these 3 nodes?

Glusterfs supports rolling upgrade for replica volumes.
But there are some issues to upgrade from 3.5 to 3.6 versions 
(depending on version used)

Adding gluster-users  Pranith for recommended procedures.


thanks
sahina



Need I update gluster version to the latest?
How I need to upgrade the nodes ?  Is there any whitepaper about this?

*
*

*
*

Thanks in advance,


Tibor



___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users




___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


___
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users