Re: [webkit-dev] Using namespace std

2012-05-16 Thread Allan Sandfeld Jensen
On Tuesday 15 May 2012, Darin Adler wrote: On May 15, 2012, at 5:48 AM, Allan Sandfeld Jensen wrote: To me it seems like an odd practice, so I would like to ask what original rationale behind that style guideline is Adding a list of using declarations like using std::min to the top of

Re: [webkit-dev] Using namespace std

2012-05-16 Thread Allan Sandfeld Jensen
On Tuesday 15 May 2012, Darin Adler wrote: On May 15, 2012, at 10:04 AM, Allan Sandfeld Jensen wrote: The conflict is between isinf, isnan and std::isinf and std::isnan, but the conflict only exists in C++11 when constexpr versions are introduced. We should try harder to come up with a

Re: [webkit-dev] paged media update?

2012-05-16 Thread Milian Wolff
On Tuesday 15 May 2012 15:20:14 adam wrote: hi Hey there! Just wanted to know if Milian and Dave Hyatt spoke about the paged media updates? In the next months I might also be able to find some resources to help but just wanting to know what the current plan is... I'm still waiting for

Re: [webkit-dev] paged media update?

2012-05-16 Thread adam
Ah, Sorry I didnt know he was sick. Best wishes to him. adam On 16/05/12 11:56, Milian Wolff wrote: On Tuesday 15 May 2012 15:20:14 adam wrote: hi Hey there! Just wanted to know if Milian and Dave Hyatt spoke about the paged media updates? In the next months I might also be able to find

Re: [webkit-dev] Using namespace std

2012-05-16 Thread Allan Sandfeld Jensen
On Wednesday 16 May 2012, Allan Sandfeld Jensen wrote: On Tuesday 15 May 2012, Darin Adler wrote: On May 15, 2012, at 10:04 AM, Allan Sandfeld Jensen wrote: The conflict is between isinf, isnan and std::isinf and std::isnan, but the conflict only exists in C++11 when constexpr versions

Re: [webkit-dev] Using namespace std

2012-05-16 Thread Darin Adler
On May 16, 2012, at 9:20 AM, Allan Sandfeld Jensen wrote: there is another conflict which is entirely our own fault. It is between WTF::bind and the new std::bind from C++11 We should find a good solution for this. I’d suggest talking with Anders Carlsson about it. -- Darin

Re: [webkit-dev] Using namespace std

2012-05-16 Thread Anders Carlsson
On May 16, 2012, at 9:31 AM, Darin Adler da...@apple.com wrote: On May 16, 2012, at 9:20 AM, Allan Sandfeld Jensen wrote: there is another conflict which is entirely our own fault. It is between WTF::bind and the new std::bind from C++11 We should find a good solution for this. I’d

Re: [webkit-dev] paged media update?

2012-05-16 Thread David Hyatt
The difficulty with implementing paged media right now is that I'm beginning work on re-architecting pagination to unify columns, pages and regions. You can see the beginnings of this with the new multi-column classes that have been added to the tree. The basic idea is that multi-column layout

Re: [webkit-dev] Using namespace std

2012-05-16 Thread Jarred Nicholls
On Wed, May 16, 2012 at 3:04 PM, Anders Carlsson ander...@apple.com wrote: On May 16, 2012, at 9:31 AM, Darin Adler da...@apple.com wrote: On May 16, 2012, at 9:20 AM, Allan Sandfeld Jensen wrote: there is another conflict which is entirely our own fault. It is between WTF::bind and the

Re: [webkit-dev] Using namespace std

2012-05-16 Thread James Robinson
On Wed, May 16, 2012 at 12:04 PM, Anders Carlsson ander...@apple.comwrote: On May 16, 2012, at 9:31 AM, Darin Adler da...@apple.com wrote: On May 16, 2012, at 9:20 AM, Allan Sandfeld Jensen wrote: there is another conflict which is entirely our own fault. It is between WTF::bind and the

Re: [webkit-dev] Using namespace std

2012-05-16 Thread Darin Adler
On May 16, 2012, at 12:47 PM, James Robinson wrote: On Wed, May 16, 2012 at 12:04 PM, Anders Carlsson ander...@apple.com wrote: FWIW, I don't think we really need using directives for the std namespace - the fully qualified name is short enough and I like the additional clarity that we're

[webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Ryosuke Niwa
Hi, There has been some complaints / discussions about how syntax in test_expectations.txt is confusing (and I agree with you) on webkit-dev and at contributors' meeting. So I have a patch on https://bugs.webkit.org/show_bug.cgi?id=86691 to simplify syntax in test_expectation.txt as follows:

Re: [webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Benjamin Poulain
On Wed, May 16, 2012 at 9:08 PM, Ryosuke Niwa rn...@webkit.org wrote: e.g. 12345 WIN MAC TEXT IMAGE test.html instead of BUGWK12345 WIN MAC : test.html = TEXT IMAGE I wonder how this is gonna help making test_expectation.txt less obscure. If anything, I would make the file more verbose. I also

Re: [webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Ryosuke Niwa
Any concrete proposals? On May 16, 2012 9:23 PM, Benjamin Poulain benja...@webkit.org wrote: On Wed, May 16, 2012 at 9:08 PM, Ryosuke Niwa rn...@webkit.org wrote: e.g. 12345 WIN MAC TEXT IMAGE test.html instead of BUGWK12345 WIN MAC : test.html = TEXT IMAGE I wonder how this is gonna help

Re: [webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Dirk Pranke
On Wed, May 16, 2012 at 9:08 PM, Ryosuke Niwa rn...@webkit.org wrote: Hi, There has been some complaints / discussions about how syntax in test_expectations.txt is confusing (and I agree with you) on webkit-dev and at contributors' meeting. So I have a patch on 

Re: [webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Maciej Stachowiak
On May 16, 2012, at 9:08 PM, Ryosuke Niwa rn...@webkit.org wrote: Hi, There has been some complaints / discussions about how syntax in test_expectations.txt is confusing (and I agree with you) on webkit-dev and at contributors' meeting. So I have a patch on

Re: [webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Ryosuke Niwa
On Wed, May 16, 2012 at 9:59 PM, Dirk Pranke dpra...@chromium.org wrote: On Wed, May 16, 2012 at 9:08 PM, Ryosuke Niwa rn...@webkit.org wrote: For those who are interested, we're also going to rename test_expectations.txt to something more WebKitty on

Re: [webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Benjamin Poulain
On Wed, May 16, 2012 at 9:34 PM, Ryosuke Niwa rn...@webkit.org wrote: Any concrete proposals? I would go for something verbose in a easy to understand format. E.g. { test: 'fast/html/keygen.html', platform: 'mac, linux', bug: 'webkit.org/b/6', expectedResults: ['crash', 'text',

Re: [webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Dirk Pranke
On Wed, May 16, 2012 at 10:30 PM, Maciej Stachowiak m...@apple.com wrote: On May 16, 2012, at 9:08 PM, Ryosuke Niwa rn...@webkit.org wrote: Hi, There has been some complaints / discussions about how syntax in test_expectations.txt is confusing (and I agree with you) on webkit-dev and at

Re: [webkit-dev] Simplifying syntax in test_expectations.txt (bug 86691)

2012-05-16 Thread Ryosuke Niwa
On Wed, May 16, 2012 at 10:39 PM, Dirk Pranke dpra...@chromium.org wrote: On Wed, May 16, 2012 at 10:30 PM, Maciej Stachowiak m...@apple.com wrote: On May 16, 2012, at 9:08 PM, Ryosuke Niwa rn...@webkit.org wrote: There has been some complaints / discussions about how syntax in