Re: [webkit-dev] Position on emerging standard: video.requestAnimationFrame()

2020-01-27 Thread Elliott Sprehn
Would a method that returns a Promise be more in line with what this is doing? On Wed, Jan 22, 2020, 1:49 PM Simon Fraser wrote: > > On Jan 21, 2020, at 5:27 PM, Thomas Guilbert wrote: > > The idea was to reuse an API name that developers are already > familiar with, in a similar context. The n

Re: [webkit-dev] The SrcN responsive images proposal

2013-11-07 Thread Elliott Sprehn
On Thu, Nov 7, 2013 at 3:39 PM, Timothy Hatcher wrote: > On Nov 7, 2013, at 2:22 PM, Tab Atkins Jr. wrote: > > > On Thu, Nov 7, 2013 at 9:24 AM, Timothy Hatcher > wrote: > >> On Nov 6, 2013, at 4:26 PM, John Mellor wrote: > >>> I've suggested before that the attributes could be combined if tha

Re: [webkit-dev] The SrcN responsive images proposal

2013-11-04 Thread Elliott Sprehn
On Mon, Nov 4, 2013 at 4:55 PM, Ryosuke Niwa wrote: > On Mon, Nov 4, 2013 at 3:12 PM, Elliott Sprehn wrote: > >> On Mon, Nov 4, 2013 at 2:19 PM, Ryosuke Niwa wrote: >> >>> 99 is a very high upper bound while it would still allow us to implement >>>

Re: [webkit-dev] The SrcN responsive images proposal

2013-11-04 Thread Elliott Sprehn
On Mon, Nov 4, 2013 at 2:19 PM, Ryosuke Niwa wrote: > 99 is a very high upper bound while it would still allow us to implement > the optimization we're thinking of. > > I'm of the opinion that we should use exactly one attribute for this > feature. > > > Can you explain what this optimization is?

Re: [webkit-dev] For your consideration: Naming scheme for fooIfExists/ensureFoo

2013-06-19 Thread Elliott Sprehn
On Wed, Jun 19, 2013 at 9:46 AM, Andreas Kling wrote: > On Jun 19, 2013, at 6:37 PM, Timothy Hatcher wrote: > > What about? > > StyleResolver* existingStyleResolver() > StyleResolver& styleResolver() > > > This doesn't make sense since calling styleResolver() again won't create a new one so it's

Re: [webkit-dev] What do we do with various Web component features?

2013-04-29 Thread Elliott Sprehn
On Mon, Apr 29, 2013 at 10:30 AM, Anders Carlsson wrote: > > ... > > +1 > > From what I’ve heard, the Shadow DOM changes have negatively impacted the > packability of the DOM code which is unfortunate. I’m all for removing it. > > Could you elaborate on what you mean by the "packability of the DOM

Re: [webkit-dev] Test frame size for reftests

2013-04-24 Thread Elliott Sprehn
On Wed, Apr 24, 2013 at 3:31 PM, Dirk Pranke wrote: > > > > On Wed, Apr 24, 2013 at 3:29 PM, Elliott Sprehn wrote: > >> On Wed, Apr 24, 2013 at 11:11 AM, Dirk Pranke wrote: >> >>> >>>> ... >>>> >>>> >>> I think

Re: [webkit-dev] Test frame size for reftests

2013-04-24 Thread Elliott Sprehn
On Wed, Apr 24, 2013 at 11:11 AM, Dirk Pranke wrote: > >> ... >> >> > I think this raises two related questions, both of which would be helped > by concrete examples: > > 1) What sort of test are you writing where 800x600 isn't big enough to > test what you need to test? > > 2) What sort of test

Re: [webkit-dev] RenderLayer::isStackingContext() confusion

2013-04-03 Thread Elliott Sprehn
The function does what it says, it's just not obvious why: https://code.google.com/p/chromium/codesearch#chromium/src/third_party/WebKit/Source/WebCore/css/StyleResolver.cpp&sq=package:chromium&type=cs&q=adjustRenderStyle&l=1469 First we set the z-index to be auto for static position elements. Ne

Re: [webkit-dev] Disable the automated markup fixes

2013-04-02 Thread Elliott Sprehn
This is just the behavior of the HTML5 parser not something special about webkit. Why do you want to turn it off? On Tue, Apr 2, 2013 at 6:58 PM, Aaron Lewis wrote: > Hi Ben, > > Thanks for reply, > > But I checked the source code, the "createMarkup" function is from > WebCore, so it's not abou

Re: [webkit-dev] Ever increasing binary size

2013-03-22 Thread Elliott Sprehn
I'd be really interesting to see what patches are causing the growth and by how much. I wonder how much of this is from some of the fancier template things we have (ex. the 600 template expansions from StyleBuilder) On Fri, Mar 22, 2013 at 5:22 AM, Eric Seidel wrote: > It seems like it should b

Re: [webkit-dev] Best way to disable JavaScript

2013-03-18 Thread Elliott Sprehn
On Sun, Mar 17, 2013 at 8:26 PM, Geoffrey Garen wrote: > ... > There are problems with mode (2): > > * It breaks features that are implemented in JavaScript. > > The Web Inspector, bookmarklets, extensions, Safari Reader, and Safari > autofill all run JavaScript. This means that they break when u

Re: [webkit-dev] New web-facing canvas feature: "opaque" attribute

2013-03-13 Thread Elliott Sprehn
alpha:false is super confusing to me. It makes it sound as though all draw*() operations that use an alpha channel will fail... does globalAlpha still work? It's sad that WebGL picked such a generic name that isn't about all "alpha" related things. On Wed, Mar 13, 2013 at 2:59 PM, Rik Cabanier

Re: [webkit-dev] Feature Proposal: Implement Stream and StreamReader

2013-02-19 Thread Elliott Sprehn
Darin Fisher pointed out to me that this is about Stream and StreamReader per the subject, not StreamBuilder (which is not planned to be implemented yet). So sounds good to me! :) On Tue, Feb 19, 2013 at 1:28 PM, Elliott Sprehn wrote: > This API seems like it's in an inconsistent st

Re: [webkit-dev] Feature Proposal: Implement Stream and StreamReader

2013-02-19 Thread Elliott Sprehn
This API seems like it's in an inconsistent state with the other web platform features going on right now. ex. StreamBuilder sounds like BlobBuilder, and we recently killed that for a constructor for Blob. It's a bit concerning that we're going to add this feature, and then perhaps change it, and

Re: [webkit-dev] WebKit2/Mac and C++11

2013-01-30 Thread Elliott Sprehn
Thanks for the advance warning! :) - E On Wed, Jan 30, 2013 at 3:17 PM, Anders Carlsson wrote: > Hello! > > This is just a friendly heads-up that the Mac specific parts of WebKit2 > will soon start requiring C++11 features (move semantics and variadic > templates being the two most important).

Re: [webkit-dev] Can we remove Notification.show()?

2013-01-28 Thread Elliott Sprehn
This seems like a badly designed API, constructors shouldn't have side effects and not having show() means after calling close() the notification object is useless which is silly. On Mon, Jan 28, 2013 at 4:35 AM, Andrew Wilson wrote: > So, we've recently landed some fixes to address permissions

Re: [webkit-dev] WebIDL implementation plans (was: Re: Multiple inheritance in the DOM)

2013-01-25 Thread Elliott Sprehn
On Fri, Jan 25, 2013 at 11:32 PM, Dirk Schulze wrote: > ... > The problem is that SVGFitToViewBox and SVGZoomAndPan of the example above > are implemented by a lot of other interfaces as well. Supplemental is just > supposed to be set once per interface. That is why Supplemental doesn't > work fo

Re: [webkit-dev] WebIDL implementation plans (was: Re: Multiple inheritance in the DOM)

2013-01-25 Thread Elliott Sprehn
On Fri, Jan 25, 2013 at 8:09 PM, Dirk Schulze wrote: > > On Jan 25, 2013, at 4:23 PM, Maciej Stachowiak wrote: > > > > > On Jan 25, 2013, at 4:13 PM, Adam Barth wrote: > > > >> On Fri, Jan 25, 2013 at 2:08 PM, Dirk Schulze > wrote: > >>> On Jan 25, 2013, at 9:14 AM, Adam Barth wrote: > O

Re: [webkit-dev] Do any ports still disable SVG?

2013-01-25 Thread Elliott Sprehn
Perhaps the time to remove ENABLE_SVG is in several years once many pages depend on it and disabling it results in a busted browser... On Fri, Jan 25, 2013 at 2:55 PM, Arunprasad Rajkumar wrote: > Eric, Most of the resource constraint environments(embedded systems) still > disables the SVG. If

Re: [webkit-dev] Proposal to remove list-item special counter

2013-01-16 Thread Elliott Sprehn
On Wed, Aug 15, 2012 at 3:50 PM, Darin Adler wrote: > On Aug 15, 2012, at 2:29 PM, Elliott Sprehn wrote: > > > WebKit is the only browser that implements the magic counter named > "list-item" and we have no tests for it. > > Seems like we really ought to add so

Re: [webkit-dev] CSSGroupingRule and a bit of refactoring?

2012-12-21 Thread Elliott Sprehn
On Fri, Dec 21, 2012 at 6:09 AM, Antti Koivisto wrote: > On Fri, Dec 21, 2012 at 3:33 AM, Tab Atkins Jr. wrote: > >> No, it's just a refactoring on the CSS side, so we don't have to >> repeat a bunch of stuff every time we have an at-rule that contains >> other rules. It just makes the WebIDL ea

Re: [webkit-dev] Behaviour of CapsLock in WebKit/Mac

2012-12-12 Thread Elliott Sprehn
This same bug exists in Gecko https://bugzilla.mozilla.org/show_bug.cgi?id=712535 It appears Cocoa just doesn't notify of this: http://stackoverflow.com/questions/12536356/how-to-detect-key-up-or-key-release-for-the-capslock-key-in-os-x so we'd probably need to interact directly with the HID mana

Re: [webkit-dev] Behaviour of CapsLock in WebKit/Mac

2012-12-11 Thread Elliott Sprehn
Does this reproduce on every platform? If it's a OS X issue then it should work on Windows or Linux I'd hope. - E On Tue, Dec 11, 2012 at 9:32 PM, Mark Rowe wrote: > > On 2012-12-11, at 21:24, Wez wrote: > > > Hi all, > > > > There's a bug reported against Chromium (crbug.com/144757) for the

Re: [webkit-dev] Rolling out a patch requires a justification beyond a test failure in downstream projects

2012-12-11 Thread Elliott Sprehn
Do you have an example of when this has occurred? It's good to have examples if we want to prevent this in the future. On Tue, Dec 11, 2012 at 1:44 PM, Ryosuke Niwa wrote: > Hi, > > I've encountered a couple of incidences where people roll out patches > saying that test X is failing on some dow

Re: [webkit-dev] Prefix naming scheme for DOM-exposed functions

2012-12-07 Thread Elliott Sprehn
This seems like it would introduce bugs and make maintaining the DOM harder since we'd need to duplicate logic. Right now we have appendChild() and parserAppendChild(), and using parserAppendChild() for anything not in the parser introduces web observable bugs and changes in behavior. We also only

Re: [webkit-dev] RenderArena: Teaching an old dog new tricks

2012-11-15 Thread Elliott Sprehn
On Thu, Nov 15, 2012 at 3:22 AM, Chris Evans wrote: > >> ... >> > > My read on the Arena is that it's fragmentation resistant (i.e. it will > not repurpose a larger free chunk to satisfy a smaller allocation.) > However, memory usage at any given time is defined by peak usage since it > cannot re

Re: [webkit-dev] RenderArena: Teaching an old dog new tricks

2012-11-14 Thread Elliott Sprehn
On Thu, Nov 15, 2012 at 1:29 AM, Ryosuke Niwa wrote: > ... > In other words, why are you interested in using the proposed allocation > mechanism for only DOM nodes/objects instead of everything in > WebCore/WebKit? > > This was my concern as well. It would seem you'd need many different arenas, a

Re: [webkit-dev] RenderArena: Teaching an old dog new tricks

2012-11-14 Thread Elliott Sprehn
I was present for one of the discussions about the exploit and how an arena like allocator could have helped at Google. One proposed solution was to allocate all the JS typed buffers in an arena. Is there a reason we can't just do that? It's much less intrusive to allocate ArrayBuffer in an arena

Re: [webkit-dev] Adding Web Animations to WebCore

2012-11-08 Thread Elliott Sprehn
I'd also like to object to this as the API is very complicated and doesn't seem incremental or like it fits with existing platform features. Also the naming of things is inconsistent and messy. Why are half the interfaces and properties abbreviated and half of them not? This doesn't feel baked e

Re: [webkit-dev] Making more use of ScriptWrappable

2012-11-01 Thread Elliott Sprehn
On Thu, Nov 1, 2012 at 2:09 PM, Kentaro Hara wrote: > ... > > Thanks to the recent efforts of Adam Barth, V8 bindings are going to > remove the need to enumerate all wrappers, and thus the HashMap does > not need to store all wrappers. On the other hand, what about JSC > bindings? > JSC has a map

Re: [webkit-dev] moving focus when clicking on scrollbars

2012-11-01 Thread Elliott Sprehn
On Thu, Nov 1, 2012 at 4:42 AM, Maciej Stachowiak wrote: > ... > Is our current behavior the same as the "every browser engine, except Gecko" > behavior described above? Yes. - Native *never* moves focus, even if the control is focusable (ex. the wireless networks list in OS X Preferences.app)

Re: [webkit-dev] DRT/WTR should clear the cache at the beginning of each test?

2012-10-26 Thread Elliott Sprehn
On Fri, Oct 26, 2012 at 11:17 AM, Ryosuke Niwa wrote: > ... > > I agree this is a good change but it appears that we should add more > cache/loader tests before changing DRT's behavior given that there are > active contributors who rely on the current DRT behaviors to detect > regressions. > Can

Re: [webkit-dev] On returning mutable pointers from const methods

2012-10-25 Thread Elliott Sprehn
This requires weird contortions in the DOM and Render tree and removes nice guarantees. For example Node.h has: TreeScope* treeScope() const; Document* document() const; Node* childNode(unsigned index) const; Returning a const Document* or Node* from childNode makes the DOM API's suddenly less u

Re: [webkit-dev] Adding high resolution platform timestamp to DOM events

2012-10-24 Thread Elliott Sprehn
This doesn't appear to be in any standard yet. You should probably send something to public-webapps or the whatwg list and make sure others are onboard for the idea before exposing it to the web. On Wed, Oct 24, 2012 at 6:17 PM, Robert Flack wrote: > Hi webkit-dev, > > I would like to add platfo

Re: [webkit-dev] Improving DOM Exception console messages.

2012-10-01 Thread Elliott Sprehn
Even so what we have right now can be improved without exposing sensitive information. For instance HIERARCHY_REQUEST_ERR or SYNTAX_ERR is really useless, it would be much nicer to have the tag name and what was really wrong. As a current example, if you create a MutationObserver with the wrong di

Re: [webkit-dev] WKCreateCTLineWithUniCharProvider

2012-09-26 Thread Elliott Sprehn
WKCreateCTLineWithUniCharProvider is in the WebKitSystemInterface so its source is not available outside Apple. On Wed, Sep 26, 2012 at 2:34 AM, Glenn Adams wrote: > Where can I find the source for WKCreateCTLineWithUniCharProvider? I'm > working on a bug [1] in which I will need to at least und

Re: [webkit-dev] New Feature: Canvas Path object

2012-09-24 Thread Elliott Sprehn
On Mon, Sep 24, 2012 at 3:56 PM, Eric Seidel wrote: > My understanding is that a name collision would only affect the > ability of existing software to use the new Path. It would not break > existing software. window.Path would just be aliased by the page, no? > > Nope, if someone had previous

Re: [webkit-dev] New Feature: Canvas Path object

2012-09-22 Thread Elliott Sprehn
On Fri, Sep 21, 2012 at 6:34 AM, Dirk Schulze wrote: > Hi WebKit, > > I would like to ask if there are objections to implement the canvas Path > object. > > Do we have metrics on how often people already have things named Path? All other canvas objects have a prefix like CanvasGradient and Canvas

[webkit-dev] Breaking cycles in mutation observers in JSC

2012-08-23 Thread Elliott Sprehn
I'm trying to fix the memory leaks in MutationObservers ( http://www.w3.org/TR/dom/#mutation-observers), https://bugs.webkit.org/show_bug.cgi?id=93661 This is easy in V8 where I've put a hidden property on the MutationObserver wrapper, and the V8MutationCallback object accesses this hidden propert

Re: [webkit-dev] PSA: removing CSS3_FLEXBOX define

2012-08-19 Thread Elliott Sprehn
On Sat, Aug 18, 2012 at 2:42 AM, Kenneth Rohde Christiansen < kenneth.christian...@gmail.com> wrote: > Nice, congratulations on getting this far! A lot of web developers are > going to find flexbox extremely useful, and we should also not forget > that it is even supported by IE10 (though prefixed

[webkit-dev] Proposal to remove list-item special counter

2012-08-15 Thread Elliott Sprehn
WebKit is the only browser that implements the magic counter named "list-item" and we have no tests for it. This is from the CSS3 Lists module (http://dev.w3.org/csswg/css3-lists/). This special counter was added back in the initial implementation of CSS counters 6 years ago. ex. li:before { con

Re: [webkit-dev] New runtime setting: css3TextDecoration

2012-08-14 Thread Elliott Sprehn
I don't think editing code breaking when the page uses -webkit prefixed properties should block launching a feature. The point of the vendor prefix is to assert the instability of the feature. This wouldn't be a regression, it's just a missing feature. On Tue, Aug 14, 2012 at 3:22 PM, Ryosuke Niw

Re: [webkit-dev] Add support for CSS3 text-decoration* properties

2012-08-01 Thread Elliott Sprehn
On Tue, Jul 31, 2012 at 7:35 PM, Bruno Abinader wrote: > Hi all :) > > As suggested by Ojan, I am writing a mail to you about my intention to > implement all updated and missing text-decoration* properties from > CSS3 spec (currently in development), named below: > > -webkit-text-decoration ( http

Re: [webkit-dev] Multiple inheritance in the DOM

2012-07-26 Thread Elliott Sprehn
On Thu, Jul 26, 2012 at 3:45 PM, Alexandru Chiculita wrote: > ... > If CSSPseudoElement would be designed to derive from the same base class > as Element and share most of their style/layout properties, then 99% of the > time people will just do region.element.style.top = '100px'; and no query > i

[webkit-dev] Feature Announcement: CSS3 intrinsic width keywords (min-content etc.)

2012-06-18 Thread Elliott Sprehn
I'm currently implementing the CSS3 writing mode spec intrinsic width keywords: http://dev.w3.org/csswg/css3-writing-modes/#intrinsic-sizing Tracking bug: https://bugs.webkit.org/show_bug.cgi?id=38919 Currently I'm only adding support for width to match the behavior of Gecko. I'll move on to heig