[Zeitgeist] [Merge] lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird

2011-08-02 Thread noreply
The proposal to merge lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird has been updated. Status: Needs review => Merged For more details, see: https://code.launchpad.net/~zeitgeist/zeitgeist/symbols/+merge/69927 -- https://code.launchpad.net/~zeitgeist/zeitgeist/symbols

Re: [Zeitgeist] [Merge] lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird

2011-08-01 Thread Michal Hruby
Review: Needs Fixing My point is that the Symbol class itself shouldn't even be public, it should be something private to this source file. Method that this file needs to expose are (all of them are static): List Symbol.get_parents (string uri) List Symbol.get_children (string uri) List Symbol.g

Re: [Zeitgeist] [Merge] lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird

2011-08-01 Thread Seif Lotfy
you can get the immidiate stuff by asking for the properties, parents and children... I will just change the names to get_all_parents On Mon, Aug 1, 2011 at 1:55 PM, Michal Hruby wrote: > Review: Needs Fixing > Since you made get_parents return all parents, there's now no way to get > the immedi

Re: [Zeitgeist] [Merge] lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird

2011-08-01 Thread Michal Hruby
Review: Needs Fixing Since you made get_parents return all parents, there's now no way to get the immediate parents and therefore reconstruct the original ontology graph easily. Fix pls... -- https://code.launchpad.net/~zeitgeist/zeitgeist/symbols/+merge/69927 Your team Zeitgeist Framework Team

Re: [Zeitgeist] [Merge] lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird

2011-07-31 Thread Seif Lotfy
> - /* datamodel.vala > ontology > > - public static HashTable SymbolsCollection = null; > rename all_symbols, put it into Symbol (it's static), make it private > why put it in symbol? > - displayName, allChildren > display_name, all_children ok > > - why are you messing with GenericArra

Re: [Zeitgeist] [Merge] lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird

2011-07-31 Thread Michal Hruby
Review: Needs Fixing I find the Symbol class just an implementation detail, there's no need to expose it at all, as RainCT said you'll want to use static functions with signature like `string[] Symbol.get_children (string uri)`, or `string Symbol.get_description (string uri)` (of course we can u

Re: [Zeitgeist] [Merge] lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird

2011-07-31 Thread Siegfried Gevatter
Review: Needs Fixing - /* datamodel.vala ontology - public static HashTable SymbolsCollection = null; rename all_symbols, put it into Symbol (it's static), make it private - displayName, allChildren display_name, all_children - why are you messing with GenericArray<->List? (parents, etc.) th

[Zeitgeist] [Merge] lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird

2011-07-31 Thread Seif Lotfy
Seif Lotfy has proposed merging lp:~zeitgeist/zeitgeist/symbols into lp:~zeitgeist/zeitgeist/bluebird. Requested reviews: Zeitgeist Framework Team (zeitgeist) For more details, see: https://code.launchpad.net/~zeitgeist/zeitgeist/symbols/+merge/69927 Symbols class for generating symbols that