On Wed, 9 Sep 2026 21:24:12 GMT, Artur Barashev <[email protected]> wrote:

>> Hai-May Chao has updated the pull request incrementally with one additional 
>> commit since the last revision:
>> 
>>   Update mldsa schemes order
>
> src/java.base/share/classes/sun/security/ssl/SignatureScheme.java line 566:
> 
>> 564:                         continue;
>> 565:                     }
>> 566:                 }
> 
> Why we didn't perform this check before for the existing signature schemes 
> using `EdDSA` keyAlgorithm: `ED25519` and `ED448`?

Presumably it was an oversight before.

> src/java.base/share/classes/sun/security/ssl/SignatureScheme.java line 628:
> 
>> 626:     }
>> 627: 
>> 628:     private boolean checkNamedParam() {
> 
> I think `isNamedParam` or `hasNamedParam` would be a better name for this 
> method.

Changed the name to `hasNamedParm` as suggested.

> src/java.base/share/classes/sun/security/ssl/SignatureScheme.java line 629:
> 
>> 627: 
>> 628:     private boolean checkNamedParam() {
>> 629:         return "ML-DSA".equalsIgnoreCase(keyAlgorithm);
> 
> Why we check only for `ML-DSA`? `EdDSA` also has named parameters.

Added the `EdDSA` check as it has negotiated SignatureScheme `ed25519` and 
`ed448`.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32529#discussion_r3975191277
PR Review Comment: https://git.openjdk.org/jdk/pull/32529#discussion_r3975191038
PR Review Comment: https://git.openjdk.org/jdk/pull/32529#discussion_r3975191174

Reply via email to