[
https://issues.apache.org/jira/browse/JAMES-2510?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17140263#comment-17140263
]
Matthieu Baechler commented on JAMES-2510:
------------------------------------------
Let me explain what I had in mind (and failed to implement):
Use groupId to put things into categories : org.apache.james.server for server
stuff, org.apache.james.mailbox for mailbox stuff, etc
Use artifactId for describing things without any prefix: cassandra in
org.apache.james.mailbox for example
Would people agree? I also have in mind some refactoring of the source tree but
I'll put that in another ticket.
> use a consistent artifact naming scheme
> ---------------------------------------
>
> Key: JAMES-2510
> URL: https://issues.apache.org/jira/browse/JAMES-2510
> Project: James Server
> Issue Type: Task
> Components: Build System
> Affects Versions: 3.1.0
> Reporter: Matthieu Baechler
> Priority: Major
>
> Maven modules have different naming scheme, for example :
> * apache-james-*
> * james-server-*
> * protocols-*
> it makes everything hard to read and to find and it's redundant because
> groupId already gives context about an artifact.
> I'll make a proposal to reduce the noise in our maven files.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]