[
https://issues.apache.org/jira/browse/JAMES-2510?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17141349#comment-17141349
]
Ioan Eugen Stan commented on JAMES-2510:
----------------------------------------
I believe we can safely do renaming once we we have documentation for
developers up.
That way we have a place where to put the upgrade guide.
> use a consistent artifact naming scheme
> ---------------------------------------
>
> Key: JAMES-2510
> URL: https://issues.apache.org/jira/browse/JAMES-2510
> Project: James Server
> Issue Type: Task
> Components: Build System
> Affects Versions: 3.1.0
> Reporter: Matthieu Baechler
> Priority: Major
>
> Maven modules have different naming scheme, for example :
> * apache-james-*
> * james-server-*
> * protocols-*
> it makes everything hard to read and to find and it's redundant because
> groupId already gives context about an artifact.
> I'll make a proposal to reduce the noise in our maven files.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]